/[smeserver]/rpms/djbdns/sme8/djbdns.spec
ViewVC logotype

Annotation of /rpms/djbdns/sme8/djbdns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Jan 10 20:18:33 2008 UTC (16 years, 5 months ago) by bytegw
Branch: MAIN
CVS Tags: djbdns-1_05-4_el5_sme
Changes since 1.1: +12 -2 lines
Updates

1 slords 1.1 #
2     # RPM spec file for Dan Bernstein's djbdns package
3     #
4     # $Id: djbdns.spec,v 1.5 2004/11/11 21:03:51 charlieb Exp $
5     #
6     Summary: collection of Domain Name System tools
7     %define name djbdns
8     Name: %{name}
9     %define version 1.05
10 bytegw 1.2 %define release 4
11 slords 1.1 Version: %{version}
12     Release: %{release}%{?dist}
13 bytegw 1.2 License: Public Domain
14 slords 1.1 Group: Networking/Daemons
15     Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz
16     URL: http://cr.yp.to/%{name}.html
17     Patch0: %{name}-%{version}.patch.2001022000
18 bytegw 1.2 Patch1: dns_transmit-bug.patch
19 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
20     Provides: djbdns
21     AutoReqProv: no
22    
23     %description
24     djbdns is a collection of Domain Name System tools. It includes several
25     components:
26    
27     - The dnscache program is a local DNS cache. It accepts recursive
28     DNS queries from local clients such as web browsers. It collects
29     responses from remote DNS servers.
30    
31     - The tinydns program is a fast, UDP-only DNS server. It makes
32     local DNS information available to the Internet. It supports load
33     balancing and client differentiation.
34    
35     - The walldns program is a reverse DNS wall. It provides matching
36     reverse and forward records while hiding local host information.
37    
38     - The rbldns program is an IP-address-listing DNS server. It uses
39     DNS to publish a list of IP addresses, such as RBL or DUL.
40    
41     - The dns library handles outgoing and incoming DNS packets. It can
42     be used by clients such as web browsers to look up host addresses,
43     host names, MX records, etc. It supports asynchronous resolution.
44    
45     - The dnsfilter program is a parallel IP-address-to-host-name
46     converter.
47    
48     - The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
49     command-line interfaces to DNS.
50    
51     - The dnsq and dnstrace programs are DNS debugging tools.
52    
53 bytegw 1.2 djbdns was written by Daniel J Bernstein, and was placed into the public
54     domain on Dec 28, 2007.
55    
56 slords 1.1 %changelog
57 bytegw 1.2 * Thu Jan 10 2008 Charlie Brady <charlieb@e-smith.com> 1.05-4
58     - Patch around TCP bug: http://alkemio.org/dns_transmit-bug.html
59     - Change license to "Public Domain' - http://cr.yp.to/distributors.html
60    
61 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
62     - Clean up spec so package can be built by koji/plague
63    
64     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
65     - Update to new release naming. No functional changes.
66     - Make Packager generic
67    
68     * Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02
69     - Use "conf-cc" value which works around errno problem.
70    
71     * Tue Feb 20 2001 Peter Samuel <peters@e-smith.com>
72     - [1.05-01]
73     - Updated for djbdns-1.05.
74    
75     * Tue Feb 6 2001 Peter Samuel <peters@e-smith.com>
76     - [1.04-01]
77     - Now installs in its own root area prior to creating binary RPM.
78    
79     %prep
80     %setup
81    
82     # This patch allows files to be installed in a relative directory prior
83     # to creating the binary RPM. It does not change the installed files or
84     # their final installed locations.
85    
86     %patch0 -p1
87    
88     # Create the relative installation directories.
89    
90     mkdir -p ./root/usr
91     mkdir -p ./root/etc
92    
93 bytegw 1.2 %patch1 -p1
94    
95 slords 1.1 %build
96     echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc
97     echo "gcc -s -Os -pipe" > conf-ld
98     make
99    
100     %install
101     make setup
102     make check
103     rm -rf $RPM_BUILD_ROOT
104     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
105    
106     %clean
107     rm -rf $RPM_BUILD_ROOT
108    
109     %files
110     %attr(644,root,root) /etc/dnsroots.global
111     %attr(755,root,root) /usr/local/bin/axfrdns
112     %attr(755,root,root) /usr/local/bin/axfrdns-conf
113     %attr(755,root,root) /usr/local/bin/axfr-get
114     %attr(755,root,root) /usr/local/bin/dnscache
115     %attr(755,root,root) /usr/local/bin/dnscache-conf
116     %attr(755,root,root) /usr/local/bin/dnsfilter
117     %attr(755,root,root) /usr/local/bin/dnsip
118     %attr(755,root,root) /usr/local/bin/dnsipq
119     %attr(755,root,root) /usr/local/bin/dnsmx
120     %attr(755,root,root) /usr/local/bin/dnsname
121     %attr(755,root,root) /usr/local/bin/dnsq
122     %attr(755,root,root) /usr/local/bin/dnsqr
123     %attr(755,root,root) /usr/local/bin/dnstrace
124     %attr(755,root,root) /usr/local/bin/dnstracesort
125     %attr(755,root,root) /usr/local/bin/dnstxt
126     %attr(755,root,root) /usr/local/bin/pickdns
127     %attr(755,root,root) /usr/local/bin/pickdns-conf
128     %attr(755,root,root) /usr/local/bin/pickdns-data
129     %attr(755,root,root) /usr/local/bin/random-ip
130     %attr(755,root,root) /usr/local/bin/rbldns
131     %attr(755,root,root) /usr/local/bin/rbldns-conf
132     %attr(755,root,root) /usr/local/bin/rbldns-data
133     %attr(755,root,root) /usr/local/bin/tinydns
134     %attr(755,root,root) /usr/local/bin/tinydns-conf
135     %attr(755,root,root) /usr/local/bin/tinydns-data
136     %attr(755,root,root) /usr/local/bin/tinydns-edit
137     %attr(755,root,root) /usr/local/bin/tinydns-get
138     %attr(755,root,root) /usr/local/bin/walldns
139     %attr(755,root,root) /usr/local/bin/walldns-conf

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed