/[smeserver]/rpms/djbdns/sme8/djbdns.spec
ViewVC logotype

Annotation of /rpms/djbdns/sme8/djbdns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Mon Mar 24 18:40:31 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: djbdns-1_05-8_el5_sme
Changes since 1.3: +6 -3 lines
* Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 1.05-8
- Comment out contentious patches for now [SME: 3826] [SME: 3824]

1 slords 1.1 #
2     # RPM spec file for Dan Bernstein's djbdns package
3     #
4     # $Id: djbdns.spec,v 1.5 2004/11/11 21:03:51 charlieb Exp $
5     #
6     Summary: collection of Domain Name System tools
7     %define name djbdns
8     Name: %{name}
9     %define version 1.05
10 slords 1.4 %define release 8
11 slords 1.1 Version: %{version}
12     Release: %{release}%{?dist}
13 bytegw 1.2 License: Public Domain
14 slords 1.1 Group: Networking/Daemons
15     Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz
16     URL: http://cr.yp.to/%{name}.html
17     Patch0: %{name}-%{version}.patch.2001022000
18 bytegw 1.2 Patch1: dns_transmit-bug.patch
19 bytegw 1.3 Patch2: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-cname-handling.patch
20     Patch3: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-strict-forwardonly.patch
21     Patch4: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/tinydns-alias-chain-truncation.patch
22 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
23     Provides: djbdns
24     AutoReqProv: no
25    
26     %description
27     djbdns is a collection of Domain Name System tools. It includes several
28     components:
29    
30     - The dnscache program is a local DNS cache. It accepts recursive
31     DNS queries from local clients such as web browsers. It collects
32     responses from remote DNS servers.
33    
34     - The tinydns program is a fast, UDP-only DNS server. It makes
35     local DNS information available to the Internet. It supports load
36     balancing and client differentiation.
37    
38     - The walldns program is a reverse DNS wall. It provides matching
39     reverse and forward records while hiding local host information.
40    
41     - The rbldns program is an IP-address-listing DNS server. It uses
42     DNS to publish a list of IP addresses, such as RBL or DUL.
43    
44     - The dns library handles outgoing and incoming DNS packets. It can
45     be used by clients such as web browsers to look up host addresses,
46     host names, MX records, etc. It supports asynchronous resolution.
47    
48     - The dnsfilter program is a parallel IP-address-to-host-name
49     converter.
50    
51     - The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
52     command-line interfaces to DNS.
53    
54     - The dnsq and dnstrace programs are DNS debugging tools.
55    
56 bytegw 1.2 djbdns was written by Daniel J Bernstein, and was placed into the public
57     domain on Dec 28, 2007.
58    
59 slords 1.1 %changelog
60 slords 1.4 * Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 1.05-8
61     - Comment out contentious patches for now [SME: 3826] [SME: 3824]
62    
63 bytegw 1.3 * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-7
64     - Patch tinydns to publish complete client-side alias chains. [SME: 3826]
65    
66     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-6
67     - Patch to fix problems with delegation loops. [SME: 3825]
68    
69     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-5
70     - Patch to fix various problems in dnscache CNAME record handling. [SME: 3824]
71    
72 bytegw 1.2 * Thu Jan 10 2008 Charlie Brady <charlieb@e-smith.com> 1.05-4
73     - Patch around TCP bug: http://alkemio.org/dns_transmit-bug.html
74     - Change license to "Public Domain' - http://cr.yp.to/distributors.html
75    
76 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
77     - Clean up spec so package can be built by koji/plague
78    
79     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
80     - Update to new release naming. No functional changes.
81     - Make Packager generic
82    
83     * Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02
84     - Use "conf-cc" value which works around errno problem.
85    
86     * Tue Feb 20 2001 Peter Samuel <peters@e-smith.com>
87     - [1.05-01]
88     - Updated for djbdns-1.05.
89    
90     * Tue Feb 6 2001 Peter Samuel <peters@e-smith.com>
91     - [1.04-01]
92     - Now installs in its own root area prior to creating binary RPM.
93    
94     %prep
95     %setup
96    
97     # This patch allows files to be installed in a relative directory prior
98     # to creating the binary RPM. It does not change the installed files or
99     # their final installed locations.
100    
101     %patch0 -p1
102    
103     # Create the relative installation directories.
104    
105     mkdir -p ./root/usr
106     mkdir -p ./root/etc
107    
108 bytegw 1.2 %patch1 -p1
109 slords 1.4 #%patch2 -p1
110 bytegw 1.3 %patch3 -p1
111 slords 1.4 #%patch4 -p1
112 bytegw 1.2
113 slords 1.1 %build
114     echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc
115     echo "gcc -s -Os -pipe" > conf-ld
116     make
117    
118     %install
119     make setup
120     make check
121     rm -rf $RPM_BUILD_ROOT
122     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
123    
124     %clean
125     rm -rf $RPM_BUILD_ROOT
126    
127     %files
128     %attr(644,root,root) /etc/dnsroots.global
129     %attr(755,root,root) /usr/local/bin/axfrdns
130     %attr(755,root,root) /usr/local/bin/axfrdns-conf
131     %attr(755,root,root) /usr/local/bin/axfr-get
132     %attr(755,root,root) /usr/local/bin/dnscache
133     %attr(755,root,root) /usr/local/bin/dnscache-conf
134     %attr(755,root,root) /usr/local/bin/dnsfilter
135     %attr(755,root,root) /usr/local/bin/dnsip
136     %attr(755,root,root) /usr/local/bin/dnsipq
137     %attr(755,root,root) /usr/local/bin/dnsmx
138     %attr(755,root,root) /usr/local/bin/dnsname
139     %attr(755,root,root) /usr/local/bin/dnsq
140     %attr(755,root,root) /usr/local/bin/dnsqr
141     %attr(755,root,root) /usr/local/bin/dnstrace
142     %attr(755,root,root) /usr/local/bin/dnstracesort
143     %attr(755,root,root) /usr/local/bin/dnstxt
144     %attr(755,root,root) /usr/local/bin/pickdns
145     %attr(755,root,root) /usr/local/bin/pickdns-conf
146     %attr(755,root,root) /usr/local/bin/pickdns-data
147     %attr(755,root,root) /usr/local/bin/random-ip
148     %attr(755,root,root) /usr/local/bin/rbldns
149     %attr(755,root,root) /usr/local/bin/rbldns-conf
150     %attr(755,root,root) /usr/local/bin/rbldns-data
151     %attr(755,root,root) /usr/local/bin/tinydns
152     %attr(755,root,root) /usr/local/bin/tinydns-conf
153     %attr(755,root,root) /usr/local/bin/tinydns-data
154     %attr(755,root,root) /usr/local/bin/tinydns-edit
155     %attr(755,root,root) /usr/local/bin/tinydns-get
156     %attr(755,root,root) /usr/local/bin/walldns
157     %attr(755,root,root) /usr/local/bin/walldns-conf

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed