/[smeserver]/rpms/djbdns/sme8/djbdns.spec
ViewVC logotype

Annotation of /rpms/djbdns/sme8/djbdns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Wed Apr 9 13:51:47 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +2 -0 lines
Add Id to top of spec

1 slords 1.5 # $Id$
2    
3 slords 1.1 #
4     # RPM spec file for Dan Bernstein's djbdns package
5     #
6     # $Id: djbdns.spec,v 1.5 2004/11/11 21:03:51 charlieb Exp $
7     #
8     Summary: collection of Domain Name System tools
9     %define name djbdns
10     Name: %{name}
11     %define version 1.05
12 slords 1.4 %define release 8
13 slords 1.1 Version: %{version}
14     Release: %{release}%{?dist}
15 bytegw 1.2 License: Public Domain
16 slords 1.1 Group: Networking/Daemons
17     Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz
18     URL: http://cr.yp.to/%{name}.html
19     Patch0: %{name}-%{version}.patch.2001022000
20 bytegw 1.2 Patch1: dns_transmit-bug.patch
21 bytegw 1.3 Patch2: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-cname-handling.patch
22     Patch3: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-strict-forwardonly.patch
23     Patch4: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/tinydns-alias-chain-truncation.patch
24 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
25     Provides: djbdns
26     AutoReqProv: no
27    
28     %description
29     djbdns is a collection of Domain Name System tools. It includes several
30     components:
31    
32     - The dnscache program is a local DNS cache. It accepts recursive
33     DNS queries from local clients such as web browsers. It collects
34     responses from remote DNS servers.
35    
36     - The tinydns program is a fast, UDP-only DNS server. It makes
37     local DNS information available to the Internet. It supports load
38     balancing and client differentiation.
39    
40     - The walldns program is a reverse DNS wall. It provides matching
41     reverse and forward records while hiding local host information.
42    
43     - The rbldns program is an IP-address-listing DNS server. It uses
44     DNS to publish a list of IP addresses, such as RBL or DUL.
45    
46     - The dns library handles outgoing and incoming DNS packets. It can
47     be used by clients such as web browsers to look up host addresses,
48     host names, MX records, etc. It supports asynchronous resolution.
49    
50     - The dnsfilter program is a parallel IP-address-to-host-name
51     converter.
52    
53     - The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
54     command-line interfaces to DNS.
55    
56     - The dnsq and dnstrace programs are DNS debugging tools.
57    
58 bytegw 1.2 djbdns was written by Daniel J Bernstein, and was placed into the public
59     domain on Dec 28, 2007.
60    
61 slords 1.1 %changelog
62 slords 1.4 * Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 1.05-8
63     - Comment out contentious patches for now [SME: 3826] [SME: 3824]
64    
65 bytegw 1.3 * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-7
66     - Patch tinydns to publish complete client-side alias chains. [SME: 3826]
67    
68     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-6
69     - Patch to fix problems with delegation loops. [SME: 3825]
70    
71     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-5
72     - Patch to fix various problems in dnscache CNAME record handling. [SME: 3824]
73    
74 bytegw 1.2 * Thu Jan 10 2008 Charlie Brady <charlieb@e-smith.com> 1.05-4
75     - Patch around TCP bug: http://alkemio.org/dns_transmit-bug.html
76     - Change license to "Public Domain' - http://cr.yp.to/distributors.html
77    
78 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
79     - Clean up spec so package can be built by koji/plague
80    
81     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
82     - Update to new release naming. No functional changes.
83     - Make Packager generic
84    
85     * Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02
86     - Use "conf-cc" value which works around errno problem.
87    
88     * Tue Feb 20 2001 Peter Samuel <peters@e-smith.com>
89     - [1.05-01]
90     - Updated for djbdns-1.05.
91    
92     * Tue Feb 6 2001 Peter Samuel <peters@e-smith.com>
93     - [1.04-01]
94     - Now installs in its own root area prior to creating binary RPM.
95    
96     %prep
97     %setup
98    
99     # This patch allows files to be installed in a relative directory prior
100     # to creating the binary RPM. It does not change the installed files or
101     # their final installed locations.
102    
103     %patch0 -p1
104    
105     # Create the relative installation directories.
106    
107     mkdir -p ./root/usr
108     mkdir -p ./root/etc
109    
110 bytegw 1.2 %patch1 -p1
111 slords 1.4 #%patch2 -p1
112 bytegw 1.3 %patch3 -p1
113 slords 1.4 #%patch4 -p1
114 bytegw 1.2
115 slords 1.1 %build
116     echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc
117     echo "gcc -s -Os -pipe" > conf-ld
118     make
119    
120     %install
121     make setup
122     make check
123     rm -rf $RPM_BUILD_ROOT
124     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
125    
126     %clean
127     rm -rf $RPM_BUILD_ROOT
128    
129     %files
130     %attr(644,root,root) /etc/dnsroots.global
131     %attr(755,root,root) /usr/local/bin/axfrdns
132     %attr(755,root,root) /usr/local/bin/axfrdns-conf
133     %attr(755,root,root) /usr/local/bin/axfr-get
134     %attr(755,root,root) /usr/local/bin/dnscache
135     %attr(755,root,root) /usr/local/bin/dnscache-conf
136     %attr(755,root,root) /usr/local/bin/dnsfilter
137     %attr(755,root,root) /usr/local/bin/dnsip
138     %attr(755,root,root) /usr/local/bin/dnsipq
139     %attr(755,root,root) /usr/local/bin/dnsmx
140     %attr(755,root,root) /usr/local/bin/dnsname
141     %attr(755,root,root) /usr/local/bin/dnsq
142     %attr(755,root,root) /usr/local/bin/dnsqr
143     %attr(755,root,root) /usr/local/bin/dnstrace
144     %attr(755,root,root) /usr/local/bin/dnstracesort
145     %attr(755,root,root) /usr/local/bin/dnstxt
146     %attr(755,root,root) /usr/local/bin/pickdns
147     %attr(755,root,root) /usr/local/bin/pickdns-conf
148     %attr(755,root,root) /usr/local/bin/pickdns-data
149     %attr(755,root,root) /usr/local/bin/random-ip
150     %attr(755,root,root) /usr/local/bin/rbldns
151     %attr(755,root,root) /usr/local/bin/rbldns-conf
152     %attr(755,root,root) /usr/local/bin/rbldns-data
153     %attr(755,root,root) /usr/local/bin/tinydns
154     %attr(755,root,root) /usr/local/bin/tinydns-conf
155     %attr(755,root,root) /usr/local/bin/tinydns-data
156     %attr(755,root,root) /usr/local/bin/tinydns-edit
157     %attr(755,root,root) /usr/local/bin/tinydns-get
158     %attr(755,root,root) /usr/local/bin/walldns
159     %attr(755,root,root) /usr/local/bin/walldns-conf

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed