/[smeserver]/rpms/djbdns/sme9/djbdns.spec
ViewVC logotype

Annotation of /rpms/djbdns/sme9/djbdns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Wed Jul 19 20:43:04 2017 UTC (6 years, 10 months ago) by unnilennium
Branch: MAIN
CVS Tags: djbdns-1_05-11_el6_sme, HEAD
Changes since 1.3: +7 -3 lines
* Wed Jul 19 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-11.sme
- improve short ttl cname resolution and glueless answer from akadns [SME: 8362]
- 500-cutom-dnscache-maxloop.patch: set QUERY_MAXLEVEL 5 QUERY_MAXLOOP 500 QUERY_MAXNS 16

1 unnilennium 1.4 # $Id: djbdns.spec,v 1.3 2017/07/12 16:41:30 unnilennium Exp $
2 slords 1.1
3     #
4     # RPM spec file for Dan Bernstein's djbdns package
5     #
6 unnilennium 1.4 # $Id: djbdns.spec,v 1.3 2017/07/12 16:41:30 unnilennium Exp $
7 slords 1.1 #
8     Summary: collection of Domain Name System tools
9     %define name djbdns
10     Name: %{name}
11     %define version 1.05
12 unnilennium 1.4 %define release 11
13 slords 1.1 Version: %{version}
14     Release: %{release}%{?dist}
15     License: Public Domain
16     Group: Networking/Daemons
17     Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz
18     URL: http://cr.yp.to/%{name}.html
19     Patch0: %{name}-%{version}.patch.2001022000
20     Patch1: dns_transmit-bug.patch
21 unnilennium 1.2 #Patch2: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-cname-handling.patch
22 slords 1.1 Patch3: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-strict-forwardonly.patch
23 unnilennium 1.2 #Patch4: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/tinydns-alias-chain-truncation.patch
24    
25     # patch from openwrt
26     Patch20: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/020-dnsroots-update.patch
27     Patch30: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/030-srv-records-and-axfrget.patch
28     Patch50: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/050-tinydns-mmap-leak.patch
29     Patch60: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/060-dnscache-big-udp-packets.patch
30     Patch70: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/070-dnscache-dpos-tcp-servfail.patch
31     Patch80: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/080-dnscache-cache-negatives.patch
32     Patch90: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/090-tinydns-one-second.patch
33     Patch120: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/120-compiler-temporary-filename.patch
34     Patch200: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/200-dnscache-cname-handling.patch
35     Patch210: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/210-dnscache-strict-forwardonly.patch
36     Patch230: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/230-tinydns-data-semantic-error.patch
37     Patch240: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/240-tinydns-alias-chain-truncation.patch
38     Patch270: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/270-dnscache-sigpipe-fix.patch
39     Patch300: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/300-bugfix-dnscache-dempsky-poison.patch
40     Patch310: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/310-bugfix-dnscache-merge-outgoing-requests.patch
41     Patch320: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/320-bugfix-dnscache-cache-soa-records.patch
42     Patch330: https://dev.openwrt.org/raw-attachment/ticket/5881/330-fix-dnscache-cname-handling.patch
43    
44     Patch450: 450-dnscache-ghost-domain-CVE-2012-1191.patch
45     Patch500: 500-cutom-dnscache-maxloop.patch
46    
47 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
48     Provides: djbdns
49     AutoReqProv: no
50    
51     %description
52     djbdns is a collection of Domain Name System tools. It includes several
53     components:
54    
55     - The dnscache program is a local DNS cache. It accepts recursive
56     DNS queries from local clients such as web browsers. It collects
57     responses from remote DNS servers.
58    
59     - The tinydns program is a fast, UDP-only DNS server. It makes
60     local DNS information available to the Internet. It supports load
61     balancing and client differentiation.
62    
63     - The walldns program is a reverse DNS wall. It provides matching
64     reverse and forward records while hiding local host information.
65    
66     - The rbldns program is an IP-address-listing DNS server. It uses
67     DNS to publish a list of IP addresses, such as RBL or DUL.
68    
69     - The dns library handles outgoing and incoming DNS packets. It can
70     be used by clients such as web browsers to look up host addresses,
71     host names, MX records, etc. It supports asynchronous resolution.
72    
73     - The dnsfilter program is a parallel IP-address-to-host-name
74     converter.
75    
76     - The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
77     command-line interfaces to DNS.
78    
79     - The dnsq and dnstrace programs are DNS debugging tools.
80    
81     djbdns was written by Daniel J Bernstein, and was placed into the public
82     domain on Dec 28, 2007.
83    
84     %changelog
85 unnilennium 1.4 * Wed Jul 19 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-11.sme
86     - improve short ttl cname resolution and glueless answer from akadns [SME: 8362]
87     - 500-cutom-dnscache-maxloop.patch: set QUERY_MAXLEVEL 5 QUERY_MAXLOOP 500 QUERY_MAXNS 16
88    
89 unnilennium 1.3 * Wed Jul 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-10.sme
90     - improve short ttl cname resolution and glueless answer from akadns [SME: 8362]
91     - 500-cutom-dnscache-maxloop.patch: increase QUERY_MAXLEVEL 5->10 , set QUERY_MAXLOOP 160
92    
93 unnilennium 1.2 * Tue Jul 11 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-9.sme
94     -- backport SME10 fixes [SME: 10381]
95     --import patches from openwrt and rename already applied patches
96     --fix security issues [SME: 10374]
97     - 020-dnsroots-update.patch: update list of root DNS servers
98     - 070-dnscache-dpos-tcp-servfail.patch: SERVFAIL rename previous patch dns_transmit-bug.patch
99     - 210-dnscache-strict-forwardonly.patch: rename previous patch dnscache-strict-forwardonly.patch
100     - 270-dnscache-sigpipe-fix.patch: SIGPIPE
101     - 300-bugfix-dnscache-dempsky-poison.patch: CVE-2009-0858
102     - 310-bugfix-dnscache-merge-outgoing-requests.patch: CVE-2008-4392
103     - 320-bugfix-dnscache-cache-soa-records.patch: CVE-2008-4392
104     - 450-dnscache-ghost-domain-CVE-2012-1191.patch: CVE-2012-1191 http://marc.info/?l=djbdns&m=134190748729079&w=2
105     --bug fixes [SME: 10374]
106     - 060-dnscache-big-udp-packets.patch: accept and handle longer than 512 bytes UDP packets
107     - 230-tinydns-data-semantic-error.patch: handle semantic error to avoid publishing false dns records
108     - 240-tinydns-alias-chain-truncation.patch: rename previous patch tinydns-alias-chain-truncation.patch
109     --fix issue with short ttl cname like akamaid [SME: 8362]
110     - 200-dnscache-cname-handling.patch: rename previous patch dnscache-cname-handling.patch
111     - 330-fix-dnscache-cname-handling.patch: fix dnscache cname for short ttl
112     - 500-cutom-dnscache-maxloop.patch: set max loop to 200
113     --needed for previous patches to apply cleanly
114     - 030-srv-records-and-axfrget.patch: add SRV record type and axfr-get decompose SRC and PTR records (for 230-*.patch)
115     - 080-dnscache-cache-negatives.patch: rfc2308 ? (for 200-*.patch)
116     - 090-tinydns-one-second.patch: improve tinydns with 8 or more concurent connections (for 240-*.patch)
117     - 120-compiler-temporary-filename.patch: change tmp filename to avoid conflicts (for 230-*.patch)
118     --not backported from SME10 branch
119     - 050-tinydns-mmap-leak.patch: report cdb leak
120    
121 slords 1.1 * Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 1.05-8
122     - Comment out contentious patches for now [SME: 3826] [SME: 3824]
123    
124     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-7
125     - Patch tinydns to publish complete client-side alias chains. [SME: 3826]
126    
127     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-6
128     - Patch to fix problems with delegation loops. [SME: 3825]
129    
130     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-5
131     - Patch to fix various problems in dnscache CNAME record handling. [SME: 3824]
132    
133     * Thu Jan 10 2008 Charlie Brady <charlieb@e-smith.com> 1.05-4
134     - Patch around TCP bug: http://alkemio.org/dns_transmit-bug.html
135     - Change license to "Public Domain' - http://cr.yp.to/distributors.html
136    
137     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
138     - Clean up spec so package can be built by koji/plague
139    
140     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
141     - Update to new release naming. No functional changes.
142     - Make Packager generic
143    
144     * Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02
145     - Use "conf-cc" value which works around errno problem.
146    
147     * Tue Feb 20 2001 Peter Samuel <peters@e-smith.com>
148     - [1.05-01]
149     - Updated for djbdns-1.05.
150    
151     * Tue Feb 6 2001 Peter Samuel <peters@e-smith.com>
152     - [1.04-01]
153     - Now installs in its own root area prior to creating binary RPM.
154    
155     %prep
156     %setup
157    
158     # This patch allows files to be installed in a relative directory prior
159     # to creating the binary RPM. It does not change the installed files or
160     # their final installed locations.
161    
162     %patch0 -p1
163    
164     # Create the relative installation directories.
165    
166     mkdir -p ./root/usr
167     mkdir -p ./root/etc
168    
169 unnilennium 1.2 %patch20 -p1
170     %patch30 -p1
171     %patch60 -p1
172     %patch70 -p1
173     %patch80 -p1
174     %patch90 -p1
175     %patch120 -p1
176     %patch200 -p1
177     %patch210 -p1
178     %patch230 -p1
179     %patch240 -p1
180     %patch270 -p1
181     %patch300 -p1
182     %patch310 -p1
183     %patch320 -p1
184     %patch330 -p1
185    
186     %patch450 -p1
187     %patch500 -p1
188    
189 slords 1.1
190     %build
191     echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc
192     echo "gcc -s -Os -pipe" > conf-ld
193     make
194    
195     %install
196     make setup
197     make check
198     rm -rf $RPM_BUILD_ROOT
199     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
200    
201     %clean
202     rm -rf $RPM_BUILD_ROOT
203    
204     %files
205     %attr(644,root,root) /etc/dnsroots.global
206     %attr(755,root,root) /usr/local/bin/axfrdns
207     %attr(755,root,root) /usr/local/bin/axfrdns-conf
208     %attr(755,root,root) /usr/local/bin/axfr-get
209     %attr(755,root,root) /usr/local/bin/dnscache
210     %attr(755,root,root) /usr/local/bin/dnscache-conf
211     %attr(755,root,root) /usr/local/bin/dnsfilter
212     %attr(755,root,root) /usr/local/bin/dnsip
213     %attr(755,root,root) /usr/local/bin/dnsipq
214     %attr(755,root,root) /usr/local/bin/dnsmx
215     %attr(755,root,root) /usr/local/bin/dnsname
216     %attr(755,root,root) /usr/local/bin/dnsq
217     %attr(755,root,root) /usr/local/bin/dnsqr
218     %attr(755,root,root) /usr/local/bin/dnstrace
219     %attr(755,root,root) /usr/local/bin/dnstracesort
220     %attr(755,root,root) /usr/local/bin/dnstxt
221     %attr(755,root,root) /usr/local/bin/pickdns
222     %attr(755,root,root) /usr/local/bin/pickdns-conf
223     %attr(755,root,root) /usr/local/bin/pickdns-data
224     %attr(755,root,root) /usr/local/bin/random-ip
225     %attr(755,root,root) /usr/local/bin/rbldns
226     %attr(755,root,root) /usr/local/bin/rbldns-conf
227     %attr(755,root,root) /usr/local/bin/rbldns-data
228     %attr(755,root,root) /usr/local/bin/tinydns
229     %attr(755,root,root) /usr/local/bin/tinydns-conf
230     %attr(755,root,root) /usr/local/bin/tinydns-data
231     %attr(755,root,root) /usr/local/bin/tinydns-edit
232     %attr(755,root,root) /usr/local/bin/tinydns-get
233     %attr(755,root,root) /usr/local/bin/walldns
234     %attr(755,root,root) /usr/local/bin/walldns-conf

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed