/[smeserver]/rpms/dovecot/sme7/dovecot.spec
ViewVC logotype

Annotation of /rpms/dovecot/sme7/dovecot.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 15:07:20 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: dovecot-1_0-1_2_rc15_el4_sme
Import on branch sme7 of package dovecot-1.0-1.2.rc15.el4.sme.src.rpm

1 slords 1.1 Summary: Dovecot Secure imap server
2     Name: dovecot
3     Version: 1.0
4     Release: 1.2.rc15%{?dist}
5     License: LGPL
6     Group: System Environment/Daemons
7    
8     %define build_postgres 1
9     %define build_mysql 1
10     %define upstream 1.0.rc15
11    
12     Source: %{name}-%{upstream}.tar.gz
13     Source1: dovecot.init
14     Source2: dovecot.pam
15     Source3: maildir-migration.txt
16     Source4: migrate-folders
17     Source5: migrate-users
18     Source6: perfect_maildir.pl
19     Source7: dovecot-REDHAT-FAQ.txt
20     Patch100: dovecot-1.0.rc15-default-settings.patch
21     Patch101: dovecot-1.0.beta2-pam-tty.patch
22     Patch102: dovecot-1.0.rc2-pam-setcred.patch
23     Patch103: dovecot-1.0.beta2-mkcert-permissions.patch
24     Patch104: dovecot-1.0.beta2-lib64.patch
25     Patch105: dovecot-1.0.rc7-mkcert-paths.patch
26     #Patch105: dovecot-1.0.beta2-sqlite-check.patch
27    
28     # XXX this patch needs review and forward porting
29     #Patch105: dovecot-auth-log.patch
30    
31     # Patches 500+ from upstream fixes
32     URL: http://www.dovecot.org/
33     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
34     BuildRequires: openssl-devel
35     BuildRequires: openldap-devel
36     BuildRequires: pam-devel
37     BuildRequires: pkgconfig
38     BuildRequires: zlib-devel
39     BuildRequires: libtool
40     BuildRequires: autoconf
41     BuildRequires: automake
42     BuildRequires: krb5-devel
43     # gettext-devel is needed for running autoconf because of the
44     # presence of AM_ICONV
45     BuildRequires: gettext-devel
46     Prereq: openssl >= 0.9.7a-43.16, /sbin/chkconfig, /usr/sbin/useradd
47    
48     %if %{build_postgres}
49     BuildRequires: postgresql-devel
50     %endif
51    
52     %if %{build_mysql}
53     BuildRequires: mysql-devel
54     %endif
55    
56     %define docdir %{_docdir}/%{name}
57     %define ssldir %{_sysconfdir}/pki/%{name}
58     %define restart_flag /var/run/%{name}-restart-after-rpm-install
59     %define dovecot_uid 97
60     %define dovecot_gid 97
61    
62     %description
63     Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
64     primarily in mind. It also contains a small POP3 server. It supports mail
65     in either of maildir or mbox formats.
66    
67     %prep
68    
69     %setup -q -n %{name}-%{upstream}
70    
71     %patch100 -p1 -b .default-settings
72     %patch101 -p2 -b .pam-tty
73     %patch102 -p1 -b .pam-setcred
74     %patch103 -p1 -b .mkcert-permissions
75     #%patch104 -p1 -b .lib64
76     %patch105 -p1 -b .mkcert-paths
77    
78     %build
79     rm -f ./configure
80     libtoolize -f
81     autoreconf
82     %configure \
83     INSTALL_DATA="install -c -p -m644" \
84     --with-doc \
85     %if %{build_postgres}
86     --with-pgsql \
87     %endif
88     %if %{build_mysql}
89     --with-mysql \
90     %endif
91     --with-ssl=openssl \
92     --with-ssldir=%{ssldir} \
93     --with-ldap \
94     --with-inotify \
95     --with-gssapi
96    
97     make
98    
99     %install
100     rm -rf $RPM_BUILD_ROOT
101     make install DESTDIR=$RPM_BUILD_ROOT
102     rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}
103     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
104     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/dovecot
105    
106     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
107     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/dovecot
108    
109     # generate ghost .pem file
110     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/certs
111     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/private
112     touch $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
113     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
114     touch $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
115     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
116    
117     mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
118     chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
119     chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
120    
121     # Install dovecot.conf and dovecot-openssl.cnf
122     mkdir -p $RPM_BUILD_ROOT/%{ssldir}
123     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/dovecot-example.conf $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot.conf
124     rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot-example.conf # dovecot seems to install this by itself
125     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/dovecot-openssl.cnf $RPM_BUILD_ROOT/%{ssldir}/dovecot-openssl.cnf
126    
127     # Install some of our own documentation
128     install -p -m644 $RPM_SOURCE_DIR/dovecot-REDHAT-FAQ.txt $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
129    
130     mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
131     install -p -m755 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/mkcert.sh $RPM_BUILD_ROOT%{docdir}/examples/mkcert.sh
132     for f in `cd $RPM_BUILD_DIR/dovecot-%{upstream}/doc; echo *.conf`; do
133     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
134     done
135    
136     install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
137     for f in maildir-migration.txt migrate-folders migrate-users perfect_maildir.pl
138     do
139     install -p -m644 $RPM_SOURCE_DIR/$f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
140     done
141    
142     mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
143     mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
144    
145     %pre
146     /usr/sbin/useradd -c "dovecot" -u %{dovecot_uid} -s /sbin/nologin -r -d /usr/libexec/dovecot dovecot 2>/dev/null || :
147    
148     # stop service during installation, keep flag if it was running to restart later
149     rm -f %{restart_flag}
150     /sbin/service %{name} status >/dev/null 2>&1
151     if [ $? -eq 0 ]; then
152     touch %{restart_flag}
153     /sbin/service %{name} stop >/dev/null 2>&1
154     fi
155    
156     %post
157     /sbin/chkconfig --add %{name}
158     # create a ssl cert
159     if [ -f %{ssldir}/%{name}.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
160     mv %{ssldir}/%{name}.pem %{ssldir}/certs/%{name}.pem
161     else
162     if [ -f /usr/share/ssl/certs/dovecot.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
163     mv /usr/share/ssl/certs/dovecot.pem %{ssldir}/certs/%{name}.pem
164     fi
165     if [ -f /usr/share/ssl/private/dovecot.pem -a ! -e %{ssldir}/private/%{name}.pem ]; then
166     mv /usr/share/ssl/private/dovecot.pem %{ssldir}/private/%{name}.pem
167     fi
168     fi
169     if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
170     SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
171     %{docdir}-%{version}/examples/mkcert.sh &> /dev/null
172     fi
173    
174     if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
175     dovecot --build-ssl-parameters &>/dev/null
176     fi
177    
178     # Restart if it had been running before installation
179     if [ -e %{restart_flag} ]; then
180     rm %{restart_flag}
181     /sbin/service %{name} start >/dev/null 2>&1
182     fi
183     exit 0
184    
185    
186     %preun
187     if [ $1 = 0 ]; then
188     /usr/sbin/userdel dovecot 2>/dev/null || :
189     /usr/sbin/groupdel dovecot 2>/dev/null || :
190     [ -f /var/lock/subsys/%{name} ] && /sbin/service %{name} stop > /dev/null 2>&1
191     /sbin/chkconfig --del %{name}
192     fi
193    
194     %clean
195     rm -rf $RPM_BUILD_ROOT
196    
197     %files
198     %defattr(-,root,root)
199     %doc %{docdir}-%{version}
200     %config(noreplace) %{_sysconfdir}/dovecot.conf
201     %config %{_sysconfdir}/rc.d/init.d/dovecot
202     %config %{_sysconfdir}/pam.d/dovecot
203     %config(noreplace) %{ssldir}/dovecot-openssl.cnf
204     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
205     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
206     %dir %{_libexecdir}/%{name}
207     %{_libexecdir}/%{name}
208     %{_libdir}/%{name}
209     %{_sbindir}/dovecot
210     %{_sbindir}/dovecotpw
211     %attr(0755,root,dovecot) %dir /var/run/dovecot
212     %attr(0750,root,dovecot) %dir /var/run/dovecot/login
213     %attr(0750,root,dovecot) %{docdir}-%{version}/examples/mkcert.sh
214     %attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
215    
216    
217     %changelog
218     * Fri Dec 22 2006 Tomas Janousek <tjanouse@redhat.com> - 1.0-1.2.rc15
219     - reenabled GSSAPI (#220582)
220    
221     * Tue Nov 21 2006 Petr Rockai <prockai@redhat.com> - 1.0-1.rc15
222     - update to latest upstream, fixes a few bugs, plus a security
223     vulnerability (#216510, CVE-2006-5973)
224    
225     * Tue Oct 10 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.3.rc7
226     - fix few inconsistencies in specfile, fixes #198940
227    
228     * Wed Oct 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.2.rc7
229     - fix default paths in the example mkcert.sh to match configuration
230     defaults (fixes #183151)
231    
232     * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.1.rc7
233     - rebuilt for unwind info generation, broken in gcc-4.1.1-21
234    
235     * Fri Sep 22 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc7
236     - update to latest upstream release candidate, should fix occasional
237     hangs and mbox issues... INBOX. namespace is still broken though
238     - do not run over symlinked certificates in new locations on upgrade
239    
240     * Tue Aug 15 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.2
241     - include /var/lib/dovecot in the package, prevents startup failure
242     on new installs
243    
244     * Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
245     - reenable inotify and see what happens
246    
247     * Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
248     - update to latest upstream release candidate
249     - disable inotify for now, doesn't build -- this needs fixing though
250    
251     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
252     - rebuild
253    
254     * Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
255     - put back pop3_uidl_format default that got lost
256     in the beta2->beta7 upgrade (would cause pop3 to not work
257     at all in many situations)
258    
259     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
260     - upgrade to latest upstream beta release (beta8)
261     - contains a security fix in mbox handling
262    
263     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
264     - upgrade to latest upstream beta release
265     - fixed BR 173048
266    
267     * Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
268     - fix sqlite detection in upstream configure checks, second part
269     of #182240
270    
271     * Wed Mar 8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
272     - fix scriplet noise some more
273    
274     * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
275     - fix scriptlet error (mitr, #184151)
276    
277     * Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
278     - fix #182240 by looking in lib64 for libs first and then lib
279     - fix comment #1 in #182240 by copying over the example config files
280     to documentation directory
281    
282     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
283     - bump again for double-long bug on ppc(64)
284    
285     * Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
286     - enable inotify as it should work now (#179431)
287    
288     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
289     - rebuilt for new gcc4.1 snapshot and glibc changes
290    
291     * Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
292     - change the compiled-in defaults and adjust the default's configfile
293     commented-out example settings to match compiled-in defaults,
294     instead of changing the defaults only in the configfile, as per #179432
295     - fix #179574 by providing a default uidl_format for pop3
296     - half-fix #179620 by having plaintext auth enabled by default... this
297     needs more thinking (which one we really want) and documentation
298     either way
299    
300     * Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
301     - update URL in description
302     - call dovecot --build-ssl-parameters in postinst as per #179430
303    
304     * Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
305     - fix spec to work with BUILD_DIR != SOURCE_DIR
306     - forward-port and split pam-nocred patch
307    
308     * Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
309     - new upstream version, hopefully fixes #173928, #163550
310     - fix #168866, use install -p to install documentation
311    
312     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
313     - rebuilt
314    
315     * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
316     - Rebuild due to mysql update.
317    
318     * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
319     - rebuilt with new openssl
320    
321     * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
322     - use include instead of pam_stack in pam config
323    
324     * Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
325     - fix bug #150888, log authenication failures with ip address
326    
327     * Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
328     - fix bug #149673, add dummy PAM_TTY
329    
330     * Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
331     - fix bug #156159 insecure location of restart flag file
332    
333     * Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
334     - openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
335    
336     * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
337     - Rebuild for Postgres 8.0.2 (new libpq major version).
338    
339     * Mon Mar 7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
340     - bump rev for gcc4 build
341    
342     * Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
343     - fix bug #147874, update to 0.99.14 release
344     v0.99.14 2005-02-11 Timo Sirainen <tss at iki.fi>
345     - Message address fields are now parsed differently, fixing some
346     issues with spaces. Affects only clients which use FETCH ENVELOPE
347     command.
348     - Message MIME parser was somewhat broken with missing MIME boundaries
349     - mbox: Don't allow X-UID headers in mails to override the UIDs we
350     would otherwise set. Too large values can break some clients and
351     cause other trouble.
352     - passwd-file userdb wasn't working
353     - PAM crashed with 64bit systems
354     - non-SSL inetd startup wasn't working
355     - If UID FETCH notices and skips an expunged message, don't return
356     a NO reply. It's not needed and only makes clients give error
357     messages.
358    
359     * Wed Feb 2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
360     - fix bug #146198, clean up temp kerberos tickets
361    
362     * Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
363     - fix bug #145214, force mbox_locks to fcntl only
364     - fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
365     dependency generator to pick up client lib dependency if needed.
366    
367     * Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
368     - make postgres & mysql conditional build
369     - remove execute bit on migration example scripts so rpm does not pull
370     in additional dependences on perl and perl modules that are not present
371     in dovecot proper.
372     - add REDHAT-FAQ.txt to doc directory
373    
374     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
375     - bring up to date with latest upstream, 0.99.13, bug #143707
376     also fix bug #14462, bad dovecot-uid macro name
377    
378     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
379     - fix bug #133618, removed LITERAL+ capability from capability string
380    
381     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
382     - fix bug #134325, stop dovecot during installation
383    
384     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
385     - fix bug #129539, dovecot starts too early,
386     set chkconfig to 65 35 to match cyrus-imapd
387     - also delete some old commented out code from SSL certificate creation
388    
389     * Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
390     - add UW to Dovecot migration documentation and scripts, bug #139954
391     fix SSL documentation and scripts, add missing documentation, bug #139276
392    
393     * Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
394     - rebuild against MySQL4
395    
396     * Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
397     - fix bug #136623
398     Change License field from GPL to LGPL to reflect actual license
399    
400     * Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
401     - fix bug #124786, listen to ipv6 as well as ipv4
402    
403     * Wed Sep 8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
404     - bring up to latest upstream,
405     comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04
406     + 127.* and ::1 IP addresses are treated as secured with
407     disable_plaintext_auth = yes
408     + auth_debug setting for extra authentication debugging
409     + Some documentation and error message updates
410     + Create PID file in /var/run/dovecot/master.pid
411     + home setting is now optional in static userdb
412     + Added mail setting to static userdb
413     - After APPENDing to selected mailbox Dovecot didn't always notice the
414     new mail immediately which broke some clients
415     - THREAD and SORT commands crashed with some mails
416     - If APPENDed mail ended with CR character, Dovecot aborted the saving
417     - Output streams sometimes sent data duplicated and lost part of it.
418     This could have caused various strange problems, but looks like in
419     practise it rarely caused real problems.
420    
421     * Wed Aug 4 2004 John Dennis <jdennis@redhat.com>
422     - change release field separator from comma to dot, bump build number
423    
424     * Mon Aug 2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
425     - bring up to date with latest upstream, fixes include:
426     - LDAP support compiles now with Solaris LDAP library
427     - IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
428     didn't contain Content-Type header.
429     - MySQL and PostgreSQL auth didn't reconnect if connection was lost
430     to SQL server
431     - Linking fixes for dovecot-auth with some systems
432     - Last fix for disconnecting client when downloading mail longer than
433     30 seconds actually made it never disconnect client. Now it works
434     properly: disconnect when client hasn't read _any_ data for 30
435     seconds.
436     - MySQL compiling got broken in last release
437     - More PostgreSQL reconnection fixing
438    
439    
440     * Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
441     - enable postgres and mySQL in build
442     - fix configure to look for mysql in alternate locations
443     - nuke configure script in tar file, recreate from configure.in using autoconf
444    
445     - bring up to latest upstream, which included:
446     - Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
447     - Config file lines can now contain quoted strings ("value ")
448     - If client didn't finish downloading a single mail in 30 seconds,
449     Dovecot closed the connection. This was supposed to work so that
450     if client hasn't read data at all in 30 seconds, it's disconnected.
451     - Maildir: LIST now doesn't skip symlinks
452    
453    
454     * Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
455     - bump rev for build
456     - change rev for FC3 build
457    
458     * Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
459     - bring up to date with upstream,
460     recent change log comments from Timo Sirainen were:
461     SHA1 password support using OpenSSL crypto library
462     mail_extra_groups setting
463     maildir_stat_dirs setting
464     Added NAMESPACE capability and command
465     Autocreate missing maildirs (instead of crashing)
466     Fixed occational crash in maildir synchronization
467     Fixed occational assertion crash in ioloop.c
468     Fixed FreeBSD compiling issue
469     Fixed issues with 64bit Solaris binary
470    
471     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
472     - rebuilt
473    
474     * Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
475     - Update to 0.99.10.5 to fix maildir segfaults (#123022)
476    
477     * Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
478     - default auth config that is actually usable
479     - Timo Sirainen (author) suggested functionality fixes
480     maildir, imap-fetch-body-section, customflags-fix
481    
482     * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
483     - Use ':' instead of '.' as separator for chown.
484    
485     * Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
486     - restart properly if it dies (#115594)
487    
488     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
489     - rebuilt
490    
491     * Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
492     - update to 0.99.10.4
493    
494     * Mon Oct 6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
495     - another patch from upstream to fix returning invalid data on partial
496     BODY[part] fetches
497     - patch to avoid confusion of draft/deleted in indexes
498    
499     * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
500     - add some patches from upstream (#104288)
501    
502     * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
503     - fix startup with 2.6 with patch from upstream (#103801)
504    
505     * Tue Sep 2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
506     - fix assert in search code (#103383)
507    
508     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
509     - rebuild
510    
511     * Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
512     - don't run by default
513    
514     * Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
515     - 0.99.10
516    
517     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
518     - 0.99.10-rc2 (includes ssl detection fix)
519     - a few tweaks from fedora
520     - noreplace the config file
521     - configure --with-ldap to get LDAP enabled
522    
523     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
524     - 0.99.10-rc1
525     - add fix for ssl detection
526     - add zlib-devel to BuildRequires
527     - change pam service name to dovecot
528     - include pam config
529    
530     * Thu May 8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
531     - update to 0.99.9.1
532     - add patch from upstream to fix potential bug when fetching with
533     CR+LF linefeeds
534     - tweak some things in the initscript and config file noticed by the
535     fedora folks
536    
537     * Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
538     - fix ssl dir
539     - own /var/run/dovecot/login with the correct perms
540     - fix chmod/chown in post
541    
542     * Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
543     - update to 0.99.8.1
544    
545     * Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
546     - add a patch to fix quoting problem from CVS
547    
548     * Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
549     - 0.99.8
550     - add some buildrequires
551     - fixup to build with openssl 0.9.7
552     - now includes a pop3 daemon (off by default)
553     - clean up description and %%preun
554     - add dovecot user (uid/gid of 97)
555     - add some buildrequires
556     - move the ssl cert to %{_datadir}/ssl/certs
557     - create a dummy ssl cert in %post
558     - own /var/run/dovecot
559     - make the config file a source so we get default mbox locks of fcntl
560    
561     * Sun Dec 1 2002 Seth Vidal <skvidal@phy.duke.edu>
562     - 0.99.4 and fix startup so it starts imap-master not vsftpd :)
563    
564     * Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
565     - first build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed