/[smeserver]/rpms/dovecot/sme7/dovecot.spec
ViewVC logotype

Annotation of /rpms/dovecot/sme7/dovecot.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 9 13:51:47 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
Changes since 1.1: +2 -0 lines
Add Id to top of spec

1 slords 1.2 # $Id$
2    
3 slords 1.1 Summary: Dovecot Secure imap server
4     Name: dovecot
5     Version: 1.0
6     Release: 1.2.rc15%{?dist}
7     License: LGPL
8     Group: System Environment/Daemons
9    
10     %define build_postgres 1
11     %define build_mysql 1
12     %define upstream 1.0.rc15
13    
14     Source: %{name}-%{upstream}.tar.gz
15     Source1: dovecot.init
16     Source2: dovecot.pam
17     Source3: maildir-migration.txt
18     Source4: migrate-folders
19     Source5: migrate-users
20     Source6: perfect_maildir.pl
21     Source7: dovecot-REDHAT-FAQ.txt
22     Patch100: dovecot-1.0.rc15-default-settings.patch
23     Patch101: dovecot-1.0.beta2-pam-tty.patch
24     Patch102: dovecot-1.0.rc2-pam-setcred.patch
25     Patch103: dovecot-1.0.beta2-mkcert-permissions.patch
26     Patch104: dovecot-1.0.beta2-lib64.patch
27     Patch105: dovecot-1.0.rc7-mkcert-paths.patch
28     #Patch105: dovecot-1.0.beta2-sqlite-check.patch
29    
30     # XXX this patch needs review and forward porting
31     #Patch105: dovecot-auth-log.patch
32    
33     # Patches 500+ from upstream fixes
34     URL: http://www.dovecot.org/
35     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
36     BuildRequires: openssl-devel
37     BuildRequires: openldap-devel
38     BuildRequires: pam-devel
39     BuildRequires: pkgconfig
40     BuildRequires: zlib-devel
41     BuildRequires: libtool
42     BuildRequires: autoconf
43     BuildRequires: automake
44     BuildRequires: krb5-devel
45     # gettext-devel is needed for running autoconf because of the
46     # presence of AM_ICONV
47     BuildRequires: gettext-devel
48     Prereq: openssl >= 0.9.7a-43.16, /sbin/chkconfig, /usr/sbin/useradd
49    
50     %if %{build_postgres}
51     BuildRequires: postgresql-devel
52     %endif
53    
54     %if %{build_mysql}
55     BuildRequires: mysql-devel
56     %endif
57    
58     %define docdir %{_docdir}/%{name}
59     %define ssldir %{_sysconfdir}/pki/%{name}
60     %define restart_flag /var/run/%{name}-restart-after-rpm-install
61     %define dovecot_uid 97
62     %define dovecot_gid 97
63    
64     %description
65     Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
66     primarily in mind. It also contains a small POP3 server. It supports mail
67     in either of maildir or mbox formats.
68    
69     %prep
70    
71     %setup -q -n %{name}-%{upstream}
72    
73     %patch100 -p1 -b .default-settings
74     %patch101 -p2 -b .pam-tty
75     %patch102 -p1 -b .pam-setcred
76     %patch103 -p1 -b .mkcert-permissions
77     #%patch104 -p1 -b .lib64
78     %patch105 -p1 -b .mkcert-paths
79    
80     %build
81     rm -f ./configure
82     libtoolize -f
83     autoreconf
84     %configure \
85     INSTALL_DATA="install -c -p -m644" \
86     --with-doc \
87     %if %{build_postgres}
88     --with-pgsql \
89     %endif
90     %if %{build_mysql}
91     --with-mysql \
92     %endif
93     --with-ssl=openssl \
94     --with-ssldir=%{ssldir} \
95     --with-ldap \
96     --with-inotify \
97     --with-gssapi
98    
99     make
100    
101     %install
102     rm -rf $RPM_BUILD_ROOT
103     make install DESTDIR=$RPM_BUILD_ROOT
104     rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}
105     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
106     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/dovecot
107    
108     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
109     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/dovecot
110    
111     # generate ghost .pem file
112     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/certs
113     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/private
114     touch $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
115     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
116     touch $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
117     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
118    
119     mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
120     chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
121     chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
122    
123     # Install dovecot.conf and dovecot-openssl.cnf
124     mkdir -p $RPM_BUILD_ROOT/%{ssldir}
125     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/dovecot-example.conf $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot.conf
126     rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot-example.conf # dovecot seems to install this by itself
127     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/dovecot-openssl.cnf $RPM_BUILD_ROOT/%{ssldir}/dovecot-openssl.cnf
128    
129     # Install some of our own documentation
130     install -p -m644 $RPM_SOURCE_DIR/dovecot-REDHAT-FAQ.txt $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
131    
132     mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
133     install -p -m755 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/mkcert.sh $RPM_BUILD_ROOT%{docdir}/examples/mkcert.sh
134     for f in `cd $RPM_BUILD_DIR/dovecot-%{upstream}/doc; echo *.conf`; do
135     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
136     done
137    
138     install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
139     for f in maildir-migration.txt migrate-folders migrate-users perfect_maildir.pl
140     do
141     install -p -m644 $RPM_SOURCE_DIR/$f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
142     done
143    
144     mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
145     mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
146    
147     %pre
148     /usr/sbin/useradd -c "dovecot" -u %{dovecot_uid} -s /sbin/nologin -r -d /usr/libexec/dovecot dovecot 2>/dev/null || :
149    
150     # stop service during installation, keep flag if it was running to restart later
151     rm -f %{restart_flag}
152     /sbin/service %{name} status >/dev/null 2>&1
153     if [ $? -eq 0 ]; then
154     touch %{restart_flag}
155     /sbin/service %{name} stop >/dev/null 2>&1
156     fi
157    
158     %post
159     /sbin/chkconfig --add %{name}
160     # create a ssl cert
161     if [ -f %{ssldir}/%{name}.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
162     mv %{ssldir}/%{name}.pem %{ssldir}/certs/%{name}.pem
163     else
164     if [ -f /usr/share/ssl/certs/dovecot.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
165     mv /usr/share/ssl/certs/dovecot.pem %{ssldir}/certs/%{name}.pem
166     fi
167     if [ -f /usr/share/ssl/private/dovecot.pem -a ! -e %{ssldir}/private/%{name}.pem ]; then
168     mv /usr/share/ssl/private/dovecot.pem %{ssldir}/private/%{name}.pem
169     fi
170     fi
171     if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
172     SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
173     %{docdir}-%{version}/examples/mkcert.sh &> /dev/null
174     fi
175    
176     if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
177     dovecot --build-ssl-parameters &>/dev/null
178     fi
179    
180     # Restart if it had been running before installation
181     if [ -e %{restart_flag} ]; then
182     rm %{restart_flag}
183     /sbin/service %{name} start >/dev/null 2>&1
184     fi
185     exit 0
186    
187    
188     %preun
189     if [ $1 = 0 ]; then
190     /usr/sbin/userdel dovecot 2>/dev/null || :
191     /usr/sbin/groupdel dovecot 2>/dev/null || :
192     [ -f /var/lock/subsys/%{name} ] && /sbin/service %{name} stop > /dev/null 2>&1
193     /sbin/chkconfig --del %{name}
194     fi
195    
196     %clean
197     rm -rf $RPM_BUILD_ROOT
198    
199     %files
200     %defattr(-,root,root)
201     %doc %{docdir}-%{version}
202     %config(noreplace) %{_sysconfdir}/dovecot.conf
203     %config %{_sysconfdir}/rc.d/init.d/dovecot
204     %config %{_sysconfdir}/pam.d/dovecot
205     %config(noreplace) %{ssldir}/dovecot-openssl.cnf
206     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
207     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
208     %dir %{_libexecdir}/%{name}
209     %{_libexecdir}/%{name}
210     %{_libdir}/%{name}
211     %{_sbindir}/dovecot
212     %{_sbindir}/dovecotpw
213     %attr(0755,root,dovecot) %dir /var/run/dovecot
214     %attr(0750,root,dovecot) %dir /var/run/dovecot/login
215     %attr(0750,root,dovecot) %{docdir}-%{version}/examples/mkcert.sh
216     %attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
217    
218    
219     %changelog
220     * Fri Dec 22 2006 Tomas Janousek <tjanouse@redhat.com> - 1.0-1.2.rc15
221     - reenabled GSSAPI (#220582)
222    
223     * Tue Nov 21 2006 Petr Rockai <prockai@redhat.com> - 1.0-1.rc15
224     - update to latest upstream, fixes a few bugs, plus a security
225     vulnerability (#216510, CVE-2006-5973)
226    
227     * Tue Oct 10 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.3.rc7
228     - fix few inconsistencies in specfile, fixes #198940
229    
230     * Wed Oct 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.2.rc7
231     - fix default paths in the example mkcert.sh to match configuration
232     defaults (fixes #183151)
233    
234     * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.1.rc7
235     - rebuilt for unwind info generation, broken in gcc-4.1.1-21
236    
237     * Fri Sep 22 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc7
238     - update to latest upstream release candidate, should fix occasional
239     hangs and mbox issues... INBOX. namespace is still broken though
240     - do not run over symlinked certificates in new locations on upgrade
241    
242     * Tue Aug 15 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.2
243     - include /var/lib/dovecot in the package, prevents startup failure
244     on new installs
245    
246     * Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
247     - reenable inotify and see what happens
248    
249     * Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
250     - update to latest upstream release candidate
251     - disable inotify for now, doesn't build -- this needs fixing though
252    
253     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
254     - rebuild
255    
256     * Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
257     - put back pop3_uidl_format default that got lost
258     in the beta2->beta7 upgrade (would cause pop3 to not work
259     at all in many situations)
260    
261     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
262     - upgrade to latest upstream beta release (beta8)
263     - contains a security fix in mbox handling
264    
265     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
266     - upgrade to latest upstream beta release
267     - fixed BR 173048
268    
269     * Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
270     - fix sqlite detection in upstream configure checks, second part
271     of #182240
272    
273     * Wed Mar 8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
274     - fix scriplet noise some more
275    
276     * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
277     - fix scriptlet error (mitr, #184151)
278    
279     * Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
280     - fix #182240 by looking in lib64 for libs first and then lib
281     - fix comment #1 in #182240 by copying over the example config files
282     to documentation directory
283    
284     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
285     - bump again for double-long bug on ppc(64)
286    
287     * Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
288     - enable inotify as it should work now (#179431)
289    
290     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
291     - rebuilt for new gcc4.1 snapshot and glibc changes
292    
293     * Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
294     - change the compiled-in defaults and adjust the default's configfile
295     commented-out example settings to match compiled-in defaults,
296     instead of changing the defaults only in the configfile, as per #179432
297     - fix #179574 by providing a default uidl_format for pop3
298     - half-fix #179620 by having plaintext auth enabled by default... this
299     needs more thinking (which one we really want) and documentation
300     either way
301    
302     * Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
303     - update URL in description
304     - call dovecot --build-ssl-parameters in postinst as per #179430
305    
306     * Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
307     - fix spec to work with BUILD_DIR != SOURCE_DIR
308     - forward-port and split pam-nocred patch
309    
310     * Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
311     - new upstream version, hopefully fixes #173928, #163550
312     - fix #168866, use install -p to install documentation
313    
314     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
315     - rebuilt
316    
317     * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
318     - Rebuild due to mysql update.
319    
320     * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
321     - rebuilt with new openssl
322    
323     * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
324     - use include instead of pam_stack in pam config
325    
326     * Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
327     - fix bug #150888, log authenication failures with ip address
328    
329     * Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
330     - fix bug #149673, add dummy PAM_TTY
331    
332     * Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
333     - fix bug #156159 insecure location of restart flag file
334    
335     * Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
336     - openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
337    
338     * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
339     - Rebuild for Postgres 8.0.2 (new libpq major version).
340    
341     * Mon Mar 7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
342     - bump rev for gcc4 build
343    
344     * Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
345     - fix bug #147874, update to 0.99.14 release
346     v0.99.14 2005-02-11 Timo Sirainen <tss at iki.fi>
347     - Message address fields are now parsed differently, fixing some
348     issues with spaces. Affects only clients which use FETCH ENVELOPE
349     command.
350     - Message MIME parser was somewhat broken with missing MIME boundaries
351     - mbox: Don't allow X-UID headers in mails to override the UIDs we
352     would otherwise set. Too large values can break some clients and
353     cause other trouble.
354     - passwd-file userdb wasn't working
355     - PAM crashed with 64bit systems
356     - non-SSL inetd startup wasn't working
357     - If UID FETCH notices and skips an expunged message, don't return
358     a NO reply. It's not needed and only makes clients give error
359     messages.
360    
361     * Wed Feb 2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
362     - fix bug #146198, clean up temp kerberos tickets
363    
364     * Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
365     - fix bug #145214, force mbox_locks to fcntl only
366     - fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
367     dependency generator to pick up client lib dependency if needed.
368    
369     * Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
370     - make postgres & mysql conditional build
371     - remove execute bit on migration example scripts so rpm does not pull
372     in additional dependences on perl and perl modules that are not present
373     in dovecot proper.
374     - add REDHAT-FAQ.txt to doc directory
375    
376     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
377     - bring up to date with latest upstream, 0.99.13, bug #143707
378     also fix bug #14462, bad dovecot-uid macro name
379    
380     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
381     - fix bug #133618, removed LITERAL+ capability from capability string
382    
383     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
384     - fix bug #134325, stop dovecot during installation
385    
386     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
387     - fix bug #129539, dovecot starts too early,
388     set chkconfig to 65 35 to match cyrus-imapd
389     - also delete some old commented out code from SSL certificate creation
390    
391     * Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
392     - add UW to Dovecot migration documentation and scripts, bug #139954
393     fix SSL documentation and scripts, add missing documentation, bug #139276
394    
395     * Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
396     - rebuild against MySQL4
397    
398     * Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
399     - fix bug #136623
400     Change License field from GPL to LGPL to reflect actual license
401    
402     * Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
403     - fix bug #124786, listen to ipv6 as well as ipv4
404    
405     * Wed Sep 8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
406     - bring up to latest upstream,
407     comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04
408     + 127.* and ::1 IP addresses are treated as secured with
409     disable_plaintext_auth = yes
410     + auth_debug setting for extra authentication debugging
411     + Some documentation and error message updates
412     + Create PID file in /var/run/dovecot/master.pid
413     + home setting is now optional in static userdb
414     + Added mail setting to static userdb
415     - After APPENDing to selected mailbox Dovecot didn't always notice the
416     new mail immediately which broke some clients
417     - THREAD and SORT commands crashed with some mails
418     - If APPENDed mail ended with CR character, Dovecot aborted the saving
419     - Output streams sometimes sent data duplicated and lost part of it.
420     This could have caused various strange problems, but looks like in
421     practise it rarely caused real problems.
422    
423     * Wed Aug 4 2004 John Dennis <jdennis@redhat.com>
424     - change release field separator from comma to dot, bump build number
425    
426     * Mon Aug 2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
427     - bring up to date with latest upstream, fixes include:
428     - LDAP support compiles now with Solaris LDAP library
429     - IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
430     didn't contain Content-Type header.
431     - MySQL and PostgreSQL auth didn't reconnect if connection was lost
432     to SQL server
433     - Linking fixes for dovecot-auth with some systems
434     - Last fix for disconnecting client when downloading mail longer than
435     30 seconds actually made it never disconnect client. Now it works
436     properly: disconnect when client hasn't read _any_ data for 30
437     seconds.
438     - MySQL compiling got broken in last release
439     - More PostgreSQL reconnection fixing
440    
441    
442     * Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
443     - enable postgres and mySQL in build
444     - fix configure to look for mysql in alternate locations
445     - nuke configure script in tar file, recreate from configure.in using autoconf
446    
447     - bring up to latest upstream, which included:
448     - Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
449     - Config file lines can now contain quoted strings ("value ")
450     - If client didn't finish downloading a single mail in 30 seconds,
451     Dovecot closed the connection. This was supposed to work so that
452     if client hasn't read data at all in 30 seconds, it's disconnected.
453     - Maildir: LIST now doesn't skip symlinks
454    
455    
456     * Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
457     - bump rev for build
458     - change rev for FC3 build
459    
460     * Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
461     - bring up to date with upstream,
462     recent change log comments from Timo Sirainen were:
463     SHA1 password support using OpenSSL crypto library
464     mail_extra_groups setting
465     maildir_stat_dirs setting
466     Added NAMESPACE capability and command
467     Autocreate missing maildirs (instead of crashing)
468     Fixed occational crash in maildir synchronization
469     Fixed occational assertion crash in ioloop.c
470     Fixed FreeBSD compiling issue
471     Fixed issues with 64bit Solaris binary
472    
473     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
474     - rebuilt
475    
476     * Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
477     - Update to 0.99.10.5 to fix maildir segfaults (#123022)
478    
479     * Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
480     - default auth config that is actually usable
481     - Timo Sirainen (author) suggested functionality fixes
482     maildir, imap-fetch-body-section, customflags-fix
483    
484     * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
485     - Use ':' instead of '.' as separator for chown.
486    
487     * Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
488     - restart properly if it dies (#115594)
489    
490     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
491     - rebuilt
492    
493     * Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
494     - update to 0.99.10.4
495    
496     * Mon Oct 6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
497     - another patch from upstream to fix returning invalid data on partial
498     BODY[part] fetches
499     - patch to avoid confusion of draft/deleted in indexes
500    
501     * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
502     - add some patches from upstream (#104288)
503    
504     * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
505     - fix startup with 2.6 with patch from upstream (#103801)
506    
507     * Tue Sep 2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
508     - fix assert in search code (#103383)
509    
510     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
511     - rebuild
512    
513     * Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
514     - don't run by default
515    
516     * Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
517     - 0.99.10
518    
519     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
520     - 0.99.10-rc2 (includes ssl detection fix)
521     - a few tweaks from fedora
522     - noreplace the config file
523     - configure --with-ldap to get LDAP enabled
524    
525     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
526     - 0.99.10-rc1
527     - add fix for ssl detection
528     - add zlib-devel to BuildRequires
529     - change pam service name to dovecot
530     - include pam config
531    
532     * Thu May 8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
533     - update to 0.99.9.1
534     - add patch from upstream to fix potential bug when fetching with
535     CR+LF linefeeds
536     - tweak some things in the initscript and config file noticed by the
537     fedora folks
538    
539     * Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
540     - fix ssl dir
541     - own /var/run/dovecot/login with the correct perms
542     - fix chmod/chown in post
543    
544     * Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
545     - update to 0.99.8.1
546    
547     * Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
548     - add a patch to fix quoting problem from CVS
549    
550     * Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
551     - 0.99.8
552     - add some buildrequires
553     - fixup to build with openssl 0.9.7
554     - now includes a pop3 daemon (off by default)
555     - clean up description and %%preun
556     - add dovecot user (uid/gid of 97)
557     - add some buildrequires
558     - move the ssl cert to %{_datadir}/ssl/certs
559     - create a dummy ssl cert in %post
560     - own /var/run/dovecot
561     - make the config file a source so we get default mbox locks of fcntl
562    
563     * Sun Dec 1 2002 Seth Vidal <skvidal@phy.duke.edu>
564     - 0.99.4 and fix startup so it starts imap-master not vsftpd :)
565    
566     * Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
567     - first build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed