/[smeserver]/rpms/dovecot/sme7/dovecot.spec
ViewVC logotype

Annotation of /rpms/dovecot/sme7/dovecot.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Fri Sep 19 21:26:12 2008 UTC (15 years, 8 months ago) by slords
Branch: MAIN
CVS Tags: dovecot-1_0_7-2_el4_sme
Changes since 1.2: +45 -17 lines
Import COS5 version of dovecot

1 slords 1.3 %define upstream 1.0.7
2     %define pkg_version 1.0.7
3     %define my_release 2
4     %define pkg_release %{my_release}%{?dist}
5 slords 1.2
6 slords 1.1 Summary: Dovecot Secure imap server
7     Name: dovecot
8 slords 1.3 Version: %{pkg_version}
9     Release: %{pkg_release}
10 slords 1.1 License: LGPL
11     Group: System Environment/Daemons
12    
13     %define build_postgres 1
14     %define build_mysql 1
15    
16 slords 1.3 Source: http://dovecot.org/releases/%{name}-%{upstream}.tar.gz
17 slords 1.1 Source1: dovecot.init
18     Source2: dovecot.pam
19     Source3: maildir-migration.txt
20     Source4: migrate-folders
21     Source5: migrate-users
22     Source6: perfect_maildir.pl
23     Source7: dovecot-REDHAT-FAQ.txt
24 slords 1.3 Patch100: dovecot-1.0.7-default-settings.patch
25     #Patch101: dovecot-1.0.beta2-pam-tty.patch
26 slords 1.1 Patch102: dovecot-1.0.rc2-pam-setcred.patch
27     Patch103: dovecot-1.0.beta2-mkcert-permissions.patch
28 slords 1.3 #Patch104: dovecot-1.0.beta2-lib64.patch
29 slords 1.1 Patch105: dovecot-1.0.rc7-mkcert-paths.patch
30     #Patch105: dovecot-1.0.beta2-sqlite-check.patch
31    
32     # XXX this patch needs review and forward porting
33     #Patch105: dovecot-auth-log.patch
34    
35     # Patches 500+ from upstream fixes
36 slords 1.3 Patch500: dovecot-1.0-CVE-2007-6598.patch
37     Patch501: dovecot-1.0-CVE-2008-1199.patch
38    
39 slords 1.1 URL: http://www.dovecot.org/
40     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
41     BuildRequires: openssl-devel
42     BuildRequires: openldap-devel
43     BuildRequires: pam-devel
44     BuildRequires: pkgconfig
45     BuildRequires: zlib-devel
46     BuildRequires: libtool
47     BuildRequires: autoconf
48     BuildRequires: automake
49     BuildRequires: krb5-devel
50     # gettext-devel is needed for running autoconf because of the
51     # presence of AM_ICONV
52     BuildRequires: gettext-devel
53 slords 1.3 # Explicit Runtime Requirements
54     Requires: openssl >= 0.9.7a-43.17
55     # Package includes an initscript service file, needs to require initscripts package
56     Requires: initscripts
57     Requires(pre): /sbin/chkconfig, /usr/sbin/useradd, /sbin/service, /bin/touch, /bin/rm
58     Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig, /bin/mv, /bin/rm
59     Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel, /sbin/chkconfig, /sbin/service
60 slords 1.1
61     %if %{build_postgres}
62     BuildRequires: postgresql-devel
63     %endif
64    
65     %if %{build_mysql}
66     BuildRequires: mysql-devel
67     %endif
68    
69     %define docdir %{_docdir}/%{name}
70     %define ssldir %{_sysconfdir}/pki/%{name}
71     %define restart_flag /var/run/%{name}-restart-after-rpm-install
72     %define dovecot_uid 97
73     %define dovecot_gid 97
74    
75     %description
76     Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
77     primarily in mind. It also contains a small POP3 server. It supports mail
78     in either of maildir or mbox formats.
79    
80     %prep
81    
82     %setup -q -n %{name}-%{upstream}
83    
84     %patch100 -p1 -b .default-settings
85 slords 1.3 #%patch101 -p2 -b .pam-tty
86 slords 1.1 %patch102 -p1 -b .pam-setcred
87     %patch103 -p1 -b .mkcert-permissions
88     #%patch104 -p1 -b .lib64
89     %patch105 -p1 -b .mkcert-paths
90 slords 1.3 %patch500 -p1 -b .CVE-2007-6598
91     %patch501 -p1 -b .CVE-2008-1199
92 slords 1.1
93     %build
94     rm -f ./configure
95     libtoolize -f
96     autoreconf
97     %configure \
98     INSTALL_DATA="install -c -p -m644" \
99     --with-doc \
100     %if %{build_postgres}
101     --with-pgsql \
102     %endif
103     %if %{build_mysql}
104     --with-mysql \
105     %endif
106     --with-ssl=openssl \
107     --with-ssldir=%{ssldir} \
108     --with-ldap \
109     --with-inotify \
110     --with-gssapi
111    
112 slords 1.3 make %{?_smp_mflags}
113 slords 1.1
114     %install
115     rm -rf $RPM_BUILD_ROOT
116     make install DESTDIR=$RPM_BUILD_ROOT
117     rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}
118     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
119     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/dovecot
120    
121     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
122     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/dovecot
123    
124     # generate ghost .pem file
125     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/certs
126     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/private
127     touch $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
128     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
129     touch $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
130     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
131    
132     mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
133     chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
134     chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
135    
136     # Install dovecot.conf and dovecot-openssl.cnf
137     mkdir -p $RPM_BUILD_ROOT/%{ssldir}
138     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/dovecot-example.conf $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot.conf
139 slords 1.3 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
140 slords 1.1 install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/dovecot-openssl.cnf $RPM_BUILD_ROOT/%{ssldir}/dovecot-openssl.cnf
141    
142     # Install some of our own documentation
143 slords 1.3 install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
144    
145     # Install the licensing files into the documentation area
146     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING $RPM_BUILD_ROOT%{docdir}/COPYING
147     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING.MIT $RPM_BUILD_ROOT%{docdir}/COPYING.MIT
148     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING.LGPL $RPM_BUILD_ROOT%{docdir}/COPYING.LGPL
149 slords 1.1
150     mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
151     install -p -m755 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/mkcert.sh $RPM_BUILD_ROOT%{docdir}/examples/mkcert.sh
152     for f in `cd $RPM_BUILD_DIR/dovecot-%{upstream}/doc; echo *.conf`; do
153     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
154     done
155    
156     install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
157 slords 1.3 for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
158 slords 1.1 do
159 slords 1.3 install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
160 slords 1.1 done
161    
162     mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
163     mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
164    
165     %pre
166     /usr/sbin/useradd -c "dovecot" -u %{dovecot_uid} -s /sbin/nologin -r -d /usr/libexec/dovecot dovecot 2>/dev/null || :
167    
168     # stop service during installation, keep flag if it was running to restart later
169     rm -f %{restart_flag}
170     /sbin/service %{name} status >/dev/null 2>&1
171     if [ $? -eq 0 ]; then
172     touch %{restart_flag}
173     /sbin/service %{name} stop >/dev/null 2>&1
174     fi
175    
176     %post
177     /sbin/chkconfig --add %{name}
178     # create a ssl cert
179     if [ -f %{ssldir}/%{name}.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
180     mv %{ssldir}/%{name}.pem %{ssldir}/certs/%{name}.pem
181     else
182     if [ -f /usr/share/ssl/certs/dovecot.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
183     mv /usr/share/ssl/certs/dovecot.pem %{ssldir}/certs/%{name}.pem
184     fi
185     if [ -f /usr/share/ssl/private/dovecot.pem -a ! -e %{ssldir}/private/%{name}.pem ]; then
186     mv /usr/share/ssl/private/dovecot.pem %{ssldir}/private/%{name}.pem
187     fi
188     fi
189     if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
190     SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
191     %{docdir}-%{version}/examples/mkcert.sh &> /dev/null
192     fi
193    
194     if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
195     dovecot --build-ssl-parameters &>/dev/null
196     fi
197    
198     # Restart if it had been running before installation
199     if [ -e %{restart_flag} ]; then
200     rm %{restart_flag}
201     /sbin/service %{name} start >/dev/null 2>&1
202     fi
203     exit 0
204    
205    
206     %preun
207     if [ $1 = 0 ]; then
208     /usr/sbin/userdel dovecot 2>/dev/null || :
209     /usr/sbin/groupdel dovecot 2>/dev/null || :
210     [ -f /var/lock/subsys/%{name} ] && /sbin/service %{name} stop > /dev/null 2>&1
211     /sbin/chkconfig --del %{name}
212     fi
213    
214     %clean
215     rm -rf $RPM_BUILD_ROOT
216    
217     %files
218     %defattr(-,root,root)
219     %doc %{docdir}-%{version}
220     %config(noreplace) %{_sysconfdir}/dovecot.conf
221     %config %{_sysconfdir}/rc.d/init.d/dovecot
222 slords 1.3 %config(noreplace) %{_sysconfdir}/pam.d/dovecot
223     %dir %{ssldir}
224     %dir %{ssldir}/certs
225 slords 1.1 %config(noreplace) %{ssldir}/dovecot-openssl.cnf
226     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
227     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
228     %{_libexecdir}/%{name}
229     %{_libdir}/%{name}
230     %{_sbindir}/dovecot
231     %{_sbindir}/dovecotpw
232     %attr(0755,root,dovecot) %dir /var/run/dovecot
233     %attr(0750,root,dovecot) %dir /var/run/dovecot/login
234     %attr(0750,root,dovecot) %{docdir}-%{version}/examples/mkcert.sh
235     %attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
236    
237    
238     %changelog
239 slords 1.3 * Thu Mar 13 2008 Tomas Janousek <tjanouse@redhat.com> - 1.0.7-2
240     - LDAP+auth cache user login mixup (CVE-2007-6598, #427575)
241     - insecure mail_extra_groups option (CVE-2008-1199, #436927)
242    
243     * Mon Nov 26 2007 Tomas Janousek <tjanouse@redhat.com> - 1.0.7-1
244     - update to latest upstream, fixes a few bugs (#331441, #245249), plus two
245     security vulnerabilities (CVE-2007-2231, CVE-2007-4211)
246     - increased default login_process_size to 64 (#253363)
247    
248 slords 1.1 * Fri Dec 22 2006 Tomas Janousek <tjanouse@redhat.com> - 1.0-1.2.rc15
249     - reenabled GSSAPI (#220582)
250    
251     * Tue Nov 21 2006 Petr Rockai <prockai@redhat.com> - 1.0-1.rc15
252     - update to latest upstream, fixes a few bugs, plus a security
253     vulnerability (#216510, CVE-2006-5973)
254    
255     * Tue Oct 10 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.3.rc7
256     - fix few inconsistencies in specfile, fixes #198940
257    
258     * Wed Oct 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.2.rc7
259     - fix default paths in the example mkcert.sh to match configuration
260     defaults (fixes #183151)
261    
262     * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.1.rc7
263     - rebuilt for unwind info generation, broken in gcc-4.1.1-21
264    
265     * Fri Sep 22 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc7
266     - update to latest upstream release candidate, should fix occasional
267     hangs and mbox issues... INBOX. namespace is still broken though
268     - do not run over symlinked certificates in new locations on upgrade
269    
270     * Tue Aug 15 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.2
271     - include /var/lib/dovecot in the package, prevents startup failure
272     on new installs
273    
274     * Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
275     - reenable inotify and see what happens
276    
277     * Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
278     - update to latest upstream release candidate
279     - disable inotify for now, doesn't build -- this needs fixing though
280    
281     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
282     - rebuild
283    
284     * Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
285     - put back pop3_uidl_format default that got lost
286     in the beta2->beta7 upgrade (would cause pop3 to not work
287     at all in many situations)
288    
289     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
290     - upgrade to latest upstream beta release (beta8)
291     - contains a security fix in mbox handling
292    
293     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
294     - upgrade to latest upstream beta release
295     - fixed BR 173048
296    
297     * Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
298     - fix sqlite detection in upstream configure checks, second part
299     of #182240
300    
301     * Wed Mar 8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
302     - fix scriplet noise some more
303    
304     * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
305     - fix scriptlet error (mitr, #184151)
306    
307     * Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
308     - fix #182240 by looking in lib64 for libs first and then lib
309     - fix comment #1 in #182240 by copying over the example config files
310     to documentation directory
311    
312     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
313     - bump again for double-long bug on ppc(64)
314    
315     * Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
316     - enable inotify as it should work now (#179431)
317    
318     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
319     - rebuilt for new gcc4.1 snapshot and glibc changes
320    
321     * Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
322     - change the compiled-in defaults and adjust the default's configfile
323     commented-out example settings to match compiled-in defaults,
324     instead of changing the defaults only in the configfile, as per #179432
325     - fix #179574 by providing a default uidl_format for pop3
326     - half-fix #179620 by having plaintext auth enabled by default... this
327     needs more thinking (which one we really want) and documentation
328     either way
329    
330     * Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
331     - update URL in description
332     - call dovecot --build-ssl-parameters in postinst as per #179430
333    
334     * Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
335     - fix spec to work with BUILD_DIR != SOURCE_DIR
336     - forward-port and split pam-nocred patch
337    
338     * Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
339     - new upstream version, hopefully fixes #173928, #163550
340     - fix #168866, use install -p to install documentation
341    
342     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
343     - rebuilt
344    
345     * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
346     - Rebuild due to mysql update.
347    
348     * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
349     - rebuilt with new openssl
350    
351     * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
352     - use include instead of pam_stack in pam config
353    
354     * Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
355     - fix bug #150888, log authenication failures with ip address
356    
357     * Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
358     - fix bug #149673, add dummy PAM_TTY
359    
360     * Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
361     - fix bug #156159 insecure location of restart flag file
362    
363     * Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
364     - openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
365    
366     * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
367     - Rebuild for Postgres 8.0.2 (new libpq major version).
368    
369     * Mon Mar 7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
370     - bump rev for gcc4 build
371    
372     * Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
373     - fix bug #147874, update to 0.99.14 release
374     v0.99.14 2005-02-11 Timo Sirainen <tss at iki.fi>
375     - Message address fields are now parsed differently, fixing some
376     issues with spaces. Affects only clients which use FETCH ENVELOPE
377     command.
378     - Message MIME parser was somewhat broken with missing MIME boundaries
379     - mbox: Don't allow X-UID headers in mails to override the UIDs we
380     would otherwise set. Too large values can break some clients and
381     cause other trouble.
382     - passwd-file userdb wasn't working
383     - PAM crashed with 64bit systems
384     - non-SSL inetd startup wasn't working
385     - If UID FETCH notices and skips an expunged message, don't return
386     a NO reply. It's not needed and only makes clients give error
387     messages.
388    
389     * Wed Feb 2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
390     - fix bug #146198, clean up temp kerberos tickets
391    
392     * Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
393     - fix bug #145214, force mbox_locks to fcntl only
394     - fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
395     dependency generator to pick up client lib dependency if needed.
396    
397     * Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
398     - make postgres & mysql conditional build
399     - remove execute bit on migration example scripts so rpm does not pull
400     in additional dependences on perl and perl modules that are not present
401     in dovecot proper.
402     - add REDHAT-FAQ.txt to doc directory
403    
404     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
405     - bring up to date with latest upstream, 0.99.13, bug #143707
406     also fix bug #14462, bad dovecot-uid macro name
407    
408     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
409     - fix bug #133618, removed LITERAL+ capability from capability string
410    
411     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
412     - fix bug #134325, stop dovecot during installation
413    
414     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
415     - fix bug #129539, dovecot starts too early,
416     set chkconfig to 65 35 to match cyrus-imapd
417     - also delete some old commented out code from SSL certificate creation
418    
419     * Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
420     - add UW to Dovecot migration documentation and scripts, bug #139954
421     fix SSL documentation and scripts, add missing documentation, bug #139276
422    
423     * Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
424     - rebuild against MySQL4
425    
426     * Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
427     - fix bug #136623
428     Change License field from GPL to LGPL to reflect actual license
429    
430     * Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
431     - fix bug #124786, listen to ipv6 as well as ipv4
432    
433     * Wed Sep 8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
434     - bring up to latest upstream,
435     comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04
436     + 127.* and ::1 IP addresses are treated as secured with
437     disable_plaintext_auth = yes
438     + auth_debug setting for extra authentication debugging
439     + Some documentation and error message updates
440     + Create PID file in /var/run/dovecot/master.pid
441     + home setting is now optional in static userdb
442     + Added mail setting to static userdb
443     - After APPENDing to selected mailbox Dovecot didn't always notice the
444     new mail immediately which broke some clients
445     - THREAD and SORT commands crashed with some mails
446     - If APPENDed mail ended with CR character, Dovecot aborted the saving
447     - Output streams sometimes sent data duplicated and lost part of it.
448     This could have caused various strange problems, but looks like in
449     practise it rarely caused real problems.
450    
451     * Wed Aug 4 2004 John Dennis <jdennis@redhat.com>
452     - change release field separator from comma to dot, bump build number
453    
454     * Mon Aug 2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
455     - bring up to date with latest upstream, fixes include:
456     - LDAP support compiles now with Solaris LDAP library
457     - IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
458     didn't contain Content-Type header.
459     - MySQL and PostgreSQL auth didn't reconnect if connection was lost
460     to SQL server
461     - Linking fixes for dovecot-auth with some systems
462     - Last fix for disconnecting client when downloading mail longer than
463     30 seconds actually made it never disconnect client. Now it works
464     properly: disconnect when client hasn't read _any_ data for 30
465     seconds.
466     - MySQL compiling got broken in last release
467     - More PostgreSQL reconnection fixing
468    
469    
470     * Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
471     - enable postgres and mySQL in build
472     - fix configure to look for mysql in alternate locations
473     - nuke configure script in tar file, recreate from configure.in using autoconf
474    
475     - bring up to latest upstream, which included:
476     - Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
477     - Config file lines can now contain quoted strings ("value ")
478     - If client didn't finish downloading a single mail in 30 seconds,
479     Dovecot closed the connection. This was supposed to work so that
480     if client hasn't read data at all in 30 seconds, it's disconnected.
481     - Maildir: LIST now doesn't skip symlinks
482    
483    
484     * Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
485     - bump rev for build
486     - change rev for FC3 build
487    
488     * Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
489     - bring up to date with upstream,
490     recent change log comments from Timo Sirainen were:
491     SHA1 password support using OpenSSL crypto library
492     mail_extra_groups setting
493     maildir_stat_dirs setting
494     Added NAMESPACE capability and command
495     Autocreate missing maildirs (instead of crashing)
496     Fixed occational crash in maildir synchronization
497     Fixed occational assertion crash in ioloop.c
498     Fixed FreeBSD compiling issue
499     Fixed issues with 64bit Solaris binary
500    
501     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
502     - rebuilt
503    
504     * Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
505     - Update to 0.99.10.5 to fix maildir segfaults (#123022)
506    
507     * Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
508     - default auth config that is actually usable
509     - Timo Sirainen (author) suggested functionality fixes
510     maildir, imap-fetch-body-section, customflags-fix
511    
512     * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
513     - Use ':' instead of '.' as separator for chown.
514    
515     * Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
516     - restart properly if it dies (#115594)
517    
518     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
519     - rebuilt
520    
521     * Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
522     - update to 0.99.10.4
523    
524     * Mon Oct 6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
525     - another patch from upstream to fix returning invalid data on partial
526     BODY[part] fetches
527     - patch to avoid confusion of draft/deleted in indexes
528    
529     * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
530     - add some patches from upstream (#104288)
531    
532     * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
533     - fix startup with 2.6 with patch from upstream (#103801)
534    
535     * Tue Sep 2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
536     - fix assert in search code (#103383)
537    
538     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
539     - rebuild
540    
541     * Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
542     - don't run by default
543    
544     * Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
545     - 0.99.10
546    
547     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
548     - 0.99.10-rc2 (includes ssl detection fix)
549     - a few tweaks from fedora
550     - noreplace the config file
551     - configure --with-ldap to get LDAP enabled
552    
553     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
554     - 0.99.10-rc1
555     - add fix for ssl detection
556     - add zlib-devel to BuildRequires
557     - change pam service name to dovecot
558     - include pam config
559    
560     * Thu May 8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
561     - update to 0.99.9.1
562     - add patch from upstream to fix potential bug when fetching with
563     CR+LF linefeeds
564     - tweak some things in the initscript and config file noticed by the
565     fedora folks
566    
567     * Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
568     - fix ssl dir
569     - own /var/run/dovecot/login with the correct perms
570     - fix chmod/chown in post
571    
572     * Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
573     - update to 0.99.8.1
574    
575     * Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
576     - add a patch to fix quoting problem from CVS
577    
578     * Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
579     - 0.99.8
580     - add some buildrequires
581     - fixup to build with openssl 0.9.7
582     - now includes a pop3 daemon (off by default)
583     - clean up description and %%preun
584     - add dovecot user (uid/gid of 97)
585     - add some buildrequires
586     - move the ssl cert to %{_datadir}/ssl/certs
587     - create a dummy ssl cert in %post
588     - own /var/run/dovecot
589     - make the config file a source so we get default mbox locks of fcntl
590    
591     * Sun Dec 1 2002 Seth Vidal <skvidal@phy.duke.edu>
592     - 0.99.4 and fix startup so it starts imap-master not vsftpd :)
593    
594     * Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
595     - first build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed