/[smeserver]/rpms/dovecot/sme7/dovecot.spec
ViewVC logotype

Annotation of /rpms/dovecot/sme7/dovecot.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Thu Mar 4 16:31:07 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +2 -0 lines
Fix headers

1 slords 1.4 # $Id$
2    
3 slords 1.3 %define upstream 1.0.7
4     %define pkg_version 1.0.7
5     %define my_release 2
6     %define pkg_release %{my_release}%{?dist}
7 slords 1.2
8 slords 1.1 Summary: Dovecot Secure imap server
9     Name: dovecot
10 slords 1.3 Version: %{pkg_version}
11     Release: %{pkg_release}
12 slords 1.1 License: LGPL
13     Group: System Environment/Daemons
14    
15     %define build_postgres 1
16     %define build_mysql 1
17    
18 slords 1.3 Source: http://dovecot.org/releases/%{name}-%{upstream}.tar.gz
19 slords 1.1 Source1: dovecot.init
20     Source2: dovecot.pam
21     Source3: maildir-migration.txt
22     Source4: migrate-folders
23     Source5: migrate-users
24     Source6: perfect_maildir.pl
25     Source7: dovecot-REDHAT-FAQ.txt
26 slords 1.3 Patch100: dovecot-1.0.7-default-settings.patch
27     #Patch101: dovecot-1.0.beta2-pam-tty.patch
28 slords 1.1 Patch102: dovecot-1.0.rc2-pam-setcred.patch
29     Patch103: dovecot-1.0.beta2-mkcert-permissions.patch
30 slords 1.3 #Patch104: dovecot-1.0.beta2-lib64.patch
31 slords 1.1 Patch105: dovecot-1.0.rc7-mkcert-paths.patch
32     #Patch105: dovecot-1.0.beta2-sqlite-check.patch
33    
34     # XXX this patch needs review and forward porting
35     #Patch105: dovecot-auth-log.patch
36    
37     # Patches 500+ from upstream fixes
38 slords 1.3 Patch500: dovecot-1.0-CVE-2007-6598.patch
39     Patch501: dovecot-1.0-CVE-2008-1199.patch
40    
41 slords 1.1 URL: http://www.dovecot.org/
42     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
43     BuildRequires: openssl-devel
44     BuildRequires: openldap-devel
45     BuildRequires: pam-devel
46     BuildRequires: pkgconfig
47     BuildRequires: zlib-devel
48     BuildRequires: libtool
49     BuildRequires: autoconf
50     BuildRequires: automake
51     BuildRequires: krb5-devel
52     # gettext-devel is needed for running autoconf because of the
53     # presence of AM_ICONV
54     BuildRequires: gettext-devel
55 slords 1.3 # Explicit Runtime Requirements
56     Requires: openssl >= 0.9.7a-43.17
57     # Package includes an initscript service file, needs to require initscripts package
58     Requires: initscripts
59     Requires(pre): /sbin/chkconfig, /usr/sbin/useradd, /sbin/service, /bin/touch, /bin/rm
60     Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig, /bin/mv, /bin/rm
61     Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel, /sbin/chkconfig, /sbin/service
62 slords 1.1
63     %if %{build_postgres}
64     BuildRequires: postgresql-devel
65     %endif
66    
67     %if %{build_mysql}
68     BuildRequires: mysql-devel
69     %endif
70    
71     %define docdir %{_docdir}/%{name}
72     %define ssldir %{_sysconfdir}/pki/%{name}
73     %define restart_flag /var/run/%{name}-restart-after-rpm-install
74     %define dovecot_uid 97
75     %define dovecot_gid 97
76    
77     %description
78     Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
79     primarily in mind. It also contains a small POP3 server. It supports mail
80     in either of maildir or mbox formats.
81    
82     %prep
83    
84     %setup -q -n %{name}-%{upstream}
85    
86     %patch100 -p1 -b .default-settings
87 slords 1.3 #%patch101 -p2 -b .pam-tty
88 slords 1.1 %patch102 -p1 -b .pam-setcred
89     %patch103 -p1 -b .mkcert-permissions
90     #%patch104 -p1 -b .lib64
91     %patch105 -p1 -b .mkcert-paths
92 slords 1.3 %patch500 -p1 -b .CVE-2007-6598
93     %patch501 -p1 -b .CVE-2008-1199
94 slords 1.1
95     %build
96     rm -f ./configure
97     libtoolize -f
98     autoreconf
99     %configure \
100     INSTALL_DATA="install -c -p -m644" \
101     --with-doc \
102     %if %{build_postgres}
103     --with-pgsql \
104     %endif
105     %if %{build_mysql}
106     --with-mysql \
107     %endif
108     --with-ssl=openssl \
109     --with-ssldir=%{ssldir} \
110     --with-ldap \
111     --with-inotify \
112     --with-gssapi
113    
114 slords 1.3 make %{?_smp_mflags}
115 slords 1.1
116     %install
117     rm -rf $RPM_BUILD_ROOT
118     make install DESTDIR=$RPM_BUILD_ROOT
119     rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}
120     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
121     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/dovecot
122    
123     mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
124     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/dovecot
125    
126     # generate ghost .pem file
127     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/certs
128     mkdir -p $RPM_BUILD_ROOT/%{ssldir}/private
129     touch $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
130     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/certs/dovecot.pem
131     touch $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
132     chmod 600 $RPM_BUILD_ROOT/%{ssldir}/private/dovecot.pem
133    
134     mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
135     chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
136     chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
137    
138     # Install dovecot.conf and dovecot-openssl.cnf
139     mkdir -p $RPM_BUILD_ROOT/%{ssldir}
140     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/dovecot-example.conf $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot.conf
141 slords 1.3 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
142 slords 1.1 install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/dovecot-openssl.cnf $RPM_BUILD_ROOT/%{ssldir}/dovecot-openssl.cnf
143    
144     # Install some of our own documentation
145 slords 1.3 install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
146    
147     # Install the licensing files into the documentation area
148     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING $RPM_BUILD_ROOT%{docdir}/COPYING
149     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING.MIT $RPM_BUILD_ROOT%{docdir}/COPYING.MIT
150     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/COPYING.LGPL $RPM_BUILD_ROOT%{docdir}/COPYING.LGPL
151 slords 1.1
152     mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
153     install -p -m755 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/mkcert.sh $RPM_BUILD_ROOT%{docdir}/examples/mkcert.sh
154     for f in `cd $RPM_BUILD_DIR/dovecot-%{upstream}/doc; echo *.conf`; do
155     install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
156     done
157    
158     install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
159 slords 1.3 for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
160 slords 1.1 do
161 slords 1.3 install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
162 slords 1.1 done
163    
164     mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
165     mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
166    
167     %pre
168     /usr/sbin/useradd -c "dovecot" -u %{dovecot_uid} -s /sbin/nologin -r -d /usr/libexec/dovecot dovecot 2>/dev/null || :
169    
170     # stop service during installation, keep flag if it was running to restart later
171     rm -f %{restart_flag}
172     /sbin/service %{name} status >/dev/null 2>&1
173     if [ $? -eq 0 ]; then
174     touch %{restart_flag}
175     /sbin/service %{name} stop >/dev/null 2>&1
176     fi
177    
178     %post
179     /sbin/chkconfig --add %{name}
180     # create a ssl cert
181     if [ -f %{ssldir}/%{name}.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
182     mv %{ssldir}/%{name}.pem %{ssldir}/certs/%{name}.pem
183     else
184     if [ -f /usr/share/ssl/certs/dovecot.pem -a ! -e %{ssldir}/certs/%{name}.pem ]; then
185     mv /usr/share/ssl/certs/dovecot.pem %{ssldir}/certs/%{name}.pem
186     fi
187     if [ -f /usr/share/ssl/private/dovecot.pem -a ! -e %{ssldir}/private/%{name}.pem ]; then
188     mv /usr/share/ssl/private/dovecot.pem %{ssldir}/private/%{name}.pem
189     fi
190     fi
191     if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
192     SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
193     %{docdir}-%{version}/examples/mkcert.sh &> /dev/null
194     fi
195    
196     if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
197     dovecot --build-ssl-parameters &>/dev/null
198     fi
199    
200     # Restart if it had been running before installation
201     if [ -e %{restart_flag} ]; then
202     rm %{restart_flag}
203     /sbin/service %{name} start >/dev/null 2>&1
204     fi
205     exit 0
206    
207    
208     %preun
209     if [ $1 = 0 ]; then
210     /usr/sbin/userdel dovecot 2>/dev/null || :
211     /usr/sbin/groupdel dovecot 2>/dev/null || :
212     [ -f /var/lock/subsys/%{name} ] && /sbin/service %{name} stop > /dev/null 2>&1
213     /sbin/chkconfig --del %{name}
214     fi
215    
216     %clean
217     rm -rf $RPM_BUILD_ROOT
218    
219     %files
220     %defattr(-,root,root)
221     %doc %{docdir}-%{version}
222     %config(noreplace) %{_sysconfdir}/dovecot.conf
223     %config %{_sysconfdir}/rc.d/init.d/dovecot
224 slords 1.3 %config(noreplace) %{_sysconfdir}/pam.d/dovecot
225     %dir %{ssldir}
226     %dir %{ssldir}/certs
227 slords 1.1 %config(noreplace) %{ssldir}/dovecot-openssl.cnf
228     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
229     %attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
230     %{_libexecdir}/%{name}
231     %{_libdir}/%{name}
232     %{_sbindir}/dovecot
233     %{_sbindir}/dovecotpw
234     %attr(0755,root,dovecot) %dir /var/run/dovecot
235     %attr(0750,root,dovecot) %dir /var/run/dovecot/login
236     %attr(0750,root,dovecot) %{docdir}-%{version}/examples/mkcert.sh
237     %attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
238    
239    
240     %changelog
241 slords 1.3 * Thu Mar 13 2008 Tomas Janousek <tjanouse@redhat.com> - 1.0.7-2
242     - LDAP+auth cache user login mixup (CVE-2007-6598, #427575)
243     - insecure mail_extra_groups option (CVE-2008-1199, #436927)
244    
245     * Mon Nov 26 2007 Tomas Janousek <tjanouse@redhat.com> - 1.0.7-1
246     - update to latest upstream, fixes a few bugs (#331441, #245249), plus two
247     security vulnerabilities (CVE-2007-2231, CVE-2007-4211)
248     - increased default login_process_size to 64 (#253363)
249    
250 slords 1.1 * Fri Dec 22 2006 Tomas Janousek <tjanouse@redhat.com> - 1.0-1.2.rc15
251     - reenabled GSSAPI (#220582)
252    
253     * Tue Nov 21 2006 Petr Rockai <prockai@redhat.com> - 1.0-1.rc15
254     - update to latest upstream, fixes a few bugs, plus a security
255     vulnerability (#216510, CVE-2006-5973)
256    
257     * Tue Oct 10 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.3.rc7
258     - fix few inconsistencies in specfile, fixes #198940
259    
260     * Wed Oct 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.2.rc7
261     - fix default paths in the example mkcert.sh to match configuration
262     defaults (fixes #183151)
263    
264     * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.1.rc7
265     - rebuilt for unwind info generation, broken in gcc-4.1.1-21
266    
267     * Fri Sep 22 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc7
268     - update to latest upstream release candidate, should fix occasional
269     hangs and mbox issues... INBOX. namespace is still broken though
270     - do not run over symlinked certificates in new locations on upgrade
271    
272     * Tue Aug 15 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.2
273     - include /var/lib/dovecot in the package, prevents startup failure
274     on new installs
275    
276     * Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
277     - reenable inotify and see what happens
278    
279     * Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
280     - update to latest upstream release candidate
281     - disable inotify for now, doesn't build -- this needs fixing though
282    
283     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
284     - rebuild
285    
286     * Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
287     - put back pop3_uidl_format default that got lost
288     in the beta2->beta7 upgrade (would cause pop3 to not work
289     at all in many situations)
290    
291     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
292     - upgrade to latest upstream beta release (beta8)
293     - contains a security fix in mbox handling
294    
295     * Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
296     - upgrade to latest upstream beta release
297     - fixed BR 173048
298    
299     * Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
300     - fix sqlite detection in upstream configure checks, second part
301     of #182240
302    
303     * Wed Mar 8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
304     - fix scriplet noise some more
305    
306     * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
307     - fix scriptlet error (mitr, #184151)
308    
309     * Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
310     - fix #182240 by looking in lib64 for libs first and then lib
311     - fix comment #1 in #182240 by copying over the example config files
312     to documentation directory
313    
314     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
315     - bump again for double-long bug on ppc(64)
316    
317     * Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
318     - enable inotify as it should work now (#179431)
319    
320     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
321     - rebuilt for new gcc4.1 snapshot and glibc changes
322    
323     * Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
324     - change the compiled-in defaults and adjust the default's configfile
325     commented-out example settings to match compiled-in defaults,
326     instead of changing the defaults only in the configfile, as per #179432
327     - fix #179574 by providing a default uidl_format for pop3
328     - half-fix #179620 by having plaintext auth enabled by default... this
329     needs more thinking (which one we really want) and documentation
330     either way
331    
332     * Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
333     - update URL in description
334     - call dovecot --build-ssl-parameters in postinst as per #179430
335    
336     * Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
337     - fix spec to work with BUILD_DIR != SOURCE_DIR
338     - forward-port and split pam-nocred patch
339    
340     * Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
341     - new upstream version, hopefully fixes #173928, #163550
342     - fix #168866, use install -p to install documentation
343    
344     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
345     - rebuilt
346    
347     * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
348     - Rebuild due to mysql update.
349    
350     * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
351     - rebuilt with new openssl
352    
353     * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
354     - use include instead of pam_stack in pam config
355    
356     * Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
357     - fix bug #150888, log authenication failures with ip address
358    
359     * Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
360     - fix bug #149673, add dummy PAM_TTY
361    
362     * Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
363     - fix bug #156159 insecure location of restart flag file
364    
365     * Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
366     - openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
367    
368     * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
369     - Rebuild for Postgres 8.0.2 (new libpq major version).
370    
371     * Mon Mar 7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
372     - bump rev for gcc4 build
373    
374     * Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
375     - fix bug #147874, update to 0.99.14 release
376     v0.99.14 2005-02-11 Timo Sirainen <tss at iki.fi>
377     - Message address fields are now parsed differently, fixing some
378     issues with spaces. Affects only clients which use FETCH ENVELOPE
379     command.
380     - Message MIME parser was somewhat broken with missing MIME boundaries
381     - mbox: Don't allow X-UID headers in mails to override the UIDs we
382     would otherwise set. Too large values can break some clients and
383     cause other trouble.
384     - passwd-file userdb wasn't working
385     - PAM crashed with 64bit systems
386     - non-SSL inetd startup wasn't working
387     - If UID FETCH notices and skips an expunged message, don't return
388     a NO reply. It's not needed and only makes clients give error
389     messages.
390    
391     * Wed Feb 2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
392     - fix bug #146198, clean up temp kerberos tickets
393    
394     * Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
395     - fix bug #145214, force mbox_locks to fcntl only
396     - fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
397     dependency generator to pick up client lib dependency if needed.
398    
399     * Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
400     - make postgres & mysql conditional build
401     - remove execute bit on migration example scripts so rpm does not pull
402     in additional dependences on perl and perl modules that are not present
403     in dovecot proper.
404     - add REDHAT-FAQ.txt to doc directory
405    
406     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
407     - bring up to date with latest upstream, 0.99.13, bug #143707
408     also fix bug #14462, bad dovecot-uid macro name
409    
410     * Thu Jan 6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
411     - fix bug #133618, removed LITERAL+ capability from capability string
412    
413     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
414     - fix bug #134325, stop dovecot during installation
415    
416     * Wed Jan 5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
417     - fix bug #129539, dovecot starts too early,
418     set chkconfig to 65 35 to match cyrus-imapd
419     - also delete some old commented out code from SSL certificate creation
420    
421     * Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
422     - add UW to Dovecot migration documentation and scripts, bug #139954
423     fix SSL documentation and scripts, add missing documentation, bug #139276
424    
425     * Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
426     - rebuild against MySQL4
427    
428     * Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
429     - fix bug #136623
430     Change License field from GPL to LGPL to reflect actual license
431    
432     * Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
433     - fix bug #124786, listen to ipv6 as well as ipv4
434    
435     * Wed Sep 8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
436     - bring up to latest upstream,
437     comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04
438     + 127.* and ::1 IP addresses are treated as secured with
439     disable_plaintext_auth = yes
440     + auth_debug setting for extra authentication debugging
441     + Some documentation and error message updates
442     + Create PID file in /var/run/dovecot/master.pid
443     + home setting is now optional in static userdb
444     + Added mail setting to static userdb
445     - After APPENDing to selected mailbox Dovecot didn't always notice the
446     new mail immediately which broke some clients
447     - THREAD and SORT commands crashed with some mails
448     - If APPENDed mail ended with CR character, Dovecot aborted the saving
449     - Output streams sometimes sent data duplicated and lost part of it.
450     This could have caused various strange problems, but looks like in
451     practise it rarely caused real problems.
452    
453     * Wed Aug 4 2004 John Dennis <jdennis@redhat.com>
454     - change release field separator from comma to dot, bump build number
455    
456     * Mon Aug 2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
457     - bring up to date with latest upstream, fixes include:
458     - LDAP support compiles now with Solaris LDAP library
459     - IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
460     didn't contain Content-Type header.
461     - MySQL and PostgreSQL auth didn't reconnect if connection was lost
462     to SQL server
463     - Linking fixes for dovecot-auth with some systems
464     - Last fix for disconnecting client when downloading mail longer than
465     30 seconds actually made it never disconnect client. Now it works
466     properly: disconnect when client hasn't read _any_ data for 30
467     seconds.
468     - MySQL compiling got broken in last release
469     - More PostgreSQL reconnection fixing
470    
471    
472     * Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
473     - enable postgres and mySQL in build
474     - fix configure to look for mysql in alternate locations
475     - nuke configure script in tar file, recreate from configure.in using autoconf
476    
477     - bring up to latest upstream, which included:
478     - Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
479     - Config file lines can now contain quoted strings ("value ")
480     - If client didn't finish downloading a single mail in 30 seconds,
481     Dovecot closed the connection. This was supposed to work so that
482     if client hasn't read data at all in 30 seconds, it's disconnected.
483     - Maildir: LIST now doesn't skip symlinks
484    
485    
486     * Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
487     - bump rev for build
488     - change rev for FC3 build
489    
490     * Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
491     - bring up to date with upstream,
492     recent change log comments from Timo Sirainen were:
493     SHA1 password support using OpenSSL crypto library
494     mail_extra_groups setting
495     maildir_stat_dirs setting
496     Added NAMESPACE capability and command
497     Autocreate missing maildirs (instead of crashing)
498     Fixed occational crash in maildir synchronization
499     Fixed occational assertion crash in ioloop.c
500     Fixed FreeBSD compiling issue
501     Fixed issues with 64bit Solaris binary
502    
503     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
504     - rebuilt
505    
506     * Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
507     - Update to 0.99.10.5 to fix maildir segfaults (#123022)
508    
509     * Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
510     - default auth config that is actually usable
511     - Timo Sirainen (author) suggested functionality fixes
512     maildir, imap-fetch-body-section, customflags-fix
513    
514     * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
515     - Use ':' instead of '.' as separator for chown.
516    
517     * Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
518     - restart properly if it dies (#115594)
519    
520     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
521     - rebuilt
522    
523     * Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
524     - update to 0.99.10.4
525    
526     * Mon Oct 6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
527     - another patch from upstream to fix returning invalid data on partial
528     BODY[part] fetches
529     - patch to avoid confusion of draft/deleted in indexes
530    
531     * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
532     - add some patches from upstream (#104288)
533    
534     * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
535     - fix startup with 2.6 with patch from upstream (#103801)
536    
537     * Tue Sep 2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
538     - fix assert in search code (#103383)
539    
540     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
541     - rebuild
542    
543     * Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
544     - don't run by default
545    
546     * Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
547     - 0.99.10
548    
549     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
550     - 0.99.10-rc2 (includes ssl detection fix)
551     - a few tweaks from fedora
552     - noreplace the config file
553     - configure --with-ldap to get LDAP enabled
554    
555     * Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
556     - 0.99.10-rc1
557     - add fix for ssl detection
558     - add zlib-devel to BuildRequires
559     - change pam service name to dovecot
560     - include pam config
561    
562     * Thu May 8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
563     - update to 0.99.9.1
564     - add patch from upstream to fix potential bug when fetching with
565     CR+LF linefeeds
566     - tweak some things in the initscript and config file noticed by the
567     fedora folks
568    
569     * Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
570     - fix ssl dir
571     - own /var/run/dovecot/login with the correct perms
572     - fix chmod/chown in post
573    
574     * Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
575     - update to 0.99.8.1
576    
577     * Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
578     - add a patch to fix quoting problem from CVS
579    
580     * Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
581     - 0.99.8
582     - add some buildrequires
583     - fixup to build with openssl 0.9.7
584     - now includes a pop3 daemon (off by default)
585     - clean up description and %%preun
586     - add dovecot user (uid/gid of 97)
587     - add some buildrequires
588     - move the ssl cert to %{_datadir}/ssl/certs
589     - create a dummy ssl cert in %post
590     - own /var/run/dovecot
591     - make the config file a source so we get default mbox locks of fcntl
592    
593     * Sun Dec 1 2002 Seth Vidal <skvidal@phy.duke.edu>
594     - 0.99.4 and fix startup so it starts imap-master not vsftpd :)
595    
596     * Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
597     - first build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed