/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.15 - (hide annotations) (download)
Fri Dec 11 02:44:25 2020 UTC (3 years, 6 months ago) by jpp
Branch: MAIN
CVS Tags: e-smith-apache-2_6_0-12_el7_sme
Changes since 1.14: +19 -2 lines
* Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
- create-update event [SME: 11123]
- move httpd-e-smith to systemd [SME: 11111]
  changed sigusr1 used in events to reload as defined in the unit file
- give a logger to httpd-e-smith : journald [SME: 1416]

1 jpp 1.15 # $Id: e-smith-apache.spec,v 1.14 2020/06/27 20:46:34 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 jpp 1.15 %define release 12
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.6
22 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
23     BuildArchitectures: noarch
24     Requires: e-smith-base >= 4.15.1
25     Requires: e-smith-lib >= 1.15.1-19
26     Requires: e-smith-daemontools >= 1.7.1-01
27     Requires: mod_ssl
28     Requires: mod_authnz_external
29     Obsoletes: distcache <= 1.4.5
30     Obsoletes: mod_auth_external
31     Obsoletes: e-smith-proxypass
32     Obsoletes: e-smith-apache-proxy
33     Conflicts: e-smith-ibays < 1.0.2
34     AutoReqProv: no
35     BuildRequires: e-smith-devtools >= 1.11.0-12
36    
37     %description
38     e-smith server and gateway software - apache module.
39    
40 unnilennium 1.5 %prep
41     %setup
42     %patch0 -p1
43 jpp 1.6 %patch1 -p1
44 jpp 1.7 %patch2 -p1
45 jpp 1.8 %patch3 -p1
46 jpp 1.11 %patch4 -p1
47 jpp 1.12 %patch5 -p1
48 jpp 1.13 %patch6 -p1
49 jpp 1.15 %patch7 -p1
50     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
51 unnilennium 1.5
52     %build
53     perl createlinks
54    
55     %install
56     rm -rf $RPM_BUILD_ROOT
57     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
58    
59     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
60 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
61 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
62     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
63     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
64     > e-smith-%{version}-filelist
65    
66     echo "%doc COPYING" >> e-smith-%{version}-filelist
67    
68     %clean
69     rm -rf $RPM_BUILD_ROOT
70    
71     %files -f e-smith-%{version}-filelist
72     %defattr(-,root,root)
73    
74 jpp 1.15 %pre
75     # ease the transition between runit and systemd
76     if [ $1 -gt 1 ] ; then
77     if [ -e /var/service/httpd-e-smith/run ] ; then
78     /usr/bin/sv d httpd-e-smith
79     fi
80     fi
81 unnilennium 1.5
82 vip-ire 1.1 %changelog
83 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
84     - create-update event [SME: 11123]
85     - move httpd-e-smith to systemd [SME: 11111]
86     changed sigusr1 used in events to reload as defined in the unit file
87     - give a logger to httpd-e-smith : journald [SME: 1416]
88    
89 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
90     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
91    
92 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
93     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
94    
95 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
96     - port 80 and 443 should not be hardcoded [SME: 9192]
97     - e-smith-apache removing hardcoded ports [SME: 10966]
98    
99 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
100     - remove php3 and php4 refs [SME: 10867]
101    
102 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
103 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
104 jpp 1.9 * put strong ciphers first in default string
105 jpp 1.10 * cipher order and properties with periods
106 jpp 1.8
107 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
108     - add SSLHonorCipherOrder Directive [SME: 10916]
109    
110 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
111     - update apache icon path [SME: 9591]
112    
113 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
114     - fix syntax preventing httpd to launch [SME: 9364]
115     - moved changelog at end of file
116    
117 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
118     - Roll new stream for sme10
119    
120     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
121     - Hook into the new ssl-update event [SME: 9152]
122    
123     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
124     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
125    
126     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
127     - Disable TLSv1 [SME: 9154]
128    
129     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
130     - Disable SSLv3 [SME: 8722]
131    
132     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
133     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
134    
135     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
136     - Mitigate CVE-2012-4929 [SME: 8613]
137    
138     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
139     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
140    
141     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
142     - Remove insecure ciphers [SME: 8138]
143    
144     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
145     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
146     - Add authz_groupfile as a loadable Module [SME: 7875]
147    
148     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
149     - Patch to add missing default httpd.conf modules [SME: 7874]
150    
151     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
152     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
153    
154     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
155     - Obsolete el5 version of distcache [SME: 7273]
156    
157     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
158     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
159     - Change the way module is loaded and initialized
160    
161     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
162     - Add missing dependency on mod_ssl [SME: 7234]
163    
164     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
165     - Roll new stream for sme9
166    
167     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
168     - Disable index listing of Apache icons folder [SME: 7015]
169    
170     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
171     - Fix server-resources redirect w/o trailing slash [SME: 6758]
172    
173     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
174     - Disable SSLv2 by default [SME: 6482]
175    
176     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
177     - Add option to disable SSLv2 [SME: 5034]
178    
179     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
180     - Add OpenOffice2 MIME Types [SME: 5112]
181    
182     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
183     - Add OpenOffice MIME Types [SME: 4848]
184     - Add XML MIME Type [SME: 5035]
185    
186     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
187     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
188    
189     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
190     - Add Microsoft Office 2007 MIME types [SME: 4548]
191    
192     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
193     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
194    
195     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
196     - Add SSL support to ProxyPass. [SME: 3481]
197    
198     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
199     - Create/Move httpd logrotate.d directory. [SME: 3380]
200    
201     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
202     - Rename apache to httpd in templates2expand. [SME: 3380]
203    
204     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
205     - Fix patch to exclude hosts if domains exist [SME: 2307]
206    
207     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
208     - Use correct lib for modules
209    
210     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
211     - Clean up spec so package can be built by koji/plague
212    
213     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
214     - Fix patch so template expands [SME: 2307]
215    
216     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
217     - Don't include host if domain exists [SME: 2307]
218    
219     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
220     - Gracefully handle differences in module names between apache
221     versions. [SME: 2471]
222     - Add logrotate changes which should have been in 1.2.0-7 (patch
223     was provided but not applied).
224    
225     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
226     - Remove proxypass fragment (now in e-smith-manager)
227    
228     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
229     - Remove proxypass fragment (now in e-smith-manager)
230    
231     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
232     - Move logrotate fragments from e-smith-base.
233    
234     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
235     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
236    
237     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
238     - Update to new release naming. No functional changes.
239     - Make Packager generic
240    
241     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
242     - Revert last change [SME: 2109]
243     - TODO: Split dev stream for that change
244     - Add Conflicts for latest e-smith-manager dev stream
245    
246     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
247     - Remove manager proxy pass fragment - moved to e-smith-manager.
248    
249     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
250     - Add ProxyPassReverse directives to allow redirects to work for proxy-
251     passed virtual domains. Also proxy pass https to https. [SME: 1735]
252    
253     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
254     - Roll stable stream version. [SME: 1016]
255    
256     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
257     - Fix lookup of 'httpd' props in a few templates. Service name is
258     httpd-e-smith. [SME: 1029]
259    
260     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
261     - Deny access to files starting with .ht typically
262     .htaccess and .htpasswd [SME: 716]
263    
264     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
265     - Change modPerl from enabled to disabled [SME: 575]
266    
267     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
268     - Add SVG filetype [SME: 374]
269    
270     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
271     - And relocate the modSSL{CipherSuite} default to e-smith-base with
272     the other modSSL defaults [SME: 194]
273    
274     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
275     - Change default CipherSuite [SME: 194]
276     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
277     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
278    
279     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
280     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
281    
282     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
283     - Remove inode from FileETag response [SME: 198]
284    
285     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
286     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
287    
288     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
289     - Add type for XSL stylesheet (.xsl) files [SME: 76]
290    
291     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
292     - Bump release number only
293    
294     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
295     - [1.1.2-26]
296     - Add content from e-smith-apache-proxy, to enable apache to
297     also operate as a non-caching proxy server. Add Obsoletes:
298     header to ensure e-smith-apache-proxy RPM is removed on
299     upgrade.
300    
301     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
302     - [1.1.2-25]
303     - Add directive for icons directory
304     - Fix newlines left on end of icons template
305     - Update server aliases to reference all local hosts [SF: 1246172]
306    
307     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
308     - [1.1.2-24]
309     - Fix Rewrite rule to include trailing stuff
310    
311     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
312     - [1.1.2-23]
313     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
314    
315     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
316     - [1.1.2-22]
317     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
318     Rowell, with some further work by Shad Lords). [SF: 1240658]
319    
320     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
321     - [1.1.2-21]
322     - Disable all low grade ciphers for SSL. [SF: 1240654]
323    
324     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
325     - [1.1.2-20]
326     - Don't load userdir module by default. It's not used, and causes
327     Nessus to complain. [SF: 1240657]
328    
329     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
330     - [1.1.2-19]
331     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
332     [SF: 1172203]
333    
334     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
335     - [1.1.2-18]
336     - Add GPL COPYING file.
337    
338     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
339     - [1.1.2-17]
340     - Clean up apache templates to use current DB interfaces.
341     - Make sure the single host ValidFrom specs for proxypass doesn't
342     upset apache.
343    
344     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
345     - [1.1.2-16]
346     - Make sure that DocumentRoot directory exists - latest apache2
347     will not start up if not.
348    
349     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
350     - [1.1.2-15]
351     - Do graceful restart of apache in domain-*, in case domain->ibay
352     assignments have changed. [SF: 1222433]
353    
354     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
355     - [1.1.2-14]
356     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
357     requests.
358    
359     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
360     - [1.1.2-13]
361     - Add support for TemplatePath => ProxyPassVirtualHost entries
362     in domains db.
363    
364     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
365     - [1.1.2-12]
366     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
367    
368     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
369     - [1.1.2-11]
370     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
371     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
372    
373     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
374     - [1.1.2-10]
375     - Add default TCPPort property to httpd-e-smith, so that correct
376     hole is punched in firewall.
377    
378     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
379     - [1.1.2-09]
380     - Remove mangling of syslog and apache log filenames - just
381     retargeting the symlinks has the same effect. [MN00064132]
382    
383     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
384     - [1.1.2-08]
385     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
386    
387     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
388     - [1.1.2-07]
389     - Fix dangling symlink in ibay-create. [MN00065576]
390    
391     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
392     - [1.1.2-06]
393     - Use generic_template_expand action where possible, in place
394     of specific actions. Update e-smith-lib dependency. [MN00064130]
395     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
396     Update e-smith-lib version dependency. [MN00065576]
397    
398     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
399     - [1.1.2-05]
400     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
401     [MN00065717]
402    
403     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
404     - [1.1.2-04]
405     - Remove stray ServiceLink sylinks. [MN00064757]
406    
407     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
408     - [1.1.2-03]
409     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
410     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
411    
412     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
413     - [1.1.2-02]
414     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
415     one in e-smith-base. [MN00062533]
416    
417     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
418     - [1.1.2-01]
419     - Picking up new directory. MN00056429.
420    
421     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
422     - [1.1.1-03]
423     - Added empty ValidFrom defaults fragment [markk MN00056429]
424    
425     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
426     - [1.1.1-02]
427     - Modify config and run script for compatibility with apache 2. Most of these
428     changes were contributed by Shad Lords. [charlieb MN00051144]
429    
430     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
431     - [1.1.1-01]
432     - New development stream for apache 2 - 1.1.1
433    
434     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
435     - [1.1.0-23]
436     - Clean BuildRequires. [charlieb MN00043055]
437    
438     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
439     - [1.1.0-22]
440     - Updated modPerl templates to remove use of esmith::config.
441     [msoulier MN00039579]
442    
443     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
444     - [1.1.0-21]
445     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
446     so ssh port-forwarding is not broken. [msoulier MN00020885]
447    
448     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
449     - [1.1.0-20]
450     - Fix LoadModule fragment from last patch [tonyc 11348]
451    
452     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
453     - [1.1.0-19]
454     - Add modPerl service and httpd.conf templates [tonyc 11348]
455    
456     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
457     - [1.1.0-18]
458     - Adding rewrite rules to prevent plaintext access to the server manager.
459     [msoulier MN00020885]
460    
461     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
462     - [1.1.0-17]
463     - Added httpd-admin's remoteaccess list to permissible networks for
464     server-resources. [msoulier MN00024949]
465    
466     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
467     - [1.1.0-16]
468     - Backing-out last change. [msoulier dpar-21489]
469    
470     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
471     - [1.1.0-15]
472     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
473    
474     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
475     - [1.1.0-14]
476     - Updating requires to e-smith-daemontools. [msoulier 7629]
477    
478     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
479     - [1.1.0-13]
480     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
481     [msoulier 7629]
482    
483     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
484     - [1.1.0-12]
485     - Staggering the symlinks a little farther. [msoulier 9955]
486    
487     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
488     - [1.1.0-11]
489     - Adding symlinks to the service-domain-create event for httpd restart.
490     [msoulier 9955]
491    
492     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
493     - [1.1.0-10]
494     - Fixed another error in the specfile, resulting in incorrect file
495     permissions. [msoulier 7629]
496     - Updated action scripts for supervise. [msoulier 7629]
497    
498     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
499     - [1.1.0-09]
500     - Fixed an error in the specfile. [msoulier 7629]
501    
502     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
503     - [1.1.0-08]
504     - Updated createlinks for daemontools. [msoulier 7629]
505    
506     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
507     - [1.1.0-07]
508     - Putting httpd-e-smith under supervision. [msoulier 7629]
509    
510     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
511     - [1.1.0-06]
512     - Added a null-string return value to the end of 00Setup, ensure no output
513     from that fragment. [msoulier 9803]
514    
515     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
516     - [1.1.0-05]
517     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
518     [charlieb 9803]
519    
520     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
521     - [1.1.0-04]
522     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
523     files. [msoulier 9866]
524    
525     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
526     - [1.1.0-03]
527     - Allow TemplatePath property in domain record to specify an alternate template
528     subdir for virtual host content specification (e.g. to proxypass a domain).
529     [charlieb 8409]
530    
531     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
532     - [1.1.0-02]
533     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
534     and modified VirtualHosts/00Setup fragment to convert it to the right class.
535     Fix scoping problem with the blessed object. [charlieb 9803]
536    
537     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
538     - [1.1.0-01]
539     - rolling to dev stream - 1.1.0
540    
541     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
542     - [1.0.0-04]
543     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
544     into an esmith::DomainsDB object. [msoulier 9803]
545    
546     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
547     - [1.0.0-03]
548     - Added a reference to the domains db in the extra data for processing the
549     VirtualHosts fragments. [msoulier 9803]
550    
551     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
552     - [1.0.0-02]
553     - Fixed a precedence error that broke virtual hosts in apache.
554     [msoulier 9640]
555    
556     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
557     - [1.0.0-01]
558     - Setting to release version number - 1.0.0
559    
560     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
561     - [0.2.0-04]
562     - Fixed breakage in admin web server when a local network with a 32-bit subnet
563     mask is used. [msoulier 9259]
564    
565     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
566     - [0.2.0-03]
567     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
568    
569     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
570     - [0.2.0-02]
571     - List primary domain as first (default) virtual domain in apache config.
572     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
573    
574     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
575     - [0.2.0-01]
576     - Changing version to stable stream number - 0.2.0
577    
578     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
579     - [0.1.2-01]
580     - Add order to migrate fragments [gordonr 9015]
581    
582     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
583     - [0.1.1-02]
584     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
585    
586     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
587     - [0.1.1-01]
588     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
589    
590     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
591     - [0.1.0-19]
592     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
593    
594     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
595     - [0.1.0-18]
596     - Do an explicit die if the httpd-e-smith record is missing from the
597     config db, rather than an implicit die due to an invalid object
598     reference [gordonr 8609]
599    
600     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
601     - [0.1.0-17]
602     - Relocated conf-httpd from e-smith-base [gordonr 8150]
603    
604     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
605     - [0.1.0-16]
606     - Moved restart-httpd-* actions from base [markk 5509]
607    
608     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
609     - [0.1.0-15]
610     - Moved db config fragments here from e-smith-base [markk 5509]
611    
612     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
613     - [0.1.0-14]
614     - Make /server-resources/ browsable from LAN [gordonr 6620]
615    
616     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
617     - [0.1.0-13]
618     - Delete Apache ReadmeName directive [gordonr 6313]
619    
620     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
621     - [0.1.0-12]
622     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
623    
624     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
625     - [0.1.0-11]
626     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
627     deleted ./etc/httpd/conf/srm.conf/template-begin
628     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
629    
630     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
631     - [0.1.0-10]
632     - Delete empty template-end file [lijied 3295]
633    
634     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
635     - [0.1.0-09]
636     - Remove more references to primary and wwwpublic in favour
637     of the "Primary" i-bay. There is still some special case code,
638     which might go later if it turns out not to be needed.
639     [charlieb 5652]
640    
641     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
642     - [0.1.0-08]
643     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
644    
645     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
646     - [0.1.0-07]
647     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
648     need to recalculate these values [gordonr 7635]
649     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
650    
651     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
652     - [0.1.0-06]
653     - Remove special case handling for /home/e-smith/files/primary in Apache
654     configuration. Migrate code and db entries for wwwpublic to Public.
655     [charlieb 5652]
656    
657     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
658     - [0.1.0-05]
659     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
660     VirtualHosts fragment of httpd.conf templates. Fixes template
661     expansion breakage (I'm not sure what broke it, but this fixes it.)
662     [charlieb]
663     - Add default config db fragments to set type and status. Remove redundant
664     conf-httpd-e-smith script. [charlieb 1507]
665    
666     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
667     - [0.1.0-04]
668     - Move SSL initialisation to global context [gordonr 1432]
669    
670     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
671     - [0.1.0-03]
672     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
673    
674     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
675     - [0.1.0-02]
676     - Added conf-httpd-e-smith action linked to the same events as conf-startup
677     in e-smith-base [markk 6428]
678    
679     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
680     - [0.1.0-01]
681     - Initial release, split out from e-smith-base [markk 6428]
682    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed