/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.16 - (hide annotations) (download)
Fri Dec 11 03:28:37 2020 UTC (3 years, 6 months ago) by jpp
Branch: MAIN
CVS Tags: e-smith-apache-2_6_0-13_el7_sme
Changes since 1.15: +8 -2 lines
* Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
- prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
  default on self generated cert

1 jpp 1.16 # $Id: e-smith-apache.spec,v 1.15 2020/12/11 02:44:25 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 jpp 1.16 %define release 13
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.16 Patch8: e-smith-apache-2.6.0-bz10826-defaultSSLCert-if-file-does-not-exist.patch
22 jpp 1.6
23 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
24     BuildArchitectures: noarch
25     Requires: e-smith-base >= 4.15.1
26     Requires: e-smith-lib >= 1.15.1-19
27     Requires: e-smith-daemontools >= 1.7.1-01
28     Requires: mod_ssl
29     Requires: mod_authnz_external
30     Obsoletes: distcache <= 1.4.5
31     Obsoletes: mod_auth_external
32     Obsoletes: e-smith-proxypass
33     Obsoletes: e-smith-apache-proxy
34     Conflicts: e-smith-ibays < 1.0.2
35     AutoReqProv: no
36     BuildRequires: e-smith-devtools >= 1.11.0-12
37    
38     %description
39     e-smith server and gateway software - apache module.
40    
41 unnilennium 1.5 %prep
42     %setup
43     %patch0 -p1
44 jpp 1.6 %patch1 -p1
45 jpp 1.7 %patch2 -p1
46 jpp 1.8 %patch3 -p1
47 jpp 1.11 %patch4 -p1
48 jpp 1.12 %patch5 -p1
49 jpp 1.13 %patch6 -p1
50 jpp 1.15 %patch7 -p1
51     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
52 jpp 1.16 %patch8 -p1
53 unnilennium 1.5
54     %build
55     perl createlinks
56    
57     %install
58     rm -rf $RPM_BUILD_ROOT
59     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
60    
61     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
62 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
63 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
64     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
65     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
66     > e-smith-%{version}-filelist
67    
68     echo "%doc COPYING" >> e-smith-%{version}-filelist
69    
70     %clean
71     rm -rf $RPM_BUILD_ROOT
72    
73     %files -f e-smith-%{version}-filelist
74     %defattr(-,root,root)
75    
76 jpp 1.15 %pre
77     # ease the transition between runit and systemd
78     if [ $1 -gt 1 ] ; then
79     if [ -e /var/service/httpd-e-smith/run ] ; then
80     /usr/bin/sv d httpd-e-smith
81     fi
82     fi
83 unnilennium 1.5
84 vip-ire 1.1 %changelog
85 jpp 1.16 * Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
86     - prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
87     default on self generated cert
88    
89 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
90     - create-update event [SME: 11123]
91     - move httpd-e-smith to systemd [SME: 11111]
92     changed sigusr1 used in events to reload as defined in the unit file
93     - give a logger to httpd-e-smith : journald [SME: 1416]
94    
95 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
96     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
97    
98 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
99     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
100    
101 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
102     - port 80 and 443 should not be hardcoded [SME: 9192]
103     - e-smith-apache removing hardcoded ports [SME: 10966]
104    
105 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
106     - remove php3 and php4 refs [SME: 10867]
107    
108 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
109 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
110 jpp 1.9 * put strong ciphers first in default string
111 jpp 1.10 * cipher order and properties with periods
112 jpp 1.8
113 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
114     - add SSLHonorCipherOrder Directive [SME: 10916]
115    
116 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
117     - update apache icon path [SME: 9591]
118    
119 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
120     - fix syntax preventing httpd to launch [SME: 9364]
121     - moved changelog at end of file
122    
123 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
124     - Roll new stream for sme10
125    
126     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
127     - Hook into the new ssl-update event [SME: 9152]
128    
129     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
130     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
131    
132     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
133     - Disable TLSv1 [SME: 9154]
134    
135     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
136     - Disable SSLv3 [SME: 8722]
137    
138     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
139     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
140    
141     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
142     - Mitigate CVE-2012-4929 [SME: 8613]
143    
144     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
145     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
146    
147     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
148     - Remove insecure ciphers [SME: 8138]
149    
150     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
151     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
152     - Add authz_groupfile as a loadable Module [SME: 7875]
153    
154     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
155     - Patch to add missing default httpd.conf modules [SME: 7874]
156    
157     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
158     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
159    
160     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
161     - Obsolete el5 version of distcache [SME: 7273]
162    
163     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
164     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
165     - Change the way module is loaded and initialized
166    
167     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
168     - Add missing dependency on mod_ssl [SME: 7234]
169    
170     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
171     - Roll new stream for sme9
172    
173     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
174     - Disable index listing of Apache icons folder [SME: 7015]
175    
176     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
177     - Fix server-resources redirect w/o trailing slash [SME: 6758]
178    
179     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
180     - Disable SSLv2 by default [SME: 6482]
181    
182     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
183     - Add option to disable SSLv2 [SME: 5034]
184    
185     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
186     - Add OpenOffice2 MIME Types [SME: 5112]
187    
188     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
189     - Add OpenOffice MIME Types [SME: 4848]
190     - Add XML MIME Type [SME: 5035]
191    
192     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
193     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
194    
195     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
196     - Add Microsoft Office 2007 MIME types [SME: 4548]
197    
198     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
199     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
200    
201     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
202     - Add SSL support to ProxyPass. [SME: 3481]
203    
204     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
205     - Create/Move httpd logrotate.d directory. [SME: 3380]
206    
207     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
208     - Rename apache to httpd in templates2expand. [SME: 3380]
209    
210     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
211     - Fix patch to exclude hosts if domains exist [SME: 2307]
212    
213     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
214     - Use correct lib for modules
215    
216     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
217     - Clean up spec so package can be built by koji/plague
218    
219     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
220     - Fix patch so template expands [SME: 2307]
221    
222     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
223     - Don't include host if domain exists [SME: 2307]
224    
225     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
226     - Gracefully handle differences in module names between apache
227     versions. [SME: 2471]
228     - Add logrotate changes which should have been in 1.2.0-7 (patch
229     was provided but not applied).
230    
231     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
232     - Remove proxypass fragment (now in e-smith-manager)
233    
234     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
235     - Remove proxypass fragment (now in e-smith-manager)
236    
237     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
238     - Move logrotate fragments from e-smith-base.
239    
240     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
241     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
242    
243     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
244     - Update to new release naming. No functional changes.
245     - Make Packager generic
246    
247     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
248     - Revert last change [SME: 2109]
249     - TODO: Split dev stream for that change
250     - Add Conflicts for latest e-smith-manager dev stream
251    
252     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
253     - Remove manager proxy pass fragment - moved to e-smith-manager.
254    
255     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
256     - Add ProxyPassReverse directives to allow redirects to work for proxy-
257     passed virtual domains. Also proxy pass https to https. [SME: 1735]
258    
259     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
260     - Roll stable stream version. [SME: 1016]
261    
262     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
263     - Fix lookup of 'httpd' props in a few templates. Service name is
264     httpd-e-smith. [SME: 1029]
265    
266     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
267     - Deny access to files starting with .ht typically
268     .htaccess and .htpasswd [SME: 716]
269    
270     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
271     - Change modPerl from enabled to disabled [SME: 575]
272    
273     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
274     - Add SVG filetype [SME: 374]
275    
276     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
277     - And relocate the modSSL{CipherSuite} default to e-smith-base with
278     the other modSSL defaults [SME: 194]
279    
280     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
281     - Change default CipherSuite [SME: 194]
282     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
283     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
284    
285     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
286     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
287    
288     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
289     - Remove inode from FileETag response [SME: 198]
290    
291     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
292     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
293    
294     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
295     - Add type for XSL stylesheet (.xsl) files [SME: 76]
296    
297     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
298     - Bump release number only
299    
300     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
301     - [1.1.2-26]
302     - Add content from e-smith-apache-proxy, to enable apache to
303     also operate as a non-caching proxy server. Add Obsoletes:
304     header to ensure e-smith-apache-proxy RPM is removed on
305     upgrade.
306    
307     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
308     - [1.1.2-25]
309     - Add directive for icons directory
310     - Fix newlines left on end of icons template
311     - Update server aliases to reference all local hosts [SF: 1246172]
312    
313     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
314     - [1.1.2-24]
315     - Fix Rewrite rule to include trailing stuff
316    
317     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
318     - [1.1.2-23]
319     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
320    
321     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
322     - [1.1.2-22]
323     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
324     Rowell, with some further work by Shad Lords). [SF: 1240658]
325    
326     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
327     - [1.1.2-21]
328     - Disable all low grade ciphers for SSL. [SF: 1240654]
329    
330     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
331     - [1.1.2-20]
332     - Don't load userdir module by default. It's not used, and causes
333     Nessus to complain. [SF: 1240657]
334    
335     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
336     - [1.1.2-19]
337     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
338     [SF: 1172203]
339    
340     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
341     - [1.1.2-18]
342     - Add GPL COPYING file.
343    
344     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
345     - [1.1.2-17]
346     - Clean up apache templates to use current DB interfaces.
347     - Make sure the single host ValidFrom specs for proxypass doesn't
348     upset apache.
349    
350     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
351     - [1.1.2-16]
352     - Make sure that DocumentRoot directory exists - latest apache2
353     will not start up if not.
354    
355     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
356     - [1.1.2-15]
357     - Do graceful restart of apache in domain-*, in case domain->ibay
358     assignments have changed. [SF: 1222433]
359    
360     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
361     - [1.1.2-14]
362     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
363     requests.
364    
365     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
366     - [1.1.2-13]
367     - Add support for TemplatePath => ProxyPassVirtualHost entries
368     in domains db.
369    
370     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
371     - [1.1.2-12]
372     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
373    
374     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
375     - [1.1.2-11]
376     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
377     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
378    
379     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
380     - [1.1.2-10]
381     - Add default TCPPort property to httpd-e-smith, so that correct
382     hole is punched in firewall.
383    
384     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
385     - [1.1.2-09]
386     - Remove mangling of syslog and apache log filenames - just
387     retargeting the symlinks has the same effect. [MN00064132]
388    
389     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
390     - [1.1.2-08]
391     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
392    
393     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
394     - [1.1.2-07]
395     - Fix dangling symlink in ibay-create. [MN00065576]
396    
397     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
398     - [1.1.2-06]
399     - Use generic_template_expand action where possible, in place
400     of specific actions. Update e-smith-lib dependency. [MN00064130]
401     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
402     Update e-smith-lib version dependency. [MN00065576]
403    
404     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
405     - [1.1.2-05]
406     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
407     [MN00065717]
408    
409     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
410     - [1.1.2-04]
411     - Remove stray ServiceLink sylinks. [MN00064757]
412    
413     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
414     - [1.1.2-03]
415     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
416     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
417    
418     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
419     - [1.1.2-02]
420     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
421     one in e-smith-base. [MN00062533]
422    
423     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
424     - [1.1.2-01]
425     - Picking up new directory. MN00056429.
426    
427     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
428     - [1.1.1-03]
429     - Added empty ValidFrom defaults fragment [markk MN00056429]
430    
431     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
432     - [1.1.1-02]
433     - Modify config and run script for compatibility with apache 2. Most of these
434     changes were contributed by Shad Lords. [charlieb MN00051144]
435    
436     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
437     - [1.1.1-01]
438     - New development stream for apache 2 - 1.1.1
439    
440     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
441     - [1.1.0-23]
442     - Clean BuildRequires. [charlieb MN00043055]
443    
444     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
445     - [1.1.0-22]
446     - Updated modPerl templates to remove use of esmith::config.
447     [msoulier MN00039579]
448    
449     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
450     - [1.1.0-21]
451     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
452     so ssh port-forwarding is not broken. [msoulier MN00020885]
453    
454     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
455     - [1.1.0-20]
456     - Fix LoadModule fragment from last patch [tonyc 11348]
457    
458     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
459     - [1.1.0-19]
460     - Add modPerl service and httpd.conf templates [tonyc 11348]
461    
462     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
463     - [1.1.0-18]
464     - Adding rewrite rules to prevent plaintext access to the server manager.
465     [msoulier MN00020885]
466    
467     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
468     - [1.1.0-17]
469     - Added httpd-admin's remoteaccess list to permissible networks for
470     server-resources. [msoulier MN00024949]
471    
472     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
473     - [1.1.0-16]
474     - Backing-out last change. [msoulier dpar-21489]
475    
476     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
477     - [1.1.0-15]
478     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
479    
480     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
481     - [1.1.0-14]
482     - Updating requires to e-smith-daemontools. [msoulier 7629]
483    
484     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
485     - [1.1.0-13]
486     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
487     [msoulier 7629]
488    
489     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
490     - [1.1.0-12]
491     - Staggering the symlinks a little farther. [msoulier 9955]
492    
493     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
494     - [1.1.0-11]
495     - Adding symlinks to the service-domain-create event for httpd restart.
496     [msoulier 9955]
497    
498     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
499     - [1.1.0-10]
500     - Fixed another error in the specfile, resulting in incorrect file
501     permissions. [msoulier 7629]
502     - Updated action scripts for supervise. [msoulier 7629]
503    
504     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
505     - [1.1.0-09]
506     - Fixed an error in the specfile. [msoulier 7629]
507    
508     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
509     - [1.1.0-08]
510     - Updated createlinks for daemontools. [msoulier 7629]
511    
512     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
513     - [1.1.0-07]
514     - Putting httpd-e-smith under supervision. [msoulier 7629]
515    
516     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
517     - [1.1.0-06]
518     - Added a null-string return value to the end of 00Setup, ensure no output
519     from that fragment. [msoulier 9803]
520    
521     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
522     - [1.1.0-05]
523     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
524     [charlieb 9803]
525    
526     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
527     - [1.1.0-04]
528     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
529     files. [msoulier 9866]
530    
531     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
532     - [1.1.0-03]
533     - Allow TemplatePath property in domain record to specify an alternate template
534     subdir for virtual host content specification (e.g. to proxypass a domain).
535     [charlieb 8409]
536    
537     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
538     - [1.1.0-02]
539     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
540     and modified VirtualHosts/00Setup fragment to convert it to the right class.
541     Fix scoping problem with the blessed object. [charlieb 9803]
542    
543     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
544     - [1.1.0-01]
545     - rolling to dev stream - 1.1.0
546    
547     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
548     - [1.0.0-04]
549     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
550     into an esmith::DomainsDB object. [msoulier 9803]
551    
552     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
553     - [1.0.0-03]
554     - Added a reference to the domains db in the extra data for processing the
555     VirtualHosts fragments. [msoulier 9803]
556    
557     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
558     - [1.0.0-02]
559     - Fixed a precedence error that broke virtual hosts in apache.
560     [msoulier 9640]
561    
562     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
563     - [1.0.0-01]
564     - Setting to release version number - 1.0.0
565    
566     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
567     - [0.2.0-04]
568     - Fixed breakage in admin web server when a local network with a 32-bit subnet
569     mask is used. [msoulier 9259]
570    
571     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
572     - [0.2.0-03]
573     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
574    
575     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
576     - [0.2.0-02]
577     - List primary domain as first (default) virtual domain in apache config.
578     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
579    
580     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
581     - [0.2.0-01]
582     - Changing version to stable stream number - 0.2.0
583    
584     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
585     - [0.1.2-01]
586     - Add order to migrate fragments [gordonr 9015]
587    
588     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
589     - [0.1.1-02]
590     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
591    
592     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
593     - [0.1.1-01]
594     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
595    
596     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
597     - [0.1.0-19]
598     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
599    
600     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
601     - [0.1.0-18]
602     - Do an explicit die if the httpd-e-smith record is missing from the
603     config db, rather than an implicit die due to an invalid object
604     reference [gordonr 8609]
605    
606     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
607     - [0.1.0-17]
608     - Relocated conf-httpd from e-smith-base [gordonr 8150]
609    
610     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
611     - [0.1.0-16]
612     - Moved restart-httpd-* actions from base [markk 5509]
613    
614     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
615     - [0.1.0-15]
616     - Moved db config fragments here from e-smith-base [markk 5509]
617    
618     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
619     - [0.1.0-14]
620     - Make /server-resources/ browsable from LAN [gordonr 6620]
621    
622     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
623     - [0.1.0-13]
624     - Delete Apache ReadmeName directive [gordonr 6313]
625    
626     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
627     - [0.1.0-12]
628     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
629    
630     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
631     - [0.1.0-11]
632     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
633     deleted ./etc/httpd/conf/srm.conf/template-begin
634     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
635    
636     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
637     - [0.1.0-10]
638     - Delete empty template-end file [lijied 3295]
639    
640     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
641     - [0.1.0-09]
642     - Remove more references to primary and wwwpublic in favour
643     of the "Primary" i-bay. There is still some special case code,
644     which might go later if it turns out not to be needed.
645     [charlieb 5652]
646    
647     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
648     - [0.1.0-08]
649     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
650    
651     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
652     - [0.1.0-07]
653     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
654     need to recalculate these values [gordonr 7635]
655     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
656    
657     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
658     - [0.1.0-06]
659     - Remove special case handling for /home/e-smith/files/primary in Apache
660     configuration. Migrate code and db entries for wwwpublic to Public.
661     [charlieb 5652]
662    
663     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
664     - [0.1.0-05]
665     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
666     VirtualHosts fragment of httpd.conf templates. Fixes template
667     expansion breakage (I'm not sure what broke it, but this fixes it.)
668     [charlieb]
669     - Add default config db fragments to set type and status. Remove redundant
670     conf-httpd-e-smith script. [charlieb 1507]
671    
672     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
673     - [0.1.0-04]
674     - Move SSL initialisation to global context [gordonr 1432]
675    
676     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
677     - [0.1.0-03]
678     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
679    
680     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
681     - [0.1.0-02]
682     - Added conf-httpd-e-smith action linked to the same events as conf-startup
683     in e-smith-base [markk 6428]
684    
685     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
686     - [0.1.0-01]
687     - Initial release, split out from e-smith-base [markk 6428]
688    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed