/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.17 - (hide annotations) (download)
Tue Mar 30 23:05:16 2021 UTC (3 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: e-smith-apache-2_6_0-14_el7_sme
Changes since 1.16: +8 -2 lines
* Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-14.sme
- add possibility to force https on LAN only [SME: 11511]
  usefull for VPN over port 443

1 jpp 1.17 # $Id: e-smith-apache.spec,v 1.16 2020/12/11 03:28:37 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 jpp 1.17 %define release 14
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.16 Patch8: e-smith-apache-2.6.0-bz10826-defaultSSLCert-if-file-does-not-exist.patch
22 jpp 1.17 Patch9: e-smith-apache-2.6.0-bz11551-httpsForceLocalOnly.patch
23 jpp 1.6
24 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
25     BuildArchitectures: noarch
26     Requires: e-smith-base >= 4.15.1
27     Requires: e-smith-lib >= 1.15.1-19
28     Requires: e-smith-daemontools >= 1.7.1-01
29     Requires: mod_ssl
30     Requires: mod_authnz_external
31     Obsoletes: distcache <= 1.4.5
32     Obsoletes: mod_auth_external
33     Obsoletes: e-smith-proxypass
34     Obsoletes: e-smith-apache-proxy
35     Conflicts: e-smith-ibays < 1.0.2
36     AutoReqProv: no
37     BuildRequires: e-smith-devtools >= 1.11.0-12
38    
39     %description
40     e-smith server and gateway software - apache module.
41    
42 unnilennium 1.5 %prep
43     %setup
44     %patch0 -p1
45 jpp 1.6 %patch1 -p1
46 jpp 1.7 %patch2 -p1
47 jpp 1.8 %patch3 -p1
48 jpp 1.11 %patch4 -p1
49 jpp 1.12 %patch5 -p1
50 jpp 1.13 %patch6 -p1
51 jpp 1.15 %patch7 -p1
52     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
53 jpp 1.16 %patch8 -p1
54 jpp 1.17 %patch9 -p1
55 unnilennium 1.5
56     %build
57     perl createlinks
58    
59     %install
60     rm -rf $RPM_BUILD_ROOT
61     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
62    
63     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
64 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
65 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
66     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
67     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
68     > e-smith-%{version}-filelist
69    
70     echo "%doc COPYING" >> e-smith-%{version}-filelist
71    
72     %clean
73     rm -rf $RPM_BUILD_ROOT
74    
75     %files -f e-smith-%{version}-filelist
76     %defattr(-,root,root)
77    
78 jpp 1.15 %pre
79     # ease the transition between runit and systemd
80     if [ $1 -gt 1 ] ; then
81     if [ -e /var/service/httpd-e-smith/run ] ; then
82     /usr/bin/sv d httpd-e-smith
83     fi
84     fi
85 unnilennium 1.5
86 vip-ire 1.1 %changelog
87 jpp 1.17 * Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-14.sme
88     - add possibility to force https on LAN only [SME: 11511]
89     usefull for VPN over port 443
90    
91 jpp 1.16 * Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
92     - prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
93     default on self generated cert
94    
95 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
96     - create-update event [SME: 11123]
97     - move httpd-e-smith to systemd [SME: 11111]
98     changed sigusr1 used in events to reload as defined in the unit file
99     - give a logger to httpd-e-smith : journald [SME: 1416]
100    
101 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
102     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
103    
104 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
105     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
106    
107 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
108     - port 80 and 443 should not be hardcoded [SME: 9192]
109     - e-smith-apache removing hardcoded ports [SME: 10966]
110    
111 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
112     - remove php3 and php4 refs [SME: 10867]
113    
114 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
115 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
116 jpp 1.9 * put strong ciphers first in default string
117 jpp 1.10 * cipher order and properties with periods
118 jpp 1.8
119 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
120     - add SSLHonorCipherOrder Directive [SME: 10916]
121    
122 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
123     - update apache icon path [SME: 9591]
124    
125 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
126     - fix syntax preventing httpd to launch [SME: 9364]
127     - moved changelog at end of file
128    
129 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
130     - Roll new stream for sme10
131    
132     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
133     - Hook into the new ssl-update event [SME: 9152]
134    
135     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
136     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
137    
138     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
139     - Disable TLSv1 [SME: 9154]
140    
141     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
142     - Disable SSLv3 [SME: 8722]
143    
144     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
145     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
146    
147     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
148     - Mitigate CVE-2012-4929 [SME: 8613]
149    
150     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
151     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
152    
153     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
154     - Remove insecure ciphers [SME: 8138]
155    
156     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
157     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
158     - Add authz_groupfile as a loadable Module [SME: 7875]
159    
160     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
161     - Patch to add missing default httpd.conf modules [SME: 7874]
162    
163     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
164     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
165    
166     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
167     - Obsolete el5 version of distcache [SME: 7273]
168    
169     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
170     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
171     - Change the way module is loaded and initialized
172    
173     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
174     - Add missing dependency on mod_ssl [SME: 7234]
175    
176     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
177     - Roll new stream for sme9
178    
179     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
180     - Disable index listing of Apache icons folder [SME: 7015]
181    
182     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
183     - Fix server-resources redirect w/o trailing slash [SME: 6758]
184    
185     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
186     - Disable SSLv2 by default [SME: 6482]
187    
188     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
189     - Add option to disable SSLv2 [SME: 5034]
190    
191     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
192     - Add OpenOffice2 MIME Types [SME: 5112]
193    
194     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
195     - Add OpenOffice MIME Types [SME: 4848]
196     - Add XML MIME Type [SME: 5035]
197    
198     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
199     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
200    
201     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
202     - Add Microsoft Office 2007 MIME types [SME: 4548]
203    
204     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
205     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
206    
207     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
208     - Add SSL support to ProxyPass. [SME: 3481]
209    
210     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
211     - Create/Move httpd logrotate.d directory. [SME: 3380]
212    
213     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
214     - Rename apache to httpd in templates2expand. [SME: 3380]
215    
216     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
217     - Fix patch to exclude hosts if domains exist [SME: 2307]
218    
219     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
220     - Use correct lib for modules
221    
222     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
223     - Clean up spec so package can be built by koji/plague
224    
225     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
226     - Fix patch so template expands [SME: 2307]
227    
228     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
229     - Don't include host if domain exists [SME: 2307]
230    
231     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
232     - Gracefully handle differences in module names between apache
233     versions. [SME: 2471]
234     - Add logrotate changes which should have been in 1.2.0-7 (patch
235     was provided but not applied).
236    
237     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
238     - Remove proxypass fragment (now in e-smith-manager)
239    
240     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
241     - Remove proxypass fragment (now in e-smith-manager)
242    
243     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
244     - Move logrotate fragments from e-smith-base.
245    
246     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
247     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
248    
249     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
250     - Update to new release naming. No functional changes.
251     - Make Packager generic
252    
253     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
254     - Revert last change [SME: 2109]
255     - TODO: Split dev stream for that change
256     - Add Conflicts for latest e-smith-manager dev stream
257    
258     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
259     - Remove manager proxy pass fragment - moved to e-smith-manager.
260    
261     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
262     - Add ProxyPassReverse directives to allow redirects to work for proxy-
263     passed virtual domains. Also proxy pass https to https. [SME: 1735]
264    
265     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
266     - Roll stable stream version. [SME: 1016]
267    
268     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
269     - Fix lookup of 'httpd' props in a few templates. Service name is
270     httpd-e-smith. [SME: 1029]
271    
272     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
273     - Deny access to files starting with .ht typically
274     .htaccess and .htpasswd [SME: 716]
275    
276     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
277     - Change modPerl from enabled to disabled [SME: 575]
278    
279     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
280     - Add SVG filetype [SME: 374]
281    
282     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
283     - And relocate the modSSL{CipherSuite} default to e-smith-base with
284     the other modSSL defaults [SME: 194]
285    
286     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
287     - Change default CipherSuite [SME: 194]
288     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
289     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
290    
291     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
292     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
293    
294     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
295     - Remove inode from FileETag response [SME: 198]
296    
297     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
298     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
299    
300     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
301     - Add type for XSL stylesheet (.xsl) files [SME: 76]
302    
303     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
304     - Bump release number only
305    
306     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
307     - [1.1.2-26]
308     - Add content from e-smith-apache-proxy, to enable apache to
309     also operate as a non-caching proxy server. Add Obsoletes:
310     header to ensure e-smith-apache-proxy RPM is removed on
311     upgrade.
312    
313     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
314     - [1.1.2-25]
315     - Add directive for icons directory
316     - Fix newlines left on end of icons template
317     - Update server aliases to reference all local hosts [SF: 1246172]
318    
319     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
320     - [1.1.2-24]
321     - Fix Rewrite rule to include trailing stuff
322    
323     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
324     - [1.1.2-23]
325     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
326    
327     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
328     - [1.1.2-22]
329     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
330     Rowell, with some further work by Shad Lords). [SF: 1240658]
331    
332     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
333     - [1.1.2-21]
334     - Disable all low grade ciphers for SSL. [SF: 1240654]
335    
336     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
337     - [1.1.2-20]
338     - Don't load userdir module by default. It's not used, and causes
339     Nessus to complain. [SF: 1240657]
340    
341     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
342     - [1.1.2-19]
343     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
344     [SF: 1172203]
345    
346     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
347     - [1.1.2-18]
348     - Add GPL COPYING file.
349    
350     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
351     - [1.1.2-17]
352     - Clean up apache templates to use current DB interfaces.
353     - Make sure the single host ValidFrom specs for proxypass doesn't
354     upset apache.
355    
356     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
357     - [1.1.2-16]
358     - Make sure that DocumentRoot directory exists - latest apache2
359     will not start up if not.
360    
361     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
362     - [1.1.2-15]
363     - Do graceful restart of apache in domain-*, in case domain->ibay
364     assignments have changed. [SF: 1222433]
365    
366     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
367     - [1.1.2-14]
368     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
369     requests.
370    
371     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
372     - [1.1.2-13]
373     - Add support for TemplatePath => ProxyPassVirtualHost entries
374     in domains db.
375    
376     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
377     - [1.1.2-12]
378     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
379    
380     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
381     - [1.1.2-11]
382     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
383     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
384    
385     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
386     - [1.1.2-10]
387     - Add default TCPPort property to httpd-e-smith, so that correct
388     hole is punched in firewall.
389    
390     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
391     - [1.1.2-09]
392     - Remove mangling of syslog and apache log filenames - just
393     retargeting the symlinks has the same effect. [MN00064132]
394    
395     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
396     - [1.1.2-08]
397     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
398    
399     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
400     - [1.1.2-07]
401     - Fix dangling symlink in ibay-create. [MN00065576]
402    
403     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
404     - [1.1.2-06]
405     - Use generic_template_expand action where possible, in place
406     of specific actions. Update e-smith-lib dependency. [MN00064130]
407     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
408     Update e-smith-lib version dependency. [MN00065576]
409    
410     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
411     - [1.1.2-05]
412     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
413     [MN00065717]
414    
415     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
416     - [1.1.2-04]
417     - Remove stray ServiceLink sylinks. [MN00064757]
418    
419     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
420     - [1.1.2-03]
421     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
422     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
423    
424     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
425     - [1.1.2-02]
426     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
427     one in e-smith-base. [MN00062533]
428    
429     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
430     - [1.1.2-01]
431     - Picking up new directory. MN00056429.
432    
433     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
434     - [1.1.1-03]
435     - Added empty ValidFrom defaults fragment [markk MN00056429]
436    
437     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
438     - [1.1.1-02]
439     - Modify config and run script for compatibility with apache 2. Most of these
440     changes were contributed by Shad Lords. [charlieb MN00051144]
441    
442     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
443     - [1.1.1-01]
444     - New development stream for apache 2 - 1.1.1
445    
446     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
447     - [1.1.0-23]
448     - Clean BuildRequires. [charlieb MN00043055]
449    
450     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
451     - [1.1.0-22]
452     - Updated modPerl templates to remove use of esmith::config.
453     [msoulier MN00039579]
454    
455     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
456     - [1.1.0-21]
457     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
458     so ssh port-forwarding is not broken. [msoulier MN00020885]
459    
460     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
461     - [1.1.0-20]
462     - Fix LoadModule fragment from last patch [tonyc 11348]
463    
464     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
465     - [1.1.0-19]
466     - Add modPerl service and httpd.conf templates [tonyc 11348]
467    
468     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
469     - [1.1.0-18]
470     - Adding rewrite rules to prevent plaintext access to the server manager.
471     [msoulier MN00020885]
472    
473     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
474     - [1.1.0-17]
475     - Added httpd-admin's remoteaccess list to permissible networks for
476     server-resources. [msoulier MN00024949]
477    
478     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
479     - [1.1.0-16]
480     - Backing-out last change. [msoulier dpar-21489]
481    
482     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
483     - [1.1.0-15]
484     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
485    
486     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
487     - [1.1.0-14]
488     - Updating requires to e-smith-daemontools. [msoulier 7629]
489    
490     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
491     - [1.1.0-13]
492     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
493     [msoulier 7629]
494    
495     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
496     - [1.1.0-12]
497     - Staggering the symlinks a little farther. [msoulier 9955]
498    
499     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
500     - [1.1.0-11]
501     - Adding symlinks to the service-domain-create event for httpd restart.
502     [msoulier 9955]
503    
504     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
505     - [1.1.0-10]
506     - Fixed another error in the specfile, resulting in incorrect file
507     permissions. [msoulier 7629]
508     - Updated action scripts for supervise. [msoulier 7629]
509    
510     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
511     - [1.1.0-09]
512     - Fixed an error in the specfile. [msoulier 7629]
513    
514     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
515     - [1.1.0-08]
516     - Updated createlinks for daemontools. [msoulier 7629]
517    
518     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
519     - [1.1.0-07]
520     - Putting httpd-e-smith under supervision. [msoulier 7629]
521    
522     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
523     - [1.1.0-06]
524     - Added a null-string return value to the end of 00Setup, ensure no output
525     from that fragment. [msoulier 9803]
526    
527     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
528     - [1.1.0-05]
529     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
530     [charlieb 9803]
531    
532     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
533     - [1.1.0-04]
534     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
535     files. [msoulier 9866]
536    
537     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
538     - [1.1.0-03]
539     - Allow TemplatePath property in domain record to specify an alternate template
540     subdir for virtual host content specification (e.g. to proxypass a domain).
541     [charlieb 8409]
542    
543     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
544     - [1.1.0-02]
545     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
546     and modified VirtualHosts/00Setup fragment to convert it to the right class.
547     Fix scoping problem with the blessed object. [charlieb 9803]
548    
549     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
550     - [1.1.0-01]
551     - rolling to dev stream - 1.1.0
552    
553     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
554     - [1.0.0-04]
555     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
556     into an esmith::DomainsDB object. [msoulier 9803]
557    
558     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
559     - [1.0.0-03]
560     - Added a reference to the domains db in the extra data for processing the
561     VirtualHosts fragments. [msoulier 9803]
562    
563     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
564     - [1.0.0-02]
565     - Fixed a precedence error that broke virtual hosts in apache.
566     [msoulier 9640]
567    
568     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
569     - [1.0.0-01]
570     - Setting to release version number - 1.0.0
571    
572     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
573     - [0.2.0-04]
574     - Fixed breakage in admin web server when a local network with a 32-bit subnet
575     mask is used. [msoulier 9259]
576    
577     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
578     - [0.2.0-03]
579     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
580    
581     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
582     - [0.2.0-02]
583     - List primary domain as first (default) virtual domain in apache config.
584     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
585    
586     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
587     - [0.2.0-01]
588     - Changing version to stable stream number - 0.2.0
589    
590     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
591     - [0.1.2-01]
592     - Add order to migrate fragments [gordonr 9015]
593    
594     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
595     - [0.1.1-02]
596     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
597    
598     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
599     - [0.1.1-01]
600     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
601    
602     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
603     - [0.1.0-19]
604     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
605    
606     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
607     - [0.1.0-18]
608     - Do an explicit die if the httpd-e-smith record is missing from the
609     config db, rather than an implicit die due to an invalid object
610     reference [gordonr 8609]
611    
612     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
613     - [0.1.0-17]
614     - Relocated conf-httpd from e-smith-base [gordonr 8150]
615    
616     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
617     - [0.1.0-16]
618     - Moved restart-httpd-* actions from base [markk 5509]
619    
620     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
621     - [0.1.0-15]
622     - Moved db config fragments here from e-smith-base [markk 5509]
623    
624     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
625     - [0.1.0-14]
626     - Make /server-resources/ browsable from LAN [gordonr 6620]
627    
628     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
629     - [0.1.0-13]
630     - Delete Apache ReadmeName directive [gordonr 6313]
631    
632     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
633     - [0.1.0-12]
634     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
635    
636     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
637     - [0.1.0-11]
638     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
639     deleted ./etc/httpd/conf/srm.conf/template-begin
640     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
641    
642     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
643     - [0.1.0-10]
644     - Delete empty template-end file [lijied 3295]
645    
646     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
647     - [0.1.0-09]
648     - Remove more references to primary and wwwpublic in favour
649     of the "Primary" i-bay. There is still some special case code,
650     which might go later if it turns out not to be needed.
651     [charlieb 5652]
652    
653     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
654     - [0.1.0-08]
655     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
656    
657     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
658     - [0.1.0-07]
659     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
660     need to recalculate these values [gordonr 7635]
661     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
662    
663     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
664     - [0.1.0-06]
665     - Remove special case handling for /home/e-smith/files/primary in Apache
666     configuration. Migrate code and db entries for wwwpublic to Public.
667     [charlieb 5652]
668    
669     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
670     - [0.1.0-05]
671     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
672     VirtualHosts fragment of httpd.conf templates. Fixes template
673     expansion breakage (I'm not sure what broke it, but this fixes it.)
674     [charlieb]
675     - Add default config db fragments to set type and status. Remove redundant
676     conf-httpd-e-smith script. [charlieb 1507]
677    
678     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
679     - [0.1.0-04]
680     - Move SSL initialisation to global context [gordonr 1432]
681    
682     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
683     - [0.1.0-03]
684     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
685    
686     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
687     - [0.1.0-02]
688     - Added conf-httpd-e-smith action linked to the same events as conf-startup
689     in e-smith-base [markk 6428]
690    
691     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
692     - [0.1.0-01]
693     - Initial release, split out from e-smith-base [markk 6428]
694    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed