/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.18 - (hide annotations) (download)
Thu Sep 16 18:32:54 2021 UTC (2 years, 9 months ago) by jpp
Branch: MAIN
CVS Tags: e-smith-apache-2_6_0-15_el7_sme
Changes since 1.17: +5 -2 lines
* Thu Sep 16 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-15.sme
- fix httpd-e-smith failing to start on reboot in private server-gateway mode [SME: 11596]

1 jpp 1.18 # $Id: e-smith-apache.spec,v 1.17 2021/03/30 23:05:16 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 jpp 1.18 %define release 15
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.16 Patch8: e-smith-apache-2.6.0-bz10826-defaultSSLCert-if-file-does-not-exist.patch
22 jpp 1.17 Patch9: e-smith-apache-2.6.0-bz11551-httpsForceLocalOnly.patch
23 jpp 1.6
24 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
25     BuildArchitectures: noarch
26     Requires: e-smith-base >= 4.15.1
27     Requires: e-smith-lib >= 1.15.1-19
28     Requires: e-smith-daemontools >= 1.7.1-01
29     Requires: mod_ssl
30     Requires: mod_authnz_external
31     Obsoletes: distcache <= 1.4.5
32     Obsoletes: mod_auth_external
33     Obsoletes: e-smith-proxypass
34     Obsoletes: e-smith-apache-proxy
35     Conflicts: e-smith-ibays < 1.0.2
36     AutoReqProv: no
37     BuildRequires: e-smith-devtools >= 1.11.0-12
38    
39     %description
40     e-smith server and gateway software - apache module.
41    
42 unnilennium 1.5 %prep
43     %setup
44     %patch0 -p1
45 jpp 1.6 %patch1 -p1
46 jpp 1.7 %patch2 -p1
47 jpp 1.8 %patch3 -p1
48 jpp 1.11 %patch4 -p1
49 jpp 1.12 %patch5 -p1
50 jpp 1.13 %patch6 -p1
51 jpp 1.15 %patch7 -p1
52     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
53 jpp 1.16 %patch8 -p1
54 jpp 1.17 %patch9 -p1
55 unnilennium 1.5
56     %build
57     perl createlinks
58    
59     %install
60     rm -rf $RPM_BUILD_ROOT
61     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
62    
63     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
64 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
65 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
66     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
67     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
68     > e-smith-%{version}-filelist
69    
70     echo "%doc COPYING" >> e-smith-%{version}-filelist
71    
72     %clean
73     rm -rf $RPM_BUILD_ROOT
74    
75     %files -f e-smith-%{version}-filelist
76     %defattr(-,root,root)
77    
78 jpp 1.15 %pre
79     # ease the transition between runit and systemd
80     if [ $1 -gt 1 ] ; then
81     if [ -e /var/service/httpd-e-smith/run ] ; then
82     /usr/bin/sv d httpd-e-smith
83     fi
84     fi
85 unnilennium 1.5
86 vip-ire 1.1 %changelog
87 jpp 1.18 * Thu Sep 16 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-15.sme
88     - fix httpd-e-smith failing to start on reboot in private server-gateway mode [SME: 11596]
89    
90 jpp 1.17 * Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-14.sme
91     - add possibility to force https on LAN only [SME: 11511]
92     usefull for VPN over port 443
93    
94 jpp 1.16 * Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
95     - prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
96     default on self generated cert
97    
98 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
99     - create-update event [SME: 11123]
100     - move httpd-e-smith to systemd [SME: 11111]
101     changed sigusr1 used in events to reload as defined in the unit file
102     - give a logger to httpd-e-smith : journald [SME: 1416]
103    
104 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
105     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
106    
107 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
108     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
109    
110 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
111     - port 80 and 443 should not be hardcoded [SME: 9192]
112     - e-smith-apache removing hardcoded ports [SME: 10966]
113    
114 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
115     - remove php3 and php4 refs [SME: 10867]
116    
117 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
118 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
119 jpp 1.9 * put strong ciphers first in default string
120 jpp 1.10 * cipher order and properties with periods
121 jpp 1.8
122 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
123     - add SSLHonorCipherOrder Directive [SME: 10916]
124    
125 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
126     - update apache icon path [SME: 9591]
127    
128 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
129     - fix syntax preventing httpd to launch [SME: 9364]
130     - moved changelog at end of file
131    
132 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
133     - Roll new stream for sme10
134    
135     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
136     - Hook into the new ssl-update event [SME: 9152]
137    
138     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
139     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
140    
141     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
142     - Disable TLSv1 [SME: 9154]
143    
144     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
145     - Disable SSLv3 [SME: 8722]
146    
147     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
148     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
149    
150     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
151     - Mitigate CVE-2012-4929 [SME: 8613]
152    
153     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
154     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
155    
156     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
157     - Remove insecure ciphers [SME: 8138]
158    
159     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
160     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
161     - Add authz_groupfile as a loadable Module [SME: 7875]
162    
163     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
164     - Patch to add missing default httpd.conf modules [SME: 7874]
165    
166     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
167     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
168    
169     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
170     - Obsolete el5 version of distcache [SME: 7273]
171    
172     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
173     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
174     - Change the way module is loaded and initialized
175    
176     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
177     - Add missing dependency on mod_ssl [SME: 7234]
178    
179     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
180     - Roll new stream for sme9
181    
182     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
183     - Disable index listing of Apache icons folder [SME: 7015]
184    
185     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
186     - Fix server-resources redirect w/o trailing slash [SME: 6758]
187    
188     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
189     - Disable SSLv2 by default [SME: 6482]
190    
191     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
192     - Add option to disable SSLv2 [SME: 5034]
193    
194     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
195     - Add OpenOffice2 MIME Types [SME: 5112]
196    
197     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
198     - Add OpenOffice MIME Types [SME: 4848]
199     - Add XML MIME Type [SME: 5035]
200    
201     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
202     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
203    
204     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
205     - Add Microsoft Office 2007 MIME types [SME: 4548]
206    
207     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
208     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
209    
210     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
211     - Add SSL support to ProxyPass. [SME: 3481]
212    
213     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
214     - Create/Move httpd logrotate.d directory. [SME: 3380]
215    
216     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
217     - Rename apache to httpd in templates2expand. [SME: 3380]
218    
219     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
220     - Fix patch to exclude hosts if domains exist [SME: 2307]
221    
222     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
223     - Use correct lib for modules
224    
225     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
226     - Clean up spec so package can be built by koji/plague
227    
228     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
229     - Fix patch so template expands [SME: 2307]
230    
231     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
232     - Don't include host if domain exists [SME: 2307]
233    
234     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
235     - Gracefully handle differences in module names between apache
236     versions. [SME: 2471]
237     - Add logrotate changes which should have been in 1.2.0-7 (patch
238     was provided but not applied).
239    
240     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
241     - Remove proxypass fragment (now in e-smith-manager)
242    
243     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
244     - Remove proxypass fragment (now in e-smith-manager)
245    
246     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
247     - Move logrotate fragments from e-smith-base.
248    
249     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
250     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
251    
252     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
253     - Update to new release naming. No functional changes.
254     - Make Packager generic
255    
256     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
257     - Revert last change [SME: 2109]
258     - TODO: Split dev stream for that change
259     - Add Conflicts for latest e-smith-manager dev stream
260    
261     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
262     - Remove manager proxy pass fragment - moved to e-smith-manager.
263    
264     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
265     - Add ProxyPassReverse directives to allow redirects to work for proxy-
266     passed virtual domains. Also proxy pass https to https. [SME: 1735]
267    
268     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
269     - Roll stable stream version. [SME: 1016]
270    
271     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
272     - Fix lookup of 'httpd' props in a few templates. Service name is
273     httpd-e-smith. [SME: 1029]
274    
275     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
276     - Deny access to files starting with .ht typically
277     .htaccess and .htpasswd [SME: 716]
278    
279     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
280     - Change modPerl from enabled to disabled [SME: 575]
281    
282     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
283     - Add SVG filetype [SME: 374]
284    
285     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
286     - And relocate the modSSL{CipherSuite} default to e-smith-base with
287     the other modSSL defaults [SME: 194]
288    
289     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
290     - Change default CipherSuite [SME: 194]
291     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
292     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
293    
294     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
295     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
296    
297     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
298     - Remove inode from FileETag response [SME: 198]
299    
300     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
301     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
302    
303     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
304     - Add type for XSL stylesheet (.xsl) files [SME: 76]
305    
306     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
307     - Bump release number only
308    
309     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
310     - [1.1.2-26]
311     - Add content from e-smith-apache-proxy, to enable apache to
312     also operate as a non-caching proxy server. Add Obsoletes:
313     header to ensure e-smith-apache-proxy RPM is removed on
314     upgrade.
315    
316     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
317     - [1.1.2-25]
318     - Add directive for icons directory
319     - Fix newlines left on end of icons template
320     - Update server aliases to reference all local hosts [SF: 1246172]
321    
322     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
323     - [1.1.2-24]
324     - Fix Rewrite rule to include trailing stuff
325    
326     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
327     - [1.1.2-23]
328     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
329    
330     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
331     - [1.1.2-22]
332     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
333     Rowell, with some further work by Shad Lords). [SF: 1240658]
334    
335     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
336     - [1.1.2-21]
337     - Disable all low grade ciphers for SSL. [SF: 1240654]
338    
339     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
340     - [1.1.2-20]
341     - Don't load userdir module by default. It's not used, and causes
342     Nessus to complain. [SF: 1240657]
343    
344     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
345     - [1.1.2-19]
346     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
347     [SF: 1172203]
348    
349     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
350     - [1.1.2-18]
351     - Add GPL COPYING file.
352    
353     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
354     - [1.1.2-17]
355     - Clean up apache templates to use current DB interfaces.
356     - Make sure the single host ValidFrom specs for proxypass doesn't
357     upset apache.
358    
359     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
360     - [1.1.2-16]
361     - Make sure that DocumentRoot directory exists - latest apache2
362     will not start up if not.
363    
364     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
365     - [1.1.2-15]
366     - Do graceful restart of apache in domain-*, in case domain->ibay
367     assignments have changed. [SF: 1222433]
368    
369     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
370     - [1.1.2-14]
371     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
372     requests.
373    
374     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
375     - [1.1.2-13]
376     - Add support for TemplatePath => ProxyPassVirtualHost entries
377     in domains db.
378    
379     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
380     - [1.1.2-12]
381     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
382    
383     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
384     - [1.1.2-11]
385     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
386     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
387    
388     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
389     - [1.1.2-10]
390     - Add default TCPPort property to httpd-e-smith, so that correct
391     hole is punched in firewall.
392    
393     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
394     - [1.1.2-09]
395     - Remove mangling of syslog and apache log filenames - just
396     retargeting the symlinks has the same effect. [MN00064132]
397    
398     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
399     - [1.1.2-08]
400     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
401    
402     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
403     - [1.1.2-07]
404     - Fix dangling symlink in ibay-create. [MN00065576]
405    
406     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
407     - [1.1.2-06]
408     - Use generic_template_expand action where possible, in place
409     of specific actions. Update e-smith-lib dependency. [MN00064130]
410     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
411     Update e-smith-lib version dependency. [MN00065576]
412    
413     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
414     - [1.1.2-05]
415     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
416     [MN00065717]
417    
418     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
419     - [1.1.2-04]
420     - Remove stray ServiceLink sylinks. [MN00064757]
421    
422     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
423     - [1.1.2-03]
424     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
425     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
426    
427     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
428     - [1.1.2-02]
429     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
430     one in e-smith-base. [MN00062533]
431    
432     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
433     - [1.1.2-01]
434     - Picking up new directory. MN00056429.
435    
436     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
437     - [1.1.1-03]
438     - Added empty ValidFrom defaults fragment [markk MN00056429]
439    
440     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
441     - [1.1.1-02]
442     - Modify config and run script for compatibility with apache 2. Most of these
443     changes were contributed by Shad Lords. [charlieb MN00051144]
444    
445     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
446     - [1.1.1-01]
447     - New development stream for apache 2 - 1.1.1
448    
449     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
450     - [1.1.0-23]
451     - Clean BuildRequires. [charlieb MN00043055]
452    
453     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
454     - [1.1.0-22]
455     - Updated modPerl templates to remove use of esmith::config.
456     [msoulier MN00039579]
457    
458     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
459     - [1.1.0-21]
460     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
461     so ssh port-forwarding is not broken. [msoulier MN00020885]
462    
463     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
464     - [1.1.0-20]
465     - Fix LoadModule fragment from last patch [tonyc 11348]
466    
467     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
468     - [1.1.0-19]
469     - Add modPerl service and httpd.conf templates [tonyc 11348]
470    
471     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
472     - [1.1.0-18]
473     - Adding rewrite rules to prevent plaintext access to the server manager.
474     [msoulier MN00020885]
475    
476     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
477     - [1.1.0-17]
478     - Added httpd-admin's remoteaccess list to permissible networks for
479     server-resources. [msoulier MN00024949]
480    
481     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
482     - [1.1.0-16]
483     - Backing-out last change. [msoulier dpar-21489]
484    
485     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
486     - [1.1.0-15]
487     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
488    
489     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
490     - [1.1.0-14]
491     - Updating requires to e-smith-daemontools. [msoulier 7629]
492    
493     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
494     - [1.1.0-13]
495     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
496     [msoulier 7629]
497    
498     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
499     - [1.1.0-12]
500     - Staggering the symlinks a little farther. [msoulier 9955]
501    
502     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
503     - [1.1.0-11]
504     - Adding symlinks to the service-domain-create event for httpd restart.
505     [msoulier 9955]
506    
507     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
508     - [1.1.0-10]
509     - Fixed another error in the specfile, resulting in incorrect file
510     permissions. [msoulier 7629]
511     - Updated action scripts for supervise. [msoulier 7629]
512    
513     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
514     - [1.1.0-09]
515     - Fixed an error in the specfile. [msoulier 7629]
516    
517     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
518     - [1.1.0-08]
519     - Updated createlinks for daemontools. [msoulier 7629]
520    
521     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
522     - [1.1.0-07]
523     - Putting httpd-e-smith under supervision. [msoulier 7629]
524    
525     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
526     - [1.1.0-06]
527     - Added a null-string return value to the end of 00Setup, ensure no output
528     from that fragment. [msoulier 9803]
529    
530     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
531     - [1.1.0-05]
532     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
533     [charlieb 9803]
534    
535     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
536     - [1.1.0-04]
537     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
538     files. [msoulier 9866]
539    
540     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
541     - [1.1.0-03]
542     - Allow TemplatePath property in domain record to specify an alternate template
543     subdir for virtual host content specification (e.g. to proxypass a domain).
544     [charlieb 8409]
545    
546     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
547     - [1.1.0-02]
548     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
549     and modified VirtualHosts/00Setup fragment to convert it to the right class.
550     Fix scoping problem with the blessed object. [charlieb 9803]
551    
552     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
553     - [1.1.0-01]
554     - rolling to dev stream - 1.1.0
555    
556     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
557     - [1.0.0-04]
558     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
559     into an esmith::DomainsDB object. [msoulier 9803]
560    
561     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
562     - [1.0.0-03]
563     - Added a reference to the domains db in the extra data for processing the
564     VirtualHosts fragments. [msoulier 9803]
565    
566     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
567     - [1.0.0-02]
568     - Fixed a precedence error that broke virtual hosts in apache.
569     [msoulier 9640]
570    
571     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
572     - [1.0.0-01]
573     - Setting to release version number - 1.0.0
574    
575     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
576     - [0.2.0-04]
577     - Fixed breakage in admin web server when a local network with a 32-bit subnet
578     mask is used. [msoulier 9259]
579    
580     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
581     - [0.2.0-03]
582     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
583    
584     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
585     - [0.2.0-02]
586     - List primary domain as first (default) virtual domain in apache config.
587     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
588    
589     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
590     - [0.2.0-01]
591     - Changing version to stable stream number - 0.2.0
592    
593     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
594     - [0.1.2-01]
595     - Add order to migrate fragments [gordonr 9015]
596    
597     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
598     - [0.1.1-02]
599     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
600    
601     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
602     - [0.1.1-01]
603     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
604    
605     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
606     - [0.1.0-19]
607     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
608    
609     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
610     - [0.1.0-18]
611     - Do an explicit die if the httpd-e-smith record is missing from the
612     config db, rather than an implicit die due to an invalid object
613     reference [gordonr 8609]
614    
615     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
616     - [0.1.0-17]
617     - Relocated conf-httpd from e-smith-base [gordonr 8150]
618    
619     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
620     - [0.1.0-16]
621     - Moved restart-httpd-* actions from base [markk 5509]
622    
623     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
624     - [0.1.0-15]
625     - Moved db config fragments here from e-smith-base [markk 5509]
626    
627     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
628     - [0.1.0-14]
629     - Make /server-resources/ browsable from LAN [gordonr 6620]
630    
631     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
632     - [0.1.0-13]
633     - Delete Apache ReadmeName directive [gordonr 6313]
634    
635     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
636     - [0.1.0-12]
637     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
638    
639     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
640     - [0.1.0-11]
641     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
642     deleted ./etc/httpd/conf/srm.conf/template-begin
643     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
644    
645     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
646     - [0.1.0-10]
647     - Delete empty template-end file [lijied 3295]
648    
649     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
650     - [0.1.0-09]
651     - Remove more references to primary and wwwpublic in favour
652     of the "Primary" i-bay. There is still some special case code,
653     which might go later if it turns out not to be needed.
654     [charlieb 5652]
655    
656     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
657     - [0.1.0-08]
658     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
659    
660     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
661     - [0.1.0-07]
662     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
663     need to recalculate these values [gordonr 7635]
664     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
665    
666     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
667     - [0.1.0-06]
668     - Remove special case handling for /home/e-smith/files/primary in Apache
669     configuration. Migrate code and db entries for wwwpublic to Public.
670     [charlieb 5652]
671    
672     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
673     - [0.1.0-05]
674     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
675     VirtualHosts fragment of httpd.conf templates. Fixes template
676     expansion breakage (I'm not sure what broke it, but this fixes it.)
677     [charlieb]
678     - Add default config db fragments to set type and status. Remove redundant
679     conf-httpd-e-smith script. [charlieb 1507]
680    
681     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
682     - [0.1.0-04]
683     - Move SSL initialisation to global context [gordonr 1432]
684    
685     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
686     - [0.1.0-03]
687     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
688    
689     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
690     - [0.1.0-02]
691     - Added conf-httpd-e-smith action linked to the same events as conf-startup
692     in e-smith-base [markk 6428]
693    
694     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
695     - [0.1.0-01]
696     - Initial release, split out from e-smith-base [markk 6428]
697    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed