/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.25 - (hide annotations) (download)
Mon Jul 25 08:51:14 2022 UTC (22 months, 3 weeks ago) by jpp
Branch: MAIN
Changes since 1.24: +9 -3 lines
* Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-22.sme
- reverting last change [SME: 9375]
- add conflict on older ibays, php, horde, proxy, manager rpms

1 jpp 1.25 # $Id: e-smith-apache.spec,v 1.24 2022/07/25 08:24:04 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 jpp 1.24 %define release 21
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.16 Patch8: e-smith-apache-2.6.0-bz10826-defaultSSLCert-if-file-does-not-exist.patch
22 jpp 1.17 Patch9: e-smith-apache-2.6.0-bz11551-httpsForceLocalOnly.patch
23 jpp 1.19 Patch10: e-smith-apache-2.6.0-bz11760-moremodules.patch
24 jpp 1.20 Patch11: e-smith-apache-2.6.0-bz11867.patch
25 jpp 1.22 Patch12: e-smith-apache-2.6.0-bz9375-Require.patch
26 jpp 1.6
27 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
28     BuildArchitectures: noarch
29     Requires: e-smith-base >= 4.15.1
30     Requires: e-smith-lib >= 1.15.1-19
31     Requires: e-smith-daemontools >= 1.7.1-01
32     Requires: mod_ssl
33     Requires: mod_authnz_external
34     Obsoletes: distcache <= 1.4.5
35     Obsoletes: mod_auth_external
36     Obsoletes: e-smith-proxypass
37     Obsoletes: e-smith-apache-proxy
38 jpp 1.25 # for the new httpd 2.4 syntax
39     Conflicts: e-smith-ibays < 2.6.0-19
40     Conflicts: smeserver-horde < 1.0.0-32
41     Conflicts: smeserver-php < 3.0.0-43
42     Conflicts: e-smith-proxy < 5.6.0-11
43     Conflicts: e-smith-manager < 2.8.0-36
44 vip-ire 1.1 AutoReqProv: no
45     BuildRequires: e-smith-devtools >= 1.11.0-12
46    
47     %description
48     e-smith server and gateway software - apache module.
49    
50 unnilennium 1.5 %prep
51     %setup
52     %patch0 -p1
53 jpp 1.6 %patch1 -p1
54 jpp 1.7 %patch2 -p1
55 jpp 1.8 %patch3 -p1
56 jpp 1.11 %patch4 -p1
57 jpp 1.12 %patch5 -p1
58 jpp 1.13 %patch6 -p1
59 jpp 1.15 %patch7 -p1
60     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
61 jpp 1.16 %patch8 -p1
62 jpp 1.17 %patch9 -p1
63 jpp 1.19 %patch10 -p1
64 jpp 1.20 %patch11 -p1
65 jpp 1.22 %patch12 -p1
66 unnilennium 1.5
67     %build
68     perl createlinks
69    
70     %install
71     rm -rf $RPM_BUILD_ROOT
72     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
73    
74     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
75 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
76 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
77     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
78     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
79     > e-smith-%{version}-filelist
80    
81     echo "%doc COPYING" >> e-smith-%{version}-filelist
82    
83     %clean
84     rm -rf $RPM_BUILD_ROOT
85    
86     %files -f e-smith-%{version}-filelist
87     %defattr(-,root,root)
88    
89 jpp 1.15 %pre
90     # ease the transition between runit and systemd
91     if [ $1 -gt 1 ] ; then
92     if [ -e /var/service/httpd-e-smith/run ] ; then
93     /usr/bin/sv d httpd-e-smith
94     fi
95     fi
96 unnilennium 1.5
97 vip-ire 1.1 %changelog
98 jpp 1.25 * Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-22.sme
99 jpp 1.24 - reverting last change [SME: 9375]
100 jpp 1.25 - add conflict on older ibays, php, horde, proxy, manager rpms
101 jpp 1.24
102 jpp 1.23 * Sun Jul 24 2022 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-20.sme
103     - removing mod_access_compat [SME: 9375]
104    
105 jpp 1.22 * Sat Apr 16 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-19.sme
106     - convert httpd 2.2 allow,deny to Require for 2.4 [SME: 9375]
107     - use maxsize, not size [SME: 11867]
108    
109 jpp 1.21 * Fri Feb 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-18.sme
110 jpp 1.20 - use logrotate.d instead of event action [SME: 11867]
111 jpp 1.21 use size to force log rotate before normal delay
112 jpp 1.20
113 jpp 1.19 * Mon Nov 15 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-16.sme
114     - add modules ldap authnz_ldap and proxy_wstunnel [SME: 11760]
115     previously provided by webapps-common
116    
117 jpp 1.18 * Thu Sep 16 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-15.sme
118     - fix httpd-e-smith failing to start on reboot in private server-gateway mode [SME: 11596]
119    
120 jpp 1.17 * Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-14.sme
121     - add possibility to force https on LAN only [SME: 11511]
122     usefull for VPN over port 443
123    
124 jpp 1.16 * Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
125     - prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
126     default on self generated cert
127    
128 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
129     - create-update event [SME: 11123]
130     - move httpd-e-smith to systemd [SME: 11111]
131     changed sigusr1 used in events to reload as defined in the unit file
132     - give a logger to httpd-e-smith : journald [SME: 1416]
133    
134 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
135     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
136    
137 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
138     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
139    
140 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
141     - port 80 and 443 should not be hardcoded [SME: 9192]
142     - e-smith-apache removing hardcoded ports [SME: 10966]
143    
144 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
145     - remove php3 and php4 refs [SME: 10867]
146    
147 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
148 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
149 jpp 1.9 * put strong ciphers first in default string
150 jpp 1.10 * cipher order and properties with periods
151 jpp 1.8
152 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
153     - add SSLHonorCipherOrder Directive [SME: 10916]
154    
155 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
156     - update apache icon path [SME: 9591]
157    
158 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
159     - fix syntax preventing httpd to launch [SME: 9364]
160     - moved changelog at end of file
161    
162 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
163     - Roll new stream for sme10
164    
165     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
166     - Hook into the new ssl-update event [SME: 9152]
167    
168     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
169     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
170    
171     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
172     - Disable TLSv1 [SME: 9154]
173    
174     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
175     - Disable SSLv3 [SME: 8722]
176    
177     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
178     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
179    
180     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
181     - Mitigate CVE-2012-4929 [SME: 8613]
182    
183     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
184     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
185    
186     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
187     - Remove insecure ciphers [SME: 8138]
188    
189     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
190     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
191     - Add authz_groupfile as a loadable Module [SME: 7875]
192    
193     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
194     - Patch to add missing default httpd.conf modules [SME: 7874]
195    
196     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
197     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
198    
199     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
200     - Obsolete el5 version of distcache [SME: 7273]
201    
202     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
203     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
204     - Change the way module is loaded and initialized
205    
206     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
207     - Add missing dependency on mod_ssl [SME: 7234]
208    
209     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
210     - Roll new stream for sme9
211    
212     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
213     - Disable index listing of Apache icons folder [SME: 7015]
214    
215     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
216     - Fix server-resources redirect w/o trailing slash [SME: 6758]
217    
218     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
219     - Disable SSLv2 by default [SME: 6482]
220    
221     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
222     - Add option to disable SSLv2 [SME: 5034]
223    
224     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
225     - Add OpenOffice2 MIME Types [SME: 5112]
226    
227     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
228     - Add OpenOffice MIME Types [SME: 4848]
229     - Add XML MIME Type [SME: 5035]
230    
231     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
232     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
233    
234     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
235     - Add Microsoft Office 2007 MIME types [SME: 4548]
236    
237     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
238     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
239    
240     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
241     - Add SSL support to ProxyPass. [SME: 3481]
242    
243     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
244     - Create/Move httpd logrotate.d directory. [SME: 3380]
245    
246     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
247     - Rename apache to httpd in templates2expand. [SME: 3380]
248    
249     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
250     - Fix patch to exclude hosts if domains exist [SME: 2307]
251    
252     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
253     - Use correct lib for modules
254    
255     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
256     - Clean up spec so package can be built by koji/plague
257    
258     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
259     - Fix patch so template expands [SME: 2307]
260    
261     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
262     - Don't include host if domain exists [SME: 2307]
263    
264     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
265     - Gracefully handle differences in module names between apache
266     versions. [SME: 2471]
267     - Add logrotate changes which should have been in 1.2.0-7 (patch
268     was provided but not applied).
269    
270     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
271     - Remove proxypass fragment (now in e-smith-manager)
272    
273     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
274     - Remove proxypass fragment (now in e-smith-manager)
275    
276     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
277     - Move logrotate fragments from e-smith-base.
278    
279     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
280     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
281    
282     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
283     - Update to new release naming. No functional changes.
284     - Make Packager generic
285    
286     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
287     - Revert last change [SME: 2109]
288     - TODO: Split dev stream for that change
289     - Add Conflicts for latest e-smith-manager dev stream
290    
291     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
292     - Remove manager proxy pass fragment - moved to e-smith-manager.
293    
294     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
295     - Add ProxyPassReverse directives to allow redirects to work for proxy-
296     passed virtual domains. Also proxy pass https to https. [SME: 1735]
297    
298     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
299     - Roll stable stream version. [SME: 1016]
300    
301     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
302     - Fix lookup of 'httpd' props in a few templates. Service name is
303     httpd-e-smith. [SME: 1029]
304    
305     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
306     - Deny access to files starting with .ht typically
307     .htaccess and .htpasswd [SME: 716]
308    
309     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
310     - Change modPerl from enabled to disabled [SME: 575]
311    
312     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
313     - Add SVG filetype [SME: 374]
314    
315     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
316     - And relocate the modSSL{CipherSuite} default to e-smith-base with
317     the other modSSL defaults [SME: 194]
318    
319     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
320     - Change default CipherSuite [SME: 194]
321     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
322     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
323    
324     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
325     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
326    
327     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
328     - Remove inode from FileETag response [SME: 198]
329    
330     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
331     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
332    
333     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
334     - Add type for XSL stylesheet (.xsl) files [SME: 76]
335    
336     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
337     - Bump release number only
338    
339     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
340     - [1.1.2-26]
341     - Add content from e-smith-apache-proxy, to enable apache to
342     also operate as a non-caching proxy server. Add Obsoletes:
343     header to ensure e-smith-apache-proxy RPM is removed on
344     upgrade.
345    
346     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
347     - [1.1.2-25]
348     - Add directive for icons directory
349     - Fix newlines left on end of icons template
350     - Update server aliases to reference all local hosts [SF: 1246172]
351    
352     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
353     - [1.1.2-24]
354     - Fix Rewrite rule to include trailing stuff
355    
356     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
357     - [1.1.2-23]
358     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
359    
360     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
361     - [1.1.2-22]
362     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
363     Rowell, with some further work by Shad Lords). [SF: 1240658]
364    
365     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
366     - [1.1.2-21]
367     - Disable all low grade ciphers for SSL. [SF: 1240654]
368    
369     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
370     - [1.1.2-20]
371     - Don't load userdir module by default. It's not used, and causes
372     Nessus to complain. [SF: 1240657]
373    
374     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
375     - [1.1.2-19]
376     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
377     [SF: 1172203]
378    
379     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
380     - [1.1.2-18]
381     - Add GPL COPYING file.
382    
383     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
384     - [1.1.2-17]
385     - Clean up apache templates to use current DB interfaces.
386     - Make sure the single host ValidFrom specs for proxypass doesn't
387     upset apache.
388    
389     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
390     - [1.1.2-16]
391     - Make sure that DocumentRoot directory exists - latest apache2
392     will not start up if not.
393    
394     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
395     - [1.1.2-15]
396     - Do graceful restart of apache in domain-*, in case domain->ibay
397     assignments have changed. [SF: 1222433]
398    
399     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
400     - [1.1.2-14]
401     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
402     requests.
403    
404     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
405     - [1.1.2-13]
406     - Add support for TemplatePath => ProxyPassVirtualHost entries
407     in domains db.
408    
409     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
410     - [1.1.2-12]
411     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
412    
413     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
414     - [1.1.2-11]
415     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
416     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
417    
418     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
419     - [1.1.2-10]
420     - Add default TCPPort property to httpd-e-smith, so that correct
421     hole is punched in firewall.
422    
423     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
424     - [1.1.2-09]
425     - Remove mangling of syslog and apache log filenames - just
426     retargeting the symlinks has the same effect. [MN00064132]
427    
428     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
429     - [1.1.2-08]
430     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
431    
432     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
433     - [1.1.2-07]
434     - Fix dangling symlink in ibay-create. [MN00065576]
435    
436     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
437     - [1.1.2-06]
438     - Use generic_template_expand action where possible, in place
439     of specific actions. Update e-smith-lib dependency. [MN00064130]
440     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
441     Update e-smith-lib version dependency. [MN00065576]
442    
443     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
444     - [1.1.2-05]
445     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
446     [MN00065717]
447    
448     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
449     - [1.1.2-04]
450     - Remove stray ServiceLink sylinks. [MN00064757]
451    
452     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
453     - [1.1.2-03]
454     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
455     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
456    
457     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
458     - [1.1.2-02]
459     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
460     one in e-smith-base. [MN00062533]
461    
462     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
463     - [1.1.2-01]
464     - Picking up new directory. MN00056429.
465    
466     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
467     - [1.1.1-03]
468     - Added empty ValidFrom defaults fragment [markk MN00056429]
469    
470     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
471     - [1.1.1-02]
472     - Modify config and run script for compatibility with apache 2. Most of these
473     changes were contributed by Shad Lords. [charlieb MN00051144]
474    
475     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
476     - [1.1.1-01]
477     - New development stream for apache 2 - 1.1.1
478    
479     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
480     - [1.1.0-23]
481     - Clean BuildRequires. [charlieb MN00043055]
482    
483     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
484     - [1.1.0-22]
485     - Updated modPerl templates to remove use of esmith::config.
486     [msoulier MN00039579]
487    
488     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
489     - [1.1.0-21]
490     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
491     so ssh port-forwarding is not broken. [msoulier MN00020885]
492    
493     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
494     - [1.1.0-20]
495     - Fix LoadModule fragment from last patch [tonyc 11348]
496    
497     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
498     - [1.1.0-19]
499     - Add modPerl service and httpd.conf templates [tonyc 11348]
500    
501     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
502     - [1.1.0-18]
503     - Adding rewrite rules to prevent plaintext access to the server manager.
504     [msoulier MN00020885]
505    
506     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
507     - [1.1.0-17]
508     - Added httpd-admin's remoteaccess list to permissible networks for
509     server-resources. [msoulier MN00024949]
510    
511     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
512     - [1.1.0-16]
513     - Backing-out last change. [msoulier dpar-21489]
514    
515     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
516     - [1.1.0-15]
517     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
518    
519     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
520     - [1.1.0-14]
521     - Updating requires to e-smith-daemontools. [msoulier 7629]
522    
523     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
524     - [1.1.0-13]
525     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
526     [msoulier 7629]
527    
528     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
529     - [1.1.0-12]
530     - Staggering the symlinks a little farther. [msoulier 9955]
531    
532     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
533     - [1.1.0-11]
534     - Adding symlinks to the service-domain-create event for httpd restart.
535     [msoulier 9955]
536    
537     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
538     - [1.1.0-10]
539     - Fixed another error in the specfile, resulting in incorrect file
540     permissions. [msoulier 7629]
541     - Updated action scripts for supervise. [msoulier 7629]
542    
543     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
544     - [1.1.0-09]
545     - Fixed an error in the specfile. [msoulier 7629]
546    
547     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
548     - [1.1.0-08]
549     - Updated createlinks for daemontools. [msoulier 7629]
550    
551     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
552     - [1.1.0-07]
553     - Putting httpd-e-smith under supervision. [msoulier 7629]
554    
555     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
556     - [1.1.0-06]
557     - Added a null-string return value to the end of 00Setup, ensure no output
558     from that fragment. [msoulier 9803]
559    
560     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
561     - [1.1.0-05]
562     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
563     [charlieb 9803]
564    
565     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
566     - [1.1.0-04]
567     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
568     files. [msoulier 9866]
569    
570     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
571     - [1.1.0-03]
572     - Allow TemplatePath property in domain record to specify an alternate template
573     subdir for virtual host content specification (e.g. to proxypass a domain).
574     [charlieb 8409]
575    
576     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
577     - [1.1.0-02]
578     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
579     and modified VirtualHosts/00Setup fragment to convert it to the right class.
580     Fix scoping problem with the blessed object. [charlieb 9803]
581    
582     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
583     - [1.1.0-01]
584     - rolling to dev stream - 1.1.0
585    
586     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
587     - [1.0.0-04]
588     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
589     into an esmith::DomainsDB object. [msoulier 9803]
590    
591     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
592     - [1.0.0-03]
593     - Added a reference to the domains db in the extra data for processing the
594     VirtualHosts fragments. [msoulier 9803]
595    
596     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
597     - [1.0.0-02]
598     - Fixed a precedence error that broke virtual hosts in apache.
599     [msoulier 9640]
600    
601     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
602     - [1.0.0-01]
603     - Setting to release version number - 1.0.0
604    
605     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
606     - [0.2.0-04]
607     - Fixed breakage in admin web server when a local network with a 32-bit subnet
608     mask is used. [msoulier 9259]
609    
610     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
611     - [0.2.0-03]
612     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
613    
614     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
615     - [0.2.0-02]
616     - List primary domain as first (default) virtual domain in apache config.
617     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
618    
619     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
620     - [0.2.0-01]
621     - Changing version to stable stream number - 0.2.0
622    
623     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
624     - [0.1.2-01]
625     - Add order to migrate fragments [gordonr 9015]
626    
627     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
628     - [0.1.1-02]
629     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
630    
631     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
632     - [0.1.1-01]
633     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
634    
635     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
636     - [0.1.0-19]
637     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
638    
639     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
640     - [0.1.0-18]
641     - Do an explicit die if the httpd-e-smith record is missing from the
642     config db, rather than an implicit die due to an invalid object
643     reference [gordonr 8609]
644    
645     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
646     - [0.1.0-17]
647     - Relocated conf-httpd from e-smith-base [gordonr 8150]
648    
649     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
650     - [0.1.0-16]
651     - Moved restart-httpd-* actions from base [markk 5509]
652    
653     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
654     - [0.1.0-15]
655     - Moved db config fragments here from e-smith-base [markk 5509]
656    
657     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
658     - [0.1.0-14]
659     - Make /server-resources/ browsable from LAN [gordonr 6620]
660    
661     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
662     - [0.1.0-13]
663     - Delete Apache ReadmeName directive [gordonr 6313]
664    
665     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
666     - [0.1.0-12]
667     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
668    
669     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
670     - [0.1.0-11]
671     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
672     deleted ./etc/httpd/conf/srm.conf/template-begin
673     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
674    
675     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
676     - [0.1.0-10]
677     - Delete empty template-end file [lijied 3295]
678    
679     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
680     - [0.1.0-09]
681     - Remove more references to primary and wwwpublic in favour
682     of the "Primary" i-bay. There is still some special case code,
683     which might go later if it turns out not to be needed.
684     [charlieb 5652]
685    
686     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
687     - [0.1.0-08]
688     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
689    
690     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
691     - [0.1.0-07]
692     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
693     need to recalculate these values [gordonr 7635]
694     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
695    
696     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
697     - [0.1.0-06]
698     - Remove special case handling for /home/e-smith/files/primary in Apache
699     configuration. Migrate code and db entries for wwwpublic to Public.
700     [charlieb 5652]
701    
702     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
703     - [0.1.0-05]
704     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
705     VirtualHosts fragment of httpd.conf templates. Fixes template
706     expansion breakage (I'm not sure what broke it, but this fixes it.)
707     [charlieb]
708     - Add default config db fragments to set type and status. Remove redundant
709     conf-httpd-e-smith script. [charlieb 1507]
710    
711     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
712     - [0.1.0-04]
713     - Move SSL initialisation to global context [gordonr 1432]
714    
715     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
716     - [0.1.0-03]
717     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
718    
719     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
720     - [0.1.0-02]
721     - Added conf-httpd-e-smith action linked to the same events as conf-startup
722     in e-smith-base [markk 6428]
723    
724     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
725     - [0.1.0-01]
726     - Initial release, split out from e-smith-base [markk 6428]
727    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed