/[smeserver]/rpms/e-smith-apache/sme10/e-smith-apache.spec
ViewVC logotype

Annotation of /rpms/e-smith-apache/sme10/e-smith-apache.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.27 - (hide annotations) (download)
Fri Oct 7 09:04:44 2022 UTC (20 months, 1 week ago) by terryfage
Branch: MAIN
CVS Tags: e-smith-apache-2_6_0-23_el7_sme, HEAD
Changes since 1.26: +7 -2 lines
* Fri Oct 07 2022 Zsolt Vasarhely <vasarhelyizsolt@hotmail.com> 2.6.0-23.sme
- Running reconfigure from server-manager hangs at S07rotate_logfiles [SME: 12207]

1 terryfage 1.27 # $Id: e-smith-apache.spec,v 1.26 2022/07/25 08:52:20 jpp Exp $
2 vip-ire 1.1
3     Summary: e-smith server and gateway - apache module
4     %define name e-smith-apache
5     Name: %{name}
6 vip-ire 1.4 %define version 2.6.0
7 terryfage 1.27 %define release 23
8 vip-ire 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.xz
13 unnilennium 1.5 Patch0: e-smith-apache-2.6.0-httpd24.patch
14 jpp 1.6 Patch1: e-smith-apache-2.6.0-bz9591-iconspath.patch
15 jpp 1.7 Patch2: e-smith-apache-2.6.0-bz10916-SSLHonorCipherOrder.patch
16 jpp 1.8 Patch3: e-smith-apache-2.6.0-bz10459-Ciphers-and-TLS.patch
17 jpp 1.11 Patch4: e-smith-apache-2.6.0-bz10867-remove-php3-refs.patch
18 jpp 1.12 Patch5: e-smith-apache-2.6.0-bz10966-remove-hardcoded-ports.patch
19 jpp 1.13 Patch6: e-smith-apache-2.6.0-bz8693-SNI.patch
20 jpp 1.15 Patch7: e-smith-apache-2.6.0-bz11123-bz11111-systemd-update.patch
21 jpp 1.16 Patch8: e-smith-apache-2.6.0-bz10826-defaultSSLCert-if-file-does-not-exist.patch
22 jpp 1.17 Patch9: e-smith-apache-2.6.0-bz11551-httpsForceLocalOnly.patch
23 jpp 1.19 Patch10: e-smith-apache-2.6.0-bz11760-moremodules.patch
24 jpp 1.20 Patch11: e-smith-apache-2.6.0-bz11867.patch
25 jpp 1.22 Patch12: e-smith-apache-2.6.0-bz9375-Require.patch
26 terryfage 1.27 Patch13: e-smith-apache-2.6.0-bz12207-reload-httpd-admin.patch
27 jpp 1.6
28 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
29     BuildArchitectures: noarch
30     Requires: e-smith-base >= 4.15.1
31     Requires: e-smith-lib >= 1.15.1-19
32     Requires: e-smith-daemontools >= 1.7.1-01
33     Requires: mod_ssl
34     Requires: mod_authnz_external
35     Obsoletes: distcache <= 1.4.5
36     Obsoletes: mod_auth_external
37     Obsoletes: e-smith-proxypass
38     Obsoletes: e-smith-apache-proxy
39 jpp 1.25 # for the new httpd 2.4 syntax
40     Conflicts: e-smith-ibays < 2.6.0-19
41     Conflicts: smeserver-horde < 1.0.0-32
42     Conflicts: smeserver-php < 3.0.0-43
43     Conflicts: e-smith-proxy < 5.6.0-11
44     Conflicts: e-smith-manager < 2.8.0-36
45 vip-ire 1.1 AutoReqProv: no
46     BuildRequires: e-smith-devtools >= 1.11.0-12
47    
48     %description
49     e-smith server and gateway software - apache module.
50    
51 unnilennium 1.5 %prep
52     %setup
53     %patch0 -p1
54 jpp 1.6 %patch1 -p1
55 jpp 1.7 %patch2 -p1
56 jpp 1.8 %patch3 -p1
57 jpp 1.11 %patch4 -p1
58 jpp 1.12 %patch5 -p1
59 jpp 1.13 %patch6 -p1
60 jpp 1.15 %patch7 -p1
61     rm -rf root/var/service/ root/service/ root/etc/rc.d/init.d/httpd-e-smith
62 jpp 1.16 %patch8 -p1
63 jpp 1.17 %patch9 -p1
64 jpp 1.19 %patch10 -p1
65 jpp 1.20 %patch11 -p1
66 jpp 1.22 %patch12 -p1
67 terryfage 1.27 %patch13 -p1
68 unnilennium 1.5
69     %build
70     perl createlinks
71    
72     %install
73     rm -rf $RPM_BUILD_ROOT
74     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
75    
76     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
77 jpp 1.15 --file /sbin/e-smith/systemd/httpd-e-smith-prepare 'attr(0554,root,root)' \
78 unnilennium 1.5 --dir /var/service/httpd-e-smith 'attr(01755,root,root)' \
79     --file /var/service/httpd-e-smith/down 'attr(0644,root,root)' \
80     --file /var/service/httpd-e-smith/run 'attr(0755,root,root)' \
81     > e-smith-%{version}-filelist
82    
83     echo "%doc COPYING" >> e-smith-%{version}-filelist
84    
85     %clean
86     rm -rf $RPM_BUILD_ROOT
87    
88     %files -f e-smith-%{version}-filelist
89     %defattr(-,root,root)
90    
91 jpp 1.15 %pre
92     # ease the transition between runit and systemd
93     if [ $1 -gt 1 ] ; then
94     if [ -e /var/service/httpd-e-smith/run ] ; then
95     /usr/bin/sv d httpd-e-smith
96     fi
97     fi
98 unnilennium 1.5
99 vip-ire 1.1 %changelog
100 terryfage 1.27 * Fri Oct 07 2022 Zsolt Vasarhely <vasarhelyizsolt@hotmail.com> 2.6.0-23.sme
101     - Running reconfigure from server-manager hangs at S07rotate_logfiles [SME: 12207]
102    
103 jpp 1.25 * Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-22.sme
104 jpp 1.24 - reverting last change [SME: 9375]
105 jpp 1.25 - add conflict on older ibays, php, horde, proxy, manager rpms
106 jpp 1.24
107 jpp 1.23 * Sun Jul 24 2022 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-20.sme
108     - removing mod_access_compat [SME: 9375]
109    
110 jpp 1.22 * Sat Apr 16 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-19.sme
111     - convert httpd 2.2 allow,deny to Require for 2.4 [SME: 9375]
112     - use maxsize, not size [SME: 11867]
113    
114 jpp 1.21 * Fri Feb 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-18.sme
115 jpp 1.20 - use logrotate.d instead of event action [SME: 11867]
116 jpp 1.21 use size to force log rotate before normal delay
117 jpp 1.20
118 jpp 1.19 * Mon Nov 15 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-16.sme
119     - add modules ldap authnz_ldap and proxy_wstunnel [SME: 11760]
120     previously provided by webapps-common
121    
122 jpp 1.18 * Thu Sep 16 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-15.sme
123     - fix httpd-e-smith failing to start on reboot in private server-gateway mode [SME: 11596]
124    
125 jpp 1.17 * Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 2.6.0-14.sme
126     - add possibility to force https on LAN only [SME: 11511]
127     usefull for VPN over port 443
128    
129 jpp 1.16 * Thu Dec 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-13.sme
130     - prevent httpd to fail if modSSL defined certs does not exist [SME: 10826]
131     default on self generated cert
132    
133 jpp 1.15 * Wed Dec 09 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-12.sme
134     - create-update event [SME: 11123]
135     - move httpd-e-smith to systemd [SME: 11111]
136     changed sigusr1 used in events to reload as defined in the unit file
137     - give a logger to httpd-e-smith : journald [SME: 1416]
138    
139 jpp 1.14 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-11.sme
140     - set default SSLStrictSNIVHostCheck to off [SME: 8693]
141    
142 jpp 1.13 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-10.sme
143     - add SNI support for individual certificates per VirtualHosts [SME: 8693]
144    
145 jpp 1.12 * Sat Jun 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-9.sme
146     - port 80 and 443 should not be hardcoded [SME: 9192]
147     - e-smith-apache removing hardcoded ports [SME: 10966]
148    
149 jpp 1.11 * Tue Jun 23 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-8.sme
150     - remove php3 and php4 refs [SME: 10867]
151    
152 jpp 1.10 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-7.sme
153 jpp 1.8 - disable TLSv1 TLSv1.1 by default [SME: 10459]
154 jpp 1.9 * put strong ciphers first in default string
155 jpp 1.10 * cipher order and properties with periods
156 jpp 1.8
157 jpp 1.7 * Fri May 01 2020 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-4.sme
158     - add SSLHonorCipherOrder Directive [SME: 10916]
159    
160 jpp 1.6 * Tue Dec 10 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-3.sme
161     - update apache icon path [SME: 9591]
162    
163 unnilennium 1.5 * Wed Mar 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.6.0-2.sme
164     - fix syntax preventing httpd to launch [SME: 9364]
165     - moved changelog at end of file
166    
167 vip-ire 1.1 * Thu Feb 4 2016 Daniel Berteaud <daniel@firewall-services.com> 2.6.0-1.sme
168     - Roll new stream for sme10
169    
170     * Sun Jan 17 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-15.sme
171     - Hook into the new ssl-update event [SME: 9152]
172    
173     * Thu Jan 7 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-14.sme
174     - Set TLSv1 back to enabled (but keep a prop to disable it if needed) [SME: 9154]
175    
176     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-13.sme
177     - Disable TLSv1 [SME: 9154]
178    
179     * Tue Dec 9 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-12.sme
180     - Disable SSLv3 [SME: 8722]
181    
182     * Fri Oct 31 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-11.sme
183     - Revert CRIME mitigation patch, as it's not needed [SME: 8613]
184    
185     * Fri Oct 24 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-10.sme
186     - Mitigate CVE-2012-4929 [SME: 8613]
187    
188     * Tue Jul 29 2014 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-9.sme
189     - Turn SSLEngine on in the SSL vhost (ProxyPassVirtualHosts) [SME: 8501]
190    
191     * Tue Jan 28 2014 Ian Wells <esmith@wellsi.com> 2.4.0-8.sme
192     - Remove insecure ciphers [SME: 8138]
193    
194     * Mon Oct 07 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-7.sme
195     - Re-do patch to add missing default httpd.conf modules [SME: 7874]
196     - Add authz_groupfile as a loadable Module [SME: 7875]
197    
198     * Fri Oct 04 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-6.sme
199     - Patch to add missing default httpd.conf modules [SME: 7874]
200    
201     * Mon Sep 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> 2.4.0-5.sme
202     - Patch to correct issue with not being able to access a password protected ibay [SME: 7794]
203    
204     * Mon Mar 11 2013 Shad L. Lords <slords@mail.com> 2.4.0-4.sme
205     - Obsolete el5 version of distcache [SME: 7273]
206    
207     * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 2.4.0-3.sme
208     - Obsolete mod_auth_external and require mod_authnz_external [SME: 7319]
209     - Change the way module is loaded and initialized
210    
211     * Mon Feb 18 2013 Daniel Berteaud <daniel@firewall-services.com> 2.4.0-2.sme
212     - Add missing dependency on mod_ssl [SME: 7234]
213    
214     * Wed Feb 13 2013 Shad L. Lords <slords@mail.com> 2.4.0-1.sme
215     - Roll new stream for sme9
216    
217     * Fri Jun 29 2012 Ian Wells <esmith@wellsi.com> 2.2.0-9.sme
218     - Disable index listing of Apache icons folder [SME: 7015]
219    
220     * Fri Dec 23 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-8.sme
221     - Fix server-resources redirect w/o trailing slash [SME: 6758]
222    
223     * Sat Mar 12 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-7.sme
224     - Disable SSLv2 by default [SME: 6482]
225    
226     * Sun Apr 26 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-6.sme
227     - Add option to disable SSLv2 [SME: 5034]
228    
229     * Sat Mar 28 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-5.sme
230     - Add OpenOffice2 MIME Types [SME: 5112]
231    
232     * Sat Mar 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-4.sme
233     - Add OpenOffice MIME Types [SME: 4848]
234     - Add XML MIME Type [SME: 5035]
235    
236     * Thu Dec 11 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-3.sme
237     - Fix issues in patch that adds Microsoft Office 2007 MIME types [SME: 4548]
238    
239     * Tue Dec 2 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.2.0-2.sme
240     - Add Microsoft Office 2007 MIME types [SME: 4548]
241    
242     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
243     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
244    
245     * Tue Oct 23 2007 Filippo Carletti <filippo.carletti@gmail.com> 1.2.0-16
246     - Add SSL support to ProxyPass. [SME: 3481]
247    
248     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-15
249     - Create/Move httpd logrotate.d directory. [SME: 3380]
250    
251     * Tue Sep 11 2007 Gavin Weight <gweight@gmail.com> 1.2.0-14
252     - Rename apache to httpd in templates2expand. [SME: 3380]
253    
254     * Wed Jun 6 2007 Shad L. Lords <slords@mail.com> 1.2.0-13
255     - Fix patch to exclude hosts if domains exist [SME: 2307]
256    
257     * Fri May 18 2007 Shad L. Lords <slords@mail.com> 1.2.0-12
258     - Use correct lib for modules
259    
260     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
261     - Clean up spec so package can be built by koji/plague
262    
263     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-11
264     - Fix patch so template expands [SME: 2307]
265    
266     * Fri Feb 23 2007 Shad L. Lords <slords@mail.com> 1.2.0-10
267     - Don't include host if domain exists [SME: 2307]
268    
269     * Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> 1.2.0-9
270     - Gracefully handle differences in module names between apache
271     versions. [SME: 2471]
272     - Add logrotate changes which should have been in 1.2.0-7 (patch
273     was provided but not applied).
274    
275     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
276     - Remove proxypass fragment (now in e-smith-manager)
277    
278     * Sat Jan 27 2007 Shad L. Lords <slords@mail.com> 1.2.0-8
279     - Remove proxypass fragment (now in e-smith-manager)
280    
281     * Fri Jan 19 2007 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-7
282     - Move logrotate fragments from e-smith-base.
283    
284     * Thu Dec 21 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-6
285     - Add support for optional modSSL{CertificateChainFile} [SME: 1779]
286    
287     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
288     - Update to new release naming. No functional changes.
289     - Make Packager generic
290    
291     * Wed Nov 29 2006 Gordon Rowell <gordonr@gormand.com.au> 1.2.0-04
292     - Revert last change [SME: 2109]
293     - TODO: Split dev stream for that change
294     - Add Conflicts for latest e-smith-manager dev stream
295    
296     * Wed Nov 08 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-03
297     - Remove manager proxy pass fragment - moved to e-smith-manager.
298    
299     * Sat Jul 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
300     - Add ProxyPassReverse directives to allow redirects to work for proxy-
301     passed virtual domains. Also proxy pass https to https. [SME: 1735]
302    
303     * Tue Mar 14 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
304     - Roll stable stream version. [SME: 1016]
305    
306     * Mon Mar 13 2006 Charlie Brady <charlie_brady@mitel.com> 1.1.2-37
307     - Fix lookup of 'httpd' props in a few templates. Service name is
308     httpd-e-smith. [SME: 1029]
309    
310     * Fri Feb 10 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-36
311     - Deny access to files starting with .ht typically
312     .htaccess and .htpasswd [SME: 716]
313    
314     * Tue Jan 31 2006 Gavin Weight <gweight@gmail.com> 1.1.2-35
315     - Change modPerl from enabled to disabled [SME: 575]
316    
317     * Fri Jan 6 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-34
318     - Add SVG filetype [SME: 374]
319    
320     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-33
321     - And relocate the modSSL{CipherSuite} default to e-smith-base with
322     the other modSSL defaults [SME: 194]
323    
324     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-32
325     - Change default CipherSuite [SME: 194]
326     Was: ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:-EXP
327     Is: ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM
328    
329     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-31
330     - Moved SSL CipherSuite into db default - modSSL{CipherSuite} [SME: 194]
331    
332     * Thu Dec 15 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-30
333     - Remove inode from FileETag response [SME: 198]
334    
335     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-29
336     - Use literal HERE document to ensure braces in TRACE/TRACK rewrite [SME: 196]
337    
338     * Wed Dec 14 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-28
339     - Add type for XSL stylesheet (.xsl) files [SME: 76]
340    
341     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.2-27
342     - Bump release number only
343    
344     * Wed Aug 17 2005 Charlie Brady <charlieb@e-smith.com>
345     - [1.1.2-26]
346     - Add content from e-smith-apache-proxy, to enable apache to
347     also operate as a non-caching proxy server. Add Obsoletes:
348     header to ensure e-smith-apache-proxy RPM is removed on
349     upgrade.
350    
351     * Tue Aug 9 2005 Shad Lords <slords@mail.com>
352     - [1.1.2-25]
353     - Add directive for icons directory
354     - Fix newlines left on end of icons template
355     - Update server aliases to reference all local hosts [SF: 1246172]
356    
357     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
358     - [1.1.2-24]
359     - Fix Rewrite rule to include trailing stuff
360    
361     * Wed Aug 3 2005 Shad Lords <slords@mail.com>
362     - [1.1.2-23]
363     - Update ProxyPass to use httpd-admin{TCPPort} [SF: 1246986]
364    
365     * Wed Jul 27 2005 Charlie Brady <charlieb@e-smith.com>
366     - [1.1.2-22]
367     - Disable HTTP TRACK and TRACE in each VirtualDomain (patch by Gordon
368     Rowell, with some further work by Shad Lords). [SF: 1240658]
369    
370     * Wed Jul 27 2005 Gordon Rowell <gordonr@gormand.com.au>
371     - [1.1.2-21]
372     - Disable all low grade ciphers for SSL. [SF: 1240654]
373    
374     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
375     - [1.1.2-20]
376     - Don't load userdir module by default. It's not used, and causes
377     Nessus to complain. [SF: 1240657]
378    
379     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
380     - [1.1.2-19]
381     - Patch from Shad: update rewrite and ProxyPass stuff for manager URLs.
382     [SF: 1172203]
383    
384     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
385     - [1.1.2-18]
386     - Add GPL COPYING file.
387    
388     * Mon Jul 18 2005 Charlie Brady <charlieb@e-smith.com>
389     - [1.1.2-17]
390     - Clean up apache templates to use current DB interfaces.
391     - Make sure the single host ValidFrom specs for proxypass doesn't
392     upset apache.
393    
394     * Tue Jun 21 2005 Charlie Brady <charlieb@e-smith.com>
395     - [1.1.2-16]
396     - Make sure that DocumentRoot directory exists - latest apache2
397     will not start up if not.
398    
399     * Fri Jun 17 2005 Charlie Brady <charlieb@e-smith.com>
400     - [1.1.2-15]
401     - Do graceful restart of apache in domain-*, in case domain->ibay
402     assignments have changed. [SF: 1222433]
403    
404     * Wed Jun 8 2005 Charlie Brady <charlieb@e-smith.com>
405     - [1.1.2-14]
406     - Add rewrite fragment for httpd.conf to disable TRACE and TRACK
407     requests.
408    
409     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
410     - [1.1.2-13]
411     - Add support for TemplatePath => ProxyPassVirtualHost entries
412     in domains db.
413    
414     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
415     - [1.1.2-12]
416     - Bring ProxyPass fragment up to latest e-smith-lib APIs.
417    
418     * Fri May 27 2005 Charlie Brady <charlieb@e-smith.com>
419     - [1.1.2-11]
420     - Remove ProxyPass support for various deprecated URIs. [SF: 1172203]
421     - Add content of e-smith-proxypass RPM. Add Obsoletes: header.
422    
423     * Wed Mar 30 2005 Charlie Brady <charlieb@e-smith.com>
424     - [1.1.2-10]
425     - Add default TCPPort property to httpd-e-smith, so that correct
426     hole is punched in firewall.
427    
428     * Mon Mar 21 2005 Charlie Brady <charlieb@e-smith.com>
429     - [1.1.2-09]
430     - Remove mangling of syslog and apache log filenames - just
431     retargeting the symlinks has the same effect. [MN00064132]
432    
433     * Sun Mar 20 2005 Charlie Brady <charlieb@e-smith.com>
434     - [1.1.2-08]
435     - Remove logrotate-httpd which is obsoleted by generic_template_expand.
436    
437     * Wed Mar 16 2005 Charlie Brady <charlieb@e-smith.com>
438     - [1.1.2-07]
439     - Fix dangling symlink in ibay-create. [MN00065576]
440    
441     * Mon Mar 14 2005 Charlie Brady <charlieb@e-smith.com>
442     - [1.1.2-06]
443     - Use generic_template_expand action where possible, in place
444     of specific actions. Update e-smith-lib dependency. [MN00064130]
445     - Replace all restart-* and most reload-* actions with calls to 'adjust-services'.
446     Update e-smith-lib version dependency. [MN00065576]
447    
448     * Tue Feb 22 2005 Charlie Brady <charlieb@e-smith.com>
449     - [1.1.2-05]
450     - Don't attempt to configure httpd.conf in post-install and post-upgrade.
451     [MN00065717]
452    
453     * Tue Jan 25 2005 Charlie Brady <charlieb@e-smith.com>
454     - [1.1.2-04]
455     - Remove stray ServiceLink sylinks. [MN00064757]
456    
457     * Tue Dec 28 2004 Charlie Brady <charlieb@e-smith.com>
458     - [1.1.2-03]
459     - Add "chpst -P" to httpd-e-smith run script, to protect runsv/supervise
460     from term signals (wrongly) relayed by apache. [charlieb MN00051144]
461    
462     * Fri Dec 24 2004 Charlie Brady <charlieb@e-smith.com>
463     - [1.1.2-02]
464     - Remove ValidFrom defaults fragment for httpd-admin - as it duplicates
465     one in e-smith-base. [MN00062533]
466    
467     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
468     - [1.1.2-01]
469     - Picking up new directory. MN00056429.
470    
471     * Wed Nov 17 2004 Mark Knox <markk@e-smith.com>
472     - [1.1.1-03]
473     - Added empty ValidFrom defaults fragment [markk MN00056429]
474    
475     * Tue Nov 9 2004 Charlie Brady <charlieb@e-smith.com>
476     - [1.1.1-02]
477     - Modify config and run script for compatibility with apache 2. Most of these
478     changes were contributed by Shad Lords. [charlieb MN00051144]
479    
480     * Mon Oct 4 2004 Charlie Brady <charlieb@e-smith.com>
481     - [1.1.1-01]
482     - New development stream for apache 2 - 1.1.1
483    
484     * Fri Sep 3 2004 Charlie Brady <charlieb@e-smith.com>
485     - [1.1.0-23]
486     - Clean BuildRequires. [charlieb MN00043055]
487    
488     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
489     - [1.1.0-22]
490     - Updated modPerl templates to remove use of esmith::config.
491     [msoulier MN00039579]
492    
493     * Tue Jun 22 2004 Michael Soulier <msoulier@e-smith.com>
494     - [1.1.0-21]
495     - Added RewriteCond statements to previous RewriteRules to exclude localhost,
496     so ssh port-forwarding is not broken. [msoulier MN00020885]
497    
498     * Fri Jun 18 2004 Tony Clayton <apc@e-smith.com>
499     - [1.1.0-20]
500     - Fix LoadModule fragment from last patch [tonyc 11348]
501    
502     * Mon Jun 14 2004 Tony Clayton <apc@e-smith.com>
503     - [1.1.0-19]
504     - Add modPerl service and httpd.conf templates [tonyc 11348]
505    
506     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
507     - [1.1.0-18]
508     - Adding rewrite rules to prevent plaintext access to the server manager.
509     [msoulier MN00020885]
510    
511     * Thu May 6 2004 Michael Soulier <msoulier@e-smith.com>
512     - [1.1.0-17]
513     - Added httpd-admin's remoteaccess list to permissible networks for
514     server-resources. [msoulier MN00024949]
515    
516     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
517     - [1.1.0-16]
518     - Backing-out last change. [msoulier dpar-21489]
519    
520     * Mon Feb 23 2004 Michael Soulier <msoulier@e-smith.com>
521     - [1.1.0-15]
522     - Added restart-httpd-graceful to domain-* events. [msoulier dpar-21489]
523    
524     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
525     - [1.1.0-14]
526     - Updating requires to e-smith-daemontools. [msoulier 7629]
527    
528     * Wed Feb 18 2004 Michael Soulier <msoulier@e-smith.com>
529     - [1.1.0-13]
530     - Updating restart-httpd-graceful to use new daemontools sigusr1 option.
531     [msoulier 7629]
532    
533     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
534     - [1.1.0-12]
535     - Staggering the symlinks a little farther. [msoulier 9955]
536    
537     * Wed Jan 21 2004 Michael Soulier <msoulier@e-smith.com>
538     - [1.1.0-11]
539     - Adding symlinks to the service-domain-create event for httpd restart.
540     [msoulier 9955]
541    
542     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
543     - [1.1.0-10]
544     - Fixed another error in the specfile, resulting in incorrect file
545     permissions. [msoulier 7629]
546     - Updated action scripts for supervise. [msoulier 7629]
547    
548     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
549     - [1.1.0-09]
550     - Fixed an error in the specfile. [msoulier 7629]
551    
552     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
553     - [1.1.0-08]
554     - Updated createlinks for daemontools. [msoulier 7629]
555    
556     * Tue Dec 9 2003 Michael Soulier <msoulier@e-smith.com>
557     - [1.1.0-07]
558     - Putting httpd-e-smith under supervision. [msoulier 7629]
559    
560     * Thu Sep 18 2003 Michael Soulier <msoulier@e-smith.com>
561     - [1.1.0-06]
562     - Added a null-string return value to the end of 00Setup, ensure no output
563     from that fragment. [msoulier 9803]
564    
565     * Wed Sep 3 2003 Charlie Brady <charlieb@e-smith.com>
566     - [1.1.0-05]
567     - Use implementation class, not virtual class in VirtualHosts/00Setup fragment.
568     [charlieb 9803]
569    
570     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
571     - [1.1.0-04]
572     - Added a 75AddType05.exe fragment to specify a proper mime-type for .exe
573     files. [msoulier 9866]
574    
575     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
576     - [1.1.0-03]
577     - Allow TemplatePath property in domain record to specify an alternate template
578     subdir for virtual host content specification (e.g. to proxypass a domain).
579     [charlieb 8409]
580    
581     * Fri Aug 29 2003 Charlie Brady <charlieb@e-smith.com>
582     - [1.1.0-02]
583     - Changed the VirtualHosts subtemplate to pass the domain object instead of db handle,
584     and modified VirtualHosts/00Setup fragment to convert it to the right class.
585     Fix scoping problem with the blessed object. [charlieb 9803]
586    
587     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
588     - [1.1.0-01]
589     - rolling to dev stream - 1.1.0
590    
591     * Fri Aug 29 2003 Michael Soulier <msoulier@e-smith.com>
592     - [1.0.0-04]
593     - Added a 00Setup fragment to VirtualHosts to process the %domainsdb hash back
594     into an esmith::DomainsDB object. [msoulier 9803]
595    
596     * Mon Aug 25 2003 Michael Soulier <msoulier@e-smith.com>
597     - [1.0.0-03]
598     - Added a reference to the domains db in the extra data for processing the
599     VirtualHosts fragments. [msoulier 9803]
600    
601     * Fri Aug 1 2003 Michael Soulier <msoulier@e-smith.com>
602     - [1.0.0-02]
603     - Fixed a precedence error that broke virtual hosts in apache.
604     [msoulier 9640]
605    
606     * Wed Jul 9 2003 Charlie Brady <charlieb@e-smith.com>
607     - [1.0.0-01]
608     - Setting to release version number - 1.0.0
609    
610     * Wed Jul 9 2003 Michael Soulier <msoulier@e-smith.com>
611     - [0.2.0-04]
612     - Fixed breakage in admin web server when a local network with a 32-bit subnet
613     mask is used. [msoulier 9259]
614    
615     * Thu Jul 3 2003 Charlie Brady <charlieb@e-smith.com>
616     - [0.2.0-03]
617     - Fix log noise problem in expansion of httpd.conf template. [charlieb 9269]
618    
619     * Wed Jul 2 2003 Charlie Brady <charlieb@e-smith.com>
620     - [0.2.0-02]
621     - List primary domain as first (default) virtual domain in apache config.
622     Include $SystemName.domain.name in ServerAlias directive. [charlieb 9241]
623    
624     * Thu Jun 26 2003 Charlie Brady <charlieb@e-smith.com>
625     - [0.2.0-01]
626     - Changing version to stable stream number - 0.2.0
627    
628     * Thu Jun 12 2003 Gordon Rowell <gordonr@e-smith.com>
629     - [0.1.2-01]
630     - Add order to migrate fragments [gordonr 9015]
631    
632     * Wed Jun 11 2003 Gordon Rowell <gordonr@e-smith.com>
633     - [0.1.1-02]
634     - Fixed Conflicts header - should be <, not <= [gordonr 8903]
635    
636     * Fri Jun 6 2003 Gordon Rowell <gordonr@e-smith.com>
637     - [0.1.1-01]
638     - Shuffled some httpd.conf fragments to e-smith-ibays [gordonr 8903]
639    
640     * Wed May 28 2003 Michael Soulier <msoulier@e-smith.com>
641     - [0.1.0-19]
642     - Moving httpd-e-smith init script to e-smith-apache. [msoulier 8852]
643    
644     * Tue Apr 29 2003 Gordon Rowell <gordonr@e-smith.com>
645     - [0.1.0-18]
646     - Do an explicit die if the httpd-e-smith record is missing from the
647     config db, rather than an implicit die due to an invalid object
648     reference [gordonr 8609]
649    
650     * Wed Apr 9 2003 Gordon Rowell <gordonr@e-smith.com>
651     - [0.1.0-17]
652     - Relocated conf-httpd from e-smith-base [gordonr 8150]
653    
654     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
655     - [0.1.0-16]
656     - Moved restart-httpd-* actions from base [markk 5509]
657    
658     * Fri Apr 4 2003 Mark Knox <markk@e-smith.com>
659     - [0.1.0-15]
660     - Moved db config fragments here from e-smith-base [markk 5509]
661    
662     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
663     - [0.1.0-14]
664     - Make /server-resources/ browsable from LAN [gordonr 6620]
665    
666     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
667     - [0.1.0-13]
668     - Delete Apache ReadmeName directive [gordonr 6313]
669    
670     * Tue Apr 1 2003 Gordon Rowell <gordonr@e-smith.com>
671     - [0.1.0-12]
672     - Fixed broken conf-httpd-e-smith links in post-{install,upgrade} [gordonr 7960]
673    
674     * Tue Mar 18 2003 Lijie Deng <lijied@e-smith.com>
675     - [0.1.0-11]
676     - Deleted ./etc/httpd/conf/httpd.conf/template-begin
677     deleted ./etc/httpd/conf/srm.conf/template-begin
678     deleted ./etc/httpd/conf/access.conf/template-begin [lijied 3295]
679    
680     * Mon Mar 17 2003 Lijie Deng <lijied@e-smith.com>
681     - [0.1.0-10]
682     - Delete empty template-end file [lijied 3295]
683    
684     * Wed Mar 12 2003 Charlie Brady <charlieb@e-smith.com>
685     - [0.1.0-09]
686     - Remove more references to primary and wwwpublic in favour
687     of the "Primary" i-bay. There is still some special case code,
688     which might go later if it turns out not to be needed.
689     [charlieb 5652]
690    
691     * Tue Mar 11 2003 Mark Knox <markk@e-smith.com>
692     - [0.1.0-08]
693     - Fixed a missing quote in 27ManagerProxyPass [markk 7635]
694    
695     * Tue Mar 11 2003 Gordon Rowell <gordonr@e-smith.com>
696     - [0.1.0-07]
697     - Pass externalSSLAccess and localAccess to VirtualDomains fragments so they don't
698     need to recalculate these values [gordonr 7635]
699     - Use early return from 27ManagerProxyPass and new DB interface [gordonr 7635]
700    
701     * Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com>
702     - [0.1.0-06]
703     - Remove special case handling for /home/e-smith/files/primary in Apache
704     configuration. Migrate code and db entries for wwwpublic to Public.
705     [charlieb 5652]
706    
707     * Fri Mar 7 2003 Charlie Brady <charlieb@e-smith.com>
708     - [0.1.0-05]
709     - Replace deprecated CONFREF with MORE_DATA in processTemplate call in
710     VirtualHosts fragment of httpd.conf templates. Fixes template
711     expansion breakage (I'm not sure what broke it, but this fixes it.)
712     [charlieb]
713     - Add default config db fragments to set type and status. Remove redundant
714     conf-httpd-e-smith script. [charlieb 1507]
715    
716     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
717     - [0.1.0-04]
718     - Move SSL initialisation to global context [gordonr 1432]
719    
720     * Fri Jan 24 2003 Gordon Rowell <gordonr@e-smith.com>
721     - [0.1.0-03]
722     - Use default SSL certificate of $SystemName.$DomainName [gordonr 4874]
723    
724     * Wed Jan 8 2003 Mark Knox <markk@e-smith.com>
725     - [0.1.0-02]
726     - Added conf-httpd-e-smith action linked to the same events as conf-startup
727     in e-smith-base [markk 6428]
728    
729     * Mon Jan 06 2003 Mark Knox <m_knox@mitel.com>
730     - [0.1.0-01]
731     - Initial release, split out from e-smith-base [markk 6428]
732    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed