1 |
slords |
1.8 |
# $Id: e-smith-horde.spec,v 1.7 2008/09/16 18:04:56 bytegw Exp $ |
2 |
slords |
1.5 |
|
3 |
slords |
1.1 |
Summary: e-smith specific Horde configuration and templates. |
4 |
|
|
%define name e-smith-horde |
5 |
|
|
Name: %{name} |
6 |
slords |
1.8 |
%define version 4.0.0 |
7 |
|
|
%define release 1 |
8 |
slords |
1.1 |
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: e-smith-base >= 4.9.44, horde >= 2.0, mysql |
16 |
|
|
Requires: e-smith-lib >= 1.15.1-16 |
17 |
|
|
Requires: enscript |
18 |
|
|
Requires: php-domxml |
19 |
|
|
Requires: php-gd |
20 |
|
|
Requires: php-mbstring |
21 |
|
|
Requires: wv |
22 |
|
|
Requires: xlhtml |
23 |
slords |
1.6 |
Requires: horde >= 3.2 |
24 |
slords |
1.1 |
Requires: php-pear |
25 |
|
|
Requires: pear-date |
26 |
|
|
Requires: pear-db |
27 |
|
|
Requires: pear-file |
28 |
|
|
Requires: pear-log |
29 |
|
|
Requires: pear-mail |
30 |
|
|
Requires: pear-mail_mime |
31 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
32 |
|
|
AutoReqProv: no |
33 |
|
|
Obsoletes: dcb-e-smith-horde |
34 |
|
|
Obsoletes: smeserver-horde-menuarray |
35 |
|
|
|
36 |
|
|
%changelog |
37 |
slords |
1.8 |
* Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 4.0.0-1.sme |
38 |
|
|
- Roll new stream to separate sme7/sme8 trees [SME: 4633] |
39 |
|
|
|
40 |
slords |
1.6 |
* Tue Jun 24 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-2 |
41 |
bytegw |
1.7 |
- Upgrade patch for Horde 3.2.1 [SME: 4532] |
42 |
mrjhb3 |
1.4 |
|
43 |
slords |
1.6 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-1 |
44 |
|
|
- Initial production build |
45 |
|
|
- Jump in package name to reflect new version of horde |
46 |
slords |
1.1 |
|
47 |
|
|
%description |
48 |
slords |
1.6 |
This package adds necessary templates and configuration items |
49 |
|
|
so that Horde will work properly on SME Server |
50 |
slords |
1.1 |
|
51 |
|
|
%prep |
52 |
|
|
%setup |
53 |
|
|
|
54 |
|
|
%build |
55 |
|
|
for i in post-install post-upgrade |
56 |
|
|
do |
57 |
|
|
mkdir -p root/etc/e-smith/events/$i |
58 |
|
|
done |
59 |
|
|
perl createlinks |
60 |
|
|
|
61 |
|
|
%install |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
64 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
65 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
66 |
|
|
|
67 |
|
|
%clean |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
|
|
|
70 |
|
|
%pre |
71 |
|
|
%preun |
72 |
|
|
%post |
73 |
|
|
%postun |
74 |
|
|
|
75 |
|
|
%files -f %{name}-%{version}-filelist |
76 |
|
|
%defattr(-,root,root) |