1 |
slords |
1.9 |
# $Id: e-smith-horde.spec,v 1.8 2008/09/16 18:04:56 bytegw Exp $ |
2 |
slords |
1.5 |
|
3 |
slords |
1.1 |
Summary: e-smith specific Horde configuration and templates. |
4 |
|
|
%define name e-smith-horde |
5 |
|
|
Name: %{name} |
6 |
slords |
1.9 |
%define version 4.2.0 |
7 |
|
|
%define release 1 |
8 |
slords |
1.1 |
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: e-smith-base >= 4.9.44, horde >= 2.0, mysql |
16 |
|
|
Requires: e-smith-lib >= 1.15.1-16 |
17 |
|
|
Requires: enscript |
18 |
|
|
Requires: php-domxml |
19 |
|
|
Requires: php-gd |
20 |
|
|
Requires: php-mbstring |
21 |
|
|
Requires: wv |
22 |
|
|
Requires: xlhtml |
23 |
slords |
1.6 |
Requires: horde >= 3.2 |
24 |
slords |
1.1 |
Requires: php-pear |
25 |
|
|
Obsoletes: pear-date |
26 |
|
|
Obsoletes: pear-db |
27 |
|
|
Obsoletes: pear-file |
28 |
|
|
Obsoletes: pear-log |
29 |
|
|
Obsoletes: pear-mail |
30 |
|
|
Obsoletes: pear-mail_mime |
31 |
|
|
Requires: php-pear(Date) |
32 |
|
|
Requires: php-pear(File) |
33 |
|
|
Requires: php-pear(HTTP) |
34 |
|
|
Requires: php-pear(Log) |
35 |
|
|
Requires: php-pear(Services_Weather) |
36 |
|
|
Requires: php-pecl(Fileinfo) |
37 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
38 |
|
|
AutoReqProv: no |
39 |
|
|
Obsoletes: dcb-e-smith-horde |
40 |
|
|
Obsoletes: smeserver-horde-menuarray |
41 |
|
|
|
42 |
|
|
%changelog |
43 |
slords |
1.9 |
* Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 4.2.0-1.sme |
44 |
|
|
- Roll new stream to separate sme7/sme8 trees [SME: 4633] |
45 |
|
|
|
46 |
slords |
1.6 |
* Tue Jun 24 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-2 |
47 |
bytegw |
1.8 |
- Upgrade patch for Horde 3.2.1 [SME: 4532] |
48 |
slords |
1.4 |
|
49 |
slords |
1.6 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-1 |
50 |
|
|
- Initial production build |
51 |
|
|
- Jump in package name to reflect new version of horde |
52 |
slords |
1.1 |
|
53 |
|
|
%description |
54 |
slords |
1.6 |
This package adds necessary templates and configuration items |
55 |
|
|
so that Horde will work properly on SME Server |
56 |
slords |
1.1 |
|
57 |
|
|
%prep |
58 |
|
|
%setup |
59 |
|
|
|
60 |
|
|
%build |
61 |
|
|
for i in post-install post-upgrade |
62 |
|
|
do |
63 |
|
|
mkdir -p root/etc/e-smith/events/$i |
64 |
|
|
done |
65 |
|
|
perl createlinks |
66 |
|
|
|
67 |
|
|
%install |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
70 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
71 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
72 |
|
|
|
73 |
|
|
%clean |
74 |
|
|
rm -rf $RPM_BUILD_ROOT |
75 |
|
|
|
76 |
|
|
%pre |
77 |
|
|
%preun |
78 |
|
|
%post |
79 |
|
|
%postun |
80 |
|
|
|
81 |
|
|
%files -f %{name}-%{version}-filelist |
82 |
|
|
%defattr(-,root,root) |