1 |
# $Id: e-smith-pop3.spec,v 1.2 2008/10/07 18:52:04 slords Exp $ |
2 |
|
3 |
Summary: startup scripts for pop3 package |
4 |
%define name e-smith-pop3 |
5 |
Name: %{name} |
6 |
%define version 2.0.0 |
7 |
%define release 2 |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: GPL |
11 |
Group: Networking/Daemons |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
Patch1: e-smith-pop3-2.0.0-PopSoftlimit.patch |
14 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
BuildRequires: e-smith-devtools >= 1.13.0-04 |
16 |
BuildArchitectures: noarch |
17 |
Requires: e-smith-email |
18 |
Requires: runit |
19 |
Requires: qmail |
20 |
Requires: checkpassword |
21 |
Obsoletes: e-smith-ssl-popd |
22 |
AutoReqProv: no |
23 |
|
24 |
%changelog |
25 |
* Tue Jul 03 2012 Ian Wells <esmith@wellsi.com> 2.0.0-2.sme |
26 |
- Softlimit is now a database variable for pop3 and pop3s [SME: 7021] |
27 |
|
28 |
* Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.0.0-1.sme |
29 |
- Roll new stream to separate sme7/sme8 trees [SME: 4633] |
30 |
|
31 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
32 |
- Clean up spec so package can be built by koji/plague |
33 |
|
34 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
35 |
- Update to new release naming. No functional changes. |
36 |
- Make Packager generic |
37 |
|
38 |
* Fri Mar 24 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02 |
39 |
- Ensure that pop3 and pop3s are started or stopped if required, |
40 |
during email-update event. [SME: 1125] |
41 |
|
42 |
* Wed Mar 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01 |
43 |
- Roll stable stream version. [SME: 1016] |
44 |
|
45 |
* Mon Mar 13 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.0-04 |
46 |
- Move pop3[s] defaults from e-smith-email [SME: 561] |
47 |
|
48 |
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.0-03 |
49 |
- Bump release number only |
50 |
|
51 |
* Thu Sep 15 2005 Charlie Brady <charlieb@e-smith.com> |
52 |
- [1.1.0-02] |
53 |
- Fix port name pop->pop3 (to match change in /etc/services). |
54 |
[SF: 1291836] |
55 |
|
56 |
* Wed Aug 10 2001 Shad L. Lords <slords@mail.com> |
57 |
- [1.1.0-01] |
58 |
- initial release (split from e-smith-email-4.15.2-27). |
59 |
|
60 |
%description |
61 |
Startup scripts for pop3 package. |
62 |
|
63 |
%prep |
64 |
%setup |
65 |
%patch1 -p1 |
66 |
|
67 |
%build |
68 |
perl createlinks |
69 |
|
70 |
mkdir -p root/service |
71 |
for i in pop3 pop3s |
72 |
do |
73 |
mkdir -p root/var/service/$i/peers |
74 |
mkdir -p root/etc/e-smith/templates/var/service/$i/peers |
75 |
mkdir -p root/etc/e-smith/templates/var/service/$i/peers/{0,local} |
76 |
touch root/etc/e-smith/templates/var/service/$i/peers/{0,local}/template-begin |
77 |
touch root/var/service/$i/down |
78 |
ln -s /var/service/$i root/service/$i |
79 |
done |
80 |
mkdir -p root/var/log/pop3 |
81 |
mkdir -p root/var/log/pop3s |
82 |
|
83 |
%install |
84 |
rm -rf $RPM_BUILD_ROOT |
85 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
86 |
rm -f %{name}-%{version}-%{release}-filelist |
87 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
88 |
--dir /var/log/pop3 'attr(0750,smelog,smelog)' \ |
89 |
--dir /var/service/pop3 'attr(01755,root,root)' \ |
90 |
--dir /var/service/pop3/control 'attr(01755,root,root)' \ |
91 |
--file /var/service/pop3/control/1 'attr(0750,root,root)' \ |
92 |
--file /var/service/pop3s/run 'attr(0750,root,root)' \ |
93 |
--file /var/service/pop3s/log/run 'attr(0750,root,root)' \ |
94 |
--dir '/var/log/pop3s' 'attr(2750,smelog,smelog)' \ |
95 |
--file /var/service/pop3/run 'attr(0750,root,root)' \ |
96 |
--file /var/service/pop3/log/run 'attr(0750,root,root)' \ |
97 |
> %{name}-%{version}-%{release}-filelist |
98 |
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
99 |
|
100 |
%clean |
101 |
rm -rf $RPM_BUILD_ROOT |
102 |
|
103 |
%pre |
104 |
%preun |
105 |
%post |
106 |
%postun |
107 |
|
108 |
%files -f %{name}-%{version}-%{release}-filelist |
109 |
%defattr(-,root,root) |