/[smeserver]/rpms/e-smith-pop3/sme8/e-smith-pop3.spec
ViewVC logotype

Annotation of /rpms/e-smith-pop3/sme8/e-smith-pop3.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Wed Jul 4 00:23:04 2012 UTC (11 years, 11 months ago) by wellsi
Branch: MAIN
CVS Tags: e-smith-pop3-2_2_0-4_el5_sme
Changes since 1.4: +7 -2 lines
Softlimit is now a database variable for pop3 and pop3s [SME: 6994]

1 wellsi 1.5 # $Id: e-smith-pop3.spec,v 1.4 2010/09/22 18:16:25 vip-ire Exp $
2 slords 1.2
3 slords 1.1 Summary: startup scripts for pop3 package
4     %define name e-smith-pop3
5     Name: %{name}
6 slords 1.2 %define version 2.2.0
7 wellsi 1.5 %define release 4
8 slords 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tar.gz
13 vip-ire 1.3 Patch1: e-smith-pop3-2.2.0-checkpassword_pam.patch
14 wellsi 1.5 Patch2: e-smith-pop3-2.2.0-PopSoftlimit.patch
15 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
16     BuildRequires: e-smith-devtools >= 1.13.0-04
17     BuildArchitectures: noarch
18     Requires: e-smith-email
19     Requires: runit
20     Requires: qmail
21 vip-ire 1.3 Requires: checkpassword-pam
22 slords 1.1 Obsoletes: e-smith-ssl-popd
23 vip-ire 1.3 Obsoletes: checkpassword
24 slords 1.1 AutoReqProv: no
25    
26     %changelog
27 wellsi 1.5 * Mon Jul 02 2012 Ian Wells <esmith@wellsi.com> 2.2.0-4.sme
28     - Softlimit is now a database variable for pop3 and pop3s [SME: 6994]
29    
30 vip-ire 1.4 * Wed Sep 22 2010 Daniel Berteaud <daniel@firewall-services.com> 2.2.0-3.sme
31     - Add symlink for template-begin of pop3 pam config [SME: 6218]
32    
33 vip-ire 1.3 * Wed Sep 22 2010 Daniel Berteaud <daniel@firewall-services.com> 2.2.0-2.sme
34     - Shift auth from passwd/shadow files to the pam database [SME: 6218]
35    
36 slords 1.2 * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.2.0-1.sme
37     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
38    
39 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
40     - Clean up spec so package can be built by koji/plague
41    
42     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
43     - Update to new release naming. No functional changes.
44     - Make Packager generic
45    
46     * Fri Mar 24 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-02
47     - Ensure that pop3 and pop3s are started or stopped if required,
48     during email-update event. [SME: 1125]
49    
50     * Wed Mar 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.2.0-01
51     - Roll stable stream version. [SME: 1016]
52    
53     * Mon Mar 13 2006 Gordon Rowell <gordonr@gormand.com.au> 1.1.0-04
54     - Move pop3[s] defaults from e-smith-email [SME: 561]
55    
56     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.1.0-03
57     - Bump release number only
58    
59     * Thu Sep 15 2005 Charlie Brady <charlieb@e-smith.com>
60     - [1.1.0-02]
61     - Fix port name pop->pop3 (to match change in /etc/services).
62     [SF: 1291836]
63    
64     * Wed Aug 10 2001 Shad L. Lords <slords@mail.com>
65     - [1.1.0-01]
66     - initial release (split from e-smith-email-4.15.2-27).
67    
68     %description
69     Startup scripts for pop3 package.
70    
71     %prep
72     %setup
73 vip-ire 1.3 %patch1 -p1
74 wellsi 1.5 %patch2 -p1
75 slords 1.1
76     %build
77     perl createlinks
78    
79     mkdir -p root/service
80     for i in pop3 pop3s
81     do
82     mkdir -p root/var/service/$i/peers
83     mkdir -p root/etc/e-smith/templates/var/service/$i/peers
84     mkdir -p root/etc/e-smith/templates/var/service/$i/peers/{0,local}
85     touch root/etc/e-smith/templates/var/service/$i/peers/{0,local}/template-begin
86     touch root/var/service/$i/down
87     ln -s /var/service/$i root/service/$i
88     done
89     mkdir -p root/var/log/pop3
90     mkdir -p root/var/log/pop3s
91    
92 vip-ire 1.4 mkdir -p root/etc/e-smith/templates/etc/pam.d/pop3
93     ln -s /etc/e-smith/templates-default/template-begin-pam \
94     root/etc/e-smith/templates/etc/pam.d/pop3/template-begin
95    
96    
97 slords 1.1 %install
98     rm -rf $RPM_BUILD_ROOT
99     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
100     rm -f %{name}-%{version}-%{release}-filelist
101     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
102     --dir /var/log/pop3 'attr(0750,smelog,smelog)' \
103     --dir /var/service/pop3 'attr(01755,root,root)' \
104     --dir /var/service/pop3/control 'attr(01755,root,root)' \
105     --file /var/service/pop3/control/1 'attr(0750,root,root)' \
106     --file /var/service/pop3s/run 'attr(0750,root,root)' \
107     --file /var/service/pop3s/log/run 'attr(0750,root,root)' \
108     --dir '/var/log/pop3s' 'attr(2750,smelog,smelog)' \
109     --file /var/service/pop3/run 'attr(0750,root,root)' \
110     --file /var/service/pop3/log/run 'attr(0750,root,root)' \
111     > %{name}-%{version}-%{release}-filelist
112     echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist
113    
114     %clean
115     rm -rf $RPM_BUILD_ROOT
116    
117     %pre
118     %preun
119     %post
120     %postun
121    
122     %files -f %{name}-%{version}-%{release}-filelist
123     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed