1 |
slords |
1.1 |
Summary: generic support framework for Gerrit Pape's runit package |
2 |
|
|
%define name e-smith-runit |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0.0 |
5 |
|
|
%define release 5 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
Patch0: e-smith-runit-1.0.0-condrestart.patch |
12 |
|
|
Patch1: e-smith-runit-1.0.0-runit17.patch |
13 |
|
|
Patch2: e-smith-runit-1.0.0-runit17.patch2 |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildRequires: e-smith-devtools |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: runit >= 1.0.5 |
18 |
|
|
Provides: e-smith-daemontools = 1.7.1-09 |
19 |
|
|
Obsoletes: e-smith-daemontools |
20 |
|
|
Obsoletes: supervise-scripts |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
24 |
|
|
- Clean up spec so package can be built by koji/plague |
25 |
|
|
|
26 |
|
|
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 1.0.0-5 |
27 |
|
|
- Fix signals sent to prevent errors and delays [SME: 1179] |
28 |
|
|
|
29 |
|
|
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 1.0.0-4 |
30 |
|
|
- Change runsvctrl to sv to support runit v1.7.x [SME: 1179] |
31 |
|
|
|
32 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
33 |
|
|
- Update to new release naming. No functional changes. |
34 |
|
|
- Make Packager generic |
35 |
|
|
|
36 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 1.0.0-02 |
37 |
|
|
- Add support for 'condrestart' param. [SME: 1870] |
38 |
|
|
|
39 |
|
|
* Wed Mar 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.0.0-01 |
40 |
|
|
- Roll stable stream version. [SME: 1016] |
41 |
|
|
|
42 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-06 |
43 |
|
|
- Bump release number only |
44 |
|
|
|
45 |
|
|
* Wed Jun 15 2005 Charlie Brady <charlieb@e-smith.com> |
46 |
|
|
- [0.0.1-05] |
47 |
|
|
- Provide more user feedback from init.d/daemontools script. |
48 |
|
|
[SF: 1218682] |
49 |
|
|
|
50 |
|
|
* Tue Apr 26 2005 Charlie Brady <charlieb@e-smith.com> |
51 |
|
|
- [0.0.1-04] |
52 |
|
|
- Reopen stdin from /dev/null before running runsvdir. This prevents any |
53 |
|
|
supervised services from stealing console input from VT1's getty/console. |
54 |
|
|
|
55 |
|
|
* Wed Dec 1 2004 Charlie Brady <charlieb@e-smith.com> |
56 |
|
|
- [0.0.1-03] |
57 |
|
|
- Call runsvctrl multiple times for multiple args - can't combine |
58 |
|
|
them (unlike svc). |
59 |
|
|
|
60 |
|
|
* Tue Sep 28 2004 Charlie Brady <charlieb@e-smith.com> |
61 |
|
|
- [0.0.1-02] |
62 |
|
|
- Add Obsoletes header for supervise-scripts |
63 |
|
|
|
64 |
|
|
* Fri Sep 24 2004 Charlie Brady <charlieb@e-smith.com> 0.0.1-01 |
65 |
|
|
- Initial - functional replacement for e-smith-daemontools 1.7.1-09. |
66 |
|
|
|
67 |
|
|
%description |
68 |
|
|
Provide integration of Gerrit Pape's runit package into a SysV init script |
69 |
|
|
process environment. |
70 |
|
|
|
71 |
|
|
%prep |
72 |
|
|
%setup |
73 |
|
|
%patch0 -p1 |
74 |
|
|
%patch1 -p1 |
75 |
|
|
%patch2 -p1 |
76 |
|
|
|
77 |
|
|
%build |
78 |
|
|
perl createlinks |
79 |
|
|
|
80 |
|
|
%install |
81 |
|
|
rm -rf $RPM_BUILD_ROOT |
82 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
83 |
|
|
rm -f %{name}-%{version}-%{release}-filelist |
84 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
85 |
|
|
> %{name}-%{version}-%{release}-filelist |
86 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
87 |
|
|
|
88 |
|
|
%clean |
89 |
|
|
rm -rf $RPM_BUILD_ROOT |
90 |
|
|
|
91 |
|
|
%pre |
92 |
|
|
%preun |
93 |
|
|
%post |
94 |
|
|
%postun |
95 |
|
|
|
96 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
97 |
|
|
%defattr(-,root,root) |