1 |
# $Id$ |
2 |
|
3 |
Summary: generic support framework for Gerrit Pape's runit package |
4 |
%define name e-smith-runit |
5 |
Name: %{name} |
6 |
%define version 2.0.0 |
7 |
%define release 1 |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: GPL |
11 |
Group: Networking/Daemons |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
BuildRequires: e-smith-devtools |
15 |
BuildArchitectures: noarch |
16 |
Requires: runit >= 1.0.5 |
17 |
Provides: e-smith-daemontools = 1.7.1-09 |
18 |
Obsoletes: e-smith-daemontools |
19 |
Obsoletes: supervise-scripts |
20 |
|
21 |
%changelog |
22 |
* Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 2.0.0-1.sme |
23 |
- Roll new stream to separate sme7/sme8 trees [SME: 4633] |
24 |
|
25 |
* Wed Mar 26 2008 Shad L. Lords <slords@mail.com> 1.0.0-6 |
26 |
- Make daemontools script use same echo that is translated [SME: 4120] |
27 |
|
28 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
29 |
- Clean up spec so package can be built by koji/plague |
30 |
|
31 |
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 1.0.0-5 |
32 |
- Fix signals sent to prevent errors and delays [SME: 1179] |
33 |
|
34 |
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 1.0.0-4 |
35 |
- Change runsvctrl to sv to support runit v1.7.x [SME: 1179] |
36 |
|
37 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
38 |
- Update to new release naming. No functional changes. |
39 |
- Make Packager generic |
40 |
|
41 |
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 1.0.0-02 |
42 |
- Add support for 'condrestart' param. [SME: 1870] |
43 |
|
44 |
* Wed Mar 15 2006 Charlie Brady <charlie_brady@mitel.com> 1.0.0-01 |
45 |
- Roll stable stream version. [SME: 1016] |
46 |
|
47 |
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-06 |
48 |
- Bump release number only |
49 |
|
50 |
* Wed Jun 15 2005 Charlie Brady <charlieb@e-smith.com> |
51 |
- [0.0.1-05] |
52 |
- Provide more user feedback from init.d/daemontools script. |
53 |
[SF: 1218682] |
54 |
|
55 |
* Tue Apr 26 2005 Charlie Brady <charlieb@e-smith.com> |
56 |
- [0.0.1-04] |
57 |
- Reopen stdin from /dev/null before running runsvdir. This prevents any |
58 |
supervised services from stealing console input from VT1's getty/console. |
59 |
|
60 |
* Wed Dec 1 2004 Charlie Brady <charlieb@e-smith.com> |
61 |
- [0.0.1-03] |
62 |
- Call runsvctrl multiple times for multiple args - can't combine |
63 |
them (unlike svc). |
64 |
|
65 |
* Tue Sep 28 2004 Charlie Brady <charlieb@e-smith.com> |
66 |
- [0.0.1-02] |
67 |
- Add Obsoletes header for supervise-scripts |
68 |
|
69 |
* Fri Sep 24 2004 Charlie Brady <charlieb@e-smith.com> 0.0.1-01 |
70 |
- Initial - functional replacement for e-smith-daemontools 1.7.1-09. |
71 |
|
72 |
%description |
73 |
Provide integration of Gerrit Pape's runit package into a SysV init script |
74 |
process environment. |
75 |
|
76 |
%prep |
77 |
%setup |
78 |
|
79 |
%build |
80 |
perl createlinks |
81 |
|
82 |
%install |
83 |
rm -rf $RPM_BUILD_ROOT |
84 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
85 |
rm -f %{name}-%{version}-%{release}-filelist |
86 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
87 |
> %{name}-%{version}-%{release}-filelist |
88 |
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
89 |
|
90 |
%clean |
91 |
rm -rf $RPM_BUILD_ROOT |
92 |
|
93 |
%pre |
94 |
%preun |
95 |
%post |
96 |
%postun |
97 |
|
98 |
%files -f %{name}-%{version}-%{release}-filelist |
99 |
%defattr(-,root,root) |