1 |
# $Id: e-smith-turba.spec,v 1.12 2009/10/14 03:13:56 mrjhb3 Exp $ |
2 |
|
3 |
Summary: e-smith module to configure Turba 1.0 |
4 |
%define name e-smith-turba |
5 |
Name: %{name} |
6 |
%define version 3.0.0 |
7 |
%define release 8 |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: GPL |
11 |
Group: Networking/Daemons |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
Patch1: e-smith-turba-2.3.patch |
14 |
Patch2: e-smith-turba-2.3.1.patch |
15 |
Patch3: e-smith-turba_remove_sql_schema.patch |
16 |
Patch4: e-smith-turba-2.3.2.patch |
17 |
Patch5: e-smith-turba-2.3.3.patch |
18 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
BuildRequires: e-smith-devtools |
20 |
BuildArchitectures: noarch |
21 |
Requires: e-smith-base, e-smith-lib, e-smith >= 4.1 |
22 |
Requires: turba-h3 >= 2.2 |
23 |
AutoReqProv: no |
24 |
Obsoletes: dcb-e-smith-turba |
25 |
Obsoletes: smeserver-turba-menuarray |
26 |
|
27 |
%changelog |
28 |
* Sat Jan 23 2010 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.0-8 |
29 |
- Updated template files to reflect changes in Turba 2.3.3 [SME: 5723] |
30 |
|
31 |
* Tue Oct 13 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.0-7 |
32 |
- Updated template files to reflect changes in Turba 2.3.2 [SME: 5512] |
33 |
|
34 |
* Wed Apr 8 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.0-6 |
35 |
- Remove redundant 49turba_migrate_contacts template fragments [SME: 5148] |
36 |
|
37 |
* Sun Jan 4 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 3.0.0-5 |
38 |
- Fix date in previous changelog entry [SME: 4910] |
39 |
|
40 |
* Sun Jan 4 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 3.0.0-4 |
41 |
- Fix turba.sql patch to prevent creating a .orig file [SME: 4910] |
42 |
|
43 |
* Fri Jan 2 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.0-3 |
44 |
- Updated template files to reflect changes in Turba 2.3.1 |
45 |
|
46 |
* Sat Dec 06 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.0-2 |
47 |
- Updated template files to reflect changes in Turba 2.3 [SME: 4833] |
48 |
|
49 |
* Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 3.0.0-1.sme |
50 |
- Roll new stream to separate sme7/sme8 trees [SME: 4633] |
51 |
|
52 |
* Fri Jul 11 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-3 |
53 |
- Patch to fix 49turba_migrate_contacts to not run on post-install |
54 |
|
55 |
* Fri Jun 20 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-2 |
56 |
- Upgrade patch for Turba 2.2.1 |
57 |
|
58 |
* Sat Jun 7 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-1 |
59 |
- Initial production build |
60 |
|
61 |
* Sat May 24 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-02 |
62 |
- Updated to include changes in Turba 2.2 RC4 |
63 |
- Re-rolled tarball |
64 |
|
65 |
* Fri Apr 11 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-01 |
66 |
- Initial build |
67 |
- Jump in package name to reflect new version of turba |
68 |
|
69 |
%description |
70 |
This package adds necessary templates and configuration items |
71 |
so that Turba will work properly on SME Server |
72 |
|
73 |
%prep |
74 |
%setup |
75 |
|
76 |
%patch1 -p1 |
77 |
%patch2 -p1 |
78 |
%patch3 -p1 |
79 |
%patch4 -p1 |
80 |
%patch5 -p1 |
81 |
|
82 |
%build |
83 |
for i in bootstrap-console-save post-install post-upgrade email-update |
84 |
do |
85 |
mkdir root/etc/e-smith/events/$i |
86 |
done |
87 |
mkdir -p root/etc/rc.d/rc7.d |
88 |
perl createlinks |
89 |
|
90 |
|
91 |
%install |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
94 |
rm -f %{name}-%{version}-filelist |
95 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
96 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
97 |
|
98 |
%clean |
99 |
rm -rf $RPM_BUILD_ROOT |
100 |
|
101 |
%files -f %{name}-%{version}-filelist |
102 |
%defattr(-,root,root) |
103 |
|