/[smeserver]/rpms/e-smith/sme9/e-smith.spec
ViewVC logotype

Annotation of /rpms/e-smith/sme9/e-smith.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Tue May 7 15:01:16 2013 UTC (11 years, 1 month ago) by wellsi
Branch: MAIN
CVS Tags: e-smith-5_4_0-4_el6_sme
Changes since 1.3: +20 -10 lines
* Sun May 05 2013 Ian Wells <esmith@wellsi.com> 5.4.0-4.sme
- Fix uid and gid to be the same for the users added in %pre [SME: 7547]
- Changed Prereq to Requires(pre) as Prereq is deprecated

1 wellsi 1.4 # $Id: e-smith.spec,v 1.3 2013/03/09 22:31:35 slords Exp $
2 slords 1.1
3     Summary: e-smith server and gateway
4     Name: e-smith
5     %define version 5.4.0
6 wellsi 1.4 %define release 4
7 slords 1.1 Version: %{version}
8     Release: %{release}%{?dist}
9     License: GPL
10     Group: Networking/Daemons
11     Source: %{name}-%{version}.tar.xz
12     BuildArch: noarch
13     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
14 wellsi 1.4 Requires(pre): /usr/sbin/useradd
15 slords 1.1 AutoReqProv: no
16    
17     %changelog
18 wellsi 1.4 * Sun May 05 2013 Ian Wells <esmith@wellsi.com> 5.4.0-4.sme
19     - Fix uid and gid to be the same for the users added in %pre [SME: 7547]
20     - Changed Prereq to Requires(pre) as Prereq is deprecated
21    
22 slords 1.3 * Sat Mar 9 2013 Shad L. Lords <slords@mail.com> 5.4.0-3.sme
23     - Ensure group www exists before user [SME: 7319]
24    
25 slords 1.2 * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 5.4.0-2.sme
26     - Fix pre script to make www and apache the same [SME: 7319]
27    
28 slords 1.1 * Fri Jan 25 2013 Shad L. Lords <slords@mail.com> 5.4.0-1.sme
29     - Roll new stream for sme9
30    
31     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 5.2.0-1.sme
32     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
33    
34     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
35     - Clean up spec so package can be built by koji/plague
36    
37     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
38     - Update to new release naming. No functional changes.
39     - Make Packager generic
40    
41     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 4.2.0-08
42     - Bump release number only
43    
44     * Fri Jan 14 2005 Charlie Brady <charlieb@e-smith.com> 4.2.0-07
45     - Re-add user and group creation. [MN00063589]
46    
47     * Fri Aug 17 2001 gordonr
48     - [4.2.0-06]
49     - Autorebuild by rebuildRPM
50    
51     * Fri Jul 27 2001 Charlie Brady <charlieb@e-smith.com>
52     - [4.2.0-05]
53     - Put defattr directive in the right spot.
54    
55     * Fri Jul 6 2001 Peter Samuel <peters@e-smith.com>
56     - [4.2.0-04]
57     - Including GPL license with package
58    
59     * Fri May 04 2001 Jason Miller <jmiller@e-smith.com>
60     - [4.2.0-03]
61     - Commenting out the harmful 'useradd' part of %pre section
62    
63     * Thu Feb 8 2001 Adrian Chung <adrianc@e-smith.com>
64     - [4.2.0-02]
65     - Rolling release number for GPG signing.
66    
67     * Thu Jan 25 2001 Peter Samuel <peters@e-smith.com>
68     - [4.2.0-01]
69     - Rolled version to 4.2.0 to indicate a stable release. Includes patches
70     upto 4.1.0-1
71    
72     * Wed Dec 6 2000 Adrian Chung <adrianc@e-smith.com>
73     - Branched for 4.1 release to 4.1.0
74    
75     * Mon Oct 16 2000 Charlie Brady <charlieb@e-smith.com>
76     - Need to add www user before trying to add admin user to
77     group www.
78    
79     * Mon Oct 16 2000 Charlie Brady <charlieb@e-smith.com>
80     - Add %pre clause to add admin, www etc.
81    
82     %description
83     e-smith server and gateway software. This is an empty
84     RPM provided so that upgrading e-smith 3.x -> e-smith 4.x
85     can work. Contents are now included in e-smith-base RPM.
86    
87     %prep
88     %setup
89    
90     %build
91    
92     %pre
93     #--------------------------------------------------
94     # add admin, public and www user accounts
95     #--------------------------------------------------
96     /usr/sbin/groupadd \
97     -g 500 shared 2>/dev/null || :
98 slords 1.3 /usr/sbin/groupadd \
99     -g 102 -o www 2>/dev/null || :
100 slords 1.1 /usr/sbin/useradd \
101 slords 1.3 -u 102 -g 102 -o -c 'e-smith web server' -d /home/e-smith \
102 wellsi 1.4 -G shared -M -s /bin/false www || :
103     /usr/sbin/groupadd \
104     -g 101 -o admin 2>/dev/null || :
105 slords 1.1 /usr/sbin/useradd \
106 wellsi 1.4 -u 101 -g 101 -c 'e-smith administrator' -d /home/e-smith \
107     -G shared,root,www -M -s /sbin/e-smith/console admin || :
108     /usr/sbin/groupadd \
109     -g 103 -o public 2>/dev/null || :
110 slords 1.1 /usr/sbin/useradd \
111 wellsi 1.4 -u 103 -g 103 -c 'e-smith guest' -d /home/e-smith \
112     -G shared -M -s /bin/false public || :
113     /usr/sbin/groupadd \
114     -g 1002 -o smelog 2>/dev/null || :
115 slords 1.1 /usr/sbin/useradd \
116 wellsi 1.4 -u 1002 -g 1002 -c 'sme log user' -d /var/log/smelog \
117     -M -s /bin/false smelog || :
118 slords 1.1
119     %clean
120     rm -rf $RPM_BUILD_ROOT
121    
122     %files
123     %defattr(-,root,root)
124     %doc COPYING

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed