/[smeserver]/rpms/e-smith/sme9/e-smith.spec
ViewVC logotype

Annotation of /rpms/e-smith/sme9/e-smith.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.6 - (hide annotations) (download)
Sun May 19 16:03:05 2013 UTC (11 years ago) by wellsi
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +2 -2 lines
Correct day in last changelog

1 wellsi 1.6 # $Id: e-smith.spec,v 1.5 2013/05/19 15:55:33 wellsi Exp $
2 slords 1.1
3     Summary: e-smith server and gateway
4     Name: e-smith
5     %define version 5.4.0
6 wellsi 1.5 %define release 5
7 slords 1.1 Version: %{version}
8     Release: %{release}%{?dist}
9     License: GPL
10     Group: Networking/Daemons
11     Source: %{name}-%{version}.tar.xz
12     BuildArch: noarch
13     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
14 wellsi 1.4 Requires(pre): /usr/sbin/useradd
15 slords 1.1 AutoReqProv: no
16    
17     %changelog
18 wellsi 1.6 * Sun May 19 2013 Ian Wells <esmith@wellsi.com> 5.4.0-5.sme
19 wellsi 1.5 - Update the full names of users added in %pre [SME: 3550]
20    
21 wellsi 1.4 * Sun May 05 2013 Ian Wells <esmith@wellsi.com> 5.4.0-4.sme
22     - Fix uid and gid to be the same for the users added in %pre [SME: 7547]
23     - Changed Prereq to Requires(pre) as Prereq is deprecated
24    
25 slords 1.3 * Sat Mar 9 2013 Shad L. Lords <slords@mail.com> 5.4.0-3.sme
26     - Ensure group www exists before user [SME: 7319]
27    
28 slords 1.2 * Wed Mar 6 2013 Shad L. Lords <slords@mail.com> 5.4.0-2.sme
29     - Fix pre script to make www and apache the same [SME: 7319]
30    
31 slords 1.1 * Fri Jan 25 2013 Shad L. Lords <slords@mail.com> 5.4.0-1.sme
32     - Roll new stream for sme9
33    
34     * Tue Oct 7 2008 Shad L. Lords <slords@mail.com> 5.2.0-1.sme
35     - Roll new stream to separate sme7/sme8 trees [SME: 4633]
36    
37     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
38     - Clean up spec so package can be built by koji/plague
39    
40     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
41     - Update to new release naming. No functional changes.
42     - Make Packager generic
43    
44     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 4.2.0-08
45     - Bump release number only
46    
47     * Fri Jan 14 2005 Charlie Brady <charlieb@e-smith.com> 4.2.0-07
48     - Re-add user and group creation. [MN00063589]
49    
50     * Fri Aug 17 2001 gordonr
51     - [4.2.0-06]
52     - Autorebuild by rebuildRPM
53    
54     * Fri Jul 27 2001 Charlie Brady <charlieb@e-smith.com>
55     - [4.2.0-05]
56     - Put defattr directive in the right spot.
57    
58     * Fri Jul 6 2001 Peter Samuel <peters@e-smith.com>
59     - [4.2.0-04]
60     - Including GPL license with package
61    
62     * Fri May 04 2001 Jason Miller <jmiller@e-smith.com>
63     - [4.2.0-03]
64     - Commenting out the harmful 'useradd' part of %pre section
65    
66     * Thu Feb 8 2001 Adrian Chung <adrianc@e-smith.com>
67     - [4.2.0-02]
68     - Rolling release number for GPG signing.
69    
70     * Thu Jan 25 2001 Peter Samuel <peters@e-smith.com>
71     - [4.2.0-01]
72     - Rolled version to 4.2.0 to indicate a stable release. Includes patches
73     upto 4.1.0-1
74    
75     * Wed Dec 6 2000 Adrian Chung <adrianc@e-smith.com>
76     - Branched for 4.1 release to 4.1.0
77    
78     * Mon Oct 16 2000 Charlie Brady <charlieb@e-smith.com>
79     - Need to add www user before trying to add admin user to
80     group www.
81    
82     * Mon Oct 16 2000 Charlie Brady <charlieb@e-smith.com>
83     - Add %pre clause to add admin, www etc.
84    
85     %description
86     e-smith server and gateway software. This is an empty
87     RPM provided so that upgrading e-smith 3.x -> e-smith 4.x
88     can work. Contents are now included in e-smith-base RPM.
89    
90     %prep
91     %setup
92    
93     %build
94    
95     %pre
96     #--------------------------------------------------
97     # add admin, public and www user accounts
98     #--------------------------------------------------
99     /usr/sbin/groupadd \
100     -g 500 shared 2>/dev/null || :
101 slords 1.3 /usr/sbin/groupadd \
102     -g 102 -o www 2>/dev/null || :
103 slords 1.1 /usr/sbin/useradd \
104 wellsi 1.5 -u 102 -g 102 -o -c 'SME Server web server' -d /home/e-smith \
105 wellsi 1.4 -G shared -M -s /bin/false www || :
106     /usr/sbin/groupadd \
107 wellsi 1.5 -g 102 -o apache 2>/dev/null || :
108     /usr/sbin/useradd \
109     -u 102 -g 102 -o -c 'Apache' -d /var/www \
110     -M -s /sbin/nologin apache || :
111     /usr/sbin/groupadd \
112 wellsi 1.4 -g 101 -o admin 2>/dev/null || :
113 slords 1.1 /usr/sbin/useradd \
114 wellsi 1.5 -u 101 -g 101 -c 'SME Server administrator' -d /home/e-smith \
115 wellsi 1.4 -G shared,root,www -M -s /sbin/e-smith/console admin || :
116     /usr/sbin/groupadd \
117     -g 103 -o public 2>/dev/null || :
118 slords 1.1 /usr/sbin/useradd \
119 wellsi 1.5 -u 103 -g 103 -c 'SME Server guest' -d /home/e-smith \
120 wellsi 1.4 -G shared -M -s /bin/false public || :
121     /usr/sbin/groupadd \
122     -g 1002 -o smelog 2>/dev/null || :
123 slords 1.1 /usr/sbin/useradd \
124 wellsi 1.5 -u 1002 -g 1002 -c 'SME Server log user' -d /var/log/smelog \
125 wellsi 1.4 -M -s /bin/false smelog || :
126 slords 1.1
127 wellsi 1.5
128 slords 1.1 %clean
129     rm -rf $RPM_BUILD_ROOT
130    
131     %files
132     %defattr(-,root,root)
133     %doc COPYING

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed