1 |
slords |
1.1 |
# $Id: flexbackup.spec,v 1.2 2008/04/09 13:51:48 slords Exp $ |
2 |
|
|
|
3 |
|
|
# Hey emacs, use -*-rpm-spec-*- mode... |
4 |
|
|
|
5 |
|
|
%define version 1.2.1 |
6 |
|
|
|
7 |
|
|
Summary: Flexible backup script |
8 |
|
|
Name: flexbackup |
9 |
|
|
Version: %{version} |
10 |
|
|
Release: 1%{?dist} |
11 |
|
|
Epoch: 0 |
12 |
|
|
License: GPL |
13 |
|
|
Group: Applications/Archiving |
14 |
|
|
URL: http://www.flexbackup.org |
15 |
|
|
Source0: flexbackup-%{version}.tar.gz |
16 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArch: noarch |
18 |
|
|
Requires: gzip |
19 |
|
|
Requires: fileutils |
20 |
|
|
Requires: findutils |
21 |
|
|
|
22 |
|
|
#--------------------------------------------------------------------- |
23 |
|
|
%description |
24 |
|
|
A flexible backup tool |
25 |
|
|
|
26 |
|
|
Features: |
27 |
|
|
o Easy to configure |
28 |
|
|
o Uses dump, afio, GNU tar, cpio, star, pax, or zip archivers |
29 |
|
|
o Full and numbered levels of incremental backup (acts like "dump") |
30 |
|
|
o Compression and buffering options for all backup types |
31 |
|
|
o Does remote filesystems (over rsh/ssh; no special service) |
32 |
|
|
o Can backup only files not owned by rpm, or changed from rpm version |
33 |
|
|
o Writes to tapes, on-disk archive files, or on-disk directory trees |
34 |
|
|
o Keeps a table of contents so you know archives are on each tape |
35 |
|
|
o Nice log files |
36 |
|
|
|
37 |
|
|
|
38 |
|
|
#--------------------------------------------------------------------- |
39 |
|
|
%prep |
40 |
|
|
%setup -q |
41 |
|
|
|
42 |
|
|
#--------------------------------------------------------------------- |
43 |
|
|
%build |
44 |
|
|
make all PREFIX=/usr CONFFILE=/etc/flexbackup.conf |
45 |
|
|
|
46 |
|
|
#--------------------------------------------------------------------- |
47 |
|
|
%install |
48 |
|
|
rm -rf %{buildroot} |
49 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc |
50 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_bindir} |
51 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1 |
52 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5 |
53 |
|
|
mkdir -p $RPM_BUILD_ROOT/var/lib/flexbackup |
54 |
|
|
mkdir -p $RPM_BUILD_ROOT/var/log/flexbackup |
55 |
|
|
make install PREFIX=$RPM_BUILD_ROOT/usr CONFFILE=$RPM_BUILD_ROOT/etc/flexbackup.conf |
56 |
|
|
|
57 |
|
|
#--------------------------------------------------------------------- |
58 |
|
|
%clean |
59 |
|
|
rm -rf %{buildroot} |
60 |
|
|
|
61 |
|
|
#--------------------------------------------------------------------- |
62 |
|
|
%files |
63 |
|
|
%defattr(-,root,root,-) |
64 |
|
|
%config(noreplace) /etc/flexbackup.conf |
65 |
|
|
%{_bindir}/* |
66 |
|
|
%{_mandir}/*/* |
67 |
|
|
%dir /var/lib/flexbackup |
68 |
|
|
%dir /var/log/flexbackup |
69 |
|
|
%doc CHANGES COPYING TODO README CREDITS INSTALL faq.html |
70 |
|
|
|
71 |
|
|
#--------------------------------------------------------------------- |
72 |
|
|
%changelog |
73 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
74 |
|
|
- Clean up spec so package can be built by koji/plague |
75 |
|
|
|
76 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
77 |
|
|
- Update to new release naming. No functional changes. |
78 |
|
|
- Make Packager generic |
79 |
|
|
|
80 |
|
|
* Tue Sep 23 2003 Edwin Huffstutler <edwinh@computer.org> |
81 |
|
|
- cleanup spec a bit |
82 |
|
|
|
83 |
|
|
* Tue Jul 29 2003 Edwin Huffstutler <edwinh@hercules.my-net> |
84 |
|
|
- add manpages, tweak a bit |
85 |
|
|
|
86 |
|
|
* Thu Jul 3 2003 Edwin Huffstutler <edwinh@hercules.my-net> |
87 |
|
|
- update description |
88 |
|
|
|
89 |
|
|
* Tue Feb 18 2003 Edwin Huffstutler <edwinh@hercules.my-net> |
90 |
|
|
- config file is noreplace |
91 |
|
|
|
92 |
|
|
* Wed Jan 15 2003 Edwin Huffstutler <edwinh+flexbackup@edwinh.org> |
93 |
|
|
- defattr in right spot |
94 |
|
|
|
95 |
|
|
* Sun Jan 12 2003 Edwin Huffstutler <edwinh+flexbackup@edwinh.org> |
96 |
|
|
- updated |
97 |
|
|
|
98 |
|
|
* Sat Sep 25 1999 Edwin Huffstutler <edwinh+flexbackup@edwinh.org> |
99 |
|
|
- add more requires, update description, email address. |
100 |
|
|
- really goes in /usr/bin since it needs perl anyway -- |
101 |
|
|
if you only have your root fs, run restore or tar by hand :) |
102 |
|
|
|
103 |
|
|
* Sat Sep 18 1999 Edwin Huffstutler <edwinh+flexbackup@edwinh.org> |
104 |
|
|
- initial rpm package |