/[smeserver]/rpms/geoipupdate/sme10/geoipupdate.spec
ViewVC logotype

Annotation of /rpms/geoipupdate/sme10/geoipupdate.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Apr 13 04:08:07 2021 UTC (3 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: geoipupdate-3_1_1-2_el6
Initial import

1 jpp 1.1 %global _hardened_build 1
2    
3     Name: geoipupdate
4     Version: 3.1.1
5     Release: 2%{?dist}
6     Summary: Update GeoIP2 and GeoIP Legacy binary databases from MaxMind
7     License: GPLv2
8     URL: http://dev.maxmind.com/geoip/geoipupdate/
9     Source0: http://github.com/maxmind/geoipupdate/releases/download/v%{version}/geoipupdate-%{version}.tar.gz
10     Source1: geoipupdate.cron
11     BuildRequires: coreutils
12     BuildRequires: crontabs
13     BuildRequires: gcc
14     BuildRequires: libcurl-devel
15     BuildRequires: make
16     BuildRequires: sed
17     BuildRequires: zlib-devel
18    
19     # Legacy databases fetched by cron6 sub-package no longer available
20     Obsoletes: geoipupdate-cron6 < %{version}-%{release}
21    
22     %description
23     The GeoIP Update program performs automatic updates of GeoIP2 and GeoIP
24     Legacy binary databases.
25    
26     %package cron
27     Summary: Cron job to do weekly updates of GeoIP databases
28     BuildArch: noarch
29     Requires: %{name} = %{version}-%{release}
30     Requires: crontabs
31     Obsoletes: GeoIP-update < 1.6.0
32     Provides: GeoIP-update = 1.6.0
33    
34     %description cron
35     Cron job for weekly updates to GeoIP2 and GeoIP Legacy binary databases from
36     MaxMind.
37    
38     %prep
39     %setup -q
40    
41     %build
42     %configure --disable-static --disable-dependency-tracking
43     make %{?_smp_mflags}
44    
45     %install
46     make install DESTDIR=%{buildroot}
47    
48     # We'll package the documentation ourselves
49     rm -rf %{buildroot}%{_datadir}/doc/geoipupdate
50    
51     install -D -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/cron.weekly/geoipupdate
52    
53     %files
54     %if 0%{?_licensedir:1}
55     %license LICENSE
56     %else
57     %doc LICENSE
58     %endif
59     %doc conf/GeoIP.conf.default README.md ChangeLog.md
60     %config(noreplace) %{_sysconfdir}/GeoIP.conf
61     %{_bindir}/geoipupdate
62     %dir %{_datadir}/GeoIP/
63     %{_mandir}/man1/geoipupdate.1*
64     %{_mandir}/man5/GeoIP.conf.5*
65    
66     %files cron
67     %config(noreplace) %{_sysconfdir}/cron.weekly/geoipupdate
68    
69     %changelog
70     * Mon Jan 21 2019 Paul Howarth <paul@city-fan.org> - 3.1.1-2
71     - Don't try to update the free legacy GeoIP databases as they are no longer
72     distributed by upstream
73     - Drop the cron6 sub-package as the files it tries to download are no longer
74     distributed by upstream
75    
76     * Tue Sep 11 2018 Paul Howarth <paul@city-fan.org> - 3.1.1-1
77     - Update to 3.1.1
78     - Allow parsing of license keys longer than 12 characters
79    
80     * Fri Aug 17 2018 Paul Howarth <paul@city-fan.org> - 3.1.0-1
81     - Update to 3.1.0
82     Changes in version 3.0.0:
83     - BREAKING CHANGE: When downloading the free databases without a MaxMind
84     account, you must either not have 'AccountID', 'UserId', or 'LicenseKey'
85     set in your configuration file or they must be set to the zero values
86     previously recommended in our documentation; any other value will cause an
87     authorization error
88     - BREAKING CHANGE: The configuration options 'Protocol',
89     'SkipPeerVerification', and `SkipHostnameVerification` are no longer
90     supported; if they are present in the configuration file, they will be
91     ignored - HTTPS with peer and hostname verification will be used on all
92     requests
93     - BREAKING CHANGE: The configuration file must have the 'AccountID' or the
94     deprecated 'UserId' when downloading a paid database; previously, when
95     downloading the GeoIP Legacy Country database, you were able to only
96     provide the 'LicenseKey'
97     - IMPORTANT: 'geoipupdate-pureperl.pl' has been removed and will no longer be
98     distributed with 'geoipupdate'; this Perl script had known issues and did
99     not have feature parity with the C implementation
100     - This program no longer uses the following endpoints:
101     '/app/update_getipaddr', '/app/update', and '/app/update_secure';
102     '/geoip/databases/{edition_id}/update' is now used instead
103     - Fixed issue in 'gu_strnlen()' dereferencing a pointer before checking that
104     it was in array bounds
105     - We now update the default GeoIP.conf during installation so that directory
106     paths match build parameters; previously this config always said the data
107     directory was under /usr/local/share which was not always accurate
108     - Improve the error checking and display the underlying reason for the error
109     when possible (GH#82)
110     - Document that the 'LockFile' is not removed from the filesystem after a
111     successful exit from the program (GH#79)
112     - Make default configuration directory agree with default installation
113     directory
114     Changes in version 3.0.1:
115     - When there were no updates available, 3.0.0 incorrectly returned an exit
116     code of 1 instead of 0; this release reverts to the pre-3.0.0 behavior,
117     returning an exit code of 0 in this case
118     Changes in version 3.1.0:
119     - This version restores the ability to use the 'AccountID'/'UserId' 999999
120     along with an all-zero license key when downloading free databases;
121     however, the use of this combination is not recommended and may break in
122     future versions
123     - When printing verbose output, only the first four characters of the
124     'LicenseKey' will now be displayed
125    
126     * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-3
127     - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
128    
129     * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-2
130     - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
131    
132     * Tue Oct 31 2017 Paul Howarth <paul@city-fan.org> - 2.5.0-1
133     - Update to 2.5.0
134     - Replace use of strnlen() due to lack of universal availability (GH#71)
135     - Document the 'LockFile' option in the 'GeoIP.conf' man page (GH#64)
136     - Remove unused base64 library (GH#68)
137     - Add the new configuration option 'PreserveFileTimes'; if set, the
138     downloaded files will get the same modification times as their original on
139     the server (default is '0') (GH#63)
140     - Use the correct types when calling 'curl_easy_setopt()'; this fixes
141     warnings generated by libcurl's 'typecheck-gcc.h' (GH#61)
142     - In 'GeoIP.conf', the 'UserId' option was renamed to 'AccountID' and the
143     'ProductIds' option was renamed to 'EditionIDs'; the old options will
144     continue to work, but upgrading to the new names is recommended for
145     forward compatibility
146    
147     * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-3
148     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
149    
150     * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-2
151     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
152    
153     * Fri May 26 2017 Paul Howarth <paul@city-fan.org> - 2.4.0-1
154     - Update to 2.4.0
155     - geoipupdate now checks that the database directory is writable: if it is
156     not, it reports the problem and aborts
157     - geoipupdate now acquires a lock when starting up to ensure only one
158     instance may run at a time: a new option, 'LockFile', exists to set the
159     file to use as a lock ('.geoipupdate.lock' in the database directory by
160     default)
161     - geoipupdate now prints out additional information from the server when a
162     download request results in something other than HTTP status 2xx; this
163     provides more information when the API does not respond with a database
164     file
165     - ${datarootdir}/GeoIP is now created on 'make install' (GH#29)
166     - Previously, a variable named 'ERROR' was used, which caused issues building
167     on Windows (GH#36)
168     - Drop EL-5 support
169     - Drop BuildRoot: and Group: tags
170     - Drop explicit buildroot cleaning in %%install section
171     - Drop explicit %%clean section
172     - noarch subpackages always available now
173     - libcurl-devel always available now
174    
175     * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.1-2
176     - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
177    
178     * Thu Jan 5 2017 Paul Howarth <paul@city-fan.org> - 2.3.1-1
179     - Update to 2.3.1
180     - geoipupdate now uses TCP keep-alive when compiled with cURL 7.25 or
181     greater
182     - Previously, on an invalid gzip file, geoipupdate would output binary data
183     to stderr; it now displays an appropriate error message
184     - Install README, ChangeLog, GeoIP.conf.default etc. into docdir (GH#33)
185     - $(sysconfdir) is now created if it doesn't exist (GH#33)
186     - The sample config file is now usable (GH#33)
187    
188     * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
189     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
190    
191     * Fri Jan 22 2016 Paul Howarth <paul@city-fan.org> - 2.2.2-1
192     - Update to 2.2.2
193     - geoipupdate now calls fsync on the database directory after a rename to
194     make it durable in the event of a crash
195     - Update autotools patch
196    
197     * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-3
198     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
199    
200     * Mon Apr 13 2015 Paul Howarth <paul@city-fan.org> - 2.2.1-2
201     - Split patch for upstream issue #26 into separate patches for upstream changes
202     and effect of running autotools
203    
204     * Wed Mar 4 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.2.1-1
205     - Update to 2.2.1
206     - geoipupdate now verifies the MD5 of the new database before deploying it;
207     if the database MD5 does not match the expected MD5, geoipupdate will exit
208     with an error
209     - The copy of 'base64.c' and 'base64.h' was switched to a version under
210     GPLv2+ to prevent a license conflict
211     - The 'LICENSE' file was added to the distribution
212     - Several issues in the documentation were fixed
213     - Use interim fix for upstream issue #26 until it's accepted:
214     https://github.com/maxmind/geoipupdate/issues/26
215     - Add buildroot and clean, BR: curl-devel rather than libcurl-devel for
216     EL-5 compatibility
217    
218     * Tue Feb 10 2015 Paul Howarth <paul@city-fan.org> - 2.1.0-4
219     - New geoipupdate6 cron script written in Perl that doesn't download the data
220     if it hasn't changed
221    
222     * Fri Feb 6 2015 Paul Howarth <paul@city-fan.org> - 2.1.0-3
223     - Add cron6 subpackage, equivalent to old GeoIP-update6 package
224     - Revise obsoletes/provides
225    
226     * Sun Feb 1 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.1.0-2
227     - Remove architecture-specific dependency in noarch subpackage
228    
229     * Mon Jan 26 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.1.0-1
230     - Initial review package (generated by rpmdev-newspec)
231    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed