1 |
%global _hardened_build 1 |
2 |
|
3 |
Name: geoipupdate |
4 |
Version: 3.1.1 |
5 |
Release: 2.1%{?dist} |
6 |
Summary: Update GeoIP2 and GeoIP Legacy binary databases from MaxMind |
7 |
License: GPLv2 |
8 |
URL: http://dev.maxmind.com/geoip/geoipupdate/ |
9 |
Source0: http://github.com/maxmind/geoipupdate/releases/download/v%{version}/geoipupdate-%{version}.tar.gz |
10 |
Source1: geoipupdate.cron |
11 |
BuildRequires: coreutils |
12 |
BuildRequires: crontabs |
13 |
BuildRequires: gcc |
14 |
BuildRequires: libcurl-devel |
15 |
BuildRequires: make |
16 |
BuildRequires: sed |
17 |
BuildRequires: zlib-devel |
18 |
|
19 |
# Legacy databases fetched by cron6 sub-package no longer available |
20 |
Obsoletes: geoipupdate-cron6 < %{version}-%{release} |
21 |
|
22 |
%description |
23 |
The GeoIP Update program performs automatic updates of GeoIP2 and GeoIP |
24 |
Legacy binary databases. |
25 |
|
26 |
%package cron |
27 |
Summary: Cron job to do weekly updates of GeoIP databases |
28 |
BuildArch: noarch |
29 |
Requires: %{name} = %{version}-%{release} |
30 |
Requires: crontabs |
31 |
Obsoletes: GeoIP-update < 1.6.0 |
32 |
Provides: GeoIP-update = 1.6.0 |
33 |
|
34 |
%description cron |
35 |
Cron job for weekly updates to GeoIP2 and GeoIP Legacy binary databases from |
36 |
MaxMind. |
37 |
|
38 |
%prep |
39 |
%setup -q |
40 |
|
41 |
%build |
42 |
%configure --disable-static --disable-dependency-tracking |
43 |
make %{?_smp_mflags} |
44 |
|
45 |
%install |
46 |
make install DESTDIR=%{buildroot} |
47 |
|
48 |
# We'll package the documentation ourselves |
49 |
rm -rf %{buildroot}%{_datadir}/doc/geoipupdate |
50 |
|
51 |
install -D -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/cron.weekly/geoipupdate |
52 |
|
53 |
%files |
54 |
%if 0%{?_licensedir:1} |
55 |
%license LICENSE |
56 |
%else |
57 |
%doc LICENSE |
58 |
%endif |
59 |
%doc conf/GeoIP.conf.default README.md ChangeLog.md |
60 |
%config(noreplace) %{_sysconfdir}/GeoIP.conf |
61 |
%{_bindir}/geoipupdate |
62 |
%dir %{_datadir}/GeoIP/ |
63 |
%{_mandir}/man1/geoipupdate.1* |
64 |
%{_mandir}/man5/GeoIP.conf.5* |
65 |
|
66 |
%files cron |
67 |
%config(noreplace) %{_sysconfdir}/cron.weekly/geoipupdate |
68 |
|
69 |
%changelog |
70 |
* Mon Apr 12 2020 Jean-Philippe Pialasse <tests@pialasse.com> - 3.1.1-2.1 |
71 |
- import to SME10 |
72 |
|
73 |
* Mon Jan 21 2019 Paul Howarth <paul@city-fan.org> - 3.1.1-2 |
74 |
- Don't try to update the free legacy GeoIP databases as they are no longer |
75 |
distributed by upstream |
76 |
- Drop the cron6 sub-package as the files it tries to download are no longer |
77 |
distributed by upstream |
78 |
|
79 |
* Tue Sep 11 2018 Paul Howarth <paul@city-fan.org> - 3.1.1-1 |
80 |
- Update to 3.1.1 |
81 |
- Allow parsing of license keys longer than 12 characters |
82 |
|
83 |
* Fri Aug 17 2018 Paul Howarth <paul@city-fan.org> - 3.1.0-1 |
84 |
- Update to 3.1.0 |
85 |
Changes in version 3.0.0: |
86 |
- BREAKING CHANGE: When downloading the free databases without a MaxMind |
87 |
account, you must either not have 'AccountID', 'UserId', or 'LicenseKey' |
88 |
set in your configuration file or they must be set to the zero values |
89 |
previously recommended in our documentation; any other value will cause an |
90 |
authorization error |
91 |
- BREAKING CHANGE: The configuration options 'Protocol', |
92 |
'SkipPeerVerification', and `SkipHostnameVerification` are no longer |
93 |
supported; if they are present in the configuration file, they will be |
94 |
ignored - HTTPS with peer and hostname verification will be used on all |
95 |
requests |
96 |
- BREAKING CHANGE: The configuration file must have the 'AccountID' or the |
97 |
deprecated 'UserId' when downloading a paid database; previously, when |
98 |
downloading the GeoIP Legacy Country database, you were able to only |
99 |
provide the 'LicenseKey' |
100 |
- IMPORTANT: 'geoipupdate-pureperl.pl' has been removed and will no longer be |
101 |
distributed with 'geoipupdate'; this Perl script had known issues and did |
102 |
not have feature parity with the C implementation |
103 |
- This program no longer uses the following endpoints: |
104 |
'/app/update_getipaddr', '/app/update', and '/app/update_secure'; |
105 |
'/geoip/databases/{edition_id}/update' is now used instead |
106 |
- Fixed issue in 'gu_strnlen()' dereferencing a pointer before checking that |
107 |
it was in array bounds |
108 |
- We now update the default GeoIP.conf during installation so that directory |
109 |
paths match build parameters; previously this config always said the data |
110 |
directory was under /usr/local/share which was not always accurate |
111 |
- Improve the error checking and display the underlying reason for the error |
112 |
when possible (GH#82) |
113 |
- Document that the 'LockFile' is not removed from the filesystem after a |
114 |
successful exit from the program (GH#79) |
115 |
- Make default configuration directory agree with default installation |
116 |
directory |
117 |
Changes in version 3.0.1: |
118 |
- When there were no updates available, 3.0.0 incorrectly returned an exit |
119 |
code of 1 instead of 0; this release reverts to the pre-3.0.0 behavior, |
120 |
returning an exit code of 0 in this case |
121 |
Changes in version 3.1.0: |
122 |
- This version restores the ability to use the 'AccountID'/'UserId' 999999 |
123 |
along with an all-zero license key when downloading free databases; |
124 |
however, the use of this combination is not recommended and may break in |
125 |
future versions |
126 |
- When printing verbose output, only the first four characters of the |
127 |
'LicenseKey' will now be displayed |
128 |
|
129 |
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-3 |
130 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
131 |
|
132 |
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-2 |
133 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
134 |
|
135 |
* Tue Oct 31 2017 Paul Howarth <paul@city-fan.org> - 2.5.0-1 |
136 |
- Update to 2.5.0 |
137 |
- Replace use of strnlen() due to lack of universal availability (GH#71) |
138 |
- Document the 'LockFile' option in the 'GeoIP.conf' man page (GH#64) |
139 |
- Remove unused base64 library (GH#68) |
140 |
- Add the new configuration option 'PreserveFileTimes'; if set, the |
141 |
downloaded files will get the same modification times as their original on |
142 |
the server (default is '0') (GH#63) |
143 |
- Use the correct types when calling 'curl_easy_setopt()'; this fixes |
144 |
warnings generated by libcurl's 'typecheck-gcc.h' (GH#61) |
145 |
- In 'GeoIP.conf', the 'UserId' option was renamed to 'AccountID' and the |
146 |
'ProductIds' option was renamed to 'EditionIDs'; the old options will |
147 |
continue to work, but upgrading to the new names is recommended for |
148 |
forward compatibility |
149 |
|
150 |
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-3 |
151 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
152 |
|
153 |
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-2 |
154 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
155 |
|
156 |
* Fri May 26 2017 Paul Howarth <paul@city-fan.org> - 2.4.0-1 |
157 |
- Update to 2.4.0 |
158 |
- geoipupdate now checks that the database directory is writable: if it is |
159 |
not, it reports the problem and aborts |
160 |
- geoipupdate now acquires a lock when starting up to ensure only one |
161 |
instance may run at a time: a new option, 'LockFile', exists to set the |
162 |
file to use as a lock ('.geoipupdate.lock' in the database directory by |
163 |
default) |
164 |
- geoipupdate now prints out additional information from the server when a |
165 |
download request results in something other than HTTP status 2xx; this |
166 |
provides more information when the API does not respond with a database |
167 |
file |
168 |
- ${datarootdir}/GeoIP is now created on 'make install' (GH#29) |
169 |
- Previously, a variable named 'ERROR' was used, which caused issues building |
170 |
on Windows (GH#36) |
171 |
- Drop EL-5 support |
172 |
- Drop BuildRoot: and Group: tags |
173 |
- Drop explicit buildroot cleaning in %%install section |
174 |
- Drop explicit %%clean section |
175 |
- noarch subpackages always available now |
176 |
- libcurl-devel always available now |
177 |
|
178 |
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.1-2 |
179 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild |
180 |
|
181 |
* Thu Jan 5 2017 Paul Howarth <paul@city-fan.org> - 2.3.1-1 |
182 |
- Update to 2.3.1 |
183 |
- geoipupdate now uses TCP keep-alive when compiled with cURL 7.25 or |
184 |
greater |
185 |
- Previously, on an invalid gzip file, geoipupdate would output binary data |
186 |
to stderr; it now displays an appropriate error message |
187 |
- Install README, ChangeLog, GeoIP.conf.default etc. into docdir (GH#33) |
188 |
- $(sysconfdir) is now created if it doesn't exist (GH#33) |
189 |
- The sample config file is now usable (GH#33) |
190 |
|
191 |
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2 |
192 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild |
193 |
|
194 |
* Fri Jan 22 2016 Paul Howarth <paul@city-fan.org> - 2.2.2-1 |
195 |
- Update to 2.2.2 |
196 |
- geoipupdate now calls fsync on the database directory after a rename to |
197 |
make it durable in the event of a crash |
198 |
- Update autotools patch |
199 |
|
200 |
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-3 |
201 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
202 |
|
203 |
* Mon Apr 13 2015 Paul Howarth <paul@city-fan.org> - 2.2.1-2 |
204 |
- Split patch for upstream issue #26 into separate patches for upstream changes |
205 |
and effect of running autotools |
206 |
|
207 |
* Wed Mar 4 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.2.1-1 |
208 |
- Update to 2.2.1 |
209 |
- geoipupdate now verifies the MD5 of the new database before deploying it; |
210 |
if the database MD5 does not match the expected MD5, geoipupdate will exit |
211 |
with an error |
212 |
- The copy of 'base64.c' and 'base64.h' was switched to a version under |
213 |
GPLv2+ to prevent a license conflict |
214 |
- The 'LICENSE' file was added to the distribution |
215 |
- Several issues in the documentation were fixed |
216 |
- Use interim fix for upstream issue #26 until it's accepted: |
217 |
https://github.com/maxmind/geoipupdate/issues/26 |
218 |
- Add buildroot and clean, BR: curl-devel rather than libcurl-devel for |
219 |
EL-5 compatibility |
220 |
|
221 |
* Tue Feb 10 2015 Paul Howarth <paul@city-fan.org> - 2.1.0-4 |
222 |
- New geoipupdate6 cron script written in Perl that doesn't download the data |
223 |
if it hasn't changed |
224 |
|
225 |
* Fri Feb 6 2015 Paul Howarth <paul@city-fan.org> - 2.1.0-3 |
226 |
- Add cron6 subpackage, equivalent to old GeoIP-update6 package |
227 |
- Revise obsoletes/provides |
228 |
|
229 |
* Sun Feb 1 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.1.0-2 |
230 |
- Remove architecture-specific dependency in noarch subpackage |
231 |
|
232 |
* Mon Jan 26 2015 Philip A. Prindeville <philipp@fedoraproject.org> - 2.1.0-1 |
233 |
- Initial review package (generated by rpmdev-newspec) |
234 |
|