/[smeserver]/rpms/hal/sme7/hal.spec
ViewVC logotype

Annotation of /rpms/hal/sme7/hal.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Thu Mar 22 16:11:10 2012 UTC (12 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: hal-0_4_2-8_EL4
Import

1 slords 1.1 %define expat_version 1.95.5
2     %define glib2_version 2.2.0
3     %define dbus_version 0.22
4     %define pygtk2 2.0.0
5     %define gnome_python2 2.0.0
6     %define libselinux_version 1.17.14-1
7     %define udev_version 034-2
8     %define util_linux_version 2.12a-16
9     %define libcap_version 1.10-20
10     %define doxygen_version 1.3.9.1-1
11    
12     %define hal_user_uid 68
13    
14     Summary: Hardware Abstraction Layer
15     Name: hal
16     Version: 0.4.2
17     Release: 8.EL4
18     URL: http://www.freedesktop.org/Software/hal
19     Source0: %{name}-%{version}.tar.gz
20     Patch0: hal-null-block-device.patch
21     Patch1: hal-osspec.patch
22     Patch2: hal-sync-callouts.patch
23     Patch3: hal-hotplug-input-quiet.patch
24     Patch4: hal-0.4.2-device-info-parse.patch
25     Patch5: hal-0.4.2-skip-sysfs-config.patch
26     Patch6: hal-0.4.2-is-mounted-crasher.patch
27     Patch7: hal-0.4.2-dont-delete-slash.patch
28     Patch8: hal-0.4.2-plug-hotplug-memleak.patch
29     Patch9: hal-0.4.2-larger-mtab-buffer.patch
30     Patch10: hal-0.4.2-size_t.patch
31     License: AFL/GPL
32     Group: System Environment/Libraries
33     BuildRoot: %{_tmppath}/%{name}-root
34     PreReq: chkconfig
35     BuildRequires: expat-devel >= %{expat_version}
36     BuildRequires: glib2-devel >= %{glib2_version}
37     BuildRequires: dbus-devel = %{dbus_version}
38     BuildRequires: python-devel
39     BuildRequires: hwdata
40     BuildRequires: libselinux-devel >= %{libselinux_version}
41     BuildRequires: libcap-devel >= %{libcap_version}
42     BuildRequires: doxygen >= %{doxygen_version}
43     Requires: dbus = %{dbus_version}
44     Requires: dbus-glib = %{dbus_version}
45     Requires: glib2 >= %{glib2_version}
46     Requires: udev >= %{udev_version}
47     Requires: util-linux >= %{util_linux_version}
48     Requires: libselinux >= %{libselinux_version}
49    
50     %description
51    
52     HAL is daemon for collection and maintaining information from several
53     sources about the hardware on the system. It provdes a live device
54     list through D-BUS.
55    
56     %package gnome
57     Summary: GNOME based device manager for HAL
58     Group: Development/Libraries
59     Requires: %name = %{version}-%{release}
60     Requires: dbus-python >= %{dbus_version}
61     Requires: pygtk2 >= %{pygtk2}
62     Requires: gnome-python2 >= %{gnome_python2}
63    
64     %description gnome
65     GNOME program for displaying the devices detected by HAL
66    
67    
68     %package devel
69     Summary: Libraries and headers for HAL
70     Group: Development/Libraries
71     Requires: %name = %{version}-%{release}
72     Requires: dbus-devel = %{dbus_version}
73    
74     %description devel
75    
76     Headers, static libraries and API docs for HAL.
77    
78     %prep
79     %setup -q
80     %patch0 -p1 -b .null-block-device
81     %patch1 -p1 -b .osspec
82     %patch2 -p1 -b .sync-callouts
83     %patch3 -p1 -b .quiet
84     %patch4 -p1 -b .fdi-typo
85     %patch5 -p1 -b .dont-read-config
86     %patch6 -p1 -b .is-mounted-crasher
87     %patch7 -p1 -b .dont-delete-slash
88     %patch8 -p1 -b .plug-hotplug-memleak.patch
89     %patch9 -p1 -b .larger-mtab-buffer
90     %patch10 -p1 -b .sizet
91    
92     %build
93    
94     %configure --disable-docbook-docs --enable-fstab-sync --enable-hotplug-map --with-init-scripts=redhat --with-pid-file=/var/run/haldaemon.pid --enable-selinux --enable-pcmcia-support
95     make
96    
97     %install
98     make install DESTDIR=$RPM_BUILD_ROOT
99    
100     rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
101    
102     %clean
103     rm -rf %{buildroot}
104    
105     %pre
106     # Add the "haldaemon" user
107     /usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
108     -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
109    
110     %post
111     /sbin/ldconfig
112     /sbin/chkconfig --add haldaemon
113    
114     %preun
115     if [ $1 = 0 ]; then
116     service haldaemon stop > /dev/null 2>&1
117     /sbin/chkconfig --del haldaemon
118     fi
119    
120     %postun
121     /sbin/ldconfig
122     if [ "$1" -ge "1" ]; then
123     service haldaemon condrestart > /dev/null 2>&1
124     fi
125    
126     %files
127     %defattr(-,root,root)
128     #%doc COPYING ChangeLog NEWS
129    
130     %dir %{_sysconfdir}/dbus-1/system.d
131    
132     %config %{_sysconfdir}/dbus-1/system.d/hal.conf
133     %config %{_sysconfdir}/rc.d/init.d/*
134    
135     %dir %{_sysconfdir}/hal
136     %dir %{_sysconfdir}/hal/capability.d
137     %dir %{_sysconfdir}/hal/device.d
138     %dir %{_sysconfdir}/hal/property.d
139    
140     %config %{_sysconfdir}/hal/hald.conf
141    
142     %{_sbindir}/hald
143     %{_sbindir}/fstab-sync
144    
145     %{_bindir}/lshal
146     %{_bindir}/hal-get-property
147     %{_bindir}/hal-set-property
148    
149     %{_libdir}/*hal*.so.*
150    
151     %{_libexecdir}/hal.hotplug
152     /etc/hotplug.d/default/20-hal.hotplug
153    
154     %{_libexecdir}/hal.dev
155     %{_sysconfdir}/dev.d/default/10-hal.dev
156    
157     %{_libexecdir}/hal-hotplug-map
158    
159     %dir %{_datadir}/hal
160     %dir %{_datadir}/hal/fdi
161     %{_datadir}/hal/fdi/*
162     %{_datadir}/locale/*
163     %{_datadir}/man/*
164     %{_datadir}/doc/hal-%{version}/conf/*
165    
166     %{_sysconfdir}/hal/device.d/40-hal-hotplug-map.hal
167     # allow users to make this symlink point to /bin/false cf. the fstab-sync
168     # manpage
169     %config(noreplace) %{_sysconfdir}/hal/device.d/50-fstab-sync.hal
170    
171     %files devel
172     %defattr(-,root,root)
173    
174     %{_libdir}/lib*.a
175     %{_libdir}/lib*.so
176     %{_libdir}/pkgconfig/*
177     %{_includedir}/*
178     %{_datadir}/doc/hal-%{version}/api/*
179     # TODO: include hal-spec
180    
181    
182    
183     %files gnome
184     %defattr(-,root,root)
185    
186     %dir %{_datadir}/hal/device-manager
187     %{_datadir}/hal/device-manager/*
188     %{_bindir}/hal-device-manager
189    
190    
191     %changelog
192     * Thu Apr 10 2008 - David Zeuthen <davidz@redhat.com> - 0.4.2-8.EL4
193     - Make fstab-sync properly handle the ENOSPC case
194     - Resolves: #250419
195    
196     * Thu Aug 02 2007 - David Zeuthen <davidz@redhat.com> - 0.4.2-7.EL4
197     - Fix memory leak when unplugging/replugging a USB device
198     - Resolves: #247734
199     - Use a larger line buffer for the /etc/mtab file (#238501)
200    
201     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-6.EL4
202     - Fix wrong patch being used for (Bug #172835)
203    
204     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-5.EL4
205     - Add patch to fix the ide-drives.fdi parsing, missing closing element
206     (Bug #164631)
207     - Patch by Jeff Layton <jlayton@redhat.com> to avoid poking the "config"
208     file in sysfs sub-dirs, as it can cause problems for some devices
209     (Bug #172835)
210     - Avoid fstab-sync crashing when checking whether a partition is mounted
211     (comparing an uninitialised variable) (Bug #175523)
212     - Add patch by Keiichi Mori <kmori@redhat.com> to not delete the '/' entry
213     from /etc/fstab (strcmp of a 0-len string always succeeds)
214     (Bug #192410)
215    
216     * Fri May 05 2006 John (J5) Palmieri <johnp@redhat.com> - 0.4.2-4.EL4
217     - Add patch to stop HAL complaining about DEVPATH not being set on
218     kernels that do not support it (Bug #169387)
219    
220     * Wed Dec 21 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-3.EL4
221     - Rebuild with gcc-3.4.5-2
222    
223     * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-2.EL4
224     - Add patch to fix segfault in fstab-sync when ejecting CD (Bug 163772)
225     - Add patch to fix hotplug issues with USB cds (Bug 164777)
226     - Add patch to run callouts synchronously (Bug 167811)
227    
228     * Wed Dec 01 2004 David Zeuthen <davidz@redhat,com> 0.4.2-1.EL4
229     - Upstream release 0.4.2
230     - Drop all patches as they are committed upstream
231     - Fixes for #140557, #139227, #139962, #139600, #136971
232     - Workaround for #138148 through blacklisting certain IDE optical drives
233    
234     * Tue Oct 19 2004 David Zeuthen <davidz@redhat,com> 0.4.0-5
235     - Make hal work with PCMCIA IDE hotpluggable devices (#133943)
236     - Fixup URL listed from rpm -qi (#136396)
237     - Add Portuguese translations for hal
238     - Fix addition of Russian and Hungarian translations
239    
240     * Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
241     - Make hald cope with missing hotplug events from buggy drivers (#135202)
242     - Fix the order of mount options in fstab-sync (#136191)
243     - Allow x86 legacy floppy drives in default policy (#133777)
244     - Fix fstab-sync crashing without any options and not run from hald (#136214)
245     - man page for fstab-sync references non-existing files (#136026)
246     - Add Russian translations for hal (#135853)
247     - Add Hungarian translations for hal
248    
249     * Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
250     - Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
251     - Never use the UUID as mount point candidate in the default policy
252     as it is unfriendly (#135907)
253     - Fix a trivial bug in fstab-sync so the syslog messages actually expose
254     the device name instead of just the word foo
255    
256     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
257     - Fix issue with fstab-sync not cleaning /etc/fstab on startup
258    
259     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
260     - Update to upstream stable version 0.4.0
261     - Remove patch for libhal shutdown since that is now upstream
262     - fstab-sync: man page, adds comment in /etc/fstab pointing to man page
263    
264     * Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
265     - Fix a bug so libhal actually invoke callback functions when needed
266    
267     * Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
268     - Use "user" mount flag for now until "pamconsole" flag gets into mount
269    
270     * Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
271     - Update to upstream CVS version
272     - Enable libselinux again
273    
274     * Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
275     - Update to upstream CVS version
276    
277     * Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
278     - Update to upstream CVS release
279     - Include libhal-storage library
280     - Should close bug #132876
281    
282     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
283     - Rebuilt
284    
285     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
286     - Rebuilt
287    
288     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
289     - Temporarily disable explicit requirement for libselinux
290    
291     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
292     - Update to upstream release 0.2.98.
293     - Use --with-pid-file so we don't depend on /etc/redhat-release
294    
295     * Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
296     - Update to upstream CVS HEAD
297    
298     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
299     - Add UID for haldaemon user
300    
301     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
302     - Rebuilt with a newer snapshot.
303    
304     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
305     - Rebuilt
306    
307     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
308     - Rebuilt
309     - Closes RH Bug #130971
310    
311     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
312     - Update to upstream CVS HEAD.
313     - Should close RH Bug #130588
314    
315     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
316     - Rebuilt
317    
318     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
319     - Apply a patch so hald doesn't hang on startup.
320    
321     * Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
322     - Update to upstream CVS HEAD
323     - Remove symlinking of fstab-sync from specfile since this is now being
324     done in the package
325    
326     * Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
327     - change the %%define names to not use "-"
328    
329     * Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
330     - Update to upstream CVS HEAD
331     - Remove suid patch as it is fixed upstream
332     - Fix some dependency issues (RH Bug #130202)
333    
334     * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
335     - Add stopgap patch to remove suid from mount flags (RH Bug #130290)
336    
337     * Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
338     - update to upstream release 0.2.97
339     - use kudzu option in fstab-sync since updfstab is now disabled
340    
341     * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
342     - fixed Requires lines to use %{} instead of ${}
343     - made dbus related requires lines use the = condition instead of =<
344     because the dbus API is still in flux
345    
346     * Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
347     - Update to upstream release 0.2.96
348     - Symlink fstab-sync into /etc/hal/device.d on install
349    
350     * Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
351     - Base hal package no longer requires python
352    
353     * Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
354     - Update to CVS head
355     - Remove Dan's patches as they were commited to CVS
356    
357     * Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
358     - Fix netlink sockets pointer arithmetic bug
359    
360     * Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
361     - Update to new CVS version as of 7-12-2004
362    
363     * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
364     - take out fstab-update.sh from install
365     - add to rawhide
366    
367     * Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
368     - update to CVS head as of 6-11-2004 which contains dcbw's
369     network link status fix
370    
371     * Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
372     - added dependency on udev
373    
374     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
375     - update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
376     and wireless network devices.
377    
378     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
379     - added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
380     the file system mounting script in /etc/hal/device.d
381    
382     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
383     - added the %{_sysconfigdir}/hal directory tree to %files
384    
385     * Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
386     - update to CVS head as of 5-11-2004
387    
388     * Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
389     - Install hal.dev from /etc/dev.d/default/
390    
391     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
392     - upstream update
393    
394     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
395     - initial checkin to package repository
396     - added dependency to the dbus-python package
397     - added %{_libexecdir}/hal.dev to teh %files section

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed