/[smeserver]/rpms/hal/sme7/hal.spec
ViewVC logotype

Annotation of /rpms/hal/sme7/hal.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Mar 22 16:16:48 2012 UTC (12 years, 2 months ago) by slords
Branch: MAIN
Changes since 1.1: +4 -1 lines
* Thu Mar 22 2012 - Shad L. Lords <slords@mail.com> 0.4.2-9.sme
- Bump version so usb plug-n-play works [SME: 6555]

1 slords 1.1 %define expat_version 1.95.5
2     %define glib2_version 2.2.0
3     %define dbus_version 0.22
4     %define pygtk2 2.0.0
5     %define gnome_python2 2.0.0
6     %define libselinux_version 1.17.14-1
7     %define udev_version 034-2
8     %define util_linux_version 2.12a-16
9     %define libcap_version 1.10-20
10     %define doxygen_version 1.3.9.1-1
11    
12     %define hal_user_uid 68
13    
14     Summary: Hardware Abstraction Layer
15     Name: hal
16     Version: 0.4.2
17 slords 1.2 Release: 9%{?dist}
18 slords 1.1 URL: http://www.freedesktop.org/Software/hal
19     Source0: %{name}-%{version}.tar.gz
20     Patch0: hal-null-block-device.patch
21     Patch1: hal-osspec.patch
22     Patch2: hal-sync-callouts.patch
23     Patch3: hal-hotplug-input-quiet.patch
24     Patch4: hal-0.4.2-device-info-parse.patch
25     Patch5: hal-0.4.2-skip-sysfs-config.patch
26     Patch6: hal-0.4.2-is-mounted-crasher.patch
27     Patch7: hal-0.4.2-dont-delete-slash.patch
28     Patch8: hal-0.4.2-plug-hotplug-memleak.patch
29     Patch9: hal-0.4.2-larger-mtab-buffer.patch
30     Patch10: hal-0.4.2-size_t.patch
31     License: AFL/GPL
32     Group: System Environment/Libraries
33     BuildRoot: %{_tmppath}/%{name}-root
34     PreReq: chkconfig
35     BuildRequires: expat-devel >= %{expat_version}
36     BuildRequires: glib2-devel >= %{glib2_version}
37     BuildRequires: dbus-devel = %{dbus_version}
38     BuildRequires: python-devel
39     BuildRequires: hwdata
40     BuildRequires: libselinux-devel >= %{libselinux_version}
41     BuildRequires: libcap-devel >= %{libcap_version}
42     BuildRequires: doxygen >= %{doxygen_version}
43     Requires: dbus = %{dbus_version}
44     Requires: dbus-glib = %{dbus_version}
45     Requires: glib2 >= %{glib2_version}
46     Requires: udev >= %{udev_version}
47     Requires: util-linux >= %{util_linux_version}
48     Requires: libselinux >= %{libselinux_version}
49    
50     %description
51    
52     HAL is daemon for collection and maintaining information from several
53     sources about the hardware on the system. It provdes a live device
54     list through D-BUS.
55    
56     %package gnome
57     Summary: GNOME based device manager for HAL
58     Group: Development/Libraries
59     Requires: %name = %{version}-%{release}
60     Requires: dbus-python >= %{dbus_version}
61     Requires: pygtk2 >= %{pygtk2}
62     Requires: gnome-python2 >= %{gnome_python2}
63    
64     %description gnome
65     GNOME program for displaying the devices detected by HAL
66    
67    
68     %package devel
69     Summary: Libraries and headers for HAL
70     Group: Development/Libraries
71     Requires: %name = %{version}-%{release}
72     Requires: dbus-devel = %{dbus_version}
73    
74     %description devel
75    
76     Headers, static libraries and API docs for HAL.
77    
78     %prep
79     %setup -q
80     %patch0 -p1 -b .null-block-device
81     %patch1 -p1 -b .osspec
82     %patch2 -p1 -b .sync-callouts
83     %patch3 -p1 -b .quiet
84     %patch4 -p1 -b .fdi-typo
85     %patch5 -p1 -b .dont-read-config
86     %patch6 -p1 -b .is-mounted-crasher
87     %patch7 -p1 -b .dont-delete-slash
88     %patch8 -p1 -b .plug-hotplug-memleak.patch
89     %patch9 -p1 -b .larger-mtab-buffer
90     %patch10 -p1 -b .sizet
91    
92     %build
93    
94     %configure --disable-docbook-docs --enable-fstab-sync --enable-hotplug-map --with-init-scripts=redhat --with-pid-file=/var/run/haldaemon.pid --enable-selinux --enable-pcmcia-support
95     make
96    
97     %install
98     make install DESTDIR=$RPM_BUILD_ROOT
99    
100     rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
101    
102     %clean
103     rm -rf %{buildroot}
104    
105     %pre
106     # Add the "haldaemon" user
107     /usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
108     -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
109    
110     %post
111     /sbin/ldconfig
112     /sbin/chkconfig --add haldaemon
113    
114     %preun
115     if [ $1 = 0 ]; then
116     service haldaemon stop > /dev/null 2>&1
117     /sbin/chkconfig --del haldaemon
118     fi
119    
120     %postun
121     /sbin/ldconfig
122     if [ "$1" -ge "1" ]; then
123     service haldaemon condrestart > /dev/null 2>&1
124     fi
125    
126     %files
127     %defattr(-,root,root)
128     #%doc COPYING ChangeLog NEWS
129    
130     %dir %{_sysconfdir}/dbus-1/system.d
131    
132     %config %{_sysconfdir}/dbus-1/system.d/hal.conf
133     %config %{_sysconfdir}/rc.d/init.d/*
134    
135     %dir %{_sysconfdir}/hal
136     %dir %{_sysconfdir}/hal/capability.d
137     %dir %{_sysconfdir}/hal/device.d
138     %dir %{_sysconfdir}/hal/property.d
139    
140     %config %{_sysconfdir}/hal/hald.conf
141    
142     %{_sbindir}/hald
143     %{_sbindir}/fstab-sync
144    
145     %{_bindir}/lshal
146     %{_bindir}/hal-get-property
147     %{_bindir}/hal-set-property
148    
149     %{_libdir}/*hal*.so.*
150    
151     %{_libexecdir}/hal.hotplug
152     /etc/hotplug.d/default/20-hal.hotplug
153    
154     %{_libexecdir}/hal.dev
155     %{_sysconfdir}/dev.d/default/10-hal.dev
156    
157     %{_libexecdir}/hal-hotplug-map
158    
159     %dir %{_datadir}/hal
160     %dir %{_datadir}/hal/fdi
161     %{_datadir}/hal/fdi/*
162     %{_datadir}/locale/*
163     %{_datadir}/man/*
164     %{_datadir}/doc/hal-%{version}/conf/*
165    
166     %{_sysconfdir}/hal/device.d/40-hal-hotplug-map.hal
167     # allow users to make this symlink point to /bin/false cf. the fstab-sync
168     # manpage
169     %config(noreplace) %{_sysconfdir}/hal/device.d/50-fstab-sync.hal
170    
171     %files devel
172     %defattr(-,root,root)
173    
174     %{_libdir}/lib*.a
175     %{_libdir}/lib*.so
176     %{_libdir}/pkgconfig/*
177     %{_includedir}/*
178     %{_datadir}/doc/hal-%{version}/api/*
179     # TODO: include hal-spec
180    
181    
182    
183     %files gnome
184     %defattr(-,root,root)
185    
186     %dir %{_datadir}/hal/device-manager
187     %{_datadir}/hal/device-manager/*
188     %{_bindir}/hal-device-manager
189    
190    
191     %changelog
192 slords 1.2 * Thu Mar 22 2012 - Shad L. Lords <slords@mail.com> 0.4.2-9.sme
193     - Bump version so usb plug-n-play works [SME: 6555]
194    
195 slords 1.1 * Thu Apr 10 2008 - David Zeuthen <davidz@redhat.com> - 0.4.2-8.EL4
196     - Make fstab-sync properly handle the ENOSPC case
197     - Resolves: #250419
198    
199     * Thu Aug 02 2007 - David Zeuthen <davidz@redhat.com> - 0.4.2-7.EL4
200     - Fix memory leak when unplugging/replugging a USB device
201     - Resolves: #247734
202     - Use a larger line buffer for the /etc/mtab file (#238501)
203    
204     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-6.EL4
205     - Fix wrong patch being used for (Bug #172835)
206    
207     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-5.EL4
208     - Add patch to fix the ide-drives.fdi parsing, missing closing element
209     (Bug #164631)
210     - Patch by Jeff Layton <jlayton@redhat.com> to avoid poking the "config"
211     file in sysfs sub-dirs, as it can cause problems for some devices
212     (Bug #172835)
213     - Avoid fstab-sync crashing when checking whether a partition is mounted
214     (comparing an uninitialised variable) (Bug #175523)
215     - Add patch by Keiichi Mori <kmori@redhat.com> to not delete the '/' entry
216     from /etc/fstab (strcmp of a 0-len string always succeeds)
217     (Bug #192410)
218    
219     * Fri May 05 2006 John (J5) Palmieri <johnp@redhat.com> - 0.4.2-4.EL4
220     - Add patch to stop HAL complaining about DEVPATH not being set on
221     kernels that do not support it (Bug #169387)
222    
223     * Wed Dec 21 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-3.EL4
224     - Rebuild with gcc-3.4.5-2
225    
226     * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-2.EL4
227     - Add patch to fix segfault in fstab-sync when ejecting CD (Bug 163772)
228     - Add patch to fix hotplug issues with USB cds (Bug 164777)
229     - Add patch to run callouts synchronously (Bug 167811)
230    
231     * Wed Dec 01 2004 David Zeuthen <davidz@redhat,com> 0.4.2-1.EL4
232     - Upstream release 0.4.2
233     - Drop all patches as they are committed upstream
234     - Fixes for #140557, #139227, #139962, #139600, #136971
235     - Workaround for #138148 through blacklisting certain IDE optical drives
236    
237     * Tue Oct 19 2004 David Zeuthen <davidz@redhat,com> 0.4.0-5
238     - Make hal work with PCMCIA IDE hotpluggable devices (#133943)
239     - Fixup URL listed from rpm -qi (#136396)
240     - Add Portuguese translations for hal
241     - Fix addition of Russian and Hungarian translations
242    
243     * Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
244     - Make hald cope with missing hotplug events from buggy drivers (#135202)
245     - Fix the order of mount options in fstab-sync (#136191)
246     - Allow x86 legacy floppy drives in default policy (#133777)
247     - Fix fstab-sync crashing without any options and not run from hald (#136214)
248     - man page for fstab-sync references non-existing files (#136026)
249     - Add Russian translations for hal (#135853)
250     - Add Hungarian translations for hal
251    
252     * Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
253     - Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
254     - Never use the UUID as mount point candidate in the default policy
255     as it is unfriendly (#135907)
256     - Fix a trivial bug in fstab-sync so the syslog messages actually expose
257     the device name instead of just the word foo
258    
259     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
260     - Fix issue with fstab-sync not cleaning /etc/fstab on startup
261    
262     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
263     - Update to upstream stable version 0.4.0
264     - Remove patch for libhal shutdown since that is now upstream
265     - fstab-sync: man page, adds comment in /etc/fstab pointing to man page
266    
267     * Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
268     - Fix a bug so libhal actually invoke callback functions when needed
269    
270     * Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
271     - Use "user" mount flag for now until "pamconsole" flag gets into mount
272    
273     * Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
274     - Update to upstream CVS version
275     - Enable libselinux again
276    
277     * Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
278     - Update to upstream CVS version
279    
280     * Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
281     - Update to upstream CVS release
282     - Include libhal-storage library
283     - Should close bug #132876
284    
285     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
286     - Rebuilt
287    
288     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
289     - Rebuilt
290    
291     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
292     - Temporarily disable explicit requirement for libselinux
293    
294     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
295     - Update to upstream release 0.2.98.
296     - Use --with-pid-file so we don't depend on /etc/redhat-release
297    
298     * Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
299     - Update to upstream CVS HEAD
300    
301     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
302     - Add UID for haldaemon user
303    
304     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
305     - Rebuilt with a newer snapshot.
306    
307     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
308     - Rebuilt
309    
310     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
311     - Rebuilt
312     - Closes RH Bug #130971
313    
314     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
315     - Update to upstream CVS HEAD.
316     - Should close RH Bug #130588
317    
318     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
319     - Rebuilt
320    
321     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
322     - Apply a patch so hald doesn't hang on startup.
323    
324     * Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
325     - Update to upstream CVS HEAD
326     - Remove symlinking of fstab-sync from specfile since this is now being
327     done in the package
328    
329     * Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
330     - change the %%define names to not use "-"
331    
332     * Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
333     - Update to upstream CVS HEAD
334     - Remove suid patch as it is fixed upstream
335     - Fix some dependency issues (RH Bug #130202)
336    
337     * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
338     - Add stopgap patch to remove suid from mount flags (RH Bug #130290)
339    
340     * Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
341     - update to upstream release 0.2.97
342     - use kudzu option in fstab-sync since updfstab is now disabled
343    
344     * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
345     - fixed Requires lines to use %{} instead of ${}
346     - made dbus related requires lines use the = condition instead of =<
347     because the dbus API is still in flux
348    
349     * Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
350     - Update to upstream release 0.2.96
351     - Symlink fstab-sync into /etc/hal/device.d on install
352    
353     * Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
354     - Base hal package no longer requires python
355    
356     * Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
357     - Update to CVS head
358     - Remove Dan's patches as they were commited to CVS
359    
360     * Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
361     - Fix netlink sockets pointer arithmetic bug
362    
363     * Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
364     - Update to new CVS version as of 7-12-2004
365    
366     * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
367     - take out fstab-update.sh from install
368     - add to rawhide
369    
370     * Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
371     - update to CVS head as of 6-11-2004 which contains dcbw's
372     network link status fix
373    
374     * Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
375     - added dependency on udev
376    
377     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
378     - update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
379     and wireless network devices.
380    
381     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
382     - added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
383     the file system mounting script in /etc/hal/device.d
384    
385     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
386     - added the %{_sysconfigdir}/hal directory tree to %files
387    
388     * Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
389     - update to CVS head as of 5-11-2004
390    
391     * Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
392     - Install hal.dev from /etc/dev.d/default/
393    
394     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
395     - upstream update
396    
397     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
398     - initial checkin to package repository
399     - added dependency to the dbus-python package
400     - added %{_libexecdir}/hal.dev to teh %files section

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed