/[smeserver]/rpms/hal/sme7/hal.spec
ViewVC logotype

Annotation of /rpms/hal/sme7/hal.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Thu Mar 22 16:29:03 2012 UTC (12 years, 2 months ago) by slords
Branch: MAIN
Changes since 1.2: +1 -0 lines
Add buildreq

1 slords 1.1 %define expat_version 1.95.5
2     %define glib2_version 2.2.0
3     %define dbus_version 0.22
4     %define pygtk2 2.0.0
5     %define gnome_python2 2.0.0
6     %define libselinux_version 1.17.14-1
7     %define udev_version 034-2
8     %define util_linux_version 2.12a-16
9     %define libcap_version 1.10-20
10     %define doxygen_version 1.3.9.1-1
11    
12     %define hal_user_uid 68
13    
14     Summary: Hardware Abstraction Layer
15     Name: hal
16     Version: 0.4.2
17 slords 1.2 Release: 9%{?dist}
18 slords 1.1 URL: http://www.freedesktop.org/Software/hal
19     Source0: %{name}-%{version}.tar.gz
20     Patch0: hal-null-block-device.patch
21     Patch1: hal-osspec.patch
22     Patch2: hal-sync-callouts.patch
23     Patch3: hal-hotplug-input-quiet.patch
24     Patch4: hal-0.4.2-device-info-parse.patch
25     Patch5: hal-0.4.2-skip-sysfs-config.patch
26     Patch6: hal-0.4.2-is-mounted-crasher.patch
27     Patch7: hal-0.4.2-dont-delete-slash.patch
28     Patch8: hal-0.4.2-plug-hotplug-memleak.patch
29     Patch9: hal-0.4.2-larger-mtab-buffer.patch
30     Patch10: hal-0.4.2-size_t.patch
31     License: AFL/GPL
32     Group: System Environment/Libraries
33     BuildRoot: %{_tmppath}/%{name}-root
34     PreReq: chkconfig
35     BuildRequires: expat-devel >= %{expat_version}
36     BuildRequires: glib2-devel >= %{glib2_version}
37     BuildRequires: dbus-devel = %{dbus_version}
38     BuildRequires: python-devel
39     BuildRequires: hwdata
40     BuildRequires: libselinux-devel >= %{libselinux_version}
41     BuildRequires: libcap-devel >= %{libcap_version}
42     BuildRequires: doxygen >= %{doxygen_version}
43 slords 1.3 BuildRequires: perl(XML::Parser)
44 slords 1.1 Requires: dbus = %{dbus_version}
45     Requires: dbus-glib = %{dbus_version}
46     Requires: glib2 >= %{glib2_version}
47     Requires: udev >= %{udev_version}
48     Requires: util-linux >= %{util_linux_version}
49     Requires: libselinux >= %{libselinux_version}
50    
51     %description
52    
53     HAL is daemon for collection and maintaining information from several
54     sources about the hardware on the system. It provdes a live device
55     list through D-BUS.
56    
57     %package gnome
58     Summary: GNOME based device manager for HAL
59     Group: Development/Libraries
60     Requires: %name = %{version}-%{release}
61     Requires: dbus-python >= %{dbus_version}
62     Requires: pygtk2 >= %{pygtk2}
63     Requires: gnome-python2 >= %{gnome_python2}
64    
65     %description gnome
66     GNOME program for displaying the devices detected by HAL
67    
68    
69     %package devel
70     Summary: Libraries and headers for HAL
71     Group: Development/Libraries
72     Requires: %name = %{version}-%{release}
73     Requires: dbus-devel = %{dbus_version}
74    
75     %description devel
76    
77     Headers, static libraries and API docs for HAL.
78    
79     %prep
80     %setup -q
81     %patch0 -p1 -b .null-block-device
82     %patch1 -p1 -b .osspec
83     %patch2 -p1 -b .sync-callouts
84     %patch3 -p1 -b .quiet
85     %patch4 -p1 -b .fdi-typo
86     %patch5 -p1 -b .dont-read-config
87     %patch6 -p1 -b .is-mounted-crasher
88     %patch7 -p1 -b .dont-delete-slash
89     %patch8 -p1 -b .plug-hotplug-memleak.patch
90     %patch9 -p1 -b .larger-mtab-buffer
91     %patch10 -p1 -b .sizet
92    
93     %build
94    
95     %configure --disable-docbook-docs --enable-fstab-sync --enable-hotplug-map --with-init-scripts=redhat --with-pid-file=/var/run/haldaemon.pid --enable-selinux --enable-pcmcia-support
96     make
97    
98     %install
99     make install DESTDIR=$RPM_BUILD_ROOT
100    
101     rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
102    
103     %clean
104     rm -rf %{buildroot}
105    
106     %pre
107     # Add the "haldaemon" user
108     /usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
109     -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
110    
111     %post
112     /sbin/ldconfig
113     /sbin/chkconfig --add haldaemon
114    
115     %preun
116     if [ $1 = 0 ]; then
117     service haldaemon stop > /dev/null 2>&1
118     /sbin/chkconfig --del haldaemon
119     fi
120    
121     %postun
122     /sbin/ldconfig
123     if [ "$1" -ge "1" ]; then
124     service haldaemon condrestart > /dev/null 2>&1
125     fi
126    
127     %files
128     %defattr(-,root,root)
129     #%doc COPYING ChangeLog NEWS
130    
131     %dir %{_sysconfdir}/dbus-1/system.d
132    
133     %config %{_sysconfdir}/dbus-1/system.d/hal.conf
134     %config %{_sysconfdir}/rc.d/init.d/*
135    
136     %dir %{_sysconfdir}/hal
137     %dir %{_sysconfdir}/hal/capability.d
138     %dir %{_sysconfdir}/hal/device.d
139     %dir %{_sysconfdir}/hal/property.d
140    
141     %config %{_sysconfdir}/hal/hald.conf
142    
143     %{_sbindir}/hald
144     %{_sbindir}/fstab-sync
145    
146     %{_bindir}/lshal
147     %{_bindir}/hal-get-property
148     %{_bindir}/hal-set-property
149    
150     %{_libdir}/*hal*.so.*
151    
152     %{_libexecdir}/hal.hotplug
153     /etc/hotplug.d/default/20-hal.hotplug
154    
155     %{_libexecdir}/hal.dev
156     %{_sysconfdir}/dev.d/default/10-hal.dev
157    
158     %{_libexecdir}/hal-hotplug-map
159    
160     %dir %{_datadir}/hal
161     %dir %{_datadir}/hal/fdi
162     %{_datadir}/hal/fdi/*
163     %{_datadir}/locale/*
164     %{_datadir}/man/*
165     %{_datadir}/doc/hal-%{version}/conf/*
166    
167     %{_sysconfdir}/hal/device.d/40-hal-hotplug-map.hal
168     # allow users to make this symlink point to /bin/false cf. the fstab-sync
169     # manpage
170     %config(noreplace) %{_sysconfdir}/hal/device.d/50-fstab-sync.hal
171    
172     %files devel
173     %defattr(-,root,root)
174    
175     %{_libdir}/lib*.a
176     %{_libdir}/lib*.so
177     %{_libdir}/pkgconfig/*
178     %{_includedir}/*
179     %{_datadir}/doc/hal-%{version}/api/*
180     # TODO: include hal-spec
181    
182    
183    
184     %files gnome
185     %defattr(-,root,root)
186    
187     %dir %{_datadir}/hal/device-manager
188     %{_datadir}/hal/device-manager/*
189     %{_bindir}/hal-device-manager
190    
191    
192     %changelog
193 slords 1.2 * Thu Mar 22 2012 - Shad L. Lords <slords@mail.com> 0.4.2-9.sme
194     - Bump version so usb plug-n-play works [SME: 6555]
195    
196 slords 1.1 * Thu Apr 10 2008 - David Zeuthen <davidz@redhat.com> - 0.4.2-8.EL4
197     - Make fstab-sync properly handle the ENOSPC case
198     - Resolves: #250419
199    
200     * Thu Aug 02 2007 - David Zeuthen <davidz@redhat.com> - 0.4.2-7.EL4
201     - Fix memory leak when unplugging/replugging a USB device
202     - Resolves: #247734
203     - Use a larger line buffer for the /etc/mtab file (#238501)
204    
205     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-6.EL4
206     - Fix wrong patch being used for (Bug #172835)
207    
208     * Wed Jan 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4.2-5.EL4
209     - Add patch to fix the ide-drives.fdi parsing, missing closing element
210     (Bug #164631)
211     - Patch by Jeff Layton <jlayton@redhat.com> to avoid poking the "config"
212     file in sysfs sub-dirs, as it can cause problems for some devices
213     (Bug #172835)
214     - Avoid fstab-sync crashing when checking whether a partition is mounted
215     (comparing an uninitialised variable) (Bug #175523)
216     - Add patch by Keiichi Mori <kmori@redhat.com> to not delete the '/' entry
217     from /etc/fstab (strcmp of a 0-len string always succeeds)
218     (Bug #192410)
219    
220     * Fri May 05 2006 John (J5) Palmieri <johnp@redhat.com> - 0.4.2-4.EL4
221     - Add patch to stop HAL complaining about DEVPATH not being set on
222     kernels that do not support it (Bug #169387)
223    
224     * Wed Dec 21 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-3.EL4
225     - Rebuild with gcc-3.4.5-2
226    
227     * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.2-2.EL4
228     - Add patch to fix segfault in fstab-sync when ejecting CD (Bug 163772)
229     - Add patch to fix hotplug issues with USB cds (Bug 164777)
230     - Add patch to run callouts synchronously (Bug 167811)
231    
232     * Wed Dec 01 2004 David Zeuthen <davidz@redhat,com> 0.4.2-1.EL4
233     - Upstream release 0.4.2
234     - Drop all patches as they are committed upstream
235     - Fixes for #140557, #139227, #139962, #139600, #136971
236     - Workaround for #138148 through blacklisting certain IDE optical drives
237    
238     * Tue Oct 19 2004 David Zeuthen <davidz@redhat,com> 0.4.0-5
239     - Make hal work with PCMCIA IDE hotpluggable devices (#133943)
240     - Fixup URL listed from rpm -qi (#136396)
241     - Add Portuguese translations for hal
242     - Fix addition of Russian and Hungarian translations
243    
244     * Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
245     - Make hald cope with missing hotplug events from buggy drivers (#135202)
246     - Fix the order of mount options in fstab-sync (#136191)
247     - Allow x86 legacy floppy drives in default policy (#133777)
248     - Fix fstab-sync crashing without any options and not run from hald (#136214)
249     - man page for fstab-sync references non-existing files (#136026)
250     - Add Russian translations for hal (#135853)
251     - Add Hungarian translations for hal
252    
253     * Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
254     - Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
255     - Never use the UUID as mount point candidate in the default policy
256     as it is unfriendly (#135907)
257     - Fix a trivial bug in fstab-sync so the syslog messages actually expose
258     the device name instead of just the word foo
259    
260     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
261     - Fix issue with fstab-sync not cleaning /etc/fstab on startup
262    
263     * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
264     - Update to upstream stable version 0.4.0
265     - Remove patch for libhal shutdown since that is now upstream
266     - fstab-sync: man page, adds comment in /etc/fstab pointing to man page
267    
268     * Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
269     - Fix a bug so libhal actually invoke callback functions when needed
270    
271     * Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
272     - Use "user" mount flag for now until "pamconsole" flag gets into mount
273    
274     * Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
275     - Update to upstream CVS version
276     - Enable libselinux again
277    
278     * Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
279     - Update to upstream CVS version
280    
281     * Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
282     - Update to upstream CVS release
283     - Include libhal-storage library
284     - Should close bug #132876
285    
286     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
287     - Rebuilt
288    
289     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
290     - Rebuilt
291    
292     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
293     - Temporarily disable explicit requirement for libselinux
294    
295     * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
296     - Update to upstream release 0.2.98.
297     - Use --with-pid-file so we don't depend on /etc/redhat-release
298    
299     * Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
300     - Update to upstream CVS HEAD
301    
302     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
303     - Add UID for haldaemon user
304    
305     * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
306     - Rebuilt with a newer snapshot.
307    
308     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
309     - Rebuilt
310    
311     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
312     - Rebuilt
313     - Closes RH Bug #130971
314    
315     * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
316     - Update to upstream CVS HEAD.
317     - Should close RH Bug #130588
318    
319     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
320     - Rebuilt
321    
322     * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
323     - Apply a patch so hald doesn't hang on startup.
324    
325     * Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
326     - Update to upstream CVS HEAD
327     - Remove symlinking of fstab-sync from specfile since this is now being
328     done in the package
329    
330     * Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
331     - change the %%define names to not use "-"
332    
333     * Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
334     - Update to upstream CVS HEAD
335     - Remove suid patch as it is fixed upstream
336     - Fix some dependency issues (RH Bug #130202)
337    
338     * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
339     - Add stopgap patch to remove suid from mount flags (RH Bug #130290)
340    
341     * Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
342     - update to upstream release 0.2.97
343     - use kudzu option in fstab-sync since updfstab is now disabled
344    
345     * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
346     - fixed Requires lines to use %{} instead of ${}
347     - made dbus related requires lines use the = condition instead of =<
348     because the dbus API is still in flux
349    
350     * Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
351     - Update to upstream release 0.2.96
352     - Symlink fstab-sync into /etc/hal/device.d on install
353    
354     * Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
355     - Base hal package no longer requires python
356    
357     * Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
358     - Update to CVS head
359     - Remove Dan's patches as they were commited to CVS
360    
361     * Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
362     - Fix netlink sockets pointer arithmetic bug
363    
364     * Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
365     - Update to new CVS version as of 7-12-2004
366    
367     * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
368     - take out fstab-update.sh from install
369     - add to rawhide
370    
371     * Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
372     - update to CVS head as of 6-11-2004 which contains dcbw's
373     network link status fix
374    
375     * Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
376     - added dependency on udev
377    
378     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
379     - update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
380     and wireless network devices.
381    
382     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
383     - added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
384     the file system mounting script in /etc/hal/device.d
385    
386     * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
387     - added the %{_sysconfigdir}/hal directory tree to %files
388    
389     * Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
390     - update to CVS head as of 5-11-2004
391    
392     * Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
393     - Install hal.dev from /etc/dev.d/default/
394    
395     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
396     - upstream update
397    
398     * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
399     - initial checkin to package repository
400     - added dependency to the dbus-python package
401     - added %{_libexecdir}/hal.dev to teh %files section

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed