1 |
slords |
1.1 |
Summary: Utility to test a mail message for a header |
2 |
|
|
%define name headermatch |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.0.1 |
5 |
|
|
%define release 3 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Applications/Text |
10 |
|
|
Source0: %{name}.c |
11 |
|
|
Source1: COPYING |
12 |
|
|
BuildRequires: dietlibc |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
14 |
|
|
%description |
15 |
|
|
|
16 |
|
|
The headermatch utility reads a mail message on standard input and indicates |
17 |
|
|
by exit status whether it contains a given mail header text. The header |
18 |
|
|
text can be provided as the first argument. If no argument is given, |
19 |
|
|
then "X-Spam-Flag: YES" is used as the default. |
20 |
|
|
|
21 |
|
|
%changelog |
22 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
23 |
|
|
- Clean up spec so package can be built by koji/plague |
24 |
|
|
|
25 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
26 |
|
|
- Update to new release naming. No functional changes. |
27 |
|
|
- Make Packager generic |
28 |
|
|
|
29 |
|
|
* Thu Nov 09 2006 Charlie Brady <charlieb@budge.apana.org.au> 0.0.1-02 |
30 |
|
|
- Clarify licensing and copyright. |
31 |
|
|
|
32 |
|
|
* Thu Nov 09 2006 Charlie Brady <charlieb@budge.apana.org.au> |
33 |
|
|
- Initial |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -c -T |
37 |
|
|
|
38 |
|
|
%build |
39 |
|
|
diet -Os gcc -o headermatch %{SOURCE0} |
40 |
|
|
|
41 |
|
|
%install |
42 |
|
|
mkdir -p $RPM_BUILD_ROOT/var/qmail/bin |
43 |
|
|
install headermatch $RPM_BUILD_ROOT/var/qmail/bin |
44 |
|
|
cp -a %{SOURCE1} . |
45 |
|
|
|
46 |
|
|
%clean |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
|
49 |
|
|
%files |
50 |
|
|
%defattr(-,root,root) |
51 |
|
|
/var/qmail/bin/* |
52 |
|
|
%doc COPYING |