1 |
# $Id: headermatch.spec,v 1.2 2008/04/09 13:51:49 slords Exp $ |
2 |
|
3 |
Summary: Utility to test a mail message for a header |
4 |
%define name headermatch |
5 |
Name: %{name} |
6 |
%define version 0.0.1 |
7 |
%define release 3 |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: GPL |
11 |
Group: Applications/Text |
12 |
Source0: %{name}.c |
13 |
Source1: COPYING |
14 |
BuildRequires: dietlibc |
15 |
BuildRoot: %{_tmppath}/%{name}-root |
16 |
%description |
17 |
|
18 |
The headermatch utility reads a mail message on standard input and indicates |
19 |
by exit status whether it contains a given mail header text. The header |
20 |
text can be provided as the first argument. If no argument is given, |
21 |
then "X-Spam-Flag: YES" is used as the default. |
22 |
|
23 |
%changelog |
24 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
25 |
- Clean up spec so package can be built by koji/plague |
26 |
|
27 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
28 |
- Update to new release naming. No functional changes. |
29 |
- Make Packager generic |
30 |
|
31 |
* Thu Nov 09 2006 Charlie Brady <charlieb@budge.apana.org.au> 0.0.1-02 |
32 |
- Clarify licensing and copyright. |
33 |
|
34 |
* Thu Nov 09 2006 Charlie Brady <charlieb@budge.apana.org.au> |
35 |
- Initial |
36 |
|
37 |
%prep |
38 |
%setup -c -T |
39 |
|
40 |
%build |
41 |
diet -Os gcc -o headermatch %{SOURCE0} |
42 |
|
43 |
%install |
44 |
mkdir -p $RPM_BUILD_ROOT/var/qmail/bin |
45 |
install headermatch $RPM_BUILD_ROOT/var/qmail/bin |
46 |
cp -a %{SOURCE1} . |
47 |
|
48 |
%clean |
49 |
rm -rf $RPM_BUILD_ROOT |
50 |
|
51 |
%files |
52 |
%defattr(-,root,root) |
53 |
/var/qmail/bin/* |
54 |
%doc COPYING |