1 |
vip-ire |
1.1 |
# $Id: horde.spec,v 1.1 2013/02/14 19:51:29 slords Exp $ |
2 |
|
|
|
3 |
|
|
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
%define phpini /etc/php.ini |
8 |
|
|
|
9 |
|
|
Summary: The common Horde Framework for all Horde modules. |
10 |
|
|
Name: horde |
11 |
|
|
Version: 3.3.11 |
12 |
|
|
Release: 2%{?dist} |
13 |
|
|
License: LGPL |
14 |
|
|
Group: Applications/Horde |
15 |
|
|
Source: ftp://ftp.horde.org/pub/horde/tarballs/horde-%{version}.tar.gz |
16 |
|
|
Patch0: horde-3.3.11-prevent-deprecated-warnings.patch |
17 |
|
|
URL: http://www.horde.org/ |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /tmp/horde-root |
20 |
|
|
AutoReq: no |
21 |
|
|
Requires: php >= 4.3.0 |
22 |
|
|
Requires: httpd >= 2.0.46 |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
The Horde Framework provides a common structure and interface for Horde |
27 |
|
|
applications (such as IMP, a web-based mail program). This RPM is |
28 |
|
|
required for all other Horde module RPMs. |
29 |
|
|
|
30 |
|
|
The Horde Project writes web applications in PHP and releases them under |
31 |
|
|
Open Source licenses. For more information (including help with Horde |
32 |
|
|
and its modules) please visit http://www.horde.org/. |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup -q -n %{name}-%{version} |
36 |
|
|
%patch0 -p1 |
37 |
|
|
%build |
38 |
|
|
|
39 |
|
|
%install |
40 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
41 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
42 |
|
|
#cp -p $RPM_SOURCE_DIR/horde.conf $RPM_BUILD_ROOT%{apachedir}/conf |
43 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde |
44 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde |
45 |
|
|
chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/test.php |
46 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/config |
47 |
|
|
mv hooks.php.dist hooks.php.dist1 |
48 |
|
|
#rm -rf hooks.php.dist |
49 |
|
|
for d in *.dist; do |
50 |
|
|
d0=`basename $d .dist` |
51 |
|
|
if [ ! -f "$d0" ]; then |
52 |
|
|
cp -p $d $d0 |
53 |
|
|
fi |
54 |
|
|
done |
55 |
|
|
mv hooks.php.dist1 hooks.php.dist |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%files |
61 |
|
|
%defattr(-,root,root) |
62 |
|
|
# Apache horde.conf file |
63 |
|
|
#%config %{apachedir}/conf/horde.conf |
64 |
|
|
# Include top level with %dir so not all files are sucked in |
65 |
|
|
%dir %{contentdir}/html/horde |
66 |
|
|
# Include top-level files by hand |
67 |
|
|
%{contentdir}/html/horde/*.php |
68 |
|
|
# Include these dirs so that all files _will_ get sucked in |
69 |
|
|
%{contentdir}/html/horde/admin |
70 |
|
|
%{contentdir}/html/horde/js |
71 |
|
|
%{contentdir}/html/horde/lib |
72 |
|
|
%{contentdir}/html/horde/locale |
73 |
|
|
%{contentdir}/html/horde/po |
74 |
|
|
%{contentdir}/html/horde/scripts |
75 |
|
|
%{contentdir}/html/horde/services |
76 |
|
|
%{contentdir}/html/horde/templates |
77 |
|
|
%{contentdir}/html/horde/themes |
78 |
|
|
%{contentdir}/html/horde/util |
79 |
|
|
%{contentdir}/html/horde/rpc |
80 |
|
|
# Mark documentation files with %doc and %docdir |
81 |
|
|
%doc %{contentdir}/html/horde/COPYING |
82 |
|
|
%doc %{contentdir}/html/horde/README |
83 |
|
|
%docdir %{contentdir}/html/horde/docs |
84 |
|
|
%{contentdir}/html/horde/docs |
85 |
|
|
# Mark configuration files with %config and use secure permissions |
86 |
|
|
# (note that .dist files are considered software; don't mark %config) |
87 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config |
88 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config/registry.d |
89 |
|
|
%defattr(640,root,%{apachegroup}) |
90 |
|
|
%{contentdir}/html/horde/config/.htaccess |
91 |
|
|
%{contentdir}/html/horde/config/*.dist |
92 |
|
|
%{contentdir}/html/horde/config/registry.d/* |
93 |
|
|
%config %{contentdir}/html/horde/config/*.php |
94 |
|
|
%config %{contentdir}/html/horde/config/*.xml |
95 |
|
|
|
96 |
|
|
%changelog |
97 |
|
|
* Mon Sep 19 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 3.3.11-2 |
98 |
|
|
- Fix deprecated warnings when using PHP 5.3+ [SME: 6726] |
99 |
|
|
|
100 |
|
|
* Tue Nov 23 2010 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.11-1 |
101 |
|
|
- Updated to Horde 3.3.11 [SME: 6395] |
102 |
|
|
|
103 |
|
|
* Sun Nov 07 2010 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.10-1 |
104 |
|
|
- Updated to Horde 3.3.10 [SME: 6348] |
105 |
|
|
|
106 |
|
|
* Mon May 10 2010 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.8-1 |
107 |
|
|
- Updated to Horde 3.3.8 [SME: 5937] |
108 |
|
|
|
109 |
|
|
* Sat Feb 13 2010 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.6-1 |
110 |
|
|
- Updated to Horde 3.3.6 [SME: 5774] |
111 |
|
|
|
112 |
|
|
* Tue Oct 13 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.5-1 |
113 |
|
|
- Updated to Horde 3.3.5 [SME: 5509] |
114 |
|
|
|
115 |
|
|
* Sat May 2 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.4-1 |
116 |
|
|
- Updated to Horde 3.3.4 [SME: 5372] |
117 |
|
|
|
118 |
|
|
* Sat Feb 21 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.3-1 |
119 |
|
|
- Updated to Horde 3.3.3 [SME: 4831] |
120 |
|
|
|
121 |
|
|
* Fri Jan 2 2009 John H. Bennett III <bennettj@johnbennettservices.com> 3.3.2-1 |
122 |
|
|
- Updated to Horde 3.3.2 [SME: 4831] |
123 |
|
|
|
124 |
|
|
* Sat Dec 06 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.3-1 |
125 |
|
|
- Updated to Horde 3.3 [SME: 4831] |
126 |
|
|
|
127 |
|
|
* Tue Sep 16 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2.2-1 |
128 |
|
|
- Update to Horde 3.2.2 [SME: 4565] |
129 |
|
|
|
130 |
|
|
* Fri Jun 13 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2.1-1 |
131 |
|
|
- Update to Horde 3.2.1 [SME: 4532] |
132 |
|
|
|
133 |
|
|
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-1 |
134 |
|
|
- initial RPM roll for Horde 3.2 |
135 |
|
|
|