/[smeserver]/rpms/horde/sme7/horde3.spec
ViewVC logotype

Annotation of /rpms/horde/sme7/horde3.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 16:23:57 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: horde-3_1_4-1_el4_sme
Import on branch sme7 of package horde-3.1.4-1.el4.sme.src.rpm

1 slords 1.1 %define apachedir /etc/httpd
2     %define apacheuser www
3     %define apachegroup www
4     %define contentdir /home/httpd
5     %define phpini /etc/php.ini
6    
7     Summary: The common Horde Framework for all Horde modules.
8     Name: horde
9     Version: 3.1.4
10     Release: 1%{?dist}
11     License: LGPL
12     Group: Applications/Horde
13     Source: ftp://ftp.horde.org/pub/horde/tarballs/horde-%{version}.tar.gz
14     URL: http://www.horde.org/
15     BuildArchitectures: noarch
16     BuildRoot: /tmp/horde-root
17     AutoReq: no
18     Requires: php >= 4.3.0
19     Requires: httpd >= 2.0.46
20     Prereq: /usr/bin/perl
21    
22     %description
23     The Horde Framework provides a common structure and interface for Horde
24     applications (such as IMP, a web-based mail program). This RPM is
25     required for all other Horde module RPMs.
26    
27     The Horde Project writes web applications in PHP and releases them under
28     Open Source licenses. For more information (including help with Horde
29     and its modules) please visit http://www.horde.org/.
30    
31     %prep
32     %setup -q -n %{name}-%{version}
33    
34     %build
35    
36     %install
37     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
38     mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf
39     #cp -p $RPM_SOURCE_DIR/horde.conf $RPM_BUILD_ROOT%{apachedir}/conf
40     mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde
41     cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde
42     chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/test.php
43     cd $RPM_BUILD_ROOT%{contentdir}/html/horde/config
44     mv hooks.php.dist hooks.php.dist1
45     #rm -rf hooks.php.dist
46     for d in *.dist; do
47     d0=`basename $d .dist`
48     if [ ! -f "$d0" ]; then
49     cp -p $d $d0
50     fi
51     done
52     mv hooks.php.dist1 hooks.php.dist
53    
54     %clean
55     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
56    
57     %post
58    
59     %postun
60    
61     %files
62     %defattr(-,root,root)
63     # Apache horde.conf file
64     #%config %{apachedir}/conf/horde.conf
65     # Include top level with %dir so not all files are sucked in
66     %dir %{contentdir}/html/horde
67     # Include top-level files by hand
68     %{contentdir}/html/horde/*.php
69     # Include these dirs so that all files _will_ get sucked in
70     %{contentdir}/html/horde/admin
71     %{contentdir}/html/horde/js
72     %{contentdir}/html/horde/lib
73     %{contentdir}/html/horde/locale
74     %{contentdir}/html/horde/po
75     %{contentdir}/html/horde/scripts
76     %{contentdir}/html/horde/services
77     %{contentdir}/html/horde/templates
78     %{contentdir}/html/horde/themes
79     %{contentdir}/html/horde/util
80     # Mark documentation files with %doc and %docdir
81     %doc %{contentdir}/html/horde/COPYING
82     %doc %{contentdir}/html/horde/README
83     %docdir %{contentdir}/html/horde/docs
84     %{contentdir}/html/horde/docs
85     # Mark configuration files with %config and use secure permissions
86     # (note that .dist files are considered software; don't mark %config)
87     %attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config
88     %defattr(640,root,%{apachegroup})
89     %{contentdir}/html/horde/config/.htaccess
90     %{contentdir}/html/horde/config/*.dist
91     %config %{contentdir}/html/horde/config/*.php
92     %config %{contentdir}/html/horde/config/*.xml
93    
94     %changelog
95     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
96     - Clean up spec so package can be built by koji/plague
97    
98     * Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.4-1.el4
99     - Update to horde 3.1.4 [SME: 2782]
100    
101     * Sat Dec 09 2006 Shad L. Lords <slords@mail.com>
102     - Update to new release naming. No functional changes.
103     - Make Packager generic
104    
105     * Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.3-00sme01
106     - Updated to Horde 3.1.3
107    
108     * Mon Aug 28 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.12-01sme01
109     - Updated to Horde 3.0.12
110    
111     * Thu Jul 06 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.11-01sme01
112     - Patch to upgrade Horde 3.0.10 to 3.0.11 maintaing the go.php patch
113     - http://lists.horde.org/archives/announce/2006/000287.html [SME: 1710]
114    
115     * Fri Apr 7 2006 Gordon Rowell <gordonr@gormand.com.au> 3.0.10-01sme01
116     - Rename to 3.0.10, maintaining the go.php patch [SME: 1157]
117    
118     * Wed Apr 05 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.9-02sme02
119     - Patch to upgrade Horde 3.0.9 to 3.0.10 [SME: 1157]
120    
121     * Thu Mar 16 2006 Charlie Brady <charlie_brady@mitel.com> 3.0.9-02sme01
122     - Include go.php from php 3.1 - security patch to fix
123     http://www.securityfocus.com/bid/17117/info [SME: 1061]
124     - Replace deprecated Copyright: header with License: header.
125    
126     * Sun Mar 5 2006 Gordon Rowell <gordonr@gormand.com.au> 3.0.9-01sme02
127     - Rebuild and sign [SME: 940]
128    
129     * Thu Feb 16 2006 John H. Bennett III <bennettj@thebennetthome.com> 3.0.9-01sme01
130     - Updated to Horde 3.09
131    
132     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 3.0.7-02sme01
133     - Adjust Release tag to our standard format [SME: 70]
134    
135     * Tue Nov 22 2005 Greg Swallow
136     - Updated to Horde 3.0.7
137    
138     * Wed Nov 09 2005 Greg Swallow
139     - Updated to Horde 3.0.6
140    
141     * Thu Aug 25 2005 Greg Swallow
142     - Updated to Horde 3.0.5
143    
144     * Thu Mar 31 2005 Greg Swallow <gregswallow@skynetonline.ca>
145     - 3.0.4-1sme01
146     - Update for Horde 3.0.4 on SME7
147    
148     * Tue Aug 10 2004 Shad L. Lords <slords@mail.com>
149     - 2.2.1-2sme01
150     - Update specfile - change apache to httpd in requires
151    
152     * Wed Apr 23 2003 Gordon Rowell <gordon_rowell@mitel.com>
153     - 2.2.1-1es00
154     - Rebuild [gordonr 7694]
155    
156     * Tue Feb 25 2003 Dan Brown <dan@familybrown.org>
157     - 2.2.1-1es
158     - Rebuilt with horde 2.2.1
159    
160     * Mon Jul 1 2002 Dan Brown <dan@familybrown.org>
161     - 2.1 release 1es
162     - changed apache user and web root to comply with SME Server
163     - removed horde.conf file, as this information is in e-smith-horde RPM
164    
165     * Tue Jun 25 2002 Brent J. Nordquist <bjn@horde.org>
166     - 2.1 release 3
167    
168     * Mon Jun 24 2002 Brent J. Nordquist <bjn@horde.org>
169     - 2.1 release 2 (private beta)
170    
171     * Thu Jun 13 2002 Brent J. Nordquist <bjn@horde.org>
172     - 2.1 release 1 (private beta)
173    
174     * Wed Jan 02 2002 Brent J. Nordquist <bjn@horde.org>
175     - 2.0 release 1
176    
177     * Mon Dec 24 2001 Brent J. Nordquist <bjn@horde.org>
178     - 2.0-RC4 release 1
179    
180     * Sat Dec 15 2001 Brent J. Nordquist <bjn@horde.org>
181     - rewritten for Horde 2.0
182    
183     * Wed Nov 14 2001 Brent J. Nordquist <bjn@horde.org>
184     - 1.2.7 release 1rh7
185    
186     * Sat Jul 21 2001 Brent J. Nordquist <bjn@horde.org>
187     - 1.2.6 release 1rh7
188    
189     * Tue Feb 06 2001 Brent J. Nordquist <bjn@horde.org>
190     - 1.2.4 release 1rh7
191    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed