/[smeserver]/rpms/horde/sme7/horde3.spec
ViewVC logotype

Annotation of /rpms/horde/sme7/horde3.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5.2.1 - (hide annotations) (download)
Tue Sep 16 23:38:36 2008 UTC (15 years, 9 months ago) by mrjhb3
Branch: horde-3_1
CVS Tags: horde-3_1_9-1_el4_sme
Changes since 1.5: +5 -2 lines
Please see changelog

1 mrjhb3 1.5.2.1 # $Id: horde3.spec,v 1.5 2008/06/16 01:37:37 mrjhb3 Exp $
2 slords 1.4
3 slords 1.1 %define apachedir /etc/httpd
4     %define apacheuser www
5     %define apachegroup www
6     %define contentdir /home/httpd
7     %define phpini /etc/php.ini
8    
9     Summary: The common Horde Framework for all Horde modules.
10     Name: horde
11 mrjhb3 1.5.2.1 Version: 3.1.9
12 slords 1.1 Release: 1%{?dist}
13     License: LGPL
14     Group: Applications/Horde
15     Source: ftp://ftp.horde.org/pub/horde/tarballs/horde-%{version}.tar.gz
16     URL: http://www.horde.org/
17     BuildArchitectures: noarch
18     BuildRoot: /tmp/horde-root
19     AutoReq: no
20     Requires: php >= 4.3.0
21     Requires: httpd >= 2.0.46
22     Prereq: /usr/bin/perl
23    
24     %description
25     The Horde Framework provides a common structure and interface for Horde
26     applications (such as IMP, a web-based mail program). This RPM is
27     required for all other Horde module RPMs.
28    
29     The Horde Project writes web applications in PHP and releases them under
30     Open Source licenses. For more information (including help with Horde
31     and its modules) please visit http://www.horde.org/.
32    
33     %prep
34     %setup -q -n %{name}-%{version}
35    
36     %build
37    
38     %install
39     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
40     mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf
41     #cp -p $RPM_SOURCE_DIR/horde.conf $RPM_BUILD_ROOT%{apachedir}/conf
42     mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde
43     cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde
44     chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/test.php
45     cd $RPM_BUILD_ROOT%{contentdir}/html/horde/config
46     mv hooks.php.dist hooks.php.dist1
47     #rm -rf hooks.php.dist
48     for d in *.dist; do
49     d0=`basename $d .dist`
50     if [ ! -f "$d0" ]; then
51     cp -p $d $d0
52     fi
53     done
54     mv hooks.php.dist1 hooks.php.dist
55    
56     %clean
57     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
58    
59     %post
60    
61     %postun
62    
63     %files
64     %defattr(-,root,root)
65     # Apache horde.conf file
66     #%config %{apachedir}/conf/horde.conf
67     # Include top level with %dir so not all files are sucked in
68     %dir %{contentdir}/html/horde
69     # Include top-level files by hand
70     %{contentdir}/html/horde/*.php
71     # Include these dirs so that all files _will_ get sucked in
72     %{contentdir}/html/horde/admin
73     %{contentdir}/html/horde/js
74     %{contentdir}/html/horde/lib
75     %{contentdir}/html/horde/locale
76     %{contentdir}/html/horde/po
77     %{contentdir}/html/horde/scripts
78     %{contentdir}/html/horde/services
79     %{contentdir}/html/horde/templates
80     %{contentdir}/html/horde/themes
81     %{contentdir}/html/horde/util
82     # Mark documentation files with %doc and %docdir
83     %doc %{contentdir}/html/horde/COPYING
84     %doc %{contentdir}/html/horde/README
85     %docdir %{contentdir}/html/horde/docs
86     %{contentdir}/html/horde/docs
87     # Mark configuration files with %config and use secure permissions
88     # (note that .dist files are considered software; don't mark %config)
89     %attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config
90     %defattr(640,root,%{apachegroup})
91     %{contentdir}/html/horde/config/.htaccess
92     %{contentdir}/html/horde/config/*.dist
93     %config %{contentdir}/html/horde/config/*.php
94     %config %{contentdir}/html/horde/config/*.xml
95    
96     %changelog
97 mrjhb3 1.5.2.1 * Tue Sep 16 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.9-1
98     - Update to horde 3.1.9 [SME: 4566]
99    
100 mrjhb3 1.5 * Sun Jun 15 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.8-1
101     - Update to horde 3.1.8 [SME: 4408]
102    
103 slords 1.3 * Tue Mar 25 2008 Shad L. Lords <slords@mail.com> 3.1.7-1
104     - Update to horde 3.1.7 [SME: 4092]
105    
106 slords 1.2 * Tue Nov 13 2007 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.5-1
107     - Update to horde 3.1.5 [SME: 3568]
108    
109 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
110     - Clean up spec so package can be built by koji/plague
111    
112     * Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.4-1.el4
113     - Update to horde 3.1.4 [SME: 2782]
114    
115     * Sat Dec 09 2006 Shad L. Lords <slords@mail.com>
116     - Update to new release naming. No functional changes.
117     - Make Packager generic
118    
119     * Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.1.3-00sme01
120     - Updated to Horde 3.1.3
121    
122     * Mon Aug 28 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.12-01sme01
123     - Updated to Horde 3.0.12
124    
125     * Thu Jul 06 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.11-01sme01
126     - Patch to upgrade Horde 3.0.10 to 3.0.11 maintaing the go.php patch
127     - http://lists.horde.org/archives/announce/2006/000287.html [SME: 1710]
128    
129     * Fri Apr 7 2006 Gordon Rowell <gordonr@gormand.com.au> 3.0.10-01sme01
130     - Rename to 3.0.10, maintaining the go.php patch [SME: 1157]
131    
132     * Wed Apr 05 2006 John H. Bennett III <bennettj@johnbennettservices.com> 3.0.9-02sme02
133     - Patch to upgrade Horde 3.0.9 to 3.0.10 [SME: 1157]
134    
135     * Thu Mar 16 2006 Charlie Brady <charlie_brady@mitel.com> 3.0.9-02sme01
136     - Include go.php from php 3.1 - security patch to fix
137     http://www.securityfocus.com/bid/17117/info [SME: 1061]
138     - Replace deprecated Copyright: header with License: header.
139    
140     * Sun Mar 5 2006 Gordon Rowell <gordonr@gormand.com.au> 3.0.9-01sme02
141     - Rebuild and sign [SME: 940]
142    
143     * Thu Feb 16 2006 John H. Bennett III <bennettj@thebennetthome.com> 3.0.9-01sme01
144     - Updated to Horde 3.09
145    
146     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 3.0.7-02sme01
147     - Adjust Release tag to our standard format [SME: 70]
148    
149     * Tue Nov 22 2005 Greg Swallow
150     - Updated to Horde 3.0.7
151    
152     * Wed Nov 09 2005 Greg Swallow
153     - Updated to Horde 3.0.6
154    
155     * Thu Aug 25 2005 Greg Swallow
156     - Updated to Horde 3.0.5
157    
158     * Thu Mar 31 2005 Greg Swallow <gregswallow@skynetonline.ca>
159     - 3.0.4-1sme01
160     - Update for Horde 3.0.4 on SME7
161    
162     * Tue Aug 10 2004 Shad L. Lords <slords@mail.com>
163     - 2.2.1-2sme01
164     - Update specfile - change apache to httpd in requires
165    
166     * Wed Apr 23 2003 Gordon Rowell <gordon_rowell@mitel.com>
167     - 2.2.1-1es00
168     - Rebuild [gordonr 7694]
169    
170     * Tue Feb 25 2003 Dan Brown <dan@familybrown.org>
171     - 2.2.1-1es
172     - Rebuilt with horde 2.2.1
173    
174     * Mon Jul 1 2002 Dan Brown <dan@familybrown.org>
175     - 2.1 release 1es
176     - changed apache user and web root to comply with SME Server
177     - removed horde.conf file, as this information is in e-smith-horde RPM
178    
179     * Tue Jun 25 2002 Brent J. Nordquist <bjn@horde.org>
180     - 2.1 release 3
181    
182     * Mon Jun 24 2002 Brent J. Nordquist <bjn@horde.org>
183     - 2.1 release 2 (private beta)
184    
185     * Thu Jun 13 2002 Brent J. Nordquist <bjn@horde.org>
186     - 2.1 release 1 (private beta)
187    
188     * Wed Jan 02 2002 Brent J. Nordquist <bjn@horde.org>
189     - 2.0 release 1
190    
191     * Mon Dec 24 2001 Brent J. Nordquist <bjn@horde.org>
192     - 2.0-RC4 release 1
193    
194     * Sat Dec 15 2001 Brent J. Nordquist <bjn@horde.org>
195     - rewritten for Horde 2.0
196    
197     * Wed Nov 14 2001 Brent J. Nordquist <bjn@horde.org>
198     - 1.2.7 release 1rh7
199    
200     * Sat Jul 21 2001 Brent J. Nordquist <bjn@horde.org>
201     - 1.2.6 release 1rh7
202    
203     * Tue Feb 06 2001 Brent J. Nordquist <bjn@horde.org>
204     - 1.2.4 release 1rh7
205    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed