/[smeserver]/rpms/horde/sme8/horde.spec
ViewVC logotype

Annotation of /rpms/horde/sme8/horde.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Mon Oct 13 16:06:17 2008 UTC (15 years, 7 months ago) by slords
Branch: MAIN
CVS Tags: horde-3_2_2-1_el5_sme
Changes since 1.2: +4 -2 lines
Update sme8

1 slords 1.3 # $Id: horde.spec,v 1.3 2008/09/16 23:24:30 mrjhb3 Exp $
2 slords 1.1
3     %define apachedir /etc/httpd
4     %define apacheuser www
5     %define apachegroup www
6     %define contentdir /home/httpd
7     %define phpini /etc/php.ini
8    
9     Summary: The common Horde Framework for all Horde modules.
10     Name: horde
11 slords 1.3 Version: 3.2.2
12 slords 1.1 Release: 1%{?dist}
13     License: LGPL
14     Group: Applications/Horde
15     Source: ftp://ftp.horde.org/pub/horde/tarballs/horde-%{version}.tar.gz
16     URL: http://www.horde.org/
17     BuildArchitectures: noarch
18     BuildRoot: /tmp/horde-root
19     AutoReq: no
20     Requires: php >= 4.3.0
21     Requires: httpd >= 2.0.46
22     Prereq: /usr/bin/perl
23    
24     %description
25     The Horde Framework provides a common structure and interface for Horde
26     applications (such as IMP, a web-based mail program). This RPM is
27     required for all other Horde module RPMs.
28    
29     The Horde Project writes web applications in PHP and releases them under
30     Open Source licenses. For more information (including help with Horde
31     and its modules) please visit http://www.horde.org/.
32    
33     %prep
34     %setup -q -n %{name}-%{version}
35    
36     %build
37    
38     %install
39     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
40     mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf
41     #cp -p $RPM_SOURCE_DIR/horde.conf $RPM_BUILD_ROOT%{apachedir}/conf
42     mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde
43     cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde
44     chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/test.php
45     cd $RPM_BUILD_ROOT%{contentdir}/html/horde/config
46     mv hooks.php.dist hooks.php.dist1
47     #rm -rf hooks.php.dist
48     for d in *.dist; do
49     d0=`basename $d .dist`
50     if [ ! -f "$d0" ]; then
51     cp -p $d $d0
52     fi
53     done
54     mv hooks.php.dist1 hooks.php.dist
55    
56     %clean
57     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
58    
59     %files
60     %defattr(-,root,root)
61     # Apache horde.conf file
62     #%config %{apachedir}/conf/horde.conf
63     # Include top level with %dir so not all files are sucked in
64     %dir %{contentdir}/html/horde
65     # Include top-level files by hand
66     %{contentdir}/html/horde/*.php
67     # Include these dirs so that all files _will_ get sucked in
68     %{contentdir}/html/horde/admin
69     %{contentdir}/html/horde/js
70     %{contentdir}/html/horde/lib
71     %{contentdir}/html/horde/locale
72     %{contentdir}/html/horde/po
73     %{contentdir}/html/horde/scripts
74     %{contentdir}/html/horde/services
75     %{contentdir}/html/horde/templates
76     %{contentdir}/html/horde/themes
77     %{contentdir}/html/horde/util
78     %{contentdir}/html/horde/rpc
79     # Mark documentation files with %doc and %docdir
80     %doc %{contentdir}/html/horde/COPYING
81     %doc %{contentdir}/html/horde/README
82     %docdir %{contentdir}/html/horde/docs
83     %{contentdir}/html/horde/docs
84     # Mark configuration files with %config and use secure permissions
85     # (note that .dist files are considered software; don't mark %config)
86     %attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config
87     %attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/config/registry.d
88     %defattr(640,root,%{apachegroup})
89     %{contentdir}/html/horde/config/.htaccess
90     %{contentdir}/html/horde/config/*.dist
91     %{contentdir}/html/horde/config/registry.d/*
92     %config %{contentdir}/html/horde/config/*.php
93     %config %{contentdir}/html/horde/config/*.xml
94    
95     %changelog
96 slords 1.3 * Tue Sep 16 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2.2-1
97     - Update to Horde 3.2.2 [SME: 4565]
98 slords 1.1
99     * Fri Jun 13 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2.1-1
100 bytegw 1.2 - Update to Horde 3.2.1 [SME: 4532]
101 slords 1.1
102     * Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 3.2-1
103     - initial RPM roll for Horde 3.2
104    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed