1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The Internet Messaging Program: webmail access to IMAP/POP3 accounts. |
7 |
|
|
Name: imp-h3 |
8 |
|
|
Version: 4.1.4 |
9 |
|
|
Release: 1%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/imp/tarballs/imp-h3-%{version}.tar.gz |
13 |
|
|
Source1: imp.conf |
14 |
|
|
URL: http://www.horde.org/ |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRoot: /tmp/imp-root |
17 |
|
|
Requires: php >= 4.3.0 |
18 |
|
|
Requires: php-imap >= 4.3.0 |
19 |
|
|
Requires: httpd >= 2.0.46 |
20 |
|
|
Requires: horde >= 3.1 |
21 |
|
|
Obsoletes: imp |
22 |
|
|
Provides: imp |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
IMP is the Internet Messaging Program, one of the Horde applications. |
27 |
|
|
It provides webmail access to IMAP and POP3 accounts. |
28 |
|
|
|
29 |
|
|
The Horde Project writes web applications in PHP and releases them under |
30 |
|
|
Open Source licenses. For more information (including help with IMP) |
31 |
|
|
please visit http://www.horde.org/. |
32 |
|
|
|
33 |
|
|
This package contains customizations for the Mitel Networks SME Server |
34 |
|
|
and will probably not work properly on other Linux systems. |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup -q -n %{name}-%{version} |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
|
41 |
|
|
%install |
42 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
43 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
44 |
|
|
cp -p $RPM_SOURCE_DIR/imp.conf $RPM_BUILD_ROOT%{apachedir}/conf |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
46 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
47 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/imp/config |
48 |
|
|
for d in *.dist; do |
49 |
|
|
d0=`basename $d .dist` |
50 |
|
|
if [ ! -f "$d0" ]; then |
51 |
|
|
cp -p $d $d0 |
52 |
|
|
fi |
53 |
|
|
done |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%pre |
59 |
|
|
|
60 |
|
|
%post |
61 |
|
|
|
62 |
|
|
%postun |
63 |
|
|
|
64 |
|
|
%files |
65 |
|
|
%defattr(-,root,root) |
66 |
|
|
# Apache imp.conf file |
67 |
|
|
%config %{apachedir}/conf/imp.conf |
68 |
|
|
# Include top level with %dir so not all files are sucked in |
69 |
|
|
%dir %{contentdir}/html/horde/imp |
70 |
|
|
# Include top-level files by hand |
71 |
|
|
%{contentdir}/html/horde/imp/*.php |
72 |
|
|
# Include these dirs so that all files _will_ get sucked in |
73 |
|
|
%{contentdir}/html/horde/imp/js |
74 |
|
|
%{contentdir}/html/horde/imp/lib |
75 |
|
|
%{contentdir}/html/horde/imp/locale |
76 |
|
|
%{contentdir}/html/horde/imp/po |
77 |
|
|
%{contentdir}/html/horde/imp/scripts |
78 |
|
|
%{contentdir}/html/horde/imp/templates |
79 |
|
|
%{contentdir}/html/horde/imp/themes |
80 |
|
|
# Mark documentation files with %doc and %docdir |
81 |
|
|
%doc %{contentdir}/html/horde/imp/COPYING |
82 |
|
|
%doc %{contentdir}/html/horde/imp/README |
83 |
|
|
%docdir %{contentdir}/html/horde/imp/docs |
84 |
|
|
%{contentdir}/html/horde/imp/docs |
85 |
|
|
# Mark configuration files with %config and use secure permissions |
86 |
|
|
# (note that .dist files are considered software; don't mark %config) |
87 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/imp/config |
88 |
|
|
%defattr(640,root,%{apachegroup}) |
89 |
|
|
%{contentdir}/html/horde/imp/config/.htaccess |
90 |
|
|
%{contentdir}/html/horde/imp/config/*.dist |
91 |
|
|
%config %{contentdir}/html/horde/imp/config/*.php |
92 |
|
|
%config %{contentdir}/html/horde/imp/config/*.txt |
93 |
|
|
%config %{contentdir}/html/horde/imp/config/*.xml |
94 |
|
|
|
95 |
|
|
%changelog |
96 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
97 |
|
|
- Clean up spec so package can be built by koji/plague |
98 |
|
|
|
99 |
|
|
* Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 4.1.4-1.el4 |
100 |
|
|
- Updated to imp 4.1.4. [SME: 2784] |
101 |
|
|
|
102 |
|
|
* Sat Dec 09 2006 Shad L. Lords <slords@mail.com> |
103 |
|
|
- Update to new release naming. No functional changes. |
104 |
|
|
- Make Packager generic |
105 |
|
|
|
106 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 4.1.3-00sme01 |
107 |
|
|
- Updated to imp 4.1.3. |
108 |
|
|
|
109 |
|
|
* Mon Aug 28 2006 John H. Bennett III <bennettj@johnbennettservices.com> 4.0.5-01sme01 |
110 |
|
|
- Updated to 4.0.5 |
111 |
|
|
|
112 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 4.0.4-02sme01 |
113 |
|
|
- Adjust Release tag to our standard format [SME: 70] |
114 |
|
|
|
115 |
|
|
* Wed Nov 09 2005 Greg Swallow 4.0.4-01.sme |
116 |
|
|
- Update to 4.0.4 |
117 |
|
|
|
118 |
|
|
* Fri May 06 2005 Charlie Brady <charlieb@e-smith.com> 4.0.3-1sme02 |
119 |
|
|
- Update to 4.0.3. |
120 |
|
|
|
121 |
|
|
* Thu Apr 21 2005 Charlie Brady <charlieb@e-smith.com> 4.0.3-rc1-1sme02 |
122 |
|
|
- Add "Provides: imp" header. |
123 |
|
|
- Remove pre and post scripts, as they're not relevant (and potentially |
124 |
|
|
troublesome) during install from CD. |
125 |
|
|
|
126 |
|
|
* Thu Mar 31 2005 Greg Swallow <gregswallow@skynetonline.ca> |
127 |
|
|
- [4.0.3-rc1-1sme01] |
128 |
|
|
- changed name to imp-h3 |
129 |
|
|
- Update for IMP 4 on SME7 |
130 |
|
|
|
131 |
|
|
* Tue Aug 10 2004 Shad L. Lords <slords@mail.com> |
132 |
|
|
- [3.2.1-3sme01] |
133 |
|
|
- Update specfile - change apache to httpd in requires |
134 |
|
|
|
135 |
|
|
* Thu Apr 24 2003 Gordon Rowell <gordon_rowell@mitel.com> |
136 |
|
|
- [3.2.1-2es01] |
137 |
|
|
- Check name of "imp" registry item, rather than "horde" so that we display |
138 |
|
|
"Welcome to webmail" [gordonr 7694] |
139 |
|
|
|
140 |
|
|
* Wed Apr 23 2003 Gordon Rowell <gordon_rowell@mitel.com> |
141 |
|
|
- [3.2.1-2es00] |
142 |
|
|
- Rebuild [gordonr 7694] |
143 |
|
|
|
144 |
|
|
* Tue Mar 25 2003 Dan Brown <dan@familybrown.org> |
145 |
|
|
- 3.2.1-2es |
146 |
|
|
- Fixed .spec file to include imp/download/ directory |
147 |
|
|
|
148 |
|
|
* Wed Mar 12 2003 Dan Brown <dan@familybrown.org> |
149 |
|
|
- 3.2.1-1es |
150 |
|
|
- Rebuild with IMP 3.2.1 |
151 |
|
|
|
152 |
|
|
* Tue Feb 25 2003 Dan Brown <dan@familybrown.org> |
153 |
|
|
- 3.2-1es |
154 |
|
|
- Rebuilt with IMP 3.2 |
155 |
|
|
|
156 |
|
|
* Tue Jun 18 2002 Dan Brown <dan@familybrown.org> |
157 |
|
|
- 3.1-2es |
158 |
|
|
- Added Obsoletes: tag for 3.1-01rc3; hopefully this will |
159 |
|
|
resolve dependency problems. |
160 |
|
|
|
161 |
|
|
* Sun Jun 16 2002 Dan Brown <dan@familybrown.org> |
162 |
|
|
- 3.1-1es |
163 |
|
|
- rebuilt for 3.1 final |
164 |
|
|
|
165 |
|
|
* Sun Jun 2 2002 Dan Brown <dan@familybrown.org> |
166 |
|
|
- 3.1rc3 release 1es |
167 |
|
|
- rebuilt for 3.1rc3 |
168 |
|
|
|
169 |
|
|
* Fri Mar 8 2002 Dan Brown <dan@familybrown.org> 3.0-3es |
170 |
|
|
- changed Apache dependency to >= 1.3.19 |
171 |
|
|
|
172 |
|
|
* Sun Feb 10 2002 Dan Brown <dan@familybrown.org> |
173 |
|
|
- 3.0 release 2es |
174 |
|
|
- removed httpd restart--it's giving errors on SME 5.1.2, and |
175 |
|
|
it's handled by the e-smith-horde RPM |
176 |
|
|
|
177 |
|
|
* Sat Feb 09 2002 Dan Brown <dan@familybrown.org> |
178 |
|
|
- 3.0 release 1es |
179 |
|
|
- changed apache user, group, and content directory |
180 |
|
|
|
181 |
|
|
* Wed Jan 02 2002 Brent J. Nordquist <bjn@horde.org> |
182 |
|
|
- 3.0 release 1 |
183 |
|
|
|
184 |
|
|
* Mon Dec 24 2001 Brent J. Nordquist <bjn@horde.org> |
185 |
|
|
- 3.0-RC4 release 1 |
186 |
|
|
|
187 |
|
|
* Sat Dec 15 2001 Brent J. Nordquist <bjn@horde.org> |
188 |
|
|
- rewritten for IMP 3.0 |
189 |
|
|
|
190 |
|
|
* Wed Nov 14 2001 Brent J. Nordquist <bjn@horde.org> |
191 |
|
|
- 2.2.7 release 1rh7 |
192 |
|
|
|
193 |
|
|
* Sat Jul 21 2001 Brent J. Nordquist <bjn@horde.org> |
194 |
|
|
- 2.2.6 release 1rh7 |
195 |
|
|
|
196 |
|
|
* Tue Feb 06 2001 Brent J. Nordquist <bjn@horde.org> |
197 |
|
|
- 2.2.4 release 1rh7 |
198 |
|
|
|