1 |
slords |
1.4 |
# $Id$ |
2 |
|
|
|
3 |
slords |
1.1 |
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
|
8 |
|
|
Summary: The Internet Messaging Program: webmail access to IMAP/POP3 accounts. |
9 |
|
|
Name: imp-h3 |
10 |
slords |
1.3 |
Version: 4.1.6 |
11 |
slords |
1.1 |
Release: 1%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Applications/Horde |
14 |
|
|
Source: ftp://ftp.horde.org/pub/imp/tarballs/imp-h3-%{version}.tar.gz |
15 |
|
|
Source1: imp.conf |
16 |
|
|
URL: http://www.horde.org/ |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
BuildRoot: /tmp/imp-root |
19 |
|
|
Requires: php >= 4.3.0 |
20 |
|
|
Requires: php-imap >= 4.3.0 |
21 |
|
|
Requires: httpd >= 2.0.46 |
22 |
|
|
Requires: horde >= 3.1 |
23 |
|
|
Obsoletes: imp |
24 |
|
|
Provides: imp |
25 |
|
|
Prereq: /usr/bin/perl |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
IMP is the Internet Messaging Program, one of the Horde applications. |
29 |
|
|
It provides webmail access to IMAP and POP3 accounts. |
30 |
|
|
|
31 |
|
|
The Horde Project writes web applications in PHP and releases them under |
32 |
|
|
Open Source licenses. For more information (including help with IMP) |
33 |
|
|
please visit http://www.horde.org/. |
34 |
|
|
|
35 |
|
|
This package contains customizations for the Mitel Networks SME Server |
36 |
|
|
and will probably not work properly on other Linux systems. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -q -n %{name}-%{version} |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
46 |
|
|
cp -p $RPM_SOURCE_DIR/imp.conf $RPM_BUILD_ROOT%{apachedir}/conf |
47 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
48 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
49 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/imp/config |
50 |
|
|
for d in *.dist; do |
51 |
|
|
d0=`basename $d .dist` |
52 |
|
|
if [ ! -f "$d0" ]; then |
53 |
|
|
cp -p $d $d0 |
54 |
|
|
fi |
55 |
|
|
done |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%pre |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
|
64 |
|
|
%postun |
65 |
|
|
|
66 |
|
|
%files |
67 |
|
|
%defattr(-,root,root) |
68 |
|
|
# Apache imp.conf file |
69 |
|
|
%config %{apachedir}/conf/imp.conf |
70 |
|
|
# Include top level with %dir so not all files are sucked in |
71 |
|
|
%dir %{contentdir}/html/horde/imp |
72 |
|
|
# Include top-level files by hand |
73 |
|
|
%{contentdir}/html/horde/imp/*.php |
74 |
|
|
# Include these dirs so that all files _will_ get sucked in |
75 |
|
|
%{contentdir}/html/horde/imp/js |
76 |
|
|
%{contentdir}/html/horde/imp/lib |
77 |
|
|
%{contentdir}/html/horde/imp/locale |
78 |
|
|
%{contentdir}/html/horde/imp/po |
79 |
|
|
%{contentdir}/html/horde/imp/scripts |
80 |
|
|
%{contentdir}/html/horde/imp/templates |
81 |
|
|
%{contentdir}/html/horde/imp/themes |
82 |
|
|
# Mark documentation files with %doc and %docdir |
83 |
|
|
%doc %{contentdir}/html/horde/imp/COPYING |
84 |
|
|
%doc %{contentdir}/html/horde/imp/README |
85 |
|
|
%docdir %{contentdir}/html/horde/imp/docs |
86 |
|
|
%{contentdir}/html/horde/imp/docs |
87 |
|
|
# Mark configuration files with %config and use secure permissions |
88 |
|
|
# (note that .dist files are considered software; don't mark %config) |
89 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/imp/config |
90 |
|
|
%defattr(640,root,%{apachegroup}) |
91 |
|
|
%{contentdir}/html/horde/imp/config/.htaccess |
92 |
|
|
%{contentdir}/html/horde/imp/config/*.dist |
93 |
|
|
%config %{contentdir}/html/horde/imp/config/*.php |
94 |
|
|
%config %{contentdir}/html/horde/imp/config/*.txt |
95 |
|
|
%config %{contentdir}/html/horde/imp/config/*.xml |
96 |
|
|
|
97 |
|
|
%changelog |
98 |
slords |
1.3 |
* Tue Mar 25 2008 Shad L. Lords <slords@mail.com> 4.1.6-1 |
99 |
|
|
- Updated to imp 4.1.6. [SME: 4098] |
100 |
|
|
|
101 |
slords |
1.2 |
* Tue Nov 13 2007 John H. Bennett III <bennettj@johnbennettservices.com> 4.1.5-1 |
102 |
|
|
- Updated to imp 4.1.5. [SME: 3569] |
103 |
|
|
|
104 |
slords |
1.1 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
105 |
|
|
- Clean up spec so package can be built by koji/plague |
106 |
|
|
|
107 |
|
|
* Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 4.1.4-1.el4 |
108 |
|
|
- Updated to imp 4.1.4. [SME: 2784] |
109 |
|
|
|
110 |
|
|
* Sat Dec 09 2006 Shad L. Lords <slords@mail.com> |
111 |
|
|
- Update to new release naming. No functional changes. |
112 |
|
|
- Make Packager generic |
113 |
|
|
|
114 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 4.1.3-00sme01 |
115 |
|
|
- Updated to imp 4.1.3. |
116 |
|
|
|
117 |
|
|
* Mon Aug 28 2006 John H. Bennett III <bennettj@johnbennettservices.com> 4.0.5-01sme01 |
118 |
|
|
- Updated to 4.0.5 |
119 |
|
|
|
120 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 4.0.4-02sme01 |
121 |
|
|
- Adjust Release tag to our standard format [SME: 70] |
122 |
|
|
|
123 |
|
|
* Wed Nov 09 2005 Greg Swallow 4.0.4-01.sme |
124 |
|
|
- Update to 4.0.4 |
125 |
|
|
|
126 |
|
|
* Fri May 06 2005 Charlie Brady <charlieb@e-smith.com> 4.0.3-1sme02 |
127 |
|
|
- Update to 4.0.3. |
128 |
|
|
|
129 |
|
|
* Thu Apr 21 2005 Charlie Brady <charlieb@e-smith.com> 4.0.3-rc1-1sme02 |
130 |
|
|
- Add "Provides: imp" header. |
131 |
|
|
- Remove pre and post scripts, as they're not relevant (and potentially |
132 |
|
|
troublesome) during install from CD. |
133 |
|
|
|
134 |
|
|
* Thu Mar 31 2005 Greg Swallow <gregswallow@skynetonline.ca> |
135 |
|
|
- [4.0.3-rc1-1sme01] |
136 |
|
|
- changed name to imp-h3 |
137 |
|
|
- Update for IMP 4 on SME7 |
138 |
|
|
|
139 |
|
|
* Tue Aug 10 2004 Shad L. Lords <slords@mail.com> |
140 |
|
|
- [3.2.1-3sme01] |
141 |
|
|
- Update specfile - change apache to httpd in requires |
142 |
|
|
|
143 |
|
|
* Thu Apr 24 2003 Gordon Rowell <gordon_rowell@mitel.com> |
144 |
|
|
- [3.2.1-2es01] |
145 |
|
|
- Check name of "imp" registry item, rather than "horde" so that we display |
146 |
|
|
"Welcome to webmail" [gordonr 7694] |
147 |
|
|
|
148 |
|
|
* Wed Apr 23 2003 Gordon Rowell <gordon_rowell@mitel.com> |
149 |
|
|
- [3.2.1-2es00] |
150 |
|
|
- Rebuild [gordonr 7694] |
151 |
|
|
|
152 |
|
|
* Tue Mar 25 2003 Dan Brown <dan@familybrown.org> |
153 |
|
|
- 3.2.1-2es |
154 |
|
|
- Fixed .spec file to include imp/download/ directory |
155 |
|
|
|
156 |
|
|
* Wed Mar 12 2003 Dan Brown <dan@familybrown.org> |
157 |
|
|
- 3.2.1-1es |
158 |
|
|
- Rebuild with IMP 3.2.1 |
159 |
|
|
|
160 |
|
|
* Tue Feb 25 2003 Dan Brown <dan@familybrown.org> |
161 |
|
|
- 3.2-1es |
162 |
|
|
- Rebuilt with IMP 3.2 |
163 |
|
|
|
164 |
|
|
* Tue Jun 18 2002 Dan Brown <dan@familybrown.org> |
165 |
|
|
- 3.1-2es |
166 |
|
|
- Added Obsoletes: tag for 3.1-01rc3; hopefully this will |
167 |
|
|
resolve dependency problems. |
168 |
|
|
|
169 |
|
|
* Sun Jun 16 2002 Dan Brown <dan@familybrown.org> |
170 |
|
|
- 3.1-1es |
171 |
|
|
- rebuilt for 3.1 final |
172 |
|
|
|
173 |
|
|
* Sun Jun 2 2002 Dan Brown <dan@familybrown.org> |
174 |
|
|
- 3.1rc3 release 1es |
175 |
|
|
- rebuilt for 3.1rc3 |
176 |
|
|
|
177 |
|
|
* Fri Mar 8 2002 Dan Brown <dan@familybrown.org> 3.0-3es |
178 |
|
|
- changed Apache dependency to >= 1.3.19 |
179 |
|
|
|
180 |
|
|
* Sun Feb 10 2002 Dan Brown <dan@familybrown.org> |
181 |
|
|
- 3.0 release 2es |
182 |
|
|
- removed httpd restart--it's giving errors on SME 5.1.2, and |
183 |
|
|
it's handled by the e-smith-horde RPM |
184 |
|
|
|
185 |
|
|
* Sat Feb 09 2002 Dan Brown <dan@familybrown.org> |
186 |
|
|
- 3.0 release 1es |
187 |
|
|
- changed apache user, group, and content directory |
188 |
|
|
|
189 |
|
|
* Wed Jan 02 2002 Brent J. Nordquist <bjn@horde.org> |
190 |
|
|
- 3.0 release 1 |
191 |
|
|
|
192 |
|
|
* Mon Dec 24 2001 Brent J. Nordquist <bjn@horde.org> |
193 |
|
|
- 3.0-RC4 release 1 |
194 |
|
|
|
195 |
|
|
* Sat Dec 15 2001 Brent J. Nordquist <bjn@horde.org> |
196 |
|
|
- rewritten for IMP 3.0 |
197 |
|
|
|
198 |
|
|
* Wed Nov 14 2001 Brent J. Nordquist <bjn@horde.org> |
199 |
|
|
- 2.2.7 release 1rh7 |
200 |
|
|
|
201 |
|
|
* Sat Jul 21 2001 Brent J. Nordquist <bjn@horde.org> |
202 |
|
|
- 2.2.6 release 1rh7 |
203 |
|
|
|
204 |
|
|
* Tue Feb 06 2001 Brent J. Nordquist <bjn@horde.org> |
205 |
|
|
- 2.2.4 release 1rh7 |
206 |
|
|
|