1 |
mrjhb3 |
1.6 |
# $Id: imp-h3.spec,v 1.5 2008/06/26 04:40:38 slords Exp $ |
2 |
slords |
1.4 |
|
3 |
slords |
1.1 |
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
|
8 |
|
|
Summary: The Internet Messaging Program: webmail access to IMAP/POP3 accounts. |
9 |
|
|
Name: imp-h3 |
10 |
mrjhb3 |
1.6 |
Version: 4.3 |
11 |
slords |
1.1 |
Release: 1%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Applications/Horde |
14 |
|
|
Source: ftp://ftp.horde.org/pub/imp/tarballs/imp-h3-%{version}.tar.gz |
15 |
|
|
URL: http://www.horde.org/ |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRoot: /tmp/imp-root |
18 |
|
|
Requires: php >= 4.3.0 |
19 |
|
|
Requires: php-imap >= 4.3.0 |
20 |
|
|
Requires: httpd >= 2.0.46 |
21 |
slords |
1.5 |
Requires: horde >= 3.2 |
22 |
slords |
1.1 |
Obsoletes: imp |
23 |
|
|
Provides: imp |
24 |
|
|
Prereq: /usr/bin/perl |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
IMP is the Internet Messaging Program, one of the Horde applications. |
28 |
|
|
It provides webmail access to IMAP and POP3 accounts. |
29 |
|
|
|
30 |
|
|
The Horde Project writes web applications in PHP and releases them under |
31 |
|
|
Open Source licenses. For more information (including help with IMP) |
32 |
|
|
please visit http://www.horde.org/. |
33 |
|
|
|
34 |
|
|
This package contains customizations for the Mitel Networks SME Server |
35 |
|
|
and will probably not work properly on other Linux systems. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{name}-%{version} |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
%install |
43 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
44 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
46 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/imp |
47 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/imp/config |
48 |
|
|
for d in *.dist; do |
49 |
|
|
d0=`basename $d .dist` |
50 |
|
|
if [ ! -f "$d0" ]; then |
51 |
|
|
cp -p $d $d0 |
52 |
|
|
fi |
53 |
|
|
done |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%pre |
59 |
|
|
|
60 |
|
|
%post |
61 |
|
|
|
62 |
|
|
%postun |
63 |
|
|
|
64 |
|
|
%files |
65 |
|
|
%defattr(-,root,root) |
66 |
|
|
# Apache imp.conf file |
67 |
|
|
# Include top level with %dir so not all files are sucked in |
68 |
|
|
%dir %{contentdir}/html/horde/imp |
69 |
|
|
# Include top-level files by hand |
70 |
|
|
%{contentdir}/html/horde/imp/*.php |
71 |
|
|
# Include these dirs so that all files _will_ get sucked in |
72 |
|
|
%{contentdir}/html/horde/imp/js |
73 |
|
|
%{contentdir}/html/horde/imp/lib |
74 |
|
|
%{contentdir}/html/horde/imp/locale |
75 |
|
|
%{contentdir}/html/horde/imp/po |
76 |
|
|
%{contentdir}/html/horde/imp/scripts |
77 |
|
|
%{contentdir}/html/horde/imp/templates |
78 |
|
|
%{contentdir}/html/horde/imp/themes |
79 |
|
|
# Mark documentation files with %doc and %docdir |
80 |
|
|
%doc %{contentdir}/html/horde/imp/COPYING |
81 |
|
|
%doc %{contentdir}/html/horde/imp/README |
82 |
|
|
%docdir %{contentdir}/html/horde/imp/docs |
83 |
|
|
%{contentdir}/html/horde/imp/docs |
84 |
|
|
# Mark configuration files with %config and use secure permissions |
85 |
|
|
# (note that .dist files are considered software; don't mark %config) |
86 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/imp/config |
87 |
|
|
%defattr(640,root,%{apachegroup}) |
88 |
|
|
%{contentdir}/html/horde/imp/config/.htaccess |
89 |
|
|
%{contentdir}/html/horde/imp/config/*.dist |
90 |
|
|
%config %{contentdir}/html/horde/imp/config/*.php |
91 |
|
|
%config %{contentdir}/html/horde/imp/config/*.txt |
92 |
|
|
%config %{contentdir}/html/horde/imp/config/*.xml |
93 |
|
|
|
94 |
|
|
%changelog |
95 |
mrjhb3 |
1.6 |
* Sat Dec 06 2008 John H. Bennett III <bennettj@johnbennettservices.com> 4.3-1 |
96 |
|
|
- Updated to Imp 4.3 [SME: 4832] |
97 |
|
|
|
98 |
slords |
1.5 |
* Mon Jun 23 2008 John H. Bennett III <bennettj@johnbennettservices.com> 4.2-1 |
99 |
|
|
- Re-rolled to released version |
100 |
slords |
1.3 |
|
101 |
slords |
1.5 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 4.2-01 |
102 |
|
|
- initial RPM roll for Imp 4.2 |
103 |
slords |
1.1 |
|