1 |
slords |
1.4 |
# $Id$ |
2 |
|
|
|
3 |
slords |
1.1 |
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
|
8 |
|
|
Summary: The email filter rules manager for Horde. |
9 |
|
|
Name: ingo-h3 |
10 |
slords |
1.3 |
Version: 1.1.5 |
11 |
slords |
1.2 |
Release: 1%{?dist} |
12 |
slords |
1.1 |
License: LGPL |
13 |
|
|
Group: Applications/Horde |
14 |
|
|
Source: ftp://ftp.horde.org/pub/ingo/tarballs/ingo-h3-%{version}.tar.gz |
15 |
slords |
1.2 |
#Patch0: |
16 |
slords |
1.1 |
URL: http://www.horde.org/ |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
BuildRoot: /tmp/horde-root |
19 |
|
|
AutoReq: no |
20 |
|
|
Requires: horde >= 3.1 |
21 |
|
|
Requires: php >= 4.3.0 |
22 |
|
|
Requires: httpd >= 2.0.46 |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
Ingo is an email filter rules manager. It can generate Sieve and procmail |
27 |
|
|
scripts and upload them to the server (using a timsieved or VFS FTP driver, |
28 |
|
|
respectively). It can also create and execute IMAP commands to run filter |
29 |
|
|
rules. |
30 |
|
|
|
31 |
|
|
The Horde Project writes web applications in PHP and releases them under |
32 |
|
|
Open Source licenses. For more information (including help with Horde |
33 |
|
|
and its modules) please visit http://www.horde.org/. |
34 |
|
|
|
35 |
|
|
This package contains customizations for SME Server |
36 |
|
|
and will probably not work properly on other Linux systems. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -q -n %{name}-%{version} |
40 |
|
|
|
41 |
slords |
1.2 |
#%patch0 -p1 |
42 |
slords |
1.1 |
|
43 |
|
|
%build |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
47 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
48 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
49 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
50 |
|
|
chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/test.php |
51 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/config |
52 |
|
|
for d in *.dist; do |
53 |
|
|
d0=`basename $d .dist` |
54 |
|
|
if [ ! -f "$d0" ]; then |
55 |
|
|
cp -p $d $d0 |
56 |
|
|
fi |
57 |
|
|
done |
58 |
|
|
|
59 |
|
|
%clean |
60 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
|
64 |
|
|
%postun |
65 |
|
|
|
66 |
|
|
%files |
67 |
|
|
%defattr(-,root,root) |
68 |
|
|
# Include top level with %dir so not all files are sucked in |
69 |
|
|
%dir %{contentdir}/html/horde/ingo |
70 |
|
|
# Include top-level files by hand |
71 |
|
|
%{contentdir}/html/horde/ingo/*.php |
72 |
|
|
# Include these dirs so that all files _will_ get sucked in |
73 |
|
|
%{contentdir}/html/horde/ingo/js |
74 |
|
|
%{contentdir}/html/horde/ingo/lib |
75 |
|
|
%{contentdir}/html/horde/ingo/locale |
76 |
|
|
%{contentdir}/html/horde/ingo/po |
77 |
|
|
%{contentdir}/html/horde/ingo/scripts |
78 |
|
|
%{contentdir}/html/horde/ingo/templates |
79 |
|
|
%{contentdir}/html/horde/ingo/themes |
80 |
|
|
# Mark documentation files with %doc and %docdir |
81 |
|
|
%doc %{contentdir}/html/horde/ingo/LICENSE |
82 |
|
|
%doc %{contentdir}/html/horde/ingo/README |
83 |
|
|
%docdir %{contentdir}/html/horde/ingo/docs |
84 |
|
|
%{contentdir}/html/horde/ingo/docs |
85 |
|
|
# Mark configuration files with %config and use secure permissions |
86 |
|
|
# (note that .dist files are considered software; don't mark %config) |
87 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/ingo/config |
88 |
|
|
%defattr(640,root,%{apachegroup}) |
89 |
|
|
%{contentdir}/html/horde/ingo/config/.htaccess |
90 |
|
|
%{contentdir}/html/horde/ingo/config/*.dist |
91 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.php |
92 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.xml |
93 |
|
|
|
94 |
|
|
%changelog |
95 |
slords |
1.3 |
* Tue Mar 25 2008 Shad L. Lords <slords@mail.com> 1.1.5-1 |
96 |
|
|
- Updated to ingo 1.1.5 [SME: 4099] |
97 |
|
|
|
98 |
slords |
1.2 |
* Tue Nov 13 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.4-1 |
99 |
|
|
- Updated to ingo 1.1.4 [SME: 3571] |
100 |
|
|
|
101 |
slords |
1.1 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
102 |
|
|
- Clean up spec so package can be built by koji/plague |
103 |
|
|
|
104 |
|
|
* Sun Apr 15 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.3-2 |
105 |
|
|
- Update to ingo to correct an issue with filter lists that didn't make it into |
106 |
|
|
the current version of ingo. http://bugs.horde.org/ticket/?id=4618. [SME: 2903] |
107 |
|
|
|
108 |
|
|
* Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.3-1 |
109 |
|
|
- Updated to ingo 1.1.3 [SME:2781] |
110 |
|
|
|
111 |
|
|
* Sat Dec 09 2006 Shad L. Lords <slords@mail.com> |
112 |
|
|
- Update to new release naming. No functional changes. |
113 |
|
|
- Make Packager generic |
114 |
|
|
|
115 |
|
|
* Mon Oct 23 2006 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.2-00sme01 |
116 |
|
|
- Re-rolled to ingo 1.1.2 |
117 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.1-00sme01 |
118 |
|
|
- Updated to ingo 1.1.1 |
119 |
|
|
|
120 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.0.2-02sme01 |
121 |
|
|
- Adjust Release tag to our standard format [SME: 70] |
122 |
|
|
|
123 |
|
|
* Wed Nov 09 2005 Greg Swallow |
124 |
|
|
- Update to 1.0.2 |
125 |
|
|
|
126 |
|
|
* Thu Sep 01 2005 Greg Swallow |
127 |
|
|
- [1.0.1-1sme01] |
128 |
|
|
- Initial Release |
129 |
|
|
|