1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The email filter rules manager for Horde. |
7 |
|
|
Name: ingo-h3 |
8 |
|
|
Version: 1.1.3 |
9 |
|
|
Release: 2%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/ingo/tarballs/ingo-h3-%{version}.tar.gz |
13 |
|
|
Patch0: ingo-1.1.3-2.filter.patch |
14 |
|
|
URL: http://www.horde.org/ |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRoot: /tmp/horde-root |
17 |
|
|
AutoReq: no |
18 |
|
|
Requires: horde >= 3.1 |
19 |
|
|
Requires: php >= 4.3.0 |
20 |
|
|
Requires: httpd >= 2.0.46 |
21 |
|
|
Prereq: /usr/bin/perl |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
Ingo is an email filter rules manager. It can generate Sieve and procmail |
25 |
|
|
scripts and upload them to the server (using a timsieved or VFS FTP driver, |
26 |
|
|
respectively). It can also create and execute IMAP commands to run filter |
27 |
|
|
rules. |
28 |
|
|
|
29 |
|
|
The Horde Project writes web applications in PHP and releases them under |
30 |
|
|
Open Source licenses. For more information (including help with Horde |
31 |
|
|
and its modules) please visit http://www.horde.org/. |
32 |
|
|
|
33 |
|
|
This package contains customizations for SME Server |
34 |
|
|
and will probably not work properly on other Linux systems. |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup -q -n %{name}-%{version} |
38 |
|
|
|
39 |
|
|
%patch0 -p1 |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
46 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
47 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
48 |
|
|
chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/test.php |
49 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/config |
50 |
|
|
for d in *.dist; do |
51 |
|
|
d0=`basename $d .dist` |
52 |
|
|
if [ ! -f "$d0" ]; then |
53 |
|
|
cp -p $d $d0 |
54 |
|
|
fi |
55 |
|
|
done |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%post |
61 |
|
|
|
62 |
|
|
%postun |
63 |
|
|
|
64 |
|
|
%files |
65 |
|
|
%defattr(-,root,root) |
66 |
|
|
# Include top level with %dir so not all files are sucked in |
67 |
|
|
%dir %{contentdir}/html/horde/ingo |
68 |
|
|
# Include top-level files by hand |
69 |
|
|
%{contentdir}/html/horde/ingo/*.php |
70 |
|
|
# Include these dirs so that all files _will_ get sucked in |
71 |
|
|
%{contentdir}/html/horde/ingo/js |
72 |
|
|
%{contentdir}/html/horde/ingo/lib |
73 |
|
|
%{contentdir}/html/horde/ingo/locale |
74 |
|
|
%{contentdir}/html/horde/ingo/po |
75 |
|
|
%{contentdir}/html/horde/ingo/scripts |
76 |
|
|
%{contentdir}/html/horde/ingo/templates |
77 |
|
|
%{contentdir}/html/horde/ingo/themes |
78 |
|
|
# Mark documentation files with %doc and %docdir |
79 |
|
|
%doc %{contentdir}/html/horde/ingo/LICENSE |
80 |
|
|
%doc %{contentdir}/html/horde/ingo/README |
81 |
|
|
%docdir %{contentdir}/html/horde/ingo/docs |
82 |
|
|
%{contentdir}/html/horde/ingo/docs |
83 |
|
|
# Mark configuration files with %config and use secure permissions |
84 |
|
|
# (note that .dist files are considered software; don't mark %config) |
85 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/ingo/config |
86 |
|
|
%defattr(640,root,%{apachegroup}) |
87 |
|
|
%{contentdir}/html/horde/ingo/config/.htaccess |
88 |
|
|
%{contentdir}/html/horde/ingo/config/*.dist |
89 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.php |
90 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.xml |
91 |
|
|
|
92 |
|
|
%changelog |
93 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
94 |
|
|
- Clean up spec so package can be built by koji/plague |
95 |
|
|
|
96 |
|
|
* Sun Apr 15 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.3-2 |
97 |
|
|
- Update to ingo to correct an issue with filter lists that didn't make it into |
98 |
|
|
the current version of ingo. http://bugs.horde.org/ticket/?id=4618. [SME: 2903] |
99 |
|
|
|
100 |
|
|
* Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.3-1 |
101 |
|
|
- Updated to ingo 1.1.3 [SME:2781] |
102 |
|
|
|
103 |
|
|
* Sat Dec 09 2006 Shad L. Lords <slords@mail.com> |
104 |
|
|
- Update to new release naming. No functional changes. |
105 |
|
|
- Make Packager generic |
106 |
|
|
|
107 |
|
|
* Mon Oct 23 2006 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.2-00sme01 |
108 |
|
|
- Re-rolled to ingo 1.1.2 |
109 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.1-00sme01 |
110 |
|
|
- Updated to ingo 1.1.1 |
111 |
|
|
|
112 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 1.0.2-02sme01 |
113 |
|
|
- Adjust Release tag to our standard format [SME: 70] |
114 |
|
|
|
115 |
|
|
* Wed Nov 09 2005 Greg Swallow |
116 |
|
|
- Update to 1.0.2 |
117 |
|
|
|
118 |
|
|
* Thu Sep 01 2005 Greg Swallow |
119 |
|
|
- [1.0.1-1sme01] |
120 |
|
|
- Initial Release |
121 |
|
|
|