1 |
mrjhb3 |
1.10 |
# $Id: ingo-h3.spec,v 1.9 2010/05/11 04:10:44 mrjhb3 Exp $ |
2 |
slords |
1.4 |
|
3 |
slords |
1.1 |
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
|
8 |
|
|
Summary: The email filter rules manager for Horde. |
9 |
|
|
Name: ingo-h3 |
10 |
mrjhb3 |
1.10 |
Version: 1.2.5 |
11 |
slords |
1.2 |
Release: 1%{?dist} |
12 |
slords |
1.1 |
License: LGPL |
13 |
|
|
Group: Applications/Horde |
14 |
|
|
Source: ftp://ftp.horde.org/pub/ingo/tarballs/ingo-h3-%{version}.tar.gz |
15 |
slords |
1.2 |
#Patch0: |
16 |
slords |
1.1 |
URL: http://www.horde.org/ |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
BuildRoot: /tmp/horde-root |
19 |
|
|
AutoReq: no |
20 |
slords |
1.5 |
Requires: horde >= 3.2 |
21 |
slords |
1.1 |
Requires: php >= 4.3.0 |
22 |
|
|
Requires: httpd >= 2.0.46 |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
Ingo is an email filter rules manager. It can generate Sieve and procmail |
27 |
|
|
scripts and upload them to the server (using a timsieved or VFS FTP driver, |
28 |
|
|
respectively). It can also create and execute IMAP commands to run filter |
29 |
|
|
rules. |
30 |
|
|
|
31 |
|
|
The Horde Project writes web applications in PHP and releases them under |
32 |
|
|
Open Source licenses. For more information (including help with Horde |
33 |
|
|
and its modules) please visit http://www.horde.org/. |
34 |
|
|
|
35 |
|
|
This package contains customizations for SME Server |
36 |
|
|
and will probably not work properly on other Linux systems. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -q -n %{name}-%{version} |
40 |
|
|
|
41 |
slords |
1.2 |
#%patch0 -p1 |
42 |
slords |
1.1 |
|
43 |
|
|
%build |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
47 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
48 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
49 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo |
50 |
|
|
chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/test.php |
51 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/ingo/config |
52 |
|
|
for d in *.dist; do |
53 |
|
|
d0=`basename $d .dist` |
54 |
|
|
if [ ! -f "$d0" ]; then |
55 |
|
|
cp -p $d $d0 |
56 |
|
|
fi |
57 |
|
|
done |
58 |
|
|
|
59 |
|
|
%clean |
60 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
|
64 |
|
|
%postun |
65 |
|
|
|
66 |
|
|
%files |
67 |
|
|
%defattr(-,root,root) |
68 |
|
|
# Include top level with %dir so not all files are sucked in |
69 |
|
|
%dir %{contentdir}/html/horde/ingo |
70 |
|
|
# Include top-level files by hand |
71 |
|
|
%{contentdir}/html/horde/ingo/*.php |
72 |
|
|
# Include these dirs so that all files _will_ get sucked in |
73 |
|
|
%{contentdir}/html/horde/ingo/js |
74 |
|
|
%{contentdir}/html/horde/ingo/lib |
75 |
|
|
%{contentdir}/html/horde/ingo/locale |
76 |
|
|
%{contentdir}/html/horde/ingo/po |
77 |
|
|
%{contentdir}/html/horde/ingo/scripts |
78 |
|
|
%{contentdir}/html/horde/ingo/templates |
79 |
|
|
%{contentdir}/html/horde/ingo/themes |
80 |
|
|
# Mark documentation files with %doc and %docdir |
81 |
|
|
%doc %{contentdir}/html/horde/ingo/LICENSE |
82 |
|
|
%doc %{contentdir}/html/horde/ingo/README |
83 |
|
|
%docdir %{contentdir}/html/horde/ingo/docs |
84 |
|
|
%{contentdir}/html/horde/ingo/docs |
85 |
|
|
# Mark configuration files with %config and use secure permissions |
86 |
|
|
# (note that .dist files are considered software; don't mark %config) |
87 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/ingo/config |
88 |
|
|
%defattr(640,root,%{apachegroup}) |
89 |
|
|
%{contentdir}/html/horde/ingo/config/.htaccess |
90 |
|
|
%{contentdir}/html/horde/ingo/config/*.dist |
91 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.php |
92 |
|
|
%config %{contentdir}/html/horde/ingo/config/*.xml |
93 |
|
|
|
94 |
|
|
%changelog |
95 |
mrjhb3 |
1.10 |
* Sun Nov 07 2010 John H. Bennett III <bennettj@johnbennettservices.com> 1.2.5-1 |
96 |
|
|
- Update to Ingo 1.2.5 [SME: 6352] |
97 |
|
|
|
98 |
mrjhb3 |
1.9 |
* Mon May 10 2010 John H. Bennett III <bennettj@johnbennettservices.com> 1.2.4-1 |
99 |
|
|
- Update to Ingo 1.2.4 [SME: 5940] |
100 |
|
|
|
101 |
mrjhb3 |
1.8 |
* Sat Feb 13 2010 John H. Bennett III <bennettj@johnbennettservices.com> 1.2.3-1 |
102 |
|
|
- Update to Ingo 1.2.3 [SME: 5777] |
103 |
|
|
|
104 |
mrjhb3 |
1.7 |
* Tue Oct 13 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.2.2-1 |
105 |
|
|
- Update to Ingo 1.2.2 [SME: 5511] |
106 |
|
|
|
107 |
slords |
1.6 |
* Tue Sep 16 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.2.1-1 |
108 |
|
|
- Update to Ingo 1.2.1 [SME: 4567] |
109 |
|
|
|
110 |
slords |
1.5 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.2-1 |
111 |
|
|
- initial RPM roll for Ingo 1.2 |
112 |
slords |
1.1 |
|