1 |
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} |
2 |
|
3 |
%define baserelease 4 |
4 |
#build with --define 'testbuild 1' to have a timestamp appended to release |
5 |
%if x%{?testbuild} == x1 |
6 |
%define release %{baserelease}.%(date +%%Y%%m%%d.%%H%%M.%%S) |
7 |
%else |
8 |
%define release %{baserelease} |
9 |
%endif |
10 |
Name: koji |
11 |
Version: 1.1 |
12 |
Release: %{release}%{?dist} |
13 |
License: LGPL |
14 |
Summary: Build system tools |
15 |
Group: Applications/System |
16 |
URL: http://hosted.fedoraproject.org/projects/koji |
17 |
Source: %{name}-%{PACKAGE_VERSION}.tar.bz2 |
18 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
19 |
BuildArch: noarch |
20 |
Requires: python-krbV >= 1.0.13 |
21 |
Requires: rpm-python |
22 |
Requires: pyOpenSSL |
23 |
BuildRequires: python |
24 |
|
25 |
%description |
26 |
Koji is a system for building and tracking RPMS. The base package |
27 |
contains shared libraries and the command-line interface. |
28 |
|
29 |
%package hub |
30 |
Summary: Koji XMLRPC interface |
31 |
Group: Applications/Internet |
32 |
Requires: httpd |
33 |
Requires: mod_python |
34 |
Requires: postgresql-python |
35 |
Requires: %{name} = %{version}-%{release} |
36 |
|
37 |
%description hub |
38 |
koji-hub is the XMLRPC interface to the koji database |
39 |
|
40 |
%package builder |
41 |
Summary: Koji RPM builder daemon |
42 |
Group: Applications/System |
43 |
Requires: %{name} = %{version}-%{release} |
44 |
Requires: mock >= 0.5-3 |
45 |
Requires(post): /sbin/chkconfig |
46 |
Requires(post): /sbin/service |
47 |
Requires(preun): /sbin/chkconfig |
48 |
Requires(preun): /sbin/service |
49 |
Requires(pre): /usr/sbin/useradd |
50 |
Requires: cvs |
51 |
Requires: rpm-build |
52 |
Requires: redhat-rpm-config |
53 |
Requires: createrepo >= 0.4.8-2 |
54 |
|
55 |
%description builder |
56 |
koji-builder is the daemon that runs on build machines and executes |
57 |
tasks that come through the Koji system. |
58 |
|
59 |
%package utils |
60 |
Summary: Koji Utilities |
61 |
Group: Applications/Internet |
62 |
Requires: postgresql-python |
63 |
Requires: %{name} = %{version}-%{release} |
64 |
|
65 |
%description utils |
66 |
Utilities for the Koji system |
67 |
|
68 |
%package web |
69 |
Summary: Koji Web UI |
70 |
Group: Applications/Internet |
71 |
Requires: httpd |
72 |
Requires: mod_python |
73 |
Requires: mod_auth_kerb |
74 |
Requires: postgresql-python |
75 |
Requires: python-cheetah |
76 |
Requires: %{name} = %{version}-%{release} |
77 |
Requires: python-krbV >= 1.0.13 |
78 |
|
79 |
%description web |
80 |
koji-web is a web UI to the Koji system. |
81 |
|
82 |
%prep |
83 |
%setup -q |
84 |
|
85 |
%build |
86 |
|
87 |
%install |
88 |
rm -rf $RPM_BUILD_ROOT |
89 |
make DESTDIR=$RPM_BUILD_ROOT install |
90 |
|
91 |
%clean |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
|
94 |
%files |
95 |
%defattr(-,root,root) |
96 |
%{_bindir}/* |
97 |
%{python_sitelib}/%{name} |
98 |
%config(noreplace) %{_sysconfdir}/koji.conf |
99 |
%doc docs Authors COPYING LGPL |
100 |
|
101 |
%files hub |
102 |
%defattr(-,root,root) |
103 |
%{_datadir}/koji-hub |
104 |
%config(noreplace) /etc/httpd/conf.d/kojihub.conf |
105 |
|
106 |
%files utils |
107 |
%defattr(-,root,root) |
108 |
%{_sbindir}/kojira |
109 |
%{_initrddir}/kojira |
110 |
%config(noreplace) %{_sysconfdir}/sysconfig/kojira |
111 |
%{_sysconfdir}/kojira |
112 |
%config(noreplace) %{_sysconfdir}/kojira/kojira.conf |
113 |
|
114 |
%files web |
115 |
%defattr(-,root,root) |
116 |
%{_datadir}/koji-web |
117 |
%{_sysconfdir}/kojiweb |
118 |
%config(noreplace) /etc/httpd/conf.d/kojiweb.conf |
119 |
|
120 |
%files builder |
121 |
%defattr(-,root,root) |
122 |
%{_sbindir}/kojid |
123 |
%{_initrddir}/kojid |
124 |
%config(noreplace) %{_sysconfdir}/sysconfig/kojid |
125 |
%{_sysconfdir}/kojid |
126 |
%config(noreplace) %{_sysconfdir}/kojid/kojid.conf |
127 |
%attr(-,kojibuilder,kojibuilder) /etc/mock/koji |
128 |
|
129 |
%pre builder |
130 |
/usr/sbin/useradd -r -s /bin/bash -G mock -d /builddir -M kojibuilder 2>/dev/null ||: |
131 |
|
132 |
%post builder |
133 |
/sbin/chkconfig --add kojid |
134 |
/sbin/service kojid condrestart &> /dev/null || : |
135 |
|
136 |
%preun builder |
137 |
if [ $1 = 0 ]; then |
138 |
/sbin/service kojid stop &> /dev/null |
139 |
/sbin/chkconfig --del kojid |
140 |
fi |
141 |
|
142 |
%post utils |
143 |
/sbin/chkconfig --add kojira |
144 |
/sbin/service kojira condrestart &> /dev/null || : |
145 |
%preun utils |
146 |
if [ $1 = 0 ]; then |
147 |
/sbin/service kojira stop &> /dev/null || : |
148 |
/sbin/chkconfig --del kojira |
149 |
fi |
150 |
|
151 |
%changelog |
152 |
* Tue May 1 2007 Mike Bonnet <mikeb@redhat.com> - 1.1-4 |
153 |
- remove spurious Requires: from the koji-utils package |
154 |
|
155 |
* Tue May 1 2007 Mike Bonnet <mikeb@redhat.com> - 1.1-3 |
156 |
- fix typo in BuildNotificationTask (patch provided by Michael Schwendt) |
157 |
- add the --changelog param to the buildinfo command |
158 |
- always send email notifications to the package builder and package owner |
159 |
- improvements to the web UI |
160 |
|
161 |
* Tue Apr 17 2007 Mike Bonnet <mikeb@redhat.com> - 1.1-2 |
162 |
- re-enable use of the --update flag to createrepo |
163 |
|
164 |
* Mon Apr 09 2007 Jesse Keating <jkeating@redhat.com> 1.1-1 |
165 |
- make the output listPackages() consistent regardless of with_dups |
166 |
- prevent large batches of repo deletes from holding up regens |
167 |
- allow sorting the host list by arches |
168 |
|
169 |
* Mon Apr 02 2007 Jesse Keating <jkeating@redhat.com> 1.0-1 |
170 |
- Release 1.0! |
171 |
|
172 |
* Wed Mar 28 2007 Mike Bonnet <mikeb@redhat.com> - 0.9.7-4 |
173 |
- set SSL connection timeout to 12 hours |
174 |
|
175 |
* Wed Mar 28 2007 Mike Bonnet <mikeb@redhat.com> - 0.9.7-3 |
176 |
- avoid SSL renegotiation |
177 |
- improve log file handling in kojid |
178 |
- bug fixes in command-line and web UI |
179 |
|
180 |
* Sun Mar 25 2007 Mike Bonnet <mikeb@redhat.com> - 0.9.7-2 |
181 |
- enable http access to packages in kojid |
182 |
- add Requires: pyOpenSSL |
183 |
- building srpms from CVS now works with the Extras CVS structure |
184 |
- fixes to the chain-build command |
185 |
- bug fixes in the XML-RPC and web interfaces |
186 |
|
187 |
* Tue Mar 20 2007 Jesse Keating <jkeating@redhat.com> - 0.9.7-1 |
188 |
- Package up the needed ssl files |
189 |
|
190 |
* Tue Mar 20 2007 Jesse Keating <jkeating@redhat.com> - 0.9.6-1 |
191 |
- 0.9.6 release, mostly ssl auth stuff |
192 |
- use named directories for config stuff |
193 |
- remove -3 requires on creatrepo, don't need that specific anymore |
194 |
|
195 |
* Tue Feb 20 2007 Jesse Keating <jkeating@redhat.com> - 0.9.5-8 |
196 |
- Add Authors COPYING LGPL to the docs of the main package |
197 |
|
198 |
* Tue Feb 20 2007 Jesse Keating <jkeating@redhat.com> - 0.9.5-7 |
199 |
- Move web files from /var/www to /usr/share |
200 |
- Use -p in install calls |
201 |
- Add rpm-python to requires for koji |
202 |
|
203 |
* Mon Feb 19 2007 Jesse Keating <jkeating@redhat.com> - 0.9.5-6 |
204 |
- Clean up spec for package review |
205 |
|
206 |
* Sun Feb 04 2007 Mike McLean <mikem@redhat.com> - 0.9.5-1 |
207 |
- project renamed to koji |