1 |
slords |
1.1 |
Summary: Analyzes and Reports on system logs |
2 |
|
|
Name: logwatch |
3 |
|
|
Version: 7.3.2 |
4 |
|
|
Release: 3%{?dist} |
5 |
|
|
License: MIT |
6 |
|
|
Group: Utilities/System |
7 |
|
|
URL: http://www.logwatch.org |
8 |
|
|
BuildArch: noarch |
9 |
|
|
Source: ftp://ftp.kaybee.org/pub/linux/logwatch-7.3.2.tar.gz |
10 |
|
|
Patch1: logwatch-7.3.2-clamd.patch |
11 |
|
|
Patch2: logwatch-7.3.2-freshclam.patch |
12 |
|
|
Patch3: logwatch-7.3.2-iptables-multi.patch |
13 |
|
|
Patch4: logwatch-7.3.2-ntpd.patch |
14 |
|
|
Patch5: logwatch-7.3.2-oidentd-multi.patch |
15 |
|
|
Patch6: logwatch-7.3.2-proftpd.patch |
16 |
|
|
Patch7: logwatch-7.3.2-sshd-multi.patch |
17 |
|
|
Patch8: logwatch-7.3.2-yum.patch |
18 |
|
|
Patch9: logwatch-7.3.2-signaturereload.patch |
19 |
|
|
Requires: perl,textutils,sh-utils,grep,mailx |
20 |
|
|
BuildRoot: %{_tmppath}/logwatch-build/ |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Logwatch is a customizable, pluggable log-monitoring system. It will go |
24 |
|
|
through your logs for a given period of time and make a report in the areas |
25 |
|
|
that you wish with the detail that you wish. Easy to use - works right out |
26 |
|
|
of the package on many systems. |
27 |
|
|
|
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
rm -rf %{buildroot} |
31 |
|
|
%setup |
32 |
|
|
%patch1 -p1 |
33 |
|
|
%patch2 -p1 |
34 |
|
|
%patch3 -p1 |
35 |
|
|
%patch4 -p1 |
36 |
|
|
%patch5 -p1 |
37 |
|
|
%patch6 -p1 |
38 |
|
|
%patch7 -p1 |
39 |
|
|
%patch8 -p1 |
40 |
|
|
%patch9 -p1 |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
|
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
install -m 0755 -d %{buildroot}%{_var}/cache/logwatch |
47 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/scripts |
48 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/scripts/services |
49 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf |
50 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf/logfiles |
51 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf/services |
52 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/logfiles |
53 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/services |
54 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/html |
55 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/dist.conf/logfiles |
56 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/dist.conf/services |
57 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/scripts/services |
58 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/scripts/shared |
59 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/lib |
60 |
|
|
|
61 |
|
|
install -m 0755 scripts/logwatch.pl %{buildroot}%{_datadir}/logwatch/scripts/logwatch.pl |
62 |
|
|
for i in scripts/logfiles/* ; do |
63 |
|
|
if [ $(ls $i | wc -l) -ne 0 ] ; then |
64 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/$i |
65 |
|
|
install -m 0755 $i/* %{buildroot}%{_datadir}/logwatch/$i |
66 |
|
|
fi |
67 |
|
|
done |
68 |
|
|
install -m 0755 scripts/services/* %{buildroot}%{_datadir}/logwatch/scripts/services |
69 |
|
|
install -m 0755 scripts/shared/* %{buildroot}%{_datadir}/logwatch/scripts/shared |
70 |
|
|
install -m 0755 lib/* %{buildroot}%{_datadir}/logwatch/lib |
71 |
|
|
|
72 |
|
|
install -m 0644 conf/*.conf %{buildroot}%{_datadir}/logwatch/default.conf |
73 |
|
|
install -m 0644 conf/logfiles/* %{buildroot}%{_datadir}/logwatch/default.conf/logfiles |
74 |
|
|
install -m 0644 conf/services/* %{buildroot}%{_datadir}/logwatch/default.conf/services |
75 |
|
|
install -m 0644 conf/html/* %{buildroot}%{_datadir}/logwatch/default.conf/html |
76 |
|
|
|
77 |
|
|
install -m 0755 -d %{buildroot}%{_mandir}/man8 |
78 |
|
|
install -m 0644 logwatch.8 %{buildroot}%{_mandir}/man8 |
79 |
|
|
|
80 |
|
|
rm -f %{buildroot}%{_sysconfdir}/cron.daily/logwatch \ |
81 |
|
|
%{buildroot}%{_sbindir}/logwatch |
82 |
|
|
|
83 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/cron.daily |
84 |
|
|
ln -s %{_datadir}/logwatch/scripts/logwatch.pl %{buildroot}%{_sysconfdir}/cron.daily/0logwatch |
85 |
|
|
install -m 0755 -d %{buildroot}%{_sbindir} |
86 |
|
|
ln -s %{_datadir}/logwatch/scripts/logwatch.pl %{buildroot}%{_sbindir}/logwatch |
87 |
|
|
|
88 |
|
|
echo "###### REGULAR EXPRESSIONS IN THIS FILE WILL BE TRIMMED FROM REPORT OUTPUT #####" > %{buildroot}%{_sysconfdir}/logwatch/conf/ignore.conf |
89 |
|
|
echo "# Local configuration options go here (defaults are in %{_datadir}/logwatch/default.conf/logwatch.conf)" > %{buildroot}%{_sysconfdir}/logwatch/conf/logwatch.conf |
90 |
|
|
echo "# Configuration overrides for specific logfiles/services may be placed here." > %{buildroot}%{_sysconfdir}/logwatch/conf/override.conf |
91 |
|
|
|
92 |
|
|
ln -s clamav %{buildroot}%{_datadir}/logwatch/scripts/services/clamd |
93 |
|
|
ln -s clam-update %{buildroot}%{_datadir}/logwatch/scripts/services/freshclam |
94 |
|
|
ln -s iptables %{buildroot}%{_datadir}/logwatch/scripts/services/iptables-multi |
95 |
|
|
ln -s xntpd %{buildroot}%{_datadir}/logwatch/scripts/services/ntpd |
96 |
|
|
ln -s oidentd %{buildroot}%{_datadir}/logwatch/scripts/services/oidentd-multi |
97 |
|
|
ln -s proftpd-messages %{buildroot}%{_datadir}/logwatch/scripts/services/proftpd |
98 |
|
|
ln -s sshd %{buildroot}%{_datadir}/logwatch/scripts/services/sshd-multi |
99 |
|
|
|
100 |
|
|
%clean |
101 |
|
|
rm -rf %{buildroot} |
102 |
|
|
|
103 |
|
|
%post |
104 |
|
|
|
105 |
|
|
|
106 |
|
|
%pre |
107 |
|
|
|
108 |
|
|
|
109 |
|
|
%preun |
110 |
|
|
|
111 |
|
|
|
112 |
|
|
%postun |
113 |
|
|
|
114 |
|
|
|
115 |
|
|
%files |
116 |
|
|
%defattr(-,root,root) |
117 |
|
|
%doc README HOWTO-Customize-LogWatch |
118 |
|
|
%dir %{_var}/cache/logwatch |
119 |
|
|
%dir %{_sysconfdir}/logwatch |
120 |
|
|
%dir %{_sysconfdir}/logwatch/scripts |
121 |
|
|
%dir %{_sysconfdir}/logwatch/scripts/services |
122 |
|
|
%dir %{_sysconfdir}/logwatch/conf |
123 |
|
|
%dir %{_sysconfdir}/logwatch/conf/logfiles |
124 |
|
|
%dir %{_sysconfdir}/logwatch/conf/services |
125 |
|
|
%dir %{_datadir}/logwatch |
126 |
|
|
%dir %{_datadir}/logwatch/default.conf |
127 |
|
|
%dir %{_datadir}/logwatch/default.conf/services |
128 |
|
|
%dir %{_datadir}/logwatch/default.conf/logfiles |
129 |
|
|
%dir %{_datadir}/logwatch/default.conf/html |
130 |
|
|
%dir %{_datadir}/logwatch/dist.conf |
131 |
|
|
%dir %{_datadir}/logwatch/dist.conf/services |
132 |
|
|
%dir %{_datadir}/logwatch/dist.conf/logfiles |
133 |
|
|
%dir %{_datadir}/logwatch/scripts |
134 |
|
|
%dir %{_datadir}/logwatch/scripts/logfiles |
135 |
|
|
%dir %{_datadir}/logwatch/scripts/services |
136 |
|
|
%dir %{_datadir}/logwatch/scripts/shared |
137 |
|
|
%dir %{_datadir}/logwatch/scripts/logfiles/* |
138 |
|
|
%dir %{_datadir}/logwatch/lib |
139 |
|
|
%{_datadir}/logwatch/scripts/logwatch.pl |
140 |
|
|
%{_sbindir}/logwatch |
141 |
|
|
%{_datadir}/logwatch/scripts/shared/* |
142 |
|
|
%{_datadir}/logwatch/scripts/services/* |
143 |
|
|
%{_datadir}/logwatch/scripts/logfiles/*/* |
144 |
|
|
%{_datadir}/logwatch/lib/Logwatch.pm |
145 |
|
|
%{_datadir}/logwatch/default.conf/*.conf |
146 |
|
|
%{_datadir}/logwatch/default.conf/services/*.conf |
147 |
|
|
%{_datadir}/logwatch/default.conf/logfiles/*.conf |
148 |
|
|
%{_datadir}/logwatch/default.conf/html/*.html |
149 |
|
|
%{_sysconfdir}/cron.daily/0logwatch |
150 |
|
|
%doc %{_mandir}/man8/logwatch.8* |
151 |
|
|
%config(noreplace) %{_sysconfdir}/logwatch/conf/*.conf |
152 |
|
|
|
153 |
|
|
%doc License project/CHANGES project/TODO |
154 |
|
|
|
155 |
|
|
%changelog |
156 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
157 |
|
|
- Clean up spec so package can be built by koji/plague |
158 |
|
|
|
159 |
|
|
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 7.3.2-3 |
160 |
|
|
- Update reload detection form clamav v0.90 |
161 |
|
|
|
162 |
|
|
* Fri Dec 29 2006 Shad L. Lords <slords@mail.com> 7.3.2-2 |
163 |
|
|
- Add log entries for smeserver multilog services |
164 |
|
|
|
165 |
|
|
* Fri Sep 15 2006 Kirk Bauer <kirk@kaybee.org> 7.3.1-1 |
166 |
|
|
- Fixed install script to create empty scripts directory in /etc |
167 |
|
|
|
168 |
|
|
* Sat Oct 08 2005 Kirk Bauer <kirk@kaybee.org> pre7.0-1 |
169 |
|
|
- Numerous changes, most notably a whole new directory structure. |
170 |
|
|
|
171 |
|
|
* Thu Feb 24 2005 Kirk Bauer <kirk@kaybee.org> 6.0.1-1 |
172 |
|
|
- Now includes ignore.conf in the RPM |
173 |
|
|
|
174 |
|
|
* Mon Nov 03 2003 Kirk Bauer <kirk@kaybee.org> pre5.0-1 |
175 |
|
|
- Now can build without change as non-root user |
176 |
|
|
|
177 |
|
|
* Thu Feb 27 2003 Erik Ogan <erik@ogan.net> 4.3.2 |
178 |
|
|
- Added libdir & lib/Logwatch.pm |
179 |
|
|
|
180 |
|
|
* Sun Oct 13 2002 Kirk Bauer <kirk@kaybee.org> pre4.0-14 |
181 |
|
|
- Changed the 'logwatch' cron.daily job to '0logwatch' to run before logrotate |
182 |
|
|
|
183 |
|
|
* Thu Oct 10 2002 Kirk Bauer <kirk@kaybee.org> pre4.0-1 |
184 |
|
|
- Cronjob is now just named logwatch and not 00-logwatch |
185 |
|
|
|
186 |
|
|
* Wed May 01 2002 Kirk Bauer <kirk@kaybee.org> 3.0-6 |
187 |
|
|
- up2date packaged... finally! |
188 |
|
|
|
189 |
|
|
* Wed May 01 2002 Kirk Bauer <kirk@kaybee.org> 3.0-5 |
190 |
|
|
- Hopefully now properly included the up2date filter! |
191 |
|
|
|
192 |
|
|
* Mon Apr 29 2002 Kirk Bauer <kirk@kaybee.org> pre3.0-1 |
193 |
|
|
- Now properly includes logfile-specific scripts |
194 |
|
|
|
195 |
|
|
* Tue Apr 09 2002 Kirk Bauer <kirk@kaybee.org> 2.8-2 |
196 |
|
|
- Made man page entry in files list backwards compatible |
197 |
|
|
|
198 |
|
|
* Thu Mar 28 2002 Kirk Bauer <kirk@kaybee.org> 2.5-2 |
199 |
|
|
- Updated new changes from Red Hat's rawhide packaging |
200 |
|
|
|
201 |
|
|
* Wed Nov 18 1998 Kirk Bauer <kirk@kaybee.org> |
202 |
|
|
- Modified to comply with RHCN standards |
203 |
|
|
|
204 |
|
|
* Sun Feb 23 1998 Kirk Bauer <kirk@kaybee.org> |
205 |
|
|
- Minor changes and addition of man-page |
206 |
|
|
|
207 |
|
|
* Sun Feb 22 1998 Kirk Bauer <kirk@kaybee.org> |
208 |
|
|
- initial release |
209 |
|
|
|