1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
|
3 |
slords |
1.1 |
Summary: Analyzes and Reports on system logs |
4 |
|
|
Name: logwatch |
5 |
|
|
Version: 7.3.2 |
6 |
|
|
Release: 3%{?dist} |
7 |
|
|
License: MIT |
8 |
|
|
Group: Utilities/System |
9 |
|
|
URL: http://www.logwatch.org |
10 |
|
|
BuildArch: noarch |
11 |
|
|
Source: ftp://ftp.kaybee.org/pub/linux/logwatch-7.3.2.tar.gz |
12 |
|
|
Patch1: logwatch-7.3.2-clamd.patch |
13 |
|
|
Patch2: logwatch-7.3.2-freshclam.patch |
14 |
|
|
Patch3: logwatch-7.3.2-iptables-multi.patch |
15 |
|
|
Patch4: logwatch-7.3.2-ntpd.patch |
16 |
|
|
Patch5: logwatch-7.3.2-oidentd-multi.patch |
17 |
|
|
Patch6: logwatch-7.3.2-proftpd.patch |
18 |
|
|
Patch7: logwatch-7.3.2-sshd-multi.patch |
19 |
|
|
Patch8: logwatch-7.3.2-yum.patch |
20 |
|
|
Patch9: logwatch-7.3.2-signaturereload.patch |
21 |
|
|
Requires: perl,textutils,sh-utils,grep,mailx |
22 |
|
|
BuildRoot: %{_tmppath}/logwatch-build/ |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
Logwatch is a customizable, pluggable log-monitoring system. It will go |
26 |
|
|
through your logs for a given period of time and make a report in the areas |
27 |
|
|
that you wish with the detail that you wish. Easy to use - works right out |
28 |
|
|
of the package on many systems. |
29 |
|
|
|
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
rm -rf %{buildroot} |
33 |
|
|
%setup |
34 |
|
|
%patch1 -p1 |
35 |
|
|
%patch2 -p1 |
36 |
|
|
%patch3 -p1 |
37 |
|
|
%patch4 -p1 |
38 |
|
|
%patch5 -p1 |
39 |
|
|
%patch6 -p1 |
40 |
|
|
%patch7 -p1 |
41 |
|
|
%patch8 -p1 |
42 |
|
|
%patch9 -p1 |
43 |
|
|
|
44 |
|
|
%build |
45 |
|
|
|
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
install -m 0755 -d %{buildroot}%{_var}/cache/logwatch |
49 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/scripts |
50 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/scripts/services |
51 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf |
52 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf/logfiles |
53 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/logwatch/conf/services |
54 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/logfiles |
55 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/services |
56 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/default.conf/html |
57 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/dist.conf/logfiles |
58 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/dist.conf/services |
59 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/scripts/services |
60 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/scripts/shared |
61 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/lib |
62 |
|
|
|
63 |
|
|
install -m 0755 scripts/logwatch.pl %{buildroot}%{_datadir}/logwatch/scripts/logwatch.pl |
64 |
|
|
for i in scripts/logfiles/* ; do |
65 |
|
|
if [ $(ls $i | wc -l) -ne 0 ] ; then |
66 |
|
|
install -m 0755 -d %{buildroot}%{_datadir}/logwatch/$i |
67 |
|
|
install -m 0755 $i/* %{buildroot}%{_datadir}/logwatch/$i |
68 |
|
|
fi |
69 |
|
|
done |
70 |
|
|
install -m 0755 scripts/services/* %{buildroot}%{_datadir}/logwatch/scripts/services |
71 |
|
|
install -m 0755 scripts/shared/* %{buildroot}%{_datadir}/logwatch/scripts/shared |
72 |
|
|
install -m 0755 lib/* %{buildroot}%{_datadir}/logwatch/lib |
73 |
|
|
|
74 |
|
|
install -m 0644 conf/*.conf %{buildroot}%{_datadir}/logwatch/default.conf |
75 |
|
|
install -m 0644 conf/logfiles/* %{buildroot}%{_datadir}/logwatch/default.conf/logfiles |
76 |
|
|
install -m 0644 conf/services/* %{buildroot}%{_datadir}/logwatch/default.conf/services |
77 |
|
|
install -m 0644 conf/html/* %{buildroot}%{_datadir}/logwatch/default.conf/html |
78 |
|
|
|
79 |
|
|
install -m 0755 -d %{buildroot}%{_mandir}/man8 |
80 |
|
|
install -m 0644 logwatch.8 %{buildroot}%{_mandir}/man8 |
81 |
|
|
|
82 |
|
|
rm -f %{buildroot}%{_sysconfdir}/cron.daily/logwatch \ |
83 |
|
|
%{buildroot}%{_sbindir}/logwatch |
84 |
|
|
|
85 |
|
|
install -m 0755 -d %{buildroot}%{_sysconfdir}/cron.daily |
86 |
|
|
ln -s %{_datadir}/logwatch/scripts/logwatch.pl %{buildroot}%{_sysconfdir}/cron.daily/0logwatch |
87 |
|
|
install -m 0755 -d %{buildroot}%{_sbindir} |
88 |
|
|
ln -s %{_datadir}/logwatch/scripts/logwatch.pl %{buildroot}%{_sbindir}/logwatch |
89 |
|
|
|
90 |
|
|
echo "###### REGULAR EXPRESSIONS IN THIS FILE WILL BE TRIMMED FROM REPORT OUTPUT #####" > %{buildroot}%{_sysconfdir}/logwatch/conf/ignore.conf |
91 |
|
|
echo "# Local configuration options go here (defaults are in %{_datadir}/logwatch/default.conf/logwatch.conf)" > %{buildroot}%{_sysconfdir}/logwatch/conf/logwatch.conf |
92 |
|
|
echo "# Configuration overrides for specific logfiles/services may be placed here." > %{buildroot}%{_sysconfdir}/logwatch/conf/override.conf |
93 |
|
|
|
94 |
|
|
ln -s clamav %{buildroot}%{_datadir}/logwatch/scripts/services/clamd |
95 |
|
|
ln -s clam-update %{buildroot}%{_datadir}/logwatch/scripts/services/freshclam |
96 |
|
|
ln -s iptables %{buildroot}%{_datadir}/logwatch/scripts/services/iptables-multi |
97 |
|
|
ln -s xntpd %{buildroot}%{_datadir}/logwatch/scripts/services/ntpd |
98 |
|
|
ln -s oidentd %{buildroot}%{_datadir}/logwatch/scripts/services/oidentd-multi |
99 |
|
|
ln -s proftpd-messages %{buildroot}%{_datadir}/logwatch/scripts/services/proftpd |
100 |
|
|
ln -s sshd %{buildroot}%{_datadir}/logwatch/scripts/services/sshd-multi |
101 |
|
|
|
102 |
|
|
%clean |
103 |
|
|
rm -rf %{buildroot} |
104 |
|
|
|
105 |
|
|
%post |
106 |
|
|
|
107 |
|
|
|
108 |
|
|
%pre |
109 |
|
|
|
110 |
|
|
|
111 |
|
|
%preun |
112 |
|
|
|
113 |
|
|
|
114 |
|
|
%postun |
115 |
|
|
|
116 |
|
|
|
117 |
|
|
%files |
118 |
|
|
%defattr(-,root,root) |
119 |
|
|
%doc README HOWTO-Customize-LogWatch |
120 |
|
|
%dir %{_var}/cache/logwatch |
121 |
|
|
%dir %{_sysconfdir}/logwatch |
122 |
|
|
%dir %{_sysconfdir}/logwatch/scripts |
123 |
|
|
%dir %{_sysconfdir}/logwatch/scripts/services |
124 |
|
|
%dir %{_sysconfdir}/logwatch/conf |
125 |
|
|
%dir %{_sysconfdir}/logwatch/conf/logfiles |
126 |
|
|
%dir %{_sysconfdir}/logwatch/conf/services |
127 |
|
|
%dir %{_datadir}/logwatch |
128 |
|
|
%dir %{_datadir}/logwatch/default.conf |
129 |
|
|
%dir %{_datadir}/logwatch/default.conf/services |
130 |
|
|
%dir %{_datadir}/logwatch/default.conf/logfiles |
131 |
|
|
%dir %{_datadir}/logwatch/default.conf/html |
132 |
|
|
%dir %{_datadir}/logwatch/dist.conf |
133 |
|
|
%dir %{_datadir}/logwatch/dist.conf/services |
134 |
|
|
%dir %{_datadir}/logwatch/dist.conf/logfiles |
135 |
|
|
%dir %{_datadir}/logwatch/scripts |
136 |
|
|
%dir %{_datadir}/logwatch/scripts/logfiles |
137 |
|
|
%dir %{_datadir}/logwatch/scripts/services |
138 |
|
|
%dir %{_datadir}/logwatch/scripts/shared |
139 |
|
|
%dir %{_datadir}/logwatch/scripts/logfiles/* |
140 |
|
|
%dir %{_datadir}/logwatch/lib |
141 |
|
|
%{_datadir}/logwatch/scripts/logwatch.pl |
142 |
|
|
%{_sbindir}/logwatch |
143 |
|
|
%{_datadir}/logwatch/scripts/shared/* |
144 |
|
|
%{_datadir}/logwatch/scripts/services/* |
145 |
|
|
%{_datadir}/logwatch/scripts/logfiles/*/* |
146 |
|
|
%{_datadir}/logwatch/lib/Logwatch.pm |
147 |
|
|
%{_datadir}/logwatch/default.conf/*.conf |
148 |
|
|
%{_datadir}/logwatch/default.conf/services/*.conf |
149 |
|
|
%{_datadir}/logwatch/default.conf/logfiles/*.conf |
150 |
|
|
%{_datadir}/logwatch/default.conf/html/*.html |
151 |
|
|
%{_sysconfdir}/cron.daily/0logwatch |
152 |
|
|
%doc %{_mandir}/man8/logwatch.8* |
153 |
|
|
%config(noreplace) %{_sysconfdir}/logwatch/conf/*.conf |
154 |
|
|
|
155 |
|
|
%doc License project/CHANGES project/TODO |
156 |
|
|
|
157 |
|
|
%changelog |
158 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
159 |
|
|
- Clean up spec so package can be built by koji/plague |
160 |
|
|
|
161 |
|
|
* Fri Feb 16 2007 Shad L. Lords <slords@mail.com> 7.3.2-3 |
162 |
|
|
- Update reload detection form clamav v0.90 |
163 |
|
|
|
164 |
|
|
* Fri Dec 29 2006 Shad L. Lords <slords@mail.com> 7.3.2-2 |
165 |
|
|
- Add log entries for smeserver multilog services |
166 |
|
|
|
167 |
|
|
* Fri Sep 15 2006 Kirk Bauer <kirk@kaybee.org> 7.3.1-1 |
168 |
|
|
- Fixed install script to create empty scripts directory in /etc |
169 |
|
|
|
170 |
|
|
* Sat Oct 08 2005 Kirk Bauer <kirk@kaybee.org> pre7.0-1 |
171 |
|
|
- Numerous changes, most notably a whole new directory structure. |
172 |
|
|
|
173 |
|
|
* Thu Feb 24 2005 Kirk Bauer <kirk@kaybee.org> 6.0.1-1 |
174 |
|
|
- Now includes ignore.conf in the RPM |
175 |
|
|
|
176 |
|
|
* Mon Nov 03 2003 Kirk Bauer <kirk@kaybee.org> pre5.0-1 |
177 |
|
|
- Now can build without change as non-root user |
178 |
|
|
|
179 |
|
|
* Thu Feb 27 2003 Erik Ogan <erik@ogan.net> 4.3.2 |
180 |
|
|
- Added libdir & lib/Logwatch.pm |
181 |
|
|
|
182 |
|
|
* Sun Oct 13 2002 Kirk Bauer <kirk@kaybee.org> pre4.0-14 |
183 |
|
|
- Changed the 'logwatch' cron.daily job to '0logwatch' to run before logrotate |
184 |
|
|
|
185 |
|
|
* Thu Oct 10 2002 Kirk Bauer <kirk@kaybee.org> pre4.0-1 |
186 |
|
|
- Cronjob is now just named logwatch and not 00-logwatch |
187 |
|
|
|
188 |
|
|
* Wed May 01 2002 Kirk Bauer <kirk@kaybee.org> 3.0-6 |
189 |
|
|
- up2date packaged... finally! |
190 |
|
|
|
191 |
|
|
* Wed May 01 2002 Kirk Bauer <kirk@kaybee.org> 3.0-5 |
192 |
|
|
- Hopefully now properly included the up2date filter! |
193 |
|
|
|
194 |
|
|
* Mon Apr 29 2002 Kirk Bauer <kirk@kaybee.org> pre3.0-1 |
195 |
|
|
- Now properly includes logfile-specific scripts |
196 |
|
|
|
197 |
|
|
* Tue Apr 09 2002 Kirk Bauer <kirk@kaybee.org> 2.8-2 |
198 |
|
|
- Made man page entry in files list backwards compatible |
199 |
|
|
|
200 |
|
|
* Thu Mar 28 2002 Kirk Bauer <kirk@kaybee.org> 2.5-2 |
201 |
|
|
- Updated new changes from Red Hat's rawhide packaging |
202 |
|
|
|
203 |
|
|
* Wed Nov 18 1998 Kirk Bauer <kirk@kaybee.org> |
204 |
|
|
- Modified to comply with RHCN standards |
205 |
|
|
|
206 |
|
|
* Sun Feb 23 1998 Kirk Bauer <kirk@kaybee.org> |
207 |
|
|
- Minor changes and addition of man-page |
208 |
|
|
|
209 |
|
|
* Sun Feb 22 1998 Kirk Bauer <kirk@kaybee.org> |
210 |
|
|
- initial release |
211 |
|
|
|