1 |
jpp |
1.1 |
%global _hardened_build 1 |
2 |
|
|
|
3 |
|
|
Summary: Mail delivery agent with filtering abilities |
4 |
|
|
Name: maildrop |
5 |
|
|
Version: 2.8.4 |
6 |
jpp |
1.2 |
Release: 2%{?dist} |
7 |
jpp |
1.1 |
# Exception is explicit permission to link to OpenSSL |
8 |
|
|
License: GPLv2 with exceptions |
9 |
|
|
Group: System Environment/Daemons |
10 |
|
|
URL: http://www.courier-mta.org/maildrop/ |
11 |
|
|
Source0: http://prdownloads.sourceforge.net/courier/%{name}/%{version}/%{name}-%{version}.tar.bz2 |
12 |
|
|
Source1: http://prdownloads.sourceforge.net/courier/%{name}/%{version}/%{name}-%{version}.tar.bz2.sig |
13 |
|
|
Source2: pubkey.maildrop |
14 |
|
|
|
15 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
16 |
|
|
Requires: courier-unicode >= 1.1 |
17 |
|
|
BuildRequires: automake, libtool, autoconf |
18 |
|
|
BuildRequires: gcc-c++, gdbm-devel, db4-devel, pcre-devel |
19 |
|
|
BuildRequires: gawk |
20 |
|
|
BuildRequires: gnupg |
21 |
|
|
BuildRequires: courier-unicode-devel >= 1.1 |
22 |
|
|
#Once this is available uncomment and rebuild |
23 |
|
|
#BuildRequires: courier-authlib-devel |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
maildrop is the mail filter/mail delivery agent that's used by the |
27 |
|
|
Courier Mail Server. This is a standalone build of the maildrop mail |
28 |
|
|
filter that can be used with other mail servers. |
29 |
|
|
|
30 |
|
|
maildrop is a replacement for your local mail delivery agent. maildrop |
31 |
|
|
reads a mail message from standard input, then delivers the message to |
32 |
|
|
your mailbox. maildrop knows how to deliver mail to mbox-style |
33 |
|
|
mailboxes, and maildirs. |
34 |
|
|
|
35 |
|
|
maildrop optionally reads instructions from a file, which describe how |
36 |
|
|
to filter incoming mail. These instructions can direct maildrop to |
37 |
|
|
deliver the message to an alternate mailbox, or forward it somewhere |
38 |
|
|
else. Unlike procmail, maildrop uses a structured filtering language. |
39 |
|
|
|
40 |
|
|
maildrop is written in C++, and is significantly larger than |
41 |
|
|
procmail. However, it uses resources much more efficiently. Unlike |
42 |
|
|
procmail, maildrop will not read a 10 megabyte mail message into |
43 |
|
|
memory. Large messages are saved in a temporary file, and are filtered |
44 |
|
|
from the temporary file. If the standard input to maildrop is a file, |
45 |
|
|
and not a pipe, a temporary file will not be necessary. |
46 |
|
|
|
47 |
|
|
maildrop checks the mail delivery instruction syntax from the filter |
48 |
|
|
file, before attempting to deliver a message. Unlike procmail, if the |
49 |
|
|
filter file contains syntax errors, maildrop terminates without |
50 |
|
|
delivering the message. The user can fix the typo without causing any |
51 |
|
|
mail to be lost. |
52 |
|
|
|
53 |
|
|
%prep |
54 |
|
|
%setup -q |
55 |
|
|
gpg --import %{SOURCE2} |
56 |
|
|
gpg --verify %{SOURCE1} %{SOURCE0} |
57 |
|
|
|
58 |
|
|
%build |
59 |
|
|
%configure --disable-shared \ |
60 |
|
|
--enable-use-flock=1 --with-locking-method=fcntl \ |
61 |
|
|
--enable-use-dotlock=1 \ |
62 |
|
|
--enable-syslog=1 \ |
63 |
|
|
--enable-sendmail=%{_sbindir}/sendmail |
64 |
|
|
# prevent 'install: will not overwrite just-created' error |
65 |
|
|
# notification sent to courier-maildrop@lists.sourceforge.net on 2009/09/04 |
66 |
|
|
#sed -i 's|DELIVERQUOTAMAN = maildirquota.7 deliverquota.8|DELIVERQUOTAMAN =|' Makefile |
67 |
|
|
make |
68 |
|
|
|
69 |
|
|
%install |
70 |
|
|
rm -rf %{buildroot} |
71 |
|
|
make install DESTDIR=%{buildroot} htmldir=%{_defaultdocdir}/%{name} |
72 |
|
|
cp -pr COPYING COPYING.GPL AUTHORS %{buildroot}%{_defaultdocdir}/%{name} |
73 |
|
|
cp -pr README README.postfix ChangeLog UPGRADE %{buildroot}%{_defaultdocdir}/%{name} |
74 |
|
|
|
75 |
|
|
%clean |
76 |
|
|
rm -rf %{buildroot} |
77 |
|
|
|
78 |
|
|
%files |
79 |
|
|
%defattr(-,root,root,-) |
80 |
|
|
%doc %{_defaultdocdir}/%{name} |
81 |
|
|
%attr(6755,root,mail) %{_bindir}/maildrop |
82 |
|
|
%attr(6755,root,mail) %{_bindir}/lockmail |
83 |
|
|
%{_bindir}/deliverquota |
84 |
|
|
%{_bindir}/mailbot |
85 |
|
|
%{_bindir}/maildirmake |
86 |
|
|
%{_bindir}/makemime |
87 |
|
|
%{_bindir}/reformail |
88 |
|
|
%{_bindir}/reformime |
89 |
|
|
%{_bindir}/makedat |
90 |
|
|
%{_bindir}/makedatprog |
91 |
|
|
%{_mandir}/man1/*.1* |
92 |
|
|
%{_mandir}/man5/*.5* |
93 |
|
|
%{_mandir}/man7/*.7* |
94 |
|
|
%{_mandir}/man8/*.8* |
95 |
|
|
|
96 |
|
|
%changelog |
97 |
jpp |
1.2 |
* Sun Apr 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> - 2.8.1-2 |
98 |
|
|
- import to SME10 |
99 |
|
|
|
100 |
jpp |
1.1 |
* Wed Sep 07 2016 Nux <rpm@li.nux.ro> - 2.8.4-1 |
101 |
|
|
- update to 2.8.4 |
102 |
|
|
|
103 |
|
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-3 |
104 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
105 |
|
|
|
106 |
|
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.8.1-2 |
107 |
|
|
- Rebuilt for GCC 5 C++11 ABI change |
108 |
|
|
|
109 |
|
|
* Tue Feb 17 2015 Brian C. Lane <bcl@redhat.com> 2.8.1-1 |
110 |
|
|
- Update to 2.8.1 |
111 |
|
|
- Add courier-unicode requirement |
112 |
|
|
|
113 |
|
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-3 |
114 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild |
115 |
|
|
|
116 |
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2 |
117 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
118 |
|
|
|
119 |
|
|
* Fri Jan 10 2014 Brian C. Lane <bcl@redhat.com> 2.7.1-1 |
120 |
|
|
- Update to 2.7.1 |
121 |
|
|
|
122 |
|
|
* Thu Sep 26 2013 Brian C. Lane <bcl@redhat.com> 2.6.0-4 |
123 |
|
|
- Remove version from the doc directory name (#993910) |
124 |
|
|
|
125 |
|
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.0-3 |
126 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
127 |
|
|
|
128 |
|
|
* Sat May 25 2013 Bruno Wolff III <bruno@wolff.to> 2.6.0-2 |
129 |
|
|
- Build with global hardening as maildrop has setuid binaries and reads untrusted input |
130 |
|
|
|
131 |
|
|
* Sat Mar 16 2013 Brian C. Lane <bcl@redhat.com> 2.6.0-1 |
132 |
|
|
- Update to 2.6.0 |
133 |
|
|
|
134 |
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.0-18 |
135 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
136 |
|
|
|
137 |
|
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.0-17 |
138 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
139 |
|
|
|
140 |
|
|
* Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 2.5.0-16 |
141 |
|
|
- Rebuild against PCRE 8.30 |
142 |
|
|
|
143 |
|
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.0-15 |
144 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
145 |
|
|
|
146 |
|
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.0-14 |
147 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
148 |
|
|
|
149 |
|
|
* Mon Jul 5 2010 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.5.0-13 |
150 |
|
|
- Update to 2.5.0. |
151 |
|
|
|
152 |
|
|
* Sun Feb 14 2010 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.4.0-12 |
153 |
|
|
- Update to 2.4.0. |
154 |
|
|
- Fixes CVE-2010-0301. |
155 |
|
|
|
156 |
|
|
* Fri Sep 4 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 2.0.4-11 |
157 |
|
|
- Fix FTBFS: prevent 'install: will not overwrite just-created' error |
158 |
|
|
|
159 |
|
|
* Wed May 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.4-7 |
160 |
|
|
- fix license tag |
161 |
|
|
|
162 |
|
|
* Sat Mar 8 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.0.4-6 |
163 |
|
|
- Try a better license tag. |
164 |
|
|
- Remove all devel parts - this is not upstream-ready yet. |
165 |
|
|
- Make the build verbose. |
166 |
|
|
|
167 |
|
|
* Sun Jan 13 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.0.4-5 |
168 |
|
|
- Go static. |
169 |
|
|
|
170 |
|
|
* Wed Oct 24 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.0.4-4 |
171 |
|
|
- Add gawk to build dependencies. |
172 |
|
|
|
173 |
|
|
* Sat Aug 4 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.0.4-3 |
174 |
|
|
- Update to 2.0.4. |
175 |
|
|
|
176 |
|
|
* Sun Mar 25 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.0.3-2 |
177 |
|
|
- Initial build. |
178 |
|
|
|