1 |
slords |
1.1 |
Summary: mdadm controls Linux md devices (software RAID arrays) |
2 |
|
|
Name: mdadm |
3 |
|
|
Version: 1.12.0 |
4 |
slords |
1.2 |
Release: 5.1%{?dist} |
5 |
slords |
1.1 |
Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz |
6 |
|
|
Source1: mdmonitor.init |
7 |
|
|
Source2: mdmpd-0.4.tgz |
8 |
|
|
Source3: mdmpd.init |
9 |
|
|
Patch1: mdadm-1.5.0-email.patch |
10 |
|
|
Patch2: mdadm-1.12.0-super-minor.patch |
11 |
|
|
Patch3: mdadm-1.12.0-s390.patch |
12 |
|
|
URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/ |
13 |
|
|
License: GPL |
14 |
|
|
Group: System Environment/Base |
15 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
16 |
|
|
Obsoletes: mdctl |
17 |
|
|
Requires: smtpdaemon |
18 |
|
|
BuildRequires: dietlibc |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
mdadm is used to create, manage, and monitor Linux MD (software RAID) |
22 |
|
|
devices. As such, it provides similar functionality to the raidtools |
23 |
|
|
package. However, mdadm is a single program, and it can perform |
24 |
|
|
almost all functions without a configuration file, though a configuration |
25 |
|
|
file can be used to help with some common tasks. |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup -q -a 2 |
29 |
|
|
%patch1 -p1 -b .email |
30 |
|
|
%patch2 -p1 -b .super-minor |
31 |
|
|
%patch3 -p1 -b .s390 |
32 |
|
|
|
33 |
|
|
%build |
34 |
|
|
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm |
35 |
|
|
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" -C mdmpd mdmpd |
36 |
|
|
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdassemble |
37 |
|
|
|
38 |
|
|
%install |
39 |
|
|
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install |
40 |
|
|
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin -C mdmpd install |
41 |
|
|
install -D -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor |
42 |
|
|
install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT/%{_initrddir}/mdmpd |
43 |
|
|
|
44 |
|
|
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdmpd |
45 |
|
|
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm |
46 |
|
|
|
47 |
|
|
install -D -m750 mdassemble $RPM_BUILD_ROOT/sbin/mdassemble |
48 |
|
|
|
49 |
|
|
%clean |
50 |
|
|
[ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT |
51 |
|
|
|
52 |
|
|
%post |
53 |
|
|
/sbin/chkconfig --add mdmonitor |
54 |
|
|
/sbin/chkconfig --add mdmpd |
55 |
|
|
|
56 |
|
|
%preun |
57 |
|
|
if [ "$1" = 0 ]; then |
58 |
|
|
service mdmonitor stop > /dev/null 2>&1 ||: |
59 |
|
|
/sbin/chkconfig --del mdmonitor |
60 |
|
|
if [ -e %{_initrddir}/mdmpd ]; then |
61 |
|
|
service mdmpd stop > /dev/null 2>&1 ||: |
62 |
|
|
/sbin/chkconfig --del mdmpd |
63 |
|
|
fi |
64 |
|
|
fi |
65 |
|
|
|
66 |
|
|
%postun |
67 |
|
|
if [ "$1" -ge "1" ]; then |
68 |
|
|
service mdmonitor condrestart > /dev/null 2>&1 |
69 |
|
|
if [ -e %{_initrddir}/mdmpd ]; then |
70 |
|
|
service mdmpd condrestart > /dev/null 2>&1 |
71 |
|
|
fi |
72 |
|
|
fi |
73 |
|
|
|
74 |
|
|
%files |
75 |
|
|
%defattr(-,root,root) |
76 |
|
|
%doc TODO ChangeLog mdadm.conf-example COPYING |
77 |
|
|
/sbin/* |
78 |
|
|
%{_initrddir}/* |
79 |
|
|
%{_mandir}/man*/md* |
80 |
|
|
%attr(0700,root,root) %dir /var/run/mdmpd |
81 |
|
|
%attr(0700,root,root) %dir /var/run/mdadm |
82 |
|
|
|
83 |
|
|
%changelog |
84 |
slords |
1.2 |
* Fri Nov 30 2007 Shad L. Lords <slords@mail.com> 1.12.0-5.1.sme |
85 |
slords |
1.1 |
- Clean up spec so package can be built by koji/plague |
86 |
|
|
- Add mdassemble [SME: 961] |
87 |
|
|
|
88 |
slords |
1.2 |
* Fri Aug 10 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-5 |
89 |
|
|
- Further tweaks to the mdmpd init script for LSB compliance |
90 |
|
|
- Related: bz242687 |
91 |
|
|
|
92 |
|
|
* Wed Aug 08 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-4 |
93 |
|
|
- Further tweaks to init script for LSB compliance |
94 |
|
|
- Related: bz242687 |
95 |
|
|
|
96 |
|
|
* Mon Aug 06 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-3 |
97 |
|
|
- Make init scripts LSB compliant |
98 |
|
|
- Always start mdadm from the / directory when starting the mdmonitor service |
99 |
|
|
to avoid SELinux warnings whenever mdadm attempts to send mail to the admin |
100 |
|
|
about a degraded array event |
101 |
|
|
- Resolves: bz242687 |
102 |
|
|
|
103 |
slords |
1.1 |
* Wed Jan 31 2007 Doug Ledford <dledford@redhat.com> 1.12.0-2 |
104 |
|
|
- Remove spurious super-minor once, super-minor=1 ignored messages |
105 |
|
|
- Attempt to catch overly large linear constituent devices and avoid |
106 |
|
|
a math overflow in the kernel linear code |
107 |
|
|
- Resolves: bz150784, bz170327 |
108 |
|
|
|
109 |
|
|
* Fri Jan 26 2007 Doug Ledford <dledford@redhat.com> 1.12.0-1 |
110 |
|
|
- Update to 1.12.0, the last version in the 1. series of mdadm (the 2. series |
111 |
|
|
was a rewrite and is not suitable for update in a stable product such as |
112 |
|
|
RHEL4) |
113 |
|
|
- Resolves: bz201067, bz154561, bz171355, bz199033 |
114 |
|
|
|
115 |
|
|
* Thu Jul 21 2005 Doug Ledford <dledford@redhat.com> 1.6.0-3 |
116 |
|
|
- Convert from using MAJOR/MINOR macros to major/minor so that it can |
117 |
|
|
handle the increased number of devices available in the 2.6 kernel. |
118 |
|
|
|
119 |
|
|
* Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2 |
120 |
|
|
- Remove /etc/mdadm.conf from the file list. Anaconda will write one out |
121 |
|
|
if it's needed. |
122 |
|
|
|
123 |
|
|
* Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1 |
124 |
|
|
- Update to newer upstream version |
125 |
|
|
- Make mdmpd work on kernels that don't have the event interface patch |
126 |
|
|
|
127 |
|
|
* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11 |
128 |
|
|
- Create a directory /var/run/mdadm to contain mdadm.pid |
129 |
|
|
- This cleans up SELinux problem |
130 |
|
|
|
131 |
|
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> |
132 |
|
|
- rebuilt |
133 |
|
|
|
134 |
|
|
* Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9 |
135 |
|
|
- Fix Makefile and build method to satisfy bz #123769 |
136 |
|
|
- Add mdmpd man page, update mdmpd version to 0.3 - bz #117160 |
137 |
|
|
- Make sure mdadm --monitor closes all md device files so that md devices |
138 |
|
|
can be stopped while mdadm is still running - bz #119532 |
139 |
|
|
|
140 |
|
|
* Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8 |
141 |
|
|
- remove unneeded patch, can use --run instead |
142 |
|
|
|
143 |
|
|
* Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7 |
144 |
|
|
- add patch with reallyforce mode on creation to be used by anaconda |
145 |
|
|
|
146 |
|
|
* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6 |
147 |
|
|
- Fix a bug in the %postun scriptlet related to downgrading to a version |
148 |
|
|
of mdadm that doesn't include the mdmpd daemon. |
149 |
|
|
|
150 |
|
|
* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5 |
151 |
|
|
- Disable service mdmpd by default to avoid [Failed] messages on |
152 |
|
|
current 2.6 kernels. Possibly re-enable it by default once the |
153 |
|
|
2.6 kernels have the md event interface. |
154 |
|
|
|
155 |
|
|
* Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4 |
156 |
|
|
- Update mdmonitor script to start daemon more cleanly |
157 |
|
|
- Repackage mdmpd tarball to include gcc-3.4 changes and to make |
158 |
|
|
mdmpd properly daemonize at startup instead of forking and leaving |
159 |
|
|
the child attached to the terminal. |
160 |
|
|
|
161 |
|
|
* Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3 |
162 |
|
|
- ship /var/run/mpmpd (#117497) |
163 |
|
|
|
164 |
|
|
* Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2 |
165 |
|
|
- Add a default MAILADDR line to the mdadm.conf file installed by default |
166 |
|
|
(Bugzilla #92447) |
167 |
|
|
- Make it build with gcc-3.4 |
168 |
|
|
|
169 |
|
|
* Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1 |
170 |
|
|
- Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>) |
171 |
|
|
|
172 |
|
|
* Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1 |
173 |
|
|
- fix problem with recovery thread sleeping in mdmpd |
174 |
|
|
|
175 |
|
|
* Fri Nov 14 2003 Doug Ledford <dledford@redhat.com> |
176 |
|
|
- sync upstream |
177 |
|
|
- add mdmpd package into mdadm package |
178 |
|
|
|
179 |
|
|
* Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1 |
180 |
|
|
- sync upstream |
181 |
|
|
|
182 |
|
|
* Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1 |
183 |
|
|
- sync upstream |
184 |
|
|
|
185 |
|
|
* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1 |
186 |
|
|
- update for rebuild |
187 |
|
|
|
188 |
|
|
* Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8 |
189 |
|
|
- fix references to %%install in the changelog so that it will build |
190 |
|
|
|
191 |
|
|
* Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7 |
192 |
|
|
- Rebuild |
193 |
|
|
|
194 |
|
|
* Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com> |
195 |
|
|
- Changed RPM Group to System Environment/Base |
196 |
|
|
|
197 |
|
|
* Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com> |
198 |
|
|
- minor cleanups to the text, conditionalize rm -rf |
199 |
|
|
- added mdmonitor init script |
200 |
|
|
|
201 |
|
|
* Fri May 10 2002 <neilb@cse.unsw.edu.au> |
202 |
|
|
- update to 1.0.0 |
203 |
|
|
- Set CXFLAGS instead of CFLAGS |
204 |
|
|
|
205 |
|
|
* Sat Apr 6 2002 <neilb@cse.unsw.edu.au> |
206 |
|
|
- change %%install to use "make install" |
207 |
|
|
|
208 |
|
|
* Fri Mar 15 2002 <gleblanc@localhost.localdomain> |
209 |
|
|
- beautification |
210 |
|
|
- made mdadm.conf non-replaceable config |
211 |
|
|
- renamed Copyright to License in the header |
212 |
|
|
- added missing license file |
213 |
|
|
- used macros for file paths |
214 |
|
|
|
215 |
|
|
* Fri Mar 15 2002 Luca Berra <bluca@comedia.it> |
216 |
|
|
- Added Obsoletes: mdctl |
217 |
|
|
- missingok for configfile |
218 |
|
|
|
219 |
|
|
* Wed Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au> |
220 |
|
|
- Add md.4 and mdadm.conf.5 man pages |
221 |
|
|
|
222 |
|
|
* Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca> |
223 |
|
|
- builds properly as non-root. |
224 |
|
|
|
225 |
|
|
* Fri Mar 08 2002 Derek Vadala <derek@cynicism.com> |
226 |
|
|
- updated for 0.7, fixed /usr/share/doc and added manpage |
227 |
|
|
|
228 |
|
|
* Tue Aug 07 2001 Danilo Godec <danci@agenda.si> |
229 |
|
|
- initial RPM build |