/[smeserver]/rpms/mdadm/sme7/mdadm.spec
ViewVC logotype

Annotation of /rpms/mdadm/sme7/mdadm.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Apr 9 13:51:51 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +2 -0 lines
Add Id to top of spec

1 slords 1.3 # $Id$
2    
3 slords 1.1 Summary: mdadm controls Linux md devices (software RAID arrays)
4     Name: mdadm
5     Version: 1.12.0
6 slords 1.2 Release: 5.1%{?dist}
7 slords 1.1 Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz
8     Source1: mdmonitor.init
9     Source2: mdmpd-0.4.tgz
10     Source3: mdmpd.init
11     Patch1: mdadm-1.5.0-email.patch
12     Patch2: mdadm-1.12.0-super-minor.patch
13     Patch3: mdadm-1.12.0-s390.patch
14     URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/
15     License: GPL
16     Group: System Environment/Base
17     BuildRoot: %{_tmppath}/%{name}-root
18     Obsoletes: mdctl
19     Requires: smtpdaemon
20     BuildRequires: dietlibc
21    
22     %description
23     mdadm is used to create, manage, and monitor Linux MD (software RAID)
24     devices. As such, it provides similar functionality to the raidtools
25     package. However, mdadm is a single program, and it can perform
26     almost all functions without a configuration file, though a configuration
27     file can be used to help with some common tasks.
28    
29     %prep
30     %setup -q -a 2
31     %patch1 -p1 -b .email
32     %patch2 -p1 -b .super-minor
33     %patch3 -p1 -b .s390
34    
35     %build
36     make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm
37     make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" -C mdmpd mdmpd
38     make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdassemble
39    
40     %install
41     make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install
42     make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin -C mdmpd install
43     install -D -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor
44     install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT/%{_initrddir}/mdmpd
45    
46     mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdmpd
47     mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm
48    
49     install -D -m750 mdassemble $RPM_BUILD_ROOT/sbin/mdassemble
50    
51     %clean
52     [ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
53    
54     %post
55     /sbin/chkconfig --add mdmonitor
56     /sbin/chkconfig --add mdmpd
57    
58     %preun
59     if [ "$1" = 0 ]; then
60     service mdmonitor stop > /dev/null 2>&1 ||:
61     /sbin/chkconfig --del mdmonitor
62     if [ -e %{_initrddir}/mdmpd ]; then
63     service mdmpd stop > /dev/null 2>&1 ||:
64     /sbin/chkconfig --del mdmpd
65     fi
66     fi
67    
68     %postun
69     if [ "$1" -ge "1" ]; then
70     service mdmonitor condrestart > /dev/null 2>&1
71     if [ -e %{_initrddir}/mdmpd ]; then
72     service mdmpd condrestart > /dev/null 2>&1
73     fi
74     fi
75    
76     %files
77     %defattr(-,root,root)
78     %doc TODO ChangeLog mdadm.conf-example COPYING
79     /sbin/*
80     %{_initrddir}/*
81     %{_mandir}/man*/md*
82     %attr(0700,root,root) %dir /var/run/mdmpd
83     %attr(0700,root,root) %dir /var/run/mdadm
84    
85     %changelog
86 slords 1.2 * Fri Nov 30 2007 Shad L. Lords <slords@mail.com> 1.12.0-5.1.sme
87 slords 1.1 - Clean up spec so package can be built by koji/plague
88     - Add mdassemble [SME: 961]
89    
90 slords 1.2 * Fri Aug 10 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-5
91     - Further tweaks to the mdmpd init script for LSB compliance
92     - Related: bz242687
93    
94     * Wed Aug 08 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-4
95     - Further tweaks to init script for LSB compliance
96     - Related: bz242687
97    
98     * Mon Aug 06 2007 Doug Ledford <dledford@redhat.com> - 1.12.0-3
99     - Make init scripts LSB compliant
100     - Always start mdadm from the / directory when starting the mdmonitor service
101     to avoid SELinux warnings whenever mdadm attempts to send mail to the admin
102     about a degraded array event
103     - Resolves: bz242687
104    
105 slords 1.1 * Wed Jan 31 2007 Doug Ledford <dledford@redhat.com> 1.12.0-2
106     - Remove spurious super-minor once, super-minor=1 ignored messages
107     - Attempt to catch overly large linear constituent devices and avoid
108     a math overflow in the kernel linear code
109     - Resolves: bz150784, bz170327
110    
111     * Fri Jan 26 2007 Doug Ledford <dledford@redhat.com> 1.12.0-1
112     - Update to 1.12.0, the last version in the 1. series of mdadm (the 2. series
113     was a rewrite and is not suitable for update in a stable product such as
114     RHEL4)
115     - Resolves: bz201067, bz154561, bz171355, bz199033
116    
117     * Thu Jul 21 2005 Doug Ledford <dledford@redhat.com> 1.6.0-3
118     - Convert from using MAJOR/MINOR macros to major/minor so that it can
119     handle the increased number of devices available in the 2.6 kernel.
120    
121     * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
122     - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
123     if it's needed.
124    
125     * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
126     - Update to newer upstream version
127     - Make mdmpd work on kernels that don't have the event interface patch
128    
129     * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
130     - Create a directory /var/run/mdadm to contain mdadm.pid
131     - This cleans up SELinux problem
132    
133     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
134     - rebuilt
135    
136     * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
137     - Fix Makefile and build method to satisfy bz #123769
138     - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
139     - Make sure mdadm --monitor closes all md device files so that md devices
140     can be stopped while mdadm is still running - bz #119532
141    
142     * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
143     - remove unneeded patch, can use --run instead
144    
145     * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
146     - add patch with reallyforce mode on creation to be used by anaconda
147    
148     * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
149     - Fix a bug in the %postun scriptlet related to downgrading to a version
150     of mdadm that doesn't include the mdmpd daemon.
151    
152     * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
153     - Disable service mdmpd by default to avoid [Failed] messages on
154     current 2.6 kernels. Possibly re-enable it by default once the
155     2.6 kernels have the md event interface.
156    
157     * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
158     - Update mdmonitor script to start daemon more cleanly
159     - Repackage mdmpd tarball to include gcc-3.4 changes and to make
160     mdmpd properly daemonize at startup instead of forking and leaving
161     the child attached to the terminal.
162    
163     * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
164     - ship /var/run/mpmpd (#117497)
165    
166     * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
167     - Add a default MAILADDR line to the mdadm.conf file installed by default
168     (Bugzilla #92447)
169     - Make it build with gcc-3.4
170    
171     * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
172     - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
173    
174     * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
175     - fix problem with recovery thread sleeping in mdmpd
176    
177     * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
178     - sync upstream
179     - add mdmpd package into mdadm package
180    
181     * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
182     - sync upstream
183    
184     * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
185     - sync upstream
186    
187     * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
188     - update for rebuild
189    
190     * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
191     - fix references to %%install in the changelog so that it will build
192    
193     * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
194     - Rebuild
195    
196     * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
197     - Changed RPM Group to System Environment/Base
198    
199     * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
200     - minor cleanups to the text, conditionalize rm -rf
201     - added mdmonitor init script
202    
203     * Fri May 10 2002 <neilb@cse.unsw.edu.au>
204     - update to 1.0.0
205     - Set CXFLAGS instead of CFLAGS
206    
207     * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
208     - change %%install to use "make install"
209    
210     * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
211     - beautification
212     - made mdadm.conf non-replaceable config
213     - renamed Copyright to License in the header
214     - added missing license file
215     - used macros for file paths
216    
217     * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
218     - Added Obsoletes: mdctl
219     - missingok for configfile
220    
221     * Wed Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
222     - Add md.4 and mdadm.conf.5 man pages
223    
224     * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
225     - builds properly as non-root.
226    
227     * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
228     - updated for 0.7, fixed /usr/share/doc and added manpage
229    
230     * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
231     - initial RPM build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed