1 |
slords |
1.1 |
Summary: mdadm controls Linux md devices (software RAID arrays) |
2 |
|
|
Name: mdadm |
3 |
|
|
Version: 2.5.4 |
4 |
|
|
Release: 3%{?dist} |
5 |
|
|
Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz |
6 |
|
|
Source1: mdmonitor.init |
7 |
|
|
Source2: mdmpd-0.4.tgz |
8 |
|
|
Source3: mdmpd.init |
9 |
|
|
Source4: mdassemble.8 |
10 |
|
|
Patch: mdadm-1.5.0-email.patch |
11 |
|
|
Patch1: mdmpd-0.4-node.patch |
12 |
|
|
Patch2: mdadm-2.5.2-s390-build.patch |
13 |
|
|
Patch3: mdadm-2.5.2-static.patch |
14 |
|
|
Patch4: mdadm-2.5.4-guid-printout.patch |
15 |
|
|
Patch5: mdadm-2.2-nodiet.patch |
16 |
|
|
Patch6: mdadm-2.5.2-cflags.patch |
17 |
|
|
Patch7: mdadm-2.3.1-fswab64.patch |
18 |
|
|
URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/ |
19 |
|
|
License: GPL |
20 |
|
|
Group: System Environment/Base |
21 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
22 |
|
|
Obsoletes: mdctl,raidtools |
23 |
|
|
Requires: smtpdaemon |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
mdadm is used to create, manage, and monitor Linux MD (software RAID) |
27 |
|
|
devices. As such, it provides similar functionality to the raidtools |
28 |
|
|
package. However, mdadm is a single program, and it can perform |
29 |
|
|
almost all functions without a configuration file, though a configuration |
30 |
|
|
file can be used to help with some common tasks. |
31 |
|
|
|
32 |
|
|
%prep |
33 |
|
|
%setup -q -a 2 |
34 |
|
|
%patch -p1 -b .email |
35 |
|
|
%patch1 -p1 -b .node |
36 |
|
|
%patch2 -p1 -b .s390 |
37 |
|
|
%patch3 -p1 -b .static |
38 |
|
|
%patch4 -p1 -b .printout |
39 |
|
|
%patch5 -p1 -b .nodiet |
40 |
|
|
%patch6 -p1 -b .cflags |
41 |
|
|
#%patch7 -p1 -b .fswab64 |
42 |
|
|
%build |
43 |
|
|
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" MDASSEMBLE_AUTO=1 mdadm mdadm.static mdassemble.static |
44 |
|
|
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" -C mdmpd mdmpd |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install |
48 |
|
|
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin -C mdmpd install |
49 |
|
|
install -D -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor |
50 |
|
|
install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT/%{_initrddir}/mdmpd |
51 |
|
|
install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_mandir}/man8/mdassemble.8 |
52 |
|
|
|
53 |
|
|
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdmpd |
54 |
|
|
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
/sbin/chkconfig --add mdmonitor |
61 |
|
|
/sbin/chkconfig --add mdmpd |
62 |
|
|
|
63 |
|
|
%preun |
64 |
|
|
if [ "$1" = 0 ]; then |
65 |
|
|
service mdmonitor stop > /dev/null 2>&1 ||: |
66 |
|
|
/sbin/chkconfig --del mdmonitor |
67 |
|
|
if [ -e %{_initrddir}/mdmpd ]; then |
68 |
|
|
service mdmpd stop > /dev/null 2>&1 ||: |
69 |
|
|
/sbin/chkconfig --del mdmpd |
70 |
|
|
fi |
71 |
|
|
fi |
72 |
|
|
|
73 |
|
|
%postun |
74 |
|
|
if [ "$1" -ge "1" ]; then |
75 |
|
|
service mdmonitor condrestart > /dev/null 2>&1 |
76 |
|
|
if [ -e %{_initrddir}/mdmpd ]; then |
77 |
|
|
service mdmpd condrestart > /dev/null 2>&1 |
78 |
|
|
fi |
79 |
|
|
fi |
80 |
|
|
|
81 |
|
|
%files |
82 |
|
|
%defattr(-,root,root) |
83 |
|
|
%doc ANNOUNCE-* TODO ChangeLog mdadm.conf-example COPYING misc/* |
84 |
|
|
/sbin/* |
85 |
|
|
%{_initrddir}/* |
86 |
|
|
%{_mandir}/man*/md* |
87 |
|
|
%attr(0700,root,root) %dir /var/run/mdmpd |
88 |
|
|
%attr(0700,root,root) %dir /var/run/mdadm |
89 |
|
|
|
90 |
|
|
%changelog |
91 |
|
|
* Thu Nov 09 2006 Doug Ledford <dledford@redhat.com> - 2.5.4-3 |
92 |
|
|
- Add a fix for the broken printout of array GUID when using the -E --brief |
93 |
|
|
flags |
94 |
|
|
|
95 |
|
|
* Fri Oct 13 2006 Doug Ledford <dledford@redhat.com> - 2.5.4-2 |
96 |
|
|
- tag present on another branch and can't be forcibly moved |
97 |
|
|
required number bump |
98 |
|
|
|
99 |
|
|
* Fri Oct 13 2006 Doug Ledford <dledford@redhat.com> - 2.5.4-1 |
100 |
|
|
- Update to 2.5.4 (listed as a bugfix update by upstream) |
101 |
|
|
- Remove previous bitmap patch that's now part of 2.5.4 |
102 |
|
|
|
103 |
|
|
* Sun Oct 8 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-2 |
104 |
|
|
- Fix a big-endian machine error in the bitmap code (Paul Clements) |
105 |
|
|
|
106 |
|
|
* Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1 |
107 |
|
|
- Update to 2.5.3 which upstream calls a "bug fix" release |
108 |
|
|
|
109 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1 |
110 |
|
|
- rebuild |
111 |
|
|
|
112 |
|
|
* Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1 |
113 |
|
|
- Update to 2.5.2 |
114 |
|
|
- Remove auto default patch as upstream now has a preferred default auto method |
115 |
|
|
|
116 |
|
|
* Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3 |
117 |
|
|
- fix build on ppc64 |
118 |
|
|
|
119 |
|
|
* Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2 |
120 |
|
|
- fix build on ppc |
121 |
|
|
|
122 |
|
|
* Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1 |
123 |
|
|
- update to 2.3.1 to fix raid5 (#184284) |
124 |
|
|
|
125 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1 |
126 |
|
|
- bump again for double-long bug on ppc(64) |
127 |
|
|
|
128 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2 |
129 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
130 |
|
|
|
131 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
132 |
|
|
- rebuilt |
133 |
|
|
|
134 |
|
|
* Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1 |
135 |
|
|
- 2.2 upgrade (#167897) |
136 |
|
|
- disable diet because we don't ship it anymore |
137 |
|
|
and we don't actually use mdassemble now |
138 |
|
|
|
139 |
|
|
* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4 |
140 |
|
|
- Make the mdmonitor init script use the pid-file option, major cleanup |
141 |
|
|
of the script now possible (#134459) |
142 |
|
|
|
143 |
|
|
* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4 |
144 |
|
|
- Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4 |
145 |
|
|
|
146 |
|
|
* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4 |
147 |
|
|
- Change the default auto= mode so it need not be on the command line to |
148 |
|
|
work with udev, however it is still supported on the command line (#132706) |
149 |
|
|
- Add a man page (from Luca Berra) for mdassemble |
150 |
|
|
|
151 |
|
|
* Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4 |
152 |
|
|
- Upgrade to 1.11.0 |
153 |
|
|
|
154 |
|
|
* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4 |
155 |
|
|
- fix mdmonitor initscript (#144717) |
156 |
|
|
|
157 |
|
|
* Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2 |
158 |
|
|
- Build mdadm.static and mdassemble (static as well) to be used in initrd |
159 |
|
|
images |
160 |
|
|
|
161 |
|
|
* Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1 |
162 |
|
|
- Initial upgrade to 1.9.0 and update of doc files |
163 |
|
|
- Fix an s390 build error |
164 |
|
|
|
165 |
|
|
* Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2 |
166 |
|
|
- Remove /etc/mdadm.conf from the file list. Anaconda will write one out |
167 |
|
|
if it's needed. |
168 |
|
|
|
169 |
|
|
* Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1 |
170 |
|
|
- Update to newer upstream version |
171 |
|
|
- Make mdmpd work on kernels that don't have the event interface patch |
172 |
|
|
|
173 |
|
|
* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11 |
174 |
|
|
- Create a directory /var/run/mdadm to contain mdadm.pid |
175 |
|
|
- This cleans up SELinux problem |
176 |
|
|
|
177 |
|
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> |
178 |
|
|
- rebuilt |
179 |
|
|
|
180 |
|
|
* Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9 |
181 |
|
|
- Fix Makefile and build method to satisfy bz #123769 |
182 |
|
|
- Add mdmpd man page, update mdmpd version to 0.3 - bz #117160 |
183 |
|
|
- Make sure mdadm --monitor closes all md device files so that md devices |
184 |
|
|
can be stopped while mdadm is still running - bz #119532 |
185 |
|
|
|
186 |
|
|
* Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8 |
187 |
|
|
- remove unneeded patch, can use --run instead |
188 |
|
|
|
189 |
|
|
* Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7 |
190 |
|
|
- add patch with reallyforce mode on creation to be used by anaconda |
191 |
|
|
|
192 |
|
|
* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6 |
193 |
|
|
- Fix a bug in the %postun scriptlet related to downgrading to a version |
194 |
|
|
of mdadm that doesn't include the mdmpd daemon. |
195 |
|
|
|
196 |
|
|
* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5 |
197 |
|
|
- Disable service mdmpd by default to avoid [Failed] messages on |
198 |
|
|
current 2.6 kernels. Possibly re-enable it by default once the |
199 |
|
|
2.6 kernels have the md event interface. |
200 |
|
|
|
201 |
|
|
* Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4 |
202 |
|
|
- Update mdmonitor script to start daemon more cleanly |
203 |
|
|
- Repackage mdmpd tarball to include gcc-3.4 changes and to make |
204 |
|
|
mdmpd properly daemonize at startup instead of forking and leaving |
205 |
|
|
the child attached to the terminal. |
206 |
|
|
|
207 |
|
|
* Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3 |
208 |
|
|
- ship /var/run/mpmpd (#117497) |
209 |
|
|
|
210 |
|
|
* Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2 |
211 |
|
|
- Add a default MAILADDR line to the mdadm.conf file installed by default |
212 |
|
|
(Bugzilla #92447) |
213 |
|
|
- Make it build with gcc-3.4 |
214 |
|
|
|
215 |
|
|
* Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1 |
216 |
|
|
- Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>) |
217 |
|
|
|
218 |
|
|
* Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1 |
219 |
|
|
- fix problem with recovery thread sleeping in mdmpd |
220 |
|
|
|
221 |
|
|
* Fri Nov 14 2003 Doug Ledford <dledford@redhat.com> |
222 |
|
|
- sync upstream |
223 |
|
|
- add mdmpd package into mdadm package |
224 |
|
|
|
225 |
|
|
* Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1 |
226 |
|
|
- sync upstream |
227 |
|
|
|
228 |
|
|
* Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1 |
229 |
|
|
- sync upstream |
230 |
|
|
|
231 |
|
|
* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1 |
232 |
|
|
- update for rebuild |
233 |
|
|
|
234 |
|
|
* Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8 |
235 |
|
|
- fix references to %%install in the changelog so that it will build |
236 |
|
|
|
237 |
|
|
* Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7 |
238 |
|
|
- Rebuild |
239 |
|
|
|
240 |
|
|
* Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com> |
241 |
|
|
- Changed RPM Group to System Environment/Base |
242 |
|
|
|
243 |
|
|
* Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com> |
244 |
|
|
- minor cleanups to the text, conditionalize rm -rf |
245 |
|
|
- added mdmonitor init script |
246 |
|
|
|
247 |
|
|
* Fri May 10 2002 <neilb@cse.unsw.edu.au> |
248 |
|
|
- update to 1.0.0 |
249 |
|
|
- Set CXFLAGS instead of CFLAGS |
250 |
|
|
|
251 |
|
|
* Sat Apr 6 2002 <neilb@cse.unsw.edu.au> |
252 |
|
|
- change %%install to use "make install" |
253 |
|
|
|
254 |
|
|
* Fri Mar 15 2002 <gleblanc@localhost.localdomain> |
255 |
|
|
- beautification |
256 |
|
|
- made mdadm.conf non-replaceable config |
257 |
|
|
- renamed Copyright to License in the header |
258 |
|
|
- added missing license file |
259 |
|
|
- used macros for file paths |
260 |
|
|
|
261 |
|
|
* Fri Mar 15 2002 Luca Berra <bluca@comedia.it> |
262 |
|
|
- Added Obsoletes: mdctl |
263 |
|
|
- missingok for configfile |
264 |
|
|
|
265 |
|
|
* Wed Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au> |
266 |
|
|
- Add md.4 and mdadm.conf.5 man pages |
267 |
|
|
|
268 |
|
|
* Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca> |
269 |
|
|
- builds properly as non-root. |
270 |
|
|
|
271 |
|
|
* Fri Mar 08 2002 Derek Vadala <derek@cynicism.com> |
272 |
|
|
- updated for 0.7, fixed /usr/share/doc and added manpage |
273 |
|
|
|
274 |
|
|
* Tue Aug 07 2001 Danilo Godec <danci@agenda.si> |
275 |
|
|
- initial RPM build |