/[smeserver]/rpms/mezzanine/sme7/mezzanine.spec
ViewVC logotype

Annotation of /rpms/mezzanine/sme7/mezzanine.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 16:35:29 2007 UTC (16 years, 11 months ago) by slords
Branch: MAIN
CVS Tags: mezzanine-1_9-0_12_el4_sme, HEAD
Import on branch sme7 of package mezzanine-1.9-0.12.el4.sme.src.rpm

1 slords 1.1 # $Id: mezzanine.spec,v 1.146 2006/09/26 20:13:30 mej Exp $
2    
3     Summary: Mezzanine -- A Software Product Management System
4     Name: mezzanine
5     Version: 1.9
6     Release: 0.12%{?dist}
7     License: BSD
8     Group: Development/Tools
9     URL: http://www.kainx.org/mezzanine/
10     Source: http://www.kainx.org/mezzanine/%{name}.tar.gz
11     Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
12     BuildRequires: docbook-style-dsssl
13     Requires: perl, perl(Net::FTP), perl(Cwd), perl(POSIX), perl(File::Copy), perl(Getopt::Long), perl(File::Find)
14     BuildArch: noarch
15     BuildRoot: %{?_tmppath}%{!?_tmppath:/tmp}/%{name}-%{version}-root
16    
17     %description
18     Mezzanine is a collection of tools, written primarily in Perl, which
19     automate and simplify many of the tasks associated with maintaining,
20     building, and releasing software products.
21    
22     %prep
23     %setup -n %{name} -T -c -a 0
24    
25     %build
26     (
27     cd doc
28     for i in *.sgml ; do
29     FNAME=${i%%%%.sgml}
30     jade -t sgml -i html -d mezzanine.dsl \
31     -D /usr/share/sgml/docbook/dsssl-stylesheets \
32     -V "%%stylesheet%%=${FNAME}.css" \
33     -V "%%root-filename%%=${FNAME}" \
34     -V nochunks -V rootchunk \
35     $i
36     done
37     ) || :
38    
39     %install
40     %define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
41     %if "%{perl_vendorlib}" == "UNKNOWN"
42     %define perl_vendorlib %(eval "`perl -V:installsitelib`"; echo $installsitelib)
43     %endif
44    
45     test "x$RPM_BUILD_ROOT" != "x" && rm -rf $RPM_BUILD_ROOT
46     mkdir -p $RPM_BUILD_ROOT%{_bindir}
47     mkdir -p $RPM_BUILD_ROOT%{perl_vendorlib}/Mezzanine/templates
48     mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
49    
50     for i in abiscan *tool pkgsort perlpkg specgen ; do
51     install -m 755 $i $RPM_BUILD_ROOT%{_bindir}/
52     done
53    
54     for i in templates/* ; do
55     install -m 644 $i $RPM_BUILD_ROOT%{perl_vendorlib}/Mezzanine/templates/
56     done
57    
58     (cd mod ; tar -cf - *.pm */*.pm) | (cd $RPM_BUILD_ROOT%{perl_vendorlib}/Mezzanine ; tar -xf -)
59    
60     for i in doc/man/*.1 ; do
61     install -m 644 $i $RPM_BUILD_ROOT%{_mandir}/man1/
62     done
63    
64     (
65     cd $RPM_BUILD_ROOT%{_bindir}
66     for i in abi abiscan ; do
67     ln -s abiscan mz$i
68     done
69     for i in get co put ci info add new rm purge rtag tag reset login ann annotate blame diff stat status log init ; do
70     ln -s revtool mz$i
71     echo ".so revtool.1" > $RPM_BUILD_ROOT%{_mandir}/man1/mz$i.1
72     done
73     for i in import prep merge patch clean sync mv ; do
74     ln -s srctool mz$i
75     echo ".so srctool.1" > $RPM_BUILD_ROOT%{_mandir}/man1/mz$i.1
76     done
77     for i in rpm pkg build inst ; do
78     ln -s pkgtool mz$i
79     echo ".so pkgtool.1" > $RPM_BUILD_ROOT%{_mandir}/man1/mz$i.1
80     done
81     for i in prod pbuild prodbuild ; do
82     ln -s buildtool mz$i
83     echo ".so buildtool.1" > $RPM_BUILD_ROOT%{_mandir}/man1/mz$i.1
84     done
85     )
86    
87     %clean
88     test "x$RPM_BUILD_ROOT" != "x" && rm -rf $RPM_BUILD_ROOT
89    
90     %files
91     %defattr(-, root, root)
92     %doc doc/*ml
93     %{_bindir}/*
94     %{perl_vendorlib}/*
95     %{_mandir}/*
96    
97     %changelog
98     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
99     - Clean up spec so package can be built by koji/plague
100    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed