1 |
slords |
1.1 |
Summary: Basic authentication for the Apache web server using an external program |
2 |
|
|
Name: mod_auth_external |
3 |
|
|
Version: 2.2.8 |
4 |
|
|
Release: 4%{?dist} |
5 |
|
|
Group: System Environment/Daemons |
6 |
|
|
URL: http://unixpapa.com/mod_auth_external.html |
7 |
|
|
Source: mod_auth_external-2.2.8.tar.gz |
8 |
|
|
Source2: auth_external.conf |
9 |
|
|
Patch0: mod_auth_external-config.patch |
10 |
|
|
Patch1: mod_auth_external-no_server_uids.patch |
11 |
|
|
License: Apache Software License |
12 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
13 |
|
|
BuildPrereq: httpd-devel >= 2.0.40-12 |
14 |
|
|
Requires: httpd >= 2.0.40 |
15 |
|
|
BuildRequires: pam-devel |
16 |
|
|
#Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn) |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
mod_auth_external can be used to limit access to documents served by a |
20 |
|
|
web server by checking data in an external program. |
21 |
|
|
|
22 |
|
|
%prep |
23 |
|
|
%setup -q -n %{name}-%{version} |
24 |
|
|
%patch0 -p1 |
25 |
|
|
%patch1 -p1 |
26 |
|
|
|
27 |
|
|
%build |
28 |
|
|
%{_sbindir}/apxs -DAPACHE2 -c %{name}.c |
29 |
|
|
mv .libs/%{name}.so . |
30 |
|
|
%{__strip} -g %{name}.so |
31 |
|
|
%{__cc} -o pwauth/pwauth pwauth/pwauth.c -lpam -ldl |
32 |
|
|
%{__strip} pwauth/pwauth |
33 |
|
|
|
34 |
|
|
%install |
35 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
36 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_docdir}/mod_auth_external-%{version} |
37 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
38 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/pam.d |
39 |
|
|
install -m755 %{name}.so $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
40 |
|
|
install -m755 pwauth/pwauth $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
41 |
|
|
|
42 |
|
|
# Install the config file |
43 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
44 |
|
|
install -m 644 $RPM_SOURCE_DIR/auth_external.conf \ |
45 |
|
|
$RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
46 |
|
|
mv pwauth/README pwauth/README.pwauth |
47 |
|
|
if test -f /lib/security/pam_pwdb.so |
48 |
|
|
then |
49 |
|
|
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
50 |
|
|
#%PAM-1.0 |
51 |
|
|
auth required /lib/security/pam_stack.so service=system-auth |
52 |
|
|
auth required /lib/security/pam_nologin.so |
53 |
|
|
account required /lib/security/pam_stack.so service=system-auth |
54 |
|
|
EOF |
55 |
|
|
else |
56 |
|
|
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
57 |
|
|
#%PAM-1.0 |
58 |
|
|
auth include system-auth |
59 |
|
|
auth required pam_nologin.so |
60 |
|
|
account include system-auth |
61 |
|
|
EOF |
62 |
|
|
fi |
63 |
|
|
|
64 |
|
|
%clean |
65 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
66 |
|
|
|
67 |
|
|
%files |
68 |
|
|
%defattr(-,root,root) |
69 |
|
|
%doc README INSTALL pwauth/README.pwauth |
70 |
|
|
%config %attr(0444,root,root) /etc/pam.d/pwauth |
71 |
|
|
%attr(04550,root,www) %{_libdir}/httpd/modules/pwauth |
72 |
|
|
%{_libdir}/httpd/modules/*.so |
73 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
74 |
|
|
|
75 |
|
|
%changelog |
76 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
77 |
|
|
- Clean up spec so package can be built by koji/plague |
78 |
|
|
|
79 |
|
|
* Thu Mar 22 2007 Charlie Brady <charlieb@e-smith.com> 2.2.8-4 |
80 |
|
|
- Conditionally use "include" in pam configuration, rather than pam_stack. |
81 |
|
|
Also mark pam config as a config file. [SME: 2551] |
82 |
|
|
|
83 |
|
|
* Mon Mar 19 2007 Shad L. Lords <slords@mail.com> 2.2.8-3 |
84 |
|
|
- Update pam module to use pam_stack with system-auth [SME: 2551] |
85 |
|
|
|
86 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
87 |
|
|
- Update to new release naming. No functional changes. |
88 |
|
|
- Make Packager generic |
89 |
|
|
|
90 |
|
|
* Mon Mar 20 2006 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme03 |
91 |
|
|
- Remove redundant SERVER_UID checking - that is taken care of by |
92 |
|
|
file system permissions. [SME: 1037] |
93 |
|
|
|
94 |
|
|
* Wed Apr 20 2005 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme02 |
95 |
|
|
- Change group of executable from admin to www, so that both apache |
96 |
|
|
instances can authenticate. Add 102 to SERVER_UIDS to cover both |
97 |
|
|
newly installed and upgraded systems. |
98 |
|
|
|
99 |
|
|
* Tue Aug 10 2004 Shad L. Lords <slords@mail.com> |
100 |
|
|
- initial package |